community/curaengine to 3.6.0-1

This commit is contained in:
Kevin Mihelich 2018-11-18 17:09:23 +00:00
parent 1b02739ae6
commit 6edd207d5c
2 changed files with 11 additions and 25 deletions

View file

@ -5,8 +5,8 @@
# - -DBUILD_TESTS=oFF
pkgname=curaengine
pkgver=3.4.1
pkgrel=3
pkgver=3.6.0
pkgrel=1
pkgdesc="Engine for processing 3D models into 3D printing instruction for Ultimaker and other GCode based 3D printers."
url="https://github.com/Ultimaker/CuraEngine"
arch=('x86_64')
@ -17,13 +17,13 @@ depends=('arcus')
checkdepends=('cppunit')
makedepends=('cmake' 'git')
source=("$pkgname-$pkgver.tar.gz::https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz"
do_not_copy_resource.patch)
md5sums=('825f80f42da70efe6c889d8acb8f6afe'
'07b0f2240737f99830c1a87c1f1f378e')
"fix_mocksocket_tests.patch::https://github.com/Ultimaker/CuraEngine/commit/7349c981135f6460640c23527f02dea650304467.patch")
sha512sums=('340dad4c697fb0d7b633091715a904ae7df8973626e217ae2528d0121723c07a6cf0bbc740b9ad9980f3b288fa690c9c3ee43d90914264855dace007bbb334c8'
'2371a984caec6b9972236f5579a4c928c6cf2c268dd994798b606ba4310333534aea52d2b465d64484081b00ab3550717d4abca3b7174f27f6e1941d43e31cff')
prepare() {
cd CuraEngine-${pkgver}
patch -Np1 -i ${srcdir}/do_not_copy_resource.patch
patch -Np1 -i $srcdir/fix_mocksocket_tests.patch
}
build() {
@ -39,14 +39,14 @@ build() {
make
}
package() {
cd CuraEngine-${pkgver}/build
make DESTDIR="${pkgdir}" install
}
check() {
cd CuraEngine-${pkgver}/build
make test
}
package() {
cd CuraEngine-${pkgver}/build
make DESTDIR="${pkgdir}" install
}
# vim:set ts=2 sw=2 et:

View file

@ -1,14 +0,0 @@
diff -aur CuraEngine-3.4.1/CMakeLists.txt CuraEngine-3.4.1.old/CMakeLists.txt
--- CuraEngine-3.4.1/CMakeLists.txt 2018-07-09 10:55:15.000000000 +0200
+++ CuraEngine-3.4.1.old/CMakeLists.txt 2018-09-07 20:16:42.621995976 +0200
@@ -252,10 +252,6 @@
endif()
-add_custom_command(TARGET CuraEngine POST_BUILD
- COMMAND ${CMAKE_COMMAND} -E copy_directory
- ${CMAKE_SOURCE_DIR}/resources $<TARGET_FILE_DIR:CuraEngine>)
-
# Installing CuraEngine.
include(GNUInstallDirs)
install(TARGETS CuraEngine DESTINATION ${CMAKE_INSTALL_BINDIR})