mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
openssl to 1.0.1g
This commit is contained in:
parent
37cb22108f
commit
6ef0e84acd
2 changed files with 4 additions and 364 deletions
|
@ -5,7 +5,7 @@
|
||||||
# - use linux-armv4 target for our architectures
|
# - use linux-armv4 target for our architectures
|
||||||
|
|
||||||
pkgname=openssl
|
pkgname=openssl
|
||||||
_ver=1.0.1g
|
_ver=1.0.1h
|
||||||
# use a pacman compatible version scheme
|
# use a pacman compatible version scheme
|
||||||
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
|
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
|
||||||
#pkgver=$_ver
|
#pkgver=$_ver
|
||||||
|
@ -20,12 +20,10 @@ options=('!makeflags')
|
||||||
backup=('etc/ssl/openssl.cnf')
|
backup=('etc/ssl/openssl.cnf')
|
||||||
source=("https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz"
|
source=("https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz"
|
||||||
'no-rpath.patch'
|
'no-rpath.patch'
|
||||||
'ca-dir.patch'
|
'ca-dir.patch')
|
||||||
'openssl-1.0.1f-perl-5.18.patch')
|
md5sums=('8d6d684a9430d5cc98a62a5d8fbda8cf'
|
||||||
md5sums=('de62b43dfcd858e66a74bee1c834e959'
|
|
||||||
'dc78d3d06baffc16217519242ce92478'
|
'dc78d3d06baffc16217519242ce92478'
|
||||||
'3bf51be3a1bbd262be46dc619f92aa90'
|
'3bf51be3a1bbd262be46dc619f92aa90')
|
||||||
'ea2a61c8bd43788d81d98f1ac36c98ac')
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd $srcdir/$pkgname-$_ver
|
cd $srcdir/$pkgname-$_ver
|
||||||
|
@ -34,8 +32,6 @@ prepare() {
|
||||||
patch -p0 -i $srcdir/no-rpath.patch
|
patch -p0 -i $srcdir/no-rpath.patch
|
||||||
# set ca dir to /etc/ssl by default
|
# set ca dir to /etc/ssl by default
|
||||||
patch -p0 -i $srcdir/ca-dir.patch
|
patch -p0 -i $srcdir/ca-dir.patch
|
||||||
|
|
||||||
patch -p1 -i $srcdir/openssl-1.0.1f-perl-5.18.patch
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
|
@ -1,356 +0,0 @@
|
||||||
Forward-ported from openssl-1.0.1e-perl-5.18.patch
|
|
||||||
Fixes install with perl-5.18.
|
|
||||||
|
|
||||||
https://bugs.gentoo.org/show_bug.cgi?id=497286
|
|
||||||
|
|
||||||
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
|
|
||||||
|
|
||||||
--- openssl-1.0.1f/doc/apps/cms.pod
|
|
||||||
+++ openssl-1.0.1f/doc/apps/cms.pod
|
|
||||||
@@ -450,28 +450,28 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
the operation was completely successfully.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
an error occurred parsing the command options.
|
|
||||||
|
|
||||||
-=item 2
|
|
||||||
+=item C<2>
|
|
||||||
|
|
||||||
one of the input files could not be read.
|
|
||||||
|
|
||||||
-=item 3
|
|
||||||
+=item C<3>
|
|
||||||
|
|
||||||
an error occurred creating the CMS file or when reading the MIME
|
|
||||||
message.
|
|
||||||
|
|
||||||
-=item 4
|
|
||||||
+=item C<4>
|
|
||||||
|
|
||||||
an error occurred decrypting or verifying the message.
|
|
||||||
|
|
||||||
-=item 5
|
|
||||||
+=item C<5>
|
|
||||||
|
|
||||||
the message was verified correctly but an error occurred writing out
|
|
||||||
the signers certificates.
|
|
||||||
--- openssl-1.0.1f/doc/apps/smime.pod
|
|
||||||
+++ openssl-1.0.1f/doc/apps/smime.pod
|
|
||||||
@@ -308,28 +308,28 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
the operation was completely successfully.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
an error occurred parsing the command options.
|
|
||||||
|
|
||||||
-=item 2
|
|
||||||
+=item C<2>
|
|
||||||
|
|
||||||
one of the input files could not be read.
|
|
||||||
|
|
||||||
-=item 3
|
|
||||||
+=item C<3>
|
|
||||||
|
|
||||||
an error occurred creating the PKCS#7 file or when reading the MIME
|
|
||||||
message.
|
|
||||||
|
|
||||||
-=item 4
|
|
||||||
+=item C<4>
|
|
||||||
|
|
||||||
an error occurred decrypting or verifying the message.
|
|
||||||
|
|
||||||
-=item 5
|
|
||||||
+=item C<5>
|
|
||||||
|
|
||||||
the message was verified correctly but an error occurred writing out
|
|
||||||
the signers certificates.
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_accept.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_accept.pod
|
|
||||||
@@ -44,13 +44,13 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The TLS/SSL handshake was not successful but was shut down controlled and
|
|
||||||
by the specifications of the TLS/SSL protocol. Call SSL_get_error() with the
|
|
||||||
return value B<ret> to find out the reason.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
The TLS/SSL handshake was successfully completed, a TLS/SSL connection has been
|
|
||||||
established.
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_clear.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_clear.pod
|
|
||||||
@@ -56,12 +56,12 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The SSL_clear() operation could not be performed. Check the error stack to
|
|
||||||
find out the reason.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
The SSL_clear() operation was successful.
|
|
||||||
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_COMP_add_compression_method.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_COMP_add_compression_method.pod
|
|
||||||
@@ -53,11 +53,11 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The operation succeeded.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
The operation failed. Check the error queue to find out the reason.
|
|
||||||
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_connect.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_connect.pod
|
|
||||||
@@ -41,13 +41,13 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The TLS/SSL handshake was not successful but was shut down controlled and
|
|
||||||
by the specifications of the TLS/SSL protocol. Call SSL_get_error() with the
|
|
||||||
return value B<ret> to find out the reason.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
The TLS/SSL handshake was successfully completed, a TLS/SSL connection has been
|
|
||||||
established.
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_CTX_add_session.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_CTX_add_session.pod
|
|
||||||
@@ -52,13 +52,13 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The operation failed. In case of the add operation, it was tried to add
|
|
||||||
the same (identical) session twice. In case of the remove operation, the
|
|
||||||
session was not found in the cache.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
The operation succeeded.
|
|
||||||
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_CTX_load_verify_locations.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_CTX_load_verify_locations.pod
|
|
||||||
@@ -100,13 +100,13 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The operation failed because B<CAfile> and B<CApath> are NULL or the
|
|
||||||
processing at one of the locations specified failed. Check the error
|
|
||||||
stack to find out the reason.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
The operation succeeded.
|
|
||||||
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_CTX_set_client_CA_list.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_CTX_set_client_CA_list.pod
|
|
||||||
@@ -66,13 +66,13 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
A failure while manipulating the STACK_OF(X509_NAME) object occurred or
|
|
||||||
the X509_NAME could not be extracted from B<cacert>. Check the error stack
|
|
||||||
to find out the reason.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
The operation succeeded.
|
|
||||||
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_CTX_set_session_id_context.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_CTX_set_session_id_context.pod
|
|
||||||
@@ -64,13 +64,13 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The length B<sid_ctx_len> of the session id context B<sid_ctx> exceeded
|
|
||||||
the maximum allowed length of B<SSL_MAX_SSL_SESSION_ID_LENGTH>. The error
|
|
||||||
is logged to the error stack.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
The operation succeeded.
|
|
||||||
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_CTX_set_ssl_version.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_CTX_set_ssl_version.pod
|
|
||||||
@@ -42,11 +42,11 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The new choice failed, check the error stack to find out the reason.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
The operation succeeded.
|
|
||||||
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_CTX_use_psk_identity_hint.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_CTX_use_psk_identity_hint.pod
|
|
||||||
@@ -96,7 +96,7 @@
|
|
||||||
connection will fail with decryption_error before it will be finished
|
|
||||||
completely.
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
PSK identity was not found. An "unknown_psk_identity" alert message
|
|
||||||
will be sent and the connection setup fails.
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_do_handshake.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_do_handshake.pod
|
|
||||||
@@ -45,13 +45,13 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The TLS/SSL handshake was not successful but was shut down controlled and
|
|
||||||
by the specifications of the TLS/SSL protocol. Call SSL_get_error() with the
|
|
||||||
return value B<ret> to find out the reason.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
The TLS/SSL handshake was successfully completed, a TLS/SSL connection has been
|
|
||||||
established.
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_read.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_read.pod
|
|
||||||
@@ -86,7 +86,7 @@
|
|
||||||
The read operation was successful; the return value is the number of
|
|
||||||
bytes actually read from the TLS/SSL connection.
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The read operation was not successful. The reason may either be a clean
|
|
||||||
shutdown due to a "close notify" alert sent by the peer (in which case
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_session_reused.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_session_reused.pod
|
|
||||||
@@ -27,11 +27,11 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
A new session was negotiated.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
A session was reused.
|
|
||||||
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_set_fd.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_set_fd.pod
|
|
||||||
@@ -35,11 +35,11 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The operation failed. Check the error stack to find out why.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
The operation succeeded.
|
|
||||||
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_set_session.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_set_session.pod
|
|
||||||
@@ -37,11 +37,11 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The operation failed; check the error stack to find out the reason.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
The operation succeeded.
|
|
||||||
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_shutdown.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_shutdown.pod
|
|
||||||
@@ -92,14 +92,14 @@
|
|
||||||
|
|
||||||
=over 4
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The shutdown is not yet finished. Call SSL_shutdown() for a second time,
|
|
||||||
if a bidirectional shutdown shall be performed.
|
|
||||||
The output of L<SSL_get_error(3)|SSL_get_error(3)> may be misleading, as an
|
|
||||||
erroneous SSL_ERROR_SYSCALL may be flagged even though no error occurred.
|
|
||||||
|
|
||||||
-=item 1
|
|
||||||
+=item C<1>
|
|
||||||
|
|
||||||
The shutdown was successfully completed. The "close notify" alert was sent
|
|
||||||
and the peer's "close notify" alert was received.
|
|
||||||
--- openssl-1.0.1f/doc/ssl/SSL_write.pod
|
|
||||||
+++ openssl-1.0.1f/doc/ssl/SSL_write.pod
|
|
||||||
@@ -79,7 +79,7 @@
|
|
||||||
The write operation was successful, the return value is the number of
|
|
||||||
bytes actually written to the TLS/SSL connection.
|
|
||||||
|
|
||||||
-=item 0
|
|
||||||
+=item C<0>
|
|
||||||
|
|
||||||
The write operation was not successful. Probably the underlying connection
|
|
||||||
was closed. Call SSL_get_error() with the return value B<ret> to find out,
|
|
Loading…
Reference in a new issue