mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/uboot-odroid-xu3 to 2018.01-2
This commit is contained in:
parent
99e24b9c32
commit
6f4d98eb52
2 changed files with 49 additions and 3 deletions
|
@ -0,0 +1,38 @@
|
||||||
|
From 8507771ad72d0f4e69bab8c6234364ebaf5e06ff Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
Date: Tue, 13 Feb 2018 21:27:47 -0700
|
||||||
|
Subject: [PATCH] ARM: Samsung: Add Exynos5422-based Odroid HC1+ support
|
||||||
|
|
||||||
|
Updated HC1 ADC value to HC1+ to capture both revisions.
|
||||||
|
|
||||||
|
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
---
|
||||||
|
board/samsung/common/exynos5-dt-types.c | 5 +++--
|
||||||
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/board/samsung/common/exynos5-dt-types.c b/board/samsung/common/exynos5-dt-types.c
|
||||||
|
index 03d3a3112a..8c92ea3e9b 100644
|
||||||
|
--- a/board/samsung/common/exynos5-dt-types.c
|
||||||
|
+++ b/board/samsung/common/exynos5-dt-types.c
|
||||||
|
@@ -32,7 +32,8 @@ static const struct udevice_id board_ids[] = {
|
||||||
|
* 0.3 1280 XU4 0.1
|
||||||
|
* 0.4 739 XU4 0.2
|
||||||
|
* 0.5 1016 XU4+Air0.1 (Passive cooling)
|
||||||
|
- * 0.6 1308 XU4S 0.1 (HC1)
|
||||||
|
+ * 0.6 1308 XU4-HC1 0.1
|
||||||
|
+ * 0.7 1470 XU4-HC1+ 0.1
|
||||||
|
* Use +1% for ADC value tolerance in the array below, the code loops until
|
||||||
|
* the measured ADC value is lower than then ADCmax from the array.
|
||||||
|
*/
|
||||||
|
@@ -40,7 +41,7 @@ struct odroid_rev_info odroid_info[] = {
|
||||||
|
{ EXYNOS5_BOARD_ODROID_XU3_REV01, 1, 10, "xu3" },
|
||||||
|
{ EXYNOS5_BOARD_ODROID_XU3_REV02, 2, 375, "xu3" },
|
||||||
|
{ EXYNOS5_BOARD_ODROID_XU4_REV01, 1, 1293, "xu4" },
|
||||||
|
- { EXYNOS5_BOARD_ODROID_HC1_REV01, 1, 1321, "hc1" },
|
||||||
|
+ { EXYNOS5_BOARD_ODROID_HC1_REV01, 1, 1485, "hc1" },
|
||||||
|
{ EXYNOS5_BOARD_ODROID_UNKNOWN, 0, 4095, "unknown" },
|
||||||
|
};
|
||||||
|
|
||||||
|
--
|
||||||
|
2.16.1
|
||||||
|
|
|
@ -5,16 +5,17 @@ buildarch=4
|
||||||
|
|
||||||
pkgname=uboot-odroid-xu3
|
pkgname=uboot-odroid-xu3
|
||||||
pkgver=2018.01
|
pkgver=2018.01
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
pkgdesc="U-Boot for ODROID-XU3/XU4/HC1"
|
pkgdesc="U-Boot for ODROID-XU3/XU4/HC1/HC2"
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url='http://www.denx.de/wiki/U-Boot/WebHome'
|
url='http://www.denx.de/wiki/U-Boot/WebHome'
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
install=$pkgname.install
|
install=$pkgname.install
|
||||||
backup=('boot/boot.txt' 'boot/boot.scr')
|
backup=('boot/boot.txt' 'boot/boot.scr')
|
||||||
makedepends=('bc' 'dtc' 'git')
|
makedepends=('bc' 'dtc145' 'git')
|
||||||
_commit=fe2f831fd44a4071f58a42f260164544697aa666
|
_commit=fe2f831fd44a4071f58a42f260164544697aa666
|
||||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
||||||
|
'0001-ARM-Samsung-Add-Exynos5422-based-Odroid-HC1-support.patch'
|
||||||
"bl1.bin::https://github.com/hardkernel/u-boot/raw/${_commit}/sd_fuse/hardkernel/bl1.bin.hardkernel"
|
"bl1.bin::https://github.com/hardkernel/u-boot/raw/${_commit}/sd_fuse/hardkernel/bl1.bin.hardkernel"
|
||||||
'http://archlinuxarm.org/builder/src/xu3/bl2.bin'
|
'http://archlinuxarm.org/builder/src/xu3/bl2.bin'
|
||||||
"tzsw.bin::https://github.com/hardkernel/u-boot/raw/${_commit}/sd_fuse/hardkernel/tzsw.bin.hardkernel"
|
"tzsw.bin::https://github.com/hardkernel/u-boot/raw/${_commit}/sd_fuse/hardkernel/tzsw.bin.hardkernel"
|
||||||
|
@ -22,6 +23,7 @@ source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
||||||
'boot.txt'
|
'boot.txt'
|
||||||
'mkscr')
|
'mkscr')
|
||||||
md5sums=('b42e45813369f4ae84490a481e531768'
|
md5sums=('b42e45813369f4ae84490a481e531768'
|
||||||
|
'32190849dbeefab68897ce8ee6e2e033'
|
||||||
'38fb058aa3bcc568f9547c85517949b9'
|
'38fb058aa3bcc568f9547c85517949b9'
|
||||||
'09c42bed980921cfc914e97e067ba9a3'
|
'09c42bed980921cfc914e97e067ba9a3'
|
||||||
'fd01dda20b999e0b731c7063431a42b3'
|
'fd01dda20b999e0b731c7063431a42b3'
|
||||||
|
@ -29,6 +31,12 @@ md5sums=('b42e45813369f4ae84490a481e531768'
|
||||||
'52306aa4cf2c3499ecfcea026fb2741c'
|
'52306aa4cf2c3499ecfcea026fb2741c'
|
||||||
'021623a04afd29ac3f368977140cfbfd')
|
'021623a04afd29ac3f368977140cfbfd')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd u-boot-${pkgver}
|
||||||
|
|
||||||
|
patch -p1 -i ../0001-ARM-Samsung-Add-Exynos5422-based-Odroid-HC1-support.patch
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd u-boot-${pkgver}
|
cd u-boot-${pkgver}
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue