mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed extra/suitesparse
This commit is contained in:
parent
a226e5296b
commit
6ffc981113
3 changed files with 0 additions and 83 deletions
|
@ -1,47 +0,0 @@
|
|||
# Maintainer: Ronald van Haren <ronald.archlinux.org>
|
||||
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch from debian to link with libatomic
|
||||
|
||||
pkgname=suitesparse
|
||||
pkgver=5.10.1
|
||||
pkgrel=2
|
||||
pkgdesc='A collection of sparse matrix libraries'
|
||||
url='http://faculty.cse.tamu.edu/davis/suitesparse.html'
|
||||
arch=(x86_64)
|
||||
depends=(metis lapack mpfr)
|
||||
makedepends=(gcc-fortran cmake chrpath)
|
||||
license=(GPL)
|
||||
options=(staticlibs)
|
||||
source=(https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v$pkgver/$pkgname-$pkgver.tar.gz
|
||||
suitesparse-no-demo.patch
|
||||
libatomic.patch)
|
||||
sha256sums=('acb4d1045f48a237e70294b950153e48dce5b5f9ca8190e86c2b8c54ce00a7ee'
|
||||
'409b32e546ec4936d0d88e39c59ee68dfd9f630d8c454ce1e3d58243df7ad396'
|
||||
'e4dd670b8406483a7b69e8ba5bdd37b83f4d08c867fd86cc0b4f2dad623e07bc')
|
||||
|
||||
prepare() {
|
||||
cd SuiteSparse-$pkgver
|
||||
patch -p1 -i ../suitesparse-no-demo.patch # Don't run demo
|
||||
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && patch -p1 -i ../libatomic.patch || true
|
||||
}
|
||||
|
||||
build() {
|
||||
cd SuiteSparse-$pkgver
|
||||
|
||||
BLAS=-lblas LAPACK=-llapack MY_METIS_LIB=/usr/lib/libmetis.so make
|
||||
}
|
||||
|
||||
|
||||
package() {
|
||||
cd SuiteSparse-$pkgver
|
||||
install -dm755 "${pkgdir}"/usr/{include,lib}
|
||||
|
||||
BLAS=-lblas LAPACK=-llapack MY_METIS_LIB=/usr/lib/libmetis.so \
|
||||
make INSTALL_LIB="${pkgdir}"/usr/lib INSTALL_INCLUDE="${pkgdir}"/usr/include install
|
||||
|
||||
# fix RPATH
|
||||
chrpath -d "$pkgdir"/usr/lib/*
|
||||
}
|
||||
|
|
@ -1,25 +0,0 @@
|
|||
Description: Add missing link of GraphBLAS to libatomic
|
||||
Needed for at least armel, mipsel, m68k and powerpc.
|
||||
Author: Sébastien Villemot <sebastien@debian.org>
|
||||
Bug: https://github.com/DrTimothyAldenDavis/SuiteSparse/issues/21
|
||||
Last-Update: 2020-02-28
|
||||
---
|
||||
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
||||
--- a/GraphBLAS/CMakeLists.txt
|
||||
+++ b/GraphBLAS/CMakeLists.txt
|
||||
@@ -270,6 +270,7 @@ SET_TARGET_PROPERTIES ( graphblas PROPER
|
||||
C_STANDARD_REQUIRED 11
|
||||
PUBLIC_HEADER "Include/GraphBLAS.h" )
|
||||
set_property ( TARGET graphblas PROPERTY C_STANDARD 11 )
|
||||
+target_link_libraries(graphblas PUBLIC atomic)
|
||||
|
||||
#-------------------------------------------------------------------------------
|
||||
# static graphblas library properties
|
||||
@@ -284,6 +285,7 @@ if ( BUILD_GRB_STATIC_LIBRARY )
|
||||
C_STANDARD_REQUIRED 11
|
||||
PUBLIC_HEADER "Include/GraphBLAS.h" )
|
||||
set_property ( TARGET graphblas_static PROPERTY C_STANDARD 11 )
|
||||
+ target_link_libraries(graphblas_static PUBLIC atomic)
|
||||
endif ( )
|
||||
|
||||
#-------------------------------------------------------------------------------
|
|
@ -1,11 +0,0 @@
|
|||
--- SuiteSparse-5.6.0/Makefile.orig 2019-11-05 22:37:26.086135974 +0000
|
||||
+++ SuiteSparse-5.6.0/Makefile 2019-11-05 22:37:37.549632429 +0000
|
||||
@@ -16,7 +16,7 @@
|
||||
# installs all libraries SuiteSparse/lib.
|
||||
go: metis
|
||||
( cd SuiteSparse_config && $(MAKE) )
|
||||
- ( cd Mongoose && $(MAKE) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
|
||||
+ ( cd Mongoose && $(MAKE) library CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
|
||||
( cd AMD && $(MAKE) )
|
||||
( cd BTF && $(MAKE) )
|
||||
( cd CAMD && $(MAKE) )
|
Loading…
Reference in a new issue