mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added extra/icu
This commit is contained in:
parent
85a27a3845
commit
7022d65ac2
3 changed files with 196 additions and 0 deletions
52
extra/icu/PKGBUILD
Normal file
52
extra/icu/PKGBUILD
Normal file
|
@ -0,0 +1,52 @@
|
|||
# $Id$
|
||||
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
|
||||
# Contributor: Art Gramlich <art@gramlich-net.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix icudata library linking on ARM
|
||||
|
||||
pkgname=icu
|
||||
pkgver=53.1
|
||||
pkgrel=1
|
||||
pkgdesc="International Components for Unicode library"
|
||||
arch=(i686 x86_64)
|
||||
url="http://www.icu-project.org/"
|
||||
license=('custom:"icu"')
|
||||
depends=('gcc-libs>=4.7.1-5' 'sh')
|
||||
#makedepends=('clang')
|
||||
source=(#http://download.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver/./_}-src.tgz
|
||||
http://download.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver//./_}-src.tgz
|
||||
icu.8198.revert.icu5431.patch
|
||||
icudata-stdlibs.patch)
|
||||
md5sums=('b73baa6fbdfef197608d1f69300919b9'
|
||||
'ebd5470fc969c75e52baf4af94a9ee82'
|
||||
'4e5202245fce364490334bd66b5edabc')
|
||||
|
||||
prepare() {
|
||||
cd icu/source
|
||||
# fix Malayalam encoding https://bugzilla.redhat.com/show_bug.cgi?id=654200
|
||||
patch -Rp3 -i ${srcdir}/icu.8198.revert.icu5431.patch
|
||||
patch -p2 -i ${srcdir}/icudata-stdlibs.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd icu/source
|
||||
./configure --prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/bin
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd icu/source
|
||||
make -k check # passes all
|
||||
}
|
||||
|
||||
package() {
|
||||
cd icu/source
|
||||
make -j1 DESTDIR=${pkgdir} install
|
||||
|
||||
# Install license
|
||||
install -Dm644 ${srcdir}/icu/license.html ${pkgdir}/usr/share/licenses/icu/license.html
|
||||
}
|
129
extra/icu/icu.8198.revert.icu5431.patch
Normal file
129
extra/icu/icu.8198.revert.icu5431.patch
Normal file
|
@ -0,0 +1,129 @@
|
|||
Index: icu/trunk/source/layout/IndicReordering.cpp
|
||||
===================================================================
|
||||
--- icu/trunk/source/layout/IndicReordering.cpp (revision 25772)
|
||||
+++ icu/trunk/source/layout/IndicReordering.cpp (revision 26090)
|
||||
@@ -126,4 +126,8 @@
|
||||
FeatureMask fSMFeatures;
|
||||
|
||||
+ LEUnicode fPreBaseConsonant;
|
||||
+ LEUnicode fPreBaseVirama;
|
||||
+ le_int32 fPBCIndex;
|
||||
+ FeatureMask fPBCFeatures;
|
||||
|
||||
void saveMatra(LEUnicode matra, le_int32 matraIndex, IndicClassTable::CharClass matraClass)
|
||||
@@ -172,5 +176,6 @@
|
||||
fMatraFeatures(0), fMPreOutIndex(-1), fMPreFixups(mpreFixups),
|
||||
fVMabove(0), fVMpost(0), fVMIndex(0), fVMFeatures(0),
|
||||
- fSMabove(0), fSMbelow(0), fSMIndex(0), fSMFeatures(0)
|
||||
+ fSMabove(0), fSMbelow(0), fSMIndex(0), fSMFeatures(0),
|
||||
+ fPreBaseConsonant(0), fPreBaseVirama(0), fPBCIndex(0), fPBCFeatures(0)
|
||||
{
|
||||
// nothing else to do...
|
||||
@@ -191,4 +196,6 @@
|
||||
fVMabove = fVMpost = 0;
|
||||
fSMabove = fSMbelow = 0;
|
||||
+
|
||||
+ fPreBaseConsonant = fPreBaseVirama = 0;
|
||||
}
|
||||
|
||||
@@ -386,4 +393,12 @@
|
||||
}
|
||||
|
||||
+ void notePreBaseConsonant(le_uint32 index,LEUnicode PBConsonant, LEUnicode PBVirama, FeatureMask features)
|
||||
+ {
|
||||
+ fPBCIndex = index;
|
||||
+ fPreBaseConsonant = PBConsonant;
|
||||
+ fPreBaseVirama = PBVirama;
|
||||
+ fPBCFeatures = features;
|
||||
+ }
|
||||
+
|
||||
void noteBaseConsonant()
|
||||
{
|
||||
@@ -465,4 +480,20 @@
|
||||
}
|
||||
|
||||
+ void writePreBaseConsonant()
|
||||
+ {
|
||||
+ // The TDIL spec says that consonant + virama + RRA should produce a rakar in Malayalam. However,
|
||||
+ // it seems that almost none of the fonts for Malayalam are set up to handle this.
|
||||
+ // So, we're going to force the issue here by using the rakar as defined with RA in most fonts.
|
||||
+
|
||||
+ if (fPreBaseConsonant == 0x0d31) { // RRA
|
||||
+ fPreBaseConsonant = 0x0d30; // RA
|
||||
+ }
|
||||
+
|
||||
+ if (fPreBaseConsonant != 0) {
|
||||
+ writeChar(fPreBaseConsonant, fPBCIndex, fPBCFeatures);
|
||||
+ writeChar(fPreBaseVirama,fPBCIndex-1,fPBCFeatures);
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
le_int32 getOutputIndex()
|
||||
{
|
||||
@@ -723,4 +754,5 @@
|
||||
}
|
||||
|
||||
+
|
||||
IndicClassTable::CharClass charClass = CC_RESERVED;
|
||||
IndicClassTable::CharClass nextClass = CC_RESERVED;
|
||||
@@ -730,7 +762,9 @@
|
||||
le_bool seenVattu = FALSE;
|
||||
le_bool seenBelowBaseForm = FALSE;
|
||||
+ le_bool seenPreBaseForm = FALSE;
|
||||
le_bool hasNukta = FALSE;
|
||||
le_bool hasBelowBaseForm = FALSE;
|
||||
le_bool hasPostBaseForm = FALSE;
|
||||
+ le_bool hasPreBaseForm = FALSE;
|
||||
|
||||
if (postBase < markStart && classTable->isNukta(chars[postBase])) {
|
||||
@@ -746,12 +780,20 @@
|
||||
hasBelowBaseForm = IndicClassTable::hasBelowBaseForm(charClass) && !hasNukta;
|
||||
hasPostBaseForm = IndicClassTable::hasPostBaseForm(charClass) && !hasNukta;
|
||||
+ hasPreBaseForm = IndicClassTable::hasPreBaseForm(charClass) && !hasNukta;
|
||||
|
||||
if (IndicClassTable::isConsonant(charClass)) {
|
||||
if (postBaseLimit == 0 || seenVattu ||
|
||||
(baseConsonant > baseLimit && !classTable->isVirama(chars[baseConsonant - 1])) ||
|
||||
- !(hasBelowBaseForm || hasPostBaseForm)) {
|
||||
+ !(hasBelowBaseForm || hasPostBaseForm || hasPreBaseForm)) {
|
||||
break;
|
||||
}
|
||||
|
||||
+ // Note any pre-base consonants
|
||||
+ if ( baseConsonant == lastConsonant && lastConsonant > 0 &&
|
||||
+ hasPreBaseForm && classTable->isVirama(chars[baseConsonant - 1])) {
|
||||
+ output.notePreBaseConsonant(lastConsonant,chars[lastConsonant],chars[lastConsonant-1],tagArray2);
|
||||
+ seenPreBaseForm = TRUE;
|
||||
+
|
||||
+ }
|
||||
// consonants with nuktas are never vattus
|
||||
seenVattu = IndicClassTable::isVattu(charClass) && !hasNukta;
|
||||
@@ -786,10 +828,12 @@
|
||||
|
||||
// write any pre-base consonants
|
||||
+ output.writePreBaseConsonant();
|
||||
+
|
||||
le_bool supressVattu = TRUE;
|
||||
|
||||
for (i = baseLimit; i < baseConsonant; i += 1) {
|
||||
LEUnicode ch = chars[i];
|
||||
- // Don't put 'blwf' on first consonant.
|
||||
- FeatureMask features = (i == baseLimit? tagArray2 : tagArray1);
|
||||
+ // Don't put 'pstf' or 'blwf' on anything before the base consonant.
|
||||
+ FeatureMask features = tagArray1 & ~( pstfFeatureMask | blwfFeatureMask );
|
||||
|
||||
charClass = classTable->getCharClass(ch);
|
||||
@@ -842,5 +886,5 @@
|
||||
|
||||
// write below-base consonants
|
||||
- if (baseConsonant != lastConsonant) {
|
||||
+ if (baseConsonant != lastConsonant && !seenPreBaseForm) {
|
||||
for (i = bcSpan + 1; i < postBase; i += 1) {
|
||||
output.writeChar(chars[i], i, tagArray1);
|
||||
@@ -872,5 +916,5 @@
|
||||
// write post-base consonants
|
||||
// FIXME: does this put the right tags on post-base consonants?
|
||||
- if (baseConsonant != lastConsonant) {
|
||||
+ if (baseConsonant != lastConsonant && !seenPreBaseForm) {
|
||||
if (postBase <= lastConsonant) {
|
||||
for (i = postBase; i <= lastConsonant; i += 1) {
|
15
extra/icu/icudata-stdlibs.patch
Normal file
15
extra/icu/icudata-stdlibs.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
Index: icu-52~m1/source/config/mh-linux
|
||||
===================================================================
|
||||
--- icu-52~m1.orig/source/config/mh-linux 2013-09-14 18:53:23.284040467 -0400
|
||||
+++ icu-52~m1/source/config/mh-linux 2013-09-14 18:53:23.284040467 -0400
|
||||
@@ -21,7 +21,9 @@
|
||||
LD_RPATH_PRE = -Wl,-rpath,
|
||||
|
||||
## These are the library specific LDFLAGS
|
||||
-LDFLAGSICUDT=-nodefaultlibs -nostdlib
|
||||
+#LDFLAGSICUDT=-nodefaultlibs -nostdlib
|
||||
+# Debian change: linking icudata as data only causes too many problems.
|
||||
+LDFLAGSICUDT=
|
||||
|
||||
## Compiler switch to embed a library name
|
||||
# The initial tab in the next line is to prevent icu-config from reading it.
|
Loading…
Reference in a new issue