mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
core/linux-armv5 to 4.8.1-1
This commit is contained in:
parent
e3646a9858
commit
7031ecc707
5 changed files with 14 additions and 68 deletions
|
@ -1,7 +1,7 @@
|
|||
From e83d3c778e4b1680f336daca93ff2736ef53cd84 Mon Sep 17 00:00:00 2001
|
||||
From 660d4994695ba46f3347ee464f84a72abf928c66 Mon Sep 17 00:00:00 2001
|
||||
From: Douglas Gilbert <[mailto:dgilbert@interlog.com]>
|
||||
Date: Mon, 12 Aug 2013 10:36:25 -0500
|
||||
Subject: [PATCH 1/4] at91: ariag25 updates
|
||||
Subject: [PATCH 1/3] at91: ariag25 updates
|
||||
|
||||
v2: dropped at91sam9x5 usart fix, as merged mainline
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 9fd19c7234f92245af7f263654665b8e09f475cf Mon Sep 17 00:00:00 2001
|
||||
From 1c07b8142cf2591ab9ff12ba17b3f1213e2cc97b Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 13 Jun 2015 13:46:30 -0600
|
||||
Subject: [PATCH 2/4] at91: arietta-g25 support
|
||||
Subject: [PATCH 2/3] at91: arietta-g25 support
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 3ff488bd66bf2bab45bdca9519916589835e6e0b Mon Sep 17 00:00:00 2001
|
||||
From ff32bdfbeb1f2167c6703d37f61e8d5e3d626eb6 Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 3/4] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
Subject: [PATCH 3/3] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
|
|
|
@ -1,52 +0,0 @@
|
|||
From 809986c8f2af8dd1d8bfdc05199248e1fa54177c Mon Sep 17 00:00:00 2001
|
||||
From: Linus Torvalds <torvalds@linux-foundation.org>
|
||||
Date: Mon, 3 Oct 2016 21:03:48 -0700
|
||||
Subject: [PATCH 4/4] Using BUG_ON() as an assert() is _never_ acceptable
|
||||
|
||||
That just generally kills the machine, and makes debugging only much
|
||||
harder, since the traces may long be gone.
|
||||
|
||||
Debugging by assert() is a disease. Don't do it. If you can continue,
|
||||
you're much better off doing so with a live machine where you have a
|
||||
much higher chance that the report actually makes it to the system logs,
|
||||
rather than result in a machine that is just completely dead.
|
||||
|
||||
The only valid situation for BUG_ON() is when continuing is not an
|
||||
option, because there is massive corruption. But if you are just
|
||||
verifying that something is true, you warn about your broken assumptions
|
||||
(preferably just once), and limp on.
|
||||
|
||||
Fixes: 22f2ac51b6d6 ("mm: workingset: fix crash in shadow node shrinker caused by replace_page_cache_page()")
|
||||
Cc: Johannes Weiner <hannes@cmpxchg.org>
|
||||
Cc: Miklos Szeredi <miklos@szeredi.hu>
|
||||
Cc: Andrew Morton <akpm@linux-foundation.org>
|
||||
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
|
||||
---
|
||||
include/linux/swap.h | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/include/linux/swap.h b/include/linux/swap.h
|
||||
index 4a529c9..e1d7614 100644
|
||||
--- a/include/linux/swap.h
|
||||
+++ b/include/linux/swap.h
|
||||
@@ -257,7 +257,7 @@ static inline void workingset_node_pages_inc(struct radix_tree_node *node)
|
||||
|
||||
static inline void workingset_node_pages_dec(struct radix_tree_node *node)
|
||||
{
|
||||
- VM_BUG_ON(!workingset_node_pages(node));
|
||||
+ VM_WARN_ON_ONCE(!workingset_node_pages(node));
|
||||
node->count--;
|
||||
}
|
||||
|
||||
@@ -273,7 +273,7 @@ static inline void workingset_node_shadows_inc(struct radix_tree_node *node)
|
||||
|
||||
static inline void workingset_node_shadows_dec(struct radix_tree_node *node)
|
||||
{
|
||||
- VM_BUG_ON(!workingset_node_shadows(node));
|
||||
+ VM_WARN_ON_ONCE(!workingset_node_shadows(node));
|
||||
node->count -= 1U << RADIX_TREE_COUNT_SHIFT;
|
||||
}
|
||||
|
||||
--
|
||||
2.10.0
|
||||
|
|
@ -7,38 +7,36 @@ pkgbase=linux-armv5
|
|||
_srcname=linux-4.8
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv5 multi-platform"
|
||||
pkgver=4.8.0
|
||||
pkgrel=2
|
||||
pkgver=4.8.1
|
||||
pkgrel=1
|
||||
arch=('arm')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
||||
options=('!strip')
|
||||
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
||||
#"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
|
||||
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
|
||||
'0001-at91-ariag25-updates.patch'
|
||||
'0002-at91-arietta-g25-support.patch'
|
||||
'0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||
'0004-Using-BUG_ON-as-an-assert-is-_never_-acceptable.patch'
|
||||
'config')
|
||||
md5sums=('c1af0afbd3df35c1ccdc7a5118cd2d07'
|
||||
'4abc5b3415be0199563eeaf5bdb222d6'
|
||||
'8e71aa21adfbf6fbc69408a6d63d9cd4'
|
||||
'57c403eab06acb9f867a694074b06f8e'
|
||||
'734cd10025655570c4d4f02041d9a44e'
|
||||
'349734be5387f1605074515ad7207627'
|
||||
'd924f9e1c4d4ee5c775c26a5fe5410ee'
|
||||
'010bda68c324c7ab962ca37fccebaba5'
|
||||
'87f22b8c22f67e21931ae762147e04e6'
|
||||
'04e8b83be4eafd9c9646d5bec6d5a772')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
# add upstream patch
|
||||
#git apply --whitespace=nowarn "${srcdir}/patch-${pkgver}"
|
||||
git apply --whitespace=nowarn "${srcdir}/patch-${pkgver}"
|
||||
|
||||
# ALARM patches
|
||||
git apply ../0001-at91-ariag25-updates.patch
|
||||
git apply ../0002-at91-arietta-g25-support.patch
|
||||
git apply ../0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||
git apply ../0004-Using-BUG_ON-as-an-assert-is-_never_-acceptable.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
|
Loading…
Reference in a new issue