mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/binutils to 2.23.2-1
This commit is contained in:
parent
a8e452c56d
commit
703e0408d8
2 changed files with 176 additions and 6 deletions
|
@ -10,8 +10,8 @@
|
|||
noautobuild=1
|
||||
|
||||
pkgname=binutils
|
||||
pkgver=2.23.1
|
||||
pkgrel=3
|
||||
pkgver=2.23.2
|
||||
pkgrel=1
|
||||
pkgdesc="A set of programs to assemble and manipulate binary and object files"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.gnu.org/software/binutils/"
|
||||
|
@ -21,11 +21,19 @@ depends=('glibc>=2.17' 'zlib')
|
|||
checkdepends=('dejagnu')
|
||||
options=('!libtool' '!distcc' '!ccache')
|
||||
install=binutils.install
|
||||
source=(ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2{,.sig})
|
||||
md5sums=('33adb18c3048d057ac58d07a3f1adb38'
|
||||
'1869b37216e7d7eff7e335a69e0882fd')
|
||||
source=(ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2{,.sig}
|
||||
binutils-2.23.2-texinfo-5.0.patch)
|
||||
md5sums=('4f8fa651e35ef262edc01d60fb45702e'
|
||||
'dfde4428f08d91f309cdcfe92bf28d08'
|
||||
'34e439ce23213a91e2af872dfbb5094c')
|
||||
|
||||
build() {
|
||||
cd ${srcdir}/binutils-${pkgver}
|
||||
|
||||
# http://sourceware.org/git/?p=binutils.git;a=patch;h=e02bf935
|
||||
# http://sourceware.org/git/?p=binutils.git;a=patch;h=935f8542
|
||||
patch -p1 -i ${srcdir}/binutils-2.23.2-texinfo-5.0.patch
|
||||
|
||||
cd ${srcdir}
|
||||
mkdir binutils-build && cd binutils-build
|
||||
|
||||
|
@ -47,7 +55,7 @@ build() {
|
|||
# check the host environment and makes sure all the necessary tools are available
|
||||
make configure-host
|
||||
|
||||
make tooldir=${pkgdir}/usr
|
||||
make tooldir=/usr
|
||||
}
|
||||
|
||||
check() {
|
||||
|
|
162
core/binutils/binutils-2.23.2-texinfo-5.0.patch
Normal file
162
core/binutils/binutils-2.23.2-texinfo-5.0.patch
Normal file
|
@ -0,0 +1,162 @@
|
|||
diff --git a/bfd/doc/bfd.texinfo b/bfd/doc/bfd.texinfo
|
||||
index 45ffa73..3aa3300 100644
|
||||
--- a/bfd/doc/bfd.texinfo
|
||||
+++ b/bfd/doc/bfd.texinfo
|
||||
@@ -322,7 +324,7 @@ All of BFD lives in one directory.
|
||||
@printindex cp
|
||||
|
||||
@tex
|
||||
-% I think something like @colophon should be in texinfo. In the
|
||||
+% I think something like @@colophon should be in texinfo. In the
|
||||
% meantime:
|
||||
\long\def\colophon{\hbox to0pt{}\vfill
|
||||
\centerline{The body of this manual is set in}
|
||||
@@ -333,7 +335,7 @@ All of BFD lives in one directory.
|
||||
\centerline{{\sl\fontname\tensl\/}}
|
||||
\centerline{are used for emphasis.}\vfill}
|
||||
\page\colophon
|
||||
-% Blame: doc@cygnus.com, 28mar91.
|
||||
+% Blame: doc@@cygnus.com, 28mar91.
|
||||
@end tex
|
||||
|
||||
@bye
|
||||
diff --git a/binutils/doc/binutils.texi b/binutils/doc/binutils.texi
|
||||
index 56a0510..fb1802b 100644
|
||||
--- a/binutils/doc/binutils.texi
|
||||
+++ b/binutils/doc/binutils.texi
|
||||
@@ -148,18 +148,18 @@ in the section entitled ``GNU Free Documentation License''.
|
||||
* objcopy:: Copy and translate object files
|
||||
* objdump:: Display information from object files
|
||||
* ranlib:: Generate index to archive contents
|
||||
-* readelf:: Display the contents of ELF format files
|
||||
* size:: List section sizes and total size
|
||||
* strings:: List printable strings from files
|
||||
* strip:: Discard symbols
|
||||
-* elfedit:: Update the ELF header of ELF files
|
||||
* c++filt:: Filter to demangle encoded C++ symbols
|
||||
* cxxfilt: c++filt. MS-DOS name for c++filt
|
||||
* addr2line:: Convert addresses to file and line
|
||||
* nlmconv:: Converts object code into an NLM
|
||||
-* windres:: Manipulate Windows resources
|
||||
* windmc:: Generator for Windows message resources
|
||||
+* windres:: Manipulate Windows resources
|
||||
* dlltool:: Create files needed to build and use DLLs
|
||||
+* readelf:: Display the contents of ELF format files
|
||||
+* elfedit:: Update the ELF header of ELF files
|
||||
* Common Options:: Command-line options for all utilities
|
||||
* Selecting the Target System:: How these utilities determine the target
|
||||
* Reporting Bugs:: Reporting Bugs
|
||||
@@ -2907,7 +2907,7 @@ the Info entries for @file{binutils}.
|
||||
@c man end
|
||||
@end ignore
|
||||
|
||||
-@node c++filt, addr2line, elfedit, Top
|
||||
+@node c++filt, addr2line, strip, Top
|
||||
@chapter c++filt
|
||||
|
||||
@kindex c++filt
|
||||
@@ -4384,7 +4384,7 @@ equivalent. At least one of the @option{--output-mach},
|
||||
|
||||
@table @env
|
||||
|
||||
-@itemx --input-mach=@var{machine}
|
||||
+@item --input-mach=@var{machine}
|
||||
Set the matching input ELF machine type to @var{machine}. If
|
||||
@option{--input-mach} isn't specified, it will match any ELF
|
||||
machine types.
|
||||
@@ -4392,21 +4392,21 @@ machine types.
|
||||
The supported ELF machine types are, @var{L1OM}, @var{K1OM} and
|
||||
@var{x86-64}.
|
||||
|
||||
-@itemx --output-mach=@var{machine}
|
||||
+@item --output-mach=@var{machine}
|
||||
Change the ELF machine type in the ELF header to @var{machine}. The
|
||||
supported ELF machine types are the same as @option{--input-mach}.
|
||||
|
||||
-@itemx --input-type=@var{type}
|
||||
+@item --input-type=@var{type}
|
||||
Set the matching input ELF file type to @var{type}. If
|
||||
@option{--input-type} isn't specified, it will match any ELF file types.
|
||||
|
||||
The supported ELF file types are, @var{rel}, @var{exec} and @var{dyn}.
|
||||
|
||||
-@itemx --output-type=@var{type}
|
||||
+@item --output-type=@var{type}
|
||||
Change the ELF file type in the ELF header to @var{type}. The
|
||||
supported ELF types are the same as @option{--input-type}.
|
||||
|
||||
-@itemx --input-osabi=@var{osabi}
|
||||
+@item --input-osabi=@var{osabi}
|
||||
Set the matching input ELF file OSABI to @var{osabi}. If
|
||||
@option{--input-osabi} isn't specified, it will match any ELF OSABIs.
|
||||
|
||||
@@ -4416,7 +4416,7 @@ The supported ELF OSABIs are, @var{none}, @var{HPUX}, @var{NetBSD},
|
||||
@var{FreeBSD}, @var{TRU64}, @var{Modesto}, @var{OpenBSD}, @var{OpenVMS},
|
||||
@var{NSK}, @var{AROS} and @var{FenixOS}.
|
||||
|
||||
-@itemx --output-osabi=@var{osabi}
|
||||
+@item --output-osabi=@var{osabi}
|
||||
Change the ELF OSABI in the ELF header to @var{osabi}. The
|
||||
supported ELF OSABI are the same as @option{--input-osabi}.
|
||||
|
||||
diff --git a/ld/ld.texinfo b/ld/ld.texinfo
|
||||
index c7ae2a5..4777ad5 100644
|
||||
--- a/ld/ld.texinfo
|
||||
+++ b/ld/ld.texinfo
|
||||
@@ -142,12 +144,12 @@ in the section entitled ``GNU Free Documentation License''.
|
||||
@ifset ARM
|
||||
* ARM:: ld and the ARM family
|
||||
@end ifset
|
||||
-@ifset HPPA
|
||||
-* HPPA ELF32:: ld and HPPA 32-bit ELF
|
||||
-@end ifset
|
||||
@ifset M68HC11
|
||||
* M68HC11/68HC12:: ld and the Motorola 68HC11 and 68HC12 families
|
||||
@end ifset
|
||||
+@ifset HPPA
|
||||
+* HPPA ELF32:: ld and HPPA 32-bit ELF
|
||||
+@end ifset
|
||||
@ifset M68K
|
||||
* M68K:: ld and Motorola 68K family
|
||||
@end ifset
|
||||
@@ -6012,6 +6014,9 @@ functionality are not listed.
|
||||
@ifset I960
|
||||
* i960:: @command{ld} and the Intel 960 family
|
||||
@end ifset
|
||||
+@ifset M68HC11
|
||||
+* M68HC11/68HC12:: @code{ld} and the Motorola 68HC11 and 68HC12 families
|
||||
+@end ifset
|
||||
@ifset ARM
|
||||
* ARM:: @command{ld} and the ARM family
|
||||
@end ifset
|
||||
@@ -6027,9 +6032,6 @@ functionality are not listed.
|
||||
@ifset MSP430
|
||||
* MSP430:: @command{ld} and MSP430
|
||||
@end ifset
|
||||
-@ifset M68HC11
|
||||
-* M68HC11/68HC12:: @code{ld} and the Motorola 68HC11 and 68HC12 families
|
||||
-@end ifset
|
||||
@ifset POWERPC
|
||||
* PowerPC ELF32:: @command{ld} and PowerPC 32-bit ELF Support
|
||||
@end ifset
|
||||
@@ -7877,7 +7879,7 @@ If you have more than one @code{SECT} statement for the same
|
||||
@printindex cp
|
||||
|
||||
@tex
|
||||
-% I think something like @colophon should be in texinfo. In the
|
||||
+% I think something like @@colophon should be in texinfo. In the
|
||||
% meantime:
|
||||
\long\def\colophon{\hbox to0pt{}\vfill
|
||||
\centerline{The body of this manual is set in}
|
||||
@@ -7888,7 +7890,7 @@ If you have more than one @code{SECT} statement for the same
|
||||
\centerline{{\sl\fontname\tensl\/}}
|
||||
\centerline{are used for emphasis.}\vfill}
|
||||
\page\colophon
|
||||
-% Blame: doc@cygnus.com, 28mar91.
|
||||
+% Blame: doc@@cygnus.com, 28mar91.
|
||||
@end tex
|
||||
|
||||
@bye
|
||||
--
|
||||
1.7.1
|
||||
|
Loading…
Reference in a new issue