mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/mesa to 20.1.0-4
This commit is contained in:
parent
5786fa1409
commit
70913abe18
4 changed files with 26 additions and 177 deletions
|
@ -1,53 +0,0 @@
|
||||||
From 979ae78318c3e37cc0e0579b8d1f05c46bb76e7d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Danylo Piliaiev <danylo.piliaiev@globallogic.com>
|
|
||||||
Date: Tue, 19 May 2020 20:35:49 +0300
|
|
||||||
Subject: [PATCH] meson: Disable GCC's dead store elimination for memory
|
|
||||||
zeroing custom new
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Some classes use custom new operator which zeroes memory, however gcc does
|
|
||||||
aggressive dead-store elimination which threats all writes to the memory
|
|
||||||
before the constructor as "dead stores".
|
|
||||||
|
|
||||||
For now we disable this optimization.
|
|
||||||
|
|
||||||
The new operators in question are declared via:
|
|
||||||
DECLARE_RZALLOC_CXX_OPERATORS
|
|
||||||
DECLARE_LINEAR_ZALLOC_CXX_OPERATORS
|
|
||||||
|
|
||||||
The issue was found with lto builds, however there is no guarantee that
|
|
||||||
it didn't happen with ordinary ones.
|
|
||||||
|
|
||||||
CC: <mesa-stable@lists.freedesktop.org>
|
|
||||||
Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/2977
|
|
||||||
Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/1358
|
|
||||||
Signed-off-by: Danylo Piliaiev <danylo.piliaiev@globallogic.com>
|
|
||||||
Reviewed-by: Marek Olšák <marek.olsak@amd.com>
|
|
||||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/5104>
|
|
||||||
(cherry picked from commit 5500a2b7fc558217bbd4c2a966ab6fcadaed8b3b)
|
|
||||||
Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
|
|
||||||
---
|
|
||||||
meson.build | 5 +++++
|
|
||||||
1 files changed, 5 insertions(+), 0 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/meson.build b/meson.build
|
|
||||||
index ba4fdb2a59f..434684c8bcc 100644
|
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -980,6 +980,11 @@ else
|
|
||||||
'-fno-math-errno',
|
|
||||||
'-fno-trapping-math',
|
|
||||||
'-Qunused-arguments',
|
|
||||||
+ # Some classes use custom new operator which zeroes memory, however
|
|
||||||
+ # gcc does aggressive dead-store elimination which threats all writes
|
|
||||||
+ # to the memory before the constructor as "dead stores".
|
|
||||||
+ # For now we disable this optimization.
|
|
||||||
+ '-flifetime-dse=1',
|
|
||||||
]
|
|
||||||
# MinGW chokes on format specifiers and I can't get it all working
|
|
||||||
if not (cc.get_id() == 'gcc' and host_machine.system() == 'windows')
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
|
@ -1,40 +0,0 @@
|
||||||
From 283e815339a15fa99039c69f1e225269790ae955 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Pierre-Eric Pelloux-Prayer <pierre-eric.pelloux-prayer@amd.com>
|
|
||||||
Date: Thu, 5 Mar 2020 09:37:58 +0100
|
|
||||||
Subject: [PATCH] omx: fix build with gcc 10
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
bellagio/omx header files reference a global variable without the
|
|
||||||
extern keyworkd.
|
|
||||||
Now that gcc-10 enables the '-fno-common' by default the build fails.
|
|
||||||
Since these are external headers we can't easily fix them, so for
|
|
||||||
now build the omx module with the '-fcommon' flag to keep the
|
|
||||||
previous behavior.
|
|
||||||
|
|
||||||
See https://gitlab.freedesktop.org/mesa/mesa/issues/2385
|
|
||||||
|
|
||||||
Reviewed-by: Michel Dänzer <mdaenzer@redhat.com>
|
|
||||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4058>
|
|
||||||
Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
|
|
||||||
---
|
|
||||||
src/gallium/state_trackers/omx/meson.build | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/gallium/state_trackers/omx/meson.build b/src/gallium/state_trackers/omx/meson.build
|
|
||||||
index 3aa82090c91..987d3e23c84 100644
|
|
||||||
--- a/src/gallium/state_trackers/omx/meson.build
|
|
||||||
+++ b/src/gallium/state_trackers/omx/meson.build
|
|
||||||
@@ -65,7 +65,7 @@ endif
|
|
||||||
libomx_st = static_library(
|
|
||||||
'omx_st',
|
|
||||||
files_omx,
|
|
||||||
- c_args : [c_vis_args],
|
|
||||||
+ c_args : [c_vis_args, '-fcommon'],
|
|
||||||
include_directories : inc_st_omx,
|
|
||||||
dependencies : dep_st_omx,
|
|
||||||
)
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
|
@ -1,56 +0,0 @@
|
||||||
From 8dacf5f9d1df95c768016a1b92465bbabed37b54 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Vinson Lee <vlee@freedesktop.org>
|
|
||||||
Date: Thu, 30 Jan 2020 20:48:26 -0800
|
|
||||||
Subject: [PATCH] swr: Fix build with GCC 10.
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
GCC 10 added _mm256_storeu2_m128i.
|
|
||||||
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=91341
|
|
||||||
|
|
||||||
This patch fixes this build error with GCC 10.
|
|
||||||
|
|
||||||
In file included from src/gallium/drivers/swr/rasterizer/codegen/gen_knobs.cpp:39:
|
|
||||||
../src/gallium/drivers/swr/rasterizer/common/os.h:178:20: error: ‘void _mm256_storeu2_m128i(__m128i*, __m128i*, __m256i)’ redeclared inline without ‘gnu_inline’ attribute
|
|
||||||
178 | static INLINE void _mm256_storeu2_m128i(__m128i* hi, __m128i* lo, __m256i a)
|
|
||||||
| ^~~~~~~~~~~~~~~~~~~~
|
|
||||||
In file included from /usr/lib/gcc/x86_64-redhat-linux/10/include/immintrin.h:51,
|
|
||||||
from /usr/lib/gcc/x86_64-redhat-linux/10/include/x86intrin.h:32,
|
|
||||||
from ../src/gallium/drivers/swr/rasterizer/common/os.h:107,
|
|
||||||
from src/gallium/drivers/swr/rasterizer/codegen/gen_knobs.cpp:39:
|
|
||||||
/usr/lib/gcc/x86_64-redhat-linux/10/include/avxintrin.h:1580:1: note: ‘void _mm256_storeu2_m128i(__m128i_u*, __m128i_u*, __m256i)’ previously defined here
|
|
||||||
1580 | _mm256_storeu2_m128i (__m128i_u *__PH, __m128i_u *__PL, __m256i __A)
|
|
||||||
| ^~~~~~~~~~~~~~~~~~~~
|
|
||||||
|
|
||||||
Signed-off-by: Vinson Lee <vlee@freedesktop.org>
|
|
||||||
Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3650>
|
|
||||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3650>
|
|
||||||
Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
|
|
||||||
---
|
|
||||||
src/gallium/drivers/swr/rasterizer/common/os.h | 4 +++-
|
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/gallium/drivers/swr/rasterizer/common/os.h b/src/gallium/drivers/swr/rasterizer/common/os.h
|
|
||||||
index e812da39851..c4ee00bc91d 100644
|
|
||||||
--- a/src/gallium/drivers/swr/rasterizer/common/os.h
|
|
||||||
+++ b/src/gallium/drivers/swr/rasterizer/common/os.h
|
|
||||||
@@ -174,12 +174,14 @@ inline uint64_t __rdtsc()
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#if !defined(__clang__) && !defined(__INTEL_COMPILER)
|
|
||||||
-// Intrinsic not defined in gcc
|
|
||||||
+// Intrinsic not defined in gcc < 10
|
|
||||||
+#if (__GNUC__) && (GCC_VERSION < 100000)
|
|
||||||
static INLINE void _mm256_storeu2_m128i(__m128i* hi, __m128i* lo, __m256i a)
|
|
||||||
{
|
|
||||||
_mm_storeu_si128((__m128i*)lo, _mm256_castsi256_si128(a));
|
|
||||||
_mm_storeu_si128((__m128i*)hi, _mm256_extractf128_si256(a, 0x1));
|
|
||||||
}
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
// gcc prior to 4.9 doesn't have _mm*_undefined_*
|
|
||||||
#if (__GNUC__) && (GCC_VERSION < 409000)
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
|
@ -1,5 +1,7 @@
|
||||||
|
# Maintainer: Laurent Carlier <lordheavym@gmail.com>
|
||||||
|
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||||
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
|
# Contributor: Andreas Radke <andyrtr@archlinux.org>
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
# - Removed DRI and Gallium3D drivers/packages for chipsets that don't exist in our ARM devices (intel, VMware svga).
|
# - Removed DRI and Gallium3D drivers/packages for chipsets that don't exist in our ARM devices (intel, VMware svga).
|
||||||
|
@ -7,46 +9,34 @@
|
||||||
# - remove makedepend on valgrind, -Dvalgrind=false
|
# - remove makedepend on valgrind, -Dvalgrind=false
|
||||||
|
|
||||||
pkgbase=mesa
|
pkgbase=mesa
|
||||||
pkgname=('vulkan-mesa-layer' 'opencl-mesa' 'vulkan-radeon' 'libva-mesa-driver' 'mesa-vdpau' 'mesa')
|
pkgname=('vulkan-mesa-layers' 'opencl-mesa' 'vulkan-radeon' 'libva-mesa-driver' 'mesa-vdpau' 'mesa')
|
||||||
pkgdesc="An open-source implementation of the OpenGL specification"
|
pkgdesc="An open-source implementation of the OpenGL specification"
|
||||||
pkgver=20.0.7
|
pkgver=20.1.0
|
||||||
pkgrel=3
|
pkgrel=4
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence' 'libxxf86vm'
|
makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence' 'libxxf86vm'
|
||||||
'libxdamage' 'libvdpau' 'libva' 'wayland' 'wayland-protocols' 'zstd'
|
'libxdamage' 'libvdpau' 'libva' 'wayland' 'wayland-protocols' 'zstd' 'elfutils' 'llvm'
|
||||||
'elfutils' 'llvm' 'libomxil-bellagio' 'libclc' 'clang' 'libglvnd' 'lm_sensors'
|
'libomxil-bellagio' 'libclc' 'clang' 'libglvnd' 'libunwind' 'lm_sensors' 'libxrandr'
|
||||||
'libxrandr' 'glslang' 'meson')
|
'glslang' 'meson')
|
||||||
url="https://www.mesa3d.org/"
|
url="https://www.mesa3d.org/"
|
||||||
license=('custom')
|
license=('custom')
|
||||||
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
|
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
|
||||||
0001-Rip-out-VC4-forced-NEON.patch
|
0001-Rip-out-VC4-forced-NEON.patch
|
||||||
0001-swr-Fix-build-with-GCC-10.patch
|
|
||||||
0001-omx-fix-build-with-gcc-10.patch
|
|
||||||
0001-meson-Disable-GCC-s-dead-store-elimination-for-memor.patch
|
|
||||||
LICENSE)
|
LICENSE)
|
||||||
sha512sums=('00baae50f14bf2b08b5654dffb11cf67499dc1825e1700b137fb5719e767e0e78e789979df2c194f677ea9c5e531f34965d47b9e37c239944c38d0570c7a9685'
|
sha512sums=('f49230d18febe1bfd7c6282ab95fc244530f5cef56df0f804d8bece8a70bafcb445b8b83df96ad1b4c5af022c4e39a71f19a8f7e47b1fb09ada2b1a1317ff3be'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'ba55fd9816ebd9147be120da1fd4fa0364d19967a11570e6d5dd9d8b4f7971df46ced8b151ee07afaaa98043e131eed14918ec25f8c9b0f7e5c53f452674ee5c'
|
'ba55fd9816ebd9147be120da1fd4fa0364d19967a11570e6d5dd9d8b4f7971df46ced8b151ee07afaaa98043e131eed14918ec25f8c9b0f7e5c53f452674ee5c'
|
||||||
'296a7502e959ccd2a6f1279878c0562a853ecdd78b5960196fc8f99ed8dd995c6e1106551aef7a53db891295235ca55676788e7cf78e336e2d5ee49e4e463be5'
|
|
||||||
'e1f0fa2a8802184580d9d95777f02a1c35bf71c3ab380d88e5b9268f84c2ac338fa517d20065094b7764490bbbfb290c1c5ad6dec6d27f3dbf737dfa0b6c7263'
|
|
||||||
'566ad6f4195124b4af05d4bba1e01cc5e9ac466f11ddd900a2f5bfd830aa19cdccb3f9625901340b5fe62e7d8ea50aa336ab5031a658fe90916d847b2e9946e0'
|
|
||||||
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7')
|
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7')
|
||||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
|
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
|
||||||
'946D09B5E4C9845E63075FF1D961C596A7203456' # Andres Gomez <tanty@igalia.com>
|
'946D09B5E4C9845E63075FF1D961C596A7203456' # Andres Gomez <tanty@igalia.com>
|
||||||
'E3E8F480C52ADD73B278EE78E1ECBE07D7D70895' # Juan Antonio Suárez Romero (Igalia, S.L.) <jasuarez@igalia.com>
|
'E3E8F480C52ADD73B278EE78E1ECBE07D7D70895' # Juan Antonio Suárez Romero (Igalia, S.L.) <jasuarez@igalia.com>
|
||||||
'A5CC9FEC93F2F837CB044912336909B6B25FADFA' # Juan A. Suarez Romero <jasuarez@igalia.com>
|
'A5CC9FEC93F2F837CB044912336909B6B25FADFA' # Juan A. Suarez Romero <jasuarez@igalia.com>
|
||||||
'71C4B75620BC75708B4BDB254C95FAAB3EB073EC' # Dylan Baker <dylan@pnwbakers.com>
|
'71C4B75620BC75708B4BDB254C95FAAB3EB073EC' # Dylan Baker <dylan@pnwbakers.com>
|
||||||
'57551DE15B968F6341C248F68D8E31AFC32428A6') # Eric Engestrom <eric@engestrom.ch>
|
'CC31EF29D32A6637889530F2481D0E9D964E5593') # Eric Engestrom <eric@engestrom.ch>
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd mesa-$pkgver
|
cd mesa-$pkgver
|
||||||
|
|
||||||
# fix building with gcc 10
|
|
||||||
patch -Np1 -i ../0001-swr-Fix-build-with-GCC-10.patch
|
|
||||||
patch -Np1 -i ../0001-omx-fix-build-with-gcc-10.patch
|
|
||||||
# LTO fix
|
|
||||||
patch -Np1 -i ../0001-meson-Disable-GCC-s-dead-store-elimination-for-memor.patch
|
|
||||||
|
|
||||||
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && patch -p1 -i ../0001-Rip-out-VC4-forced-NEON.patch || true
|
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && patch -p1 -i ../0001-Rip-out-VC4-forced-NEON.patch || true
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -66,6 +56,7 @@ build() {
|
||||||
-D gallium-drivers=r300,r600,radeonsi,freedreno,nouveau,swrast,virgl${GALLIUM} \
|
-D gallium-drivers=r300,r600,radeonsi,freedreno,nouveau,swrast,virgl${GALLIUM} \
|
||||||
-D vulkan-drivers=amd \
|
-D vulkan-drivers=amd \
|
||||||
-D vulkan-overlay-layer=true \
|
-D vulkan-overlay-layer=true \
|
||||||
|
-D vulkan-device-select-layer=true \
|
||||||
-D dri3=true \
|
-D dri3=true \
|
||||||
-D egl=true \
|
-D egl=true \
|
||||||
-D gallium-extra-hud=true \
|
-D gallium-extra-hud=true \
|
||||||
|
@ -92,11 +83,11 @@ build() {
|
||||||
meson configure build
|
meson configure build
|
||||||
|
|
||||||
ninja -C build xmlpool-pot xmlpool-update-po xmlpool-gmo
|
ninja -C build xmlpool-pot xmlpool-update-po xmlpool-gmo
|
||||||
ninja -C build
|
meson compile -C build
|
||||||
|
|
||||||
# fake installation to be seperated into packages
|
# fake installation to be seperated into packages
|
||||||
# outside of fakeroot but mesa doesn't need to chown/mod
|
# outside of fakeroot but mesa doesn't need to chown/mod
|
||||||
DESTDIR="${srcdir}/fakeinstall" ninja -C build install
|
DESTDIR="${srcdir}/fakeinstall" meson install -C build
|
||||||
}
|
}
|
||||||
|
|
||||||
_install() {
|
_install() {
|
||||||
|
@ -109,13 +100,19 @@ _install() {
|
||||||
done
|
done
|
||||||
}
|
}
|
||||||
|
|
||||||
package_vulkan-mesa-layer() {
|
package_vulkan-mesa-layers() {
|
||||||
pkgdesc="Vulkan overlay layer to display information about the application"
|
pkgdesc="Mesa's Vulkan layers"
|
||||||
|
depends=('libdrm' 'libxcb' 'wayland')
|
||||||
|
conflicts=('vulkan-mesa-layer')
|
||||||
|
replaces=('vulkan-mesa-layer')
|
||||||
|
|
||||||
_install fakeinstall/usr/share/vulkan/explicit_layer.d
|
_install fakeinstall/usr/share/vulkan/explicit_layer.d
|
||||||
_install fakeinstall/usr/lib/libVkLayer_MESA_overlay.so
|
_install fakeinstall/usr/lib/libVkLayer_MESA_overlay.so
|
||||||
_install fakeinstall/usr/bin/mesa-overlay-control.py
|
_install fakeinstall/usr/bin/mesa-overlay-control.py
|
||||||
|
|
||||||
|
_install fakeinstall/usr/share/vulkan/implicit_layer.d
|
||||||
|
_install fakeinstall/usr/lib/libVkLayer_MESA_device_select.so
|
||||||
|
|
||||||
install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
|
install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -135,7 +132,7 @@ package_opencl-mesa() {
|
||||||
package_vulkan-radeon() {
|
package_vulkan-radeon() {
|
||||||
pkgdesc="Radeon's Vulkan mesa driver"
|
pkgdesc="Radeon's Vulkan mesa driver"
|
||||||
depends=('wayland' 'libx11' 'libxshmfence' 'libelf' 'libdrm' 'zstd' 'llvm-libs')
|
depends=('wayland' 'libx11' 'libxshmfence' 'libelf' 'libdrm' 'zstd' 'llvm-libs')
|
||||||
optdepends=('vulkan-mesa-layer: a vulkan layer to display information using an overlay')
|
optdepends=('vulkan-mesa-layers: additional vulkan layers')
|
||||||
provides=('vulkan-driver')
|
provides=('vulkan-driver')
|
||||||
|
|
||||||
_install fakeinstall/usr/share/vulkan/icd.d/radeon_icd*.json
|
_install fakeinstall/usr/share/vulkan/icd.d/radeon_icd*.json
|
||||||
|
@ -164,7 +161,8 @@ package_mesa-vdpau() {
|
||||||
|
|
||||||
package_mesa() {
|
package_mesa() {
|
||||||
depends=('libdrm' 'wayland' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'libelf'
|
depends=('libdrm' 'wayland' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'libelf'
|
||||||
'libomxil-bellagio' 'llvm-libs' 'lm_sensors' 'libglvnd')
|
'libomxil-bellagio' 'libunwind' 'llvm-libs' 'lm_sensors' 'libglvnd'
|
||||||
|
'zstd')
|
||||||
optdepends=('opengl-man-pages: for the OpenGL API man pages'
|
optdepends=('opengl-man-pages: for the OpenGL API man pages'
|
||||||
'mesa-vdpau: for accelerated video playback'
|
'mesa-vdpau: for accelerated video playback'
|
||||||
'libva-mesa-driver: for accelerated video playback')
|
'libva-mesa-driver: for accelerated video playback')
|
||||||
|
@ -196,7 +194,7 @@ package_mesa() {
|
||||||
|
|
||||||
# indirect rendering
|
# indirect rendering
|
||||||
ln -s /usr/lib/libGLX_mesa.so.0 "${pkgdir}/usr/lib/libGLX_indirect.so.0"
|
ln -s /usr/lib/libGLX_mesa.so.0 "${pkgdir}/usr/lib/libGLX_indirect.so.0"
|
||||||
|
|
||||||
# make sure there are no files left to install
|
# make sure there are no files left to install
|
||||||
find fakeinstall -depth -print0 | xargs -0 rmdir
|
find fakeinstall -depth -print0 | xargs -0 rmdir
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue