mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/uboot-odroid to 2014.10-1
This commit is contained in:
parent
1b255c97cb
commit
70a7afca4b
4 changed files with 28 additions and 1855 deletions
|
@ -1,33 +1,33 @@
|
|||
From b6e6bb2392cbf8d2e21685ae7b7d818436d146f6 Mon Sep 17 00:00:00 2001
|
||||
From d07e0f54020cf26196e2554c6dbabf62bc729ab1 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 22 Aug 2014 17:51:41 -0600
|
||||
Subject: [PATCH 2/2] arch linux arm modifications
|
||||
Subject: [PATCH] arch linux arm modifications
|
||||
|
||||
---
|
||||
include/configs/odroid.h | 163 ++++++++++++++++++-----------------------------
|
||||
1 file changed, 62 insertions(+), 101 deletions(-)
|
||||
|
||||
diff --git a/include/configs/odroid.h b/include/configs/odroid.h
|
||||
index c0d4157..da1957e 100644
|
||||
index b928af8..8466e57 100644
|
||||
--- a/include/configs/odroid.h
|
||||
+++ b/include/configs/odroid.h
|
||||
@@ -14,6 +14,7 @@
|
||||
|
||||
#include <configs/exynos4-dt.h>
|
||||
#include <configs/exynos4-common.h>
|
||||
|
||||
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
|
||||
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
|
||||
#define CONFIG_SYS_PROMPT "Odroid # " /* Monitor Command Prompt */
|
||||
|
||||
#undef CONFIG_DEFAULT_DEVICE_TREE
|
||||
@@ -37,6 +38,7 @@
|
||||
|
||||
@@ -35,6 +36,7 @@
|
||||
#define CONFIG_SYS_MEMTEST_END (CONFIG_SYS_SDRAM_BASE + 0x5E00000)
|
||||
#define CONFIG_SYS_LOAD_ADDR (CONFIG_SYS_SDRAM_BASE + 0x3E00000)
|
||||
#define CONFIG_SYS_TEXT_BASE 0x43e00000
|
||||
+#define CONFIG_LOADADDR 0x40007FC0
|
||||
|
||||
#include <linux/sizes.h>
|
||||
/* Size of malloc() pool */
|
||||
@@ -51,11 +53,12 @@
|
||||
|
||||
@@ -47,11 +49,12 @@
|
||||
#define CONFIG_SYS_CONSOLE_IS_IN_ENV
|
||||
|
||||
#define CONFIG_CMD_BOOTZ
|
||||
|
@ -43,7 +43,7 @@ index c0d4157..da1957e 100644
|
|||
|
||||
#define CONFIG_SYS_INIT_SP_ADDR (CONFIG_SYS_LOAD_ADDR \
|
||||
- GENERATED_GBL_DATA_SIZE)
|
||||
@@ -70,35 +73,6 @@
|
||||
@@ -66,35 +69,6 @@
|
||||
#define CONFIG_ENV_OFFSET (SZ_1K * 1280) /* 1.25 MiB offset */
|
||||
#define CONFIG_ENV_OVERWRITE
|
||||
|
||||
|
@ -79,7 +79,7 @@ index c0d4157..da1957e 100644
|
|||
/*
|
||||
* Bootable media layout:
|
||||
* dev: SD eMMC(part boot)
|
||||
@@ -107,77 +81,64 @@
|
||||
@@ -103,77 +77,64 @@
|
||||
* UBOOT 63 62
|
||||
* TZSW 2111 2110
|
||||
* ENV 2560 2560(part user)
|
||||
|
@ -99,15 +99,15 @@ index c0d4157..da1957e 100644
|
|||
- "${fdtfile}\0" \
|
||||
- "check_ramdisk=" \
|
||||
- "if run loadinitrd; then " \
|
||||
- "setenv ramdisk_addr ${initrdaddr};" \
|
||||
- "setenv initrd_addr ${initrdaddr};" \
|
||||
- "else " \
|
||||
- "setenv ramdisk_addr;" \
|
||||
- "setenv initrd_addr -;" \
|
||||
- "fi;\0" \
|
||||
- "check_dtb=" \
|
||||
- "if run loaddtb; then " \
|
||||
- "setenv image_addr ${kerneladdr} - ${fdtaddr};" \
|
||||
- "setenv fdt_addr ${fdtaddr};" \
|
||||
- "else " \
|
||||
- "setenv image_addr ${kerneladdr};" \
|
||||
- "setenv fdt_addr;" \
|
||||
- "fi;\0" \
|
||||
- "kernel_args=" \
|
||||
- "setenv bootargs root=/dev/mmcblk${mmcrootdev}p${mmcrootpart}" \
|
||||
|
@ -125,7 +125,7 @@ index c0d4157..da1957e 100644
|
|||
- "run check_ramdisk;" \
|
||||
- "run loadkernel;" \
|
||||
- "run kernel_args;" \
|
||||
- "bootm ${image_addr} ${ramdisk_addr};\0" \
|
||||
- "bootm ${kerneladdr} ${initrd_addr} ${fdt_addr};\0" \
|
||||
- "boot_zimg=" \
|
||||
- "setenv kerneladdr 0x40007FC0;" \
|
||||
- "setenv kernelname zImage;" \
|
||||
|
@ -133,7 +133,7 @@ index c0d4157..da1957e 100644
|
|||
- "run check_ramdisk;" \
|
||||
- "run loadkernel;" \
|
||||
- "run kernel_args;" \
|
||||
- "bootz ${image_addr} ${ramdisk_addr};\0" \
|
||||
- "bootz ${kerneladdr} ${initrd_addr} ${fdt_addr};\0" \
|
||||
- "autoboot=" \
|
||||
- "if test -e mmc 0 Image.itb; then; " \
|
||||
- "run boot_fit;" \
|
||||
|
@ -214,5 +214,5 @@ index c0d4157..da1957e 100644
|
|||
/* I2C */
|
||||
#define CONFIG_CMD_I2C
|
||||
--
|
||||
1.9.0
|
||||
2.2.1
|
||||
|
File diff suppressed because it is too large
Load diff
|
@ -4,37 +4,35 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=uboot-odroid
|
||||
pkgver=2014.07
|
||||
pkgrel=4
|
||||
pkgver=2014.10
|
||||
pkgrel=1
|
||||
pkgdesc="U-Boot for ODROID-X/X2/U2/U3"
|
||||
arch=('armv7h')
|
||||
url="https://github.com/hardkernel/u-boot"
|
||||
license=('GPL')
|
||||
install=$pkgname.install
|
||||
makedepends=('bc' 'dtc')
|
||||
backup=('boot/uEnv.txt')
|
||||
makedepends=('bc' 'dtc' 'git')
|
||||
_commit=dd9a970aa4accf5d266d334c0f319c674e933027
|
||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
||||
"https://github.com/hardkernel/u-boot/raw/${_commit}/sd_fuse/bl1.HardKernel"
|
||||
"https://github.com/hardkernel/u-boot/raw/${_commit}/sd_fuse/bl2.HardKernel"
|
||||
"https://github.com/hardkernel/u-boot/raw/${_commit}/sd_fuse/tzsw.HardKernel"
|
||||
"sd_fusing.sh"
|
||||
'0001-support-for-odroid-4412-machines.patch'
|
||||
'0002-arch-linux-arm-modifications.patch'
|
||||
'0001-arch-linux-arm-modifications.patch'
|
||||
'uEnv.txt')
|
||||
md5sums=('36d4bad687edcafa396fee607e505d4e'
|
||||
md5sums=('3ddcaee2f05b7c464778112ec83664b5'
|
||||
'3ab6d3cc2061bc2590d60320254017c6'
|
||||
'841502de02bd42f2898e36c89c260b0f'
|
||||
'c38faafa02a6a1ae834457f378c82113'
|
||||
'17909ae93a0ae7b4c155234040105035'
|
||||
'b527876d561cc88cc0d6e077e831918b'
|
||||
'70e0122f419416062e434c295670946c'
|
||||
'db13b6e82ae36b916c826383b04fb9c2')
|
||||
'565256b2d83b05906074dc40ed3b8e8c'
|
||||
'08921d3ead5fa3e97dfc1b8e50334677')
|
||||
|
||||
prepare() {
|
||||
cd u-boot-${pkgver}
|
||||
|
||||
patch -p1 -i ../0001-support-for-odroid-4412-machines.patch
|
||||
patch -p1 -i ../0002-arch-linux-arm-modifications.patch
|
||||
git apply ../0001-arch-linux-arm-modifications.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -42,6 +40,7 @@ build() {
|
|||
|
||||
unset CFLAGS
|
||||
unset CXXFLAGS
|
||||
unset CPPFLAGS
|
||||
|
||||
make distclean
|
||||
make odroid_config
|
||||
|
|
|
@ -12,7 +12,6 @@
|
|||
# optargs=
|
||||
|
||||
### Flattened Device Tree file (specify for mainline kernel use)
|
||||
# fdtdir=/boot/dtbs
|
||||
# fdtfile=exynos4412-odroidu3.dtb
|
||||
# fdtfile=exynos4412-odroidx.dtb
|
||||
# fdtfile=exynos4412-odroidx2.dtb
|
||||
|
|
Loading…
Reference in a new issue