community/xulrunner to 31.0-2

This commit is contained in:
Kevin Mihelich 2014-09-22 21:00:52 +00:00
parent 711bdbd1de
commit 70bf1e9510
2 changed files with 31 additions and 3 deletions

View file

@ -9,7 +9,7 @@
pkgname=xulrunner
pkgver=31.0
pkgrel=1
pkgrel=2
pkgdesc="Mozilla Runtime Environment"
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
@ -19,13 +19,15 @@ url="http://wiki.mozilla.org/XUL:Xul_Runner"
source=(ftp://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/$pkgver/source/xulrunner-$pkgver.source.tar.bz2
mozconfig
mozilla-pkgconfig.patch
shared-libs.patch)
shared-libs.patch
rhbz-966424.patch)
options=('!emptydirs' 'staticlibs')
replaces=('xulrunner-oss')
sha256sums=('6f4cb97e4debe2225f94bc813057154d2aa2680f5aa69573048633507cecb21e'
'6d9bae5f7bc952583fddff7ae839bc559ae9be784d5021784653963875905489'
'23485d937035648add27a7657f6934dc5b295e886cdb0506eebd02a43d07f269'
'e2b4a00d14f4ba69c62b3f9ef9908263fbab179ba8004197cbc67edbd916fdf1')
'e2b4a00d14f4ba69c62b3f9ef9908263fbab179ba8004197cbc67edbd916fdf1'
'746cb474c5a2c26fc474256e430e035e604b71b27df1003d4af85018fa263f4a')
prepare() {
cd "$srcdir/mozilla-release"
@ -35,6 +37,9 @@ prepare() {
patch -Np1 -i ../mozilla-pkgconfig.patch
patch -Np1 -i ../shared-libs.patch
# https://bugs.archlinux.org/task/41689
patch -Np1 -i ../rhbz-966424.patch
# WebRTC build tries to execute "python" and expects Python 2
# Workaround taken from chromium PKGBUILD
mkdir "$srcdir/python2-path"

View file

@ -0,0 +1,23 @@
--- a/toolkit/modules/CertUtils.jsm
+++ b/toolkit/modules/CertUtils.jsm
@@ -170,17 +170,19 @@ this.checkCert =
issuerCert = issuerCert.QueryInterface(Ci.nsIX509Cert3);
var tokenNames = issuerCert.getAllTokenNames({});
if (!tokenNames || !tokenNames.some(isBuiltinToken))
throw new Ce(certNotBuiltInErr, Cr.NS_ERROR_ABORT);
}
function isBuiltinToken(tokenName) {
- return tokenName == "Builtin Object Token";
+ return tokenName == "Builtin Object Token" ||
+ tokenName == "Default Trust" ||
+ tokenName == "System Trust";
}
/**
* This class implements nsIBadCertListener. Its job is to prevent "bad cert"
* security dialogs from being shown to the user. It is better to simply fail
* if the certificate is bad. See bug 304286.
*
* @param aAllowNonBuiltInCerts (optional)