mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/js60 to 60.9.0-2
This commit is contained in:
parent
fcbc92b99b
commit
70bfb8293c
2 changed files with 3 additions and 35 deletions
|
@ -5,7 +5,7 @@
|
||||||
|
|
||||||
pkgname=js60
|
pkgname=js60
|
||||||
pkgver=60.9.0
|
pkgver=60.9.0
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
pkgdesc="JavaScript interpreter and libraries - Version 60"
|
pkgdesc="JavaScript interpreter and libraries - Version 60"
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
|
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
|
||||||
|
@ -14,12 +14,10 @@ depends=(gcc-libs readline zlib sh)
|
||||||
makedepends=(python2 zip autoconf2.13)
|
makedepends=(python2 zip autoconf2.13)
|
||||||
_relver=${pkgver}esr
|
_relver=${pkgver}esr
|
||||||
source=(https://archive.mozilla.org/pub/firefox/releases/$_relver/source/firefox-$_relver.source.tar.xz{,.asc}
|
source=(https://archive.mozilla.org/pub/firefox/releases/$_relver/source/firefox-$_relver.source.tar.xz{,.asc}
|
||||||
bug1415202.patch
|
bug1415202.patch)
|
||||||
mozjs60-fix-soname.patch)
|
|
||||||
sha256sums=('9f453c8cc5669e46e38f977764d49a36295bf0d023619d9aac782e6bb3e8c53f'
|
sha256sums=('9f453c8cc5669e46e38f977764d49a36295bf0d023619d9aac782e6bb3e8c53f'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'0b410aa6ebd0236cd3ea524340c2da2235973a42cd0eaa90f7f394cd5bcbab95'
|
'0b410aa6ebd0236cd3ea524340c2da2235973a42cd0eaa90f7f394cd5bcbab95')
|
||||||
'c792837930defe27355941080e9b80ec1d45003c097e4707860acc13d43bc519')
|
|
||||||
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
|
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
|
@ -28,9 +26,6 @@ prepare() {
|
||||||
|
|
||||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1479687
|
# https://bugzilla.mozilla.org/show_bug.cgi?id=1479687
|
||||||
patch -Np1 -i ../bug1415202.patch
|
patch -Np1 -i ../bug1415202.patch
|
||||||
|
|
||||||
# https://salsa.debian.org/gnome-team/mozjs52/tree/debian/master/debian/patches
|
|
||||||
patch -Np1 -i ../mozjs60-fix-soname.patch
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
@ -54,8 +49,6 @@ build() {
|
||||||
|
|
||||||
cd firefox-$pkgver/obj
|
cd firefox-$pkgver/obj
|
||||||
|
|
||||||
export PYTHON=/usr/bin/python2
|
|
||||||
|
|
||||||
sh ../js/src/configure "${configure_args[@]}"
|
sh ../js/src/configure "${configure_args[@]}"
|
||||||
make
|
make
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,25 +0,0 @@
|
||||||
diff --git i/js/src/build/Makefile.in w/js/src/build/Makefile.in
|
|
||||||
index ee19104e0ef5..a0f06fd35a18 100644
|
|
||||||
--- i/js/src/build/Makefile.in
|
|
||||||
+++ w/js/src/build/Makefile.in
|
|
||||||
@@ -89,6 +89,8 @@ ifneq (,$(REAL_LIBRARY))
|
|
||||||
endif
|
|
||||||
ifneq (,$(SHARED_LIBRARY))
|
|
||||||
$(SYSINSTALL) $(SHARED_LIBRARY) $(DESTDIR)$(libdir)
|
|
||||||
+ mv -f $(DESTDIR)$(libdir)/$(SHARED_LIBRARY) $(DESTDIR)$(libdir)/$(SHARED_LIBRARY).0
|
|
||||||
+ ln -s $(SHARED_LIBRARY).0 $(DESTDIR)$(libdir)/$(SHARED_LIBRARY)
|
|
||||||
ifeq ($(OS_ARCH),Darwin)
|
|
||||||
install_name_tool -id $(abspath $(libdir)/$(SHARED_LIBRARY)) $(DESTDIR)$(libdir)/$(SHARED_LIBRARY)
|
|
||||||
endif
|
|
||||||
diff --git i/js/src/build/moz.build w/js/src/build/moz.build
|
|
||||||
index a7f5fa4ce8eb..726687c13fb0 100644
|
|
||||||
--- i/js/src/build/moz.build
|
|
||||||
+++ w/js/src/build/moz.build
|
|
||||||
@@ -23,6 +23,7 @@ if not CONFIG['JS_STANDALONE']:
|
|
||||||
if CONFIG['JS_SHARED_LIBRARY']:
|
|
||||||
GeckoSharedLibrary('js', linkage=None)
|
|
||||||
SHARED_LIBRARY_NAME = CONFIG['JS_LIBRARY_NAME']
|
|
||||||
+ LDFLAGS += ['-Wl,-soname,lib{}.so.0'.format(SHARED_LIBRARY_NAME)]
|
|
||||||
else:
|
|
||||||
Library('js')
|
|
||||||
|
|
Loading…
Reference in a new issue