mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/mesa to 23.0.0-3
This commit is contained in:
parent
cd1f8addfe
commit
70f8bab641
4 changed files with 30 additions and 20 deletions
|
@ -21,15 +21,18 @@ This would happen in the following case :
|
|||
vkCmdDispatch(...);
|
||||
|
||||
Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com>
|
||||
Reviewed-by: Ivan Briano <ivan.briano@intel.com>
|
||||
Cc: mesa-stable
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/17247>
|
||||
---
|
||||
src/intel/vulkan/genX_cmd_buffer.c | 14 ++++++++++++++
|
||||
1 file changed, 14 insertions(+)
|
||||
|
||||
diff --git a/src/intel/vulkan/genX_cmd_buffer.c b/src/intel/vulkan/genX_cmd_buffer.c
|
||||
index 594b2e595139..4529cd3826fc 100644
|
||||
index 25d337945896..1b382cae49a1 100644
|
||||
--- a/src/intel/vulkan/genX_cmd_buffer.c
|
||||
+++ b/src/intel/vulkan/genX_cmd_buffer.c
|
||||
@@ -6039,6 +6039,20 @@ genX(flush_pipeline_select)(struct anv_cmd_buffer *cmd_buffer,
|
||||
@@ -6383,6 +6383,20 @@ genX(flush_pipeline_select)(struct anv_cmd_buffer *cmd_buffer,
|
||||
}
|
||||
#endif
|
||||
|
||||
|
@ -47,6 +50,6 @@ index 594b2e595139..4529cd3826fc 100644
|
|||
+ cmd_buffer->state.compute.pipeline_dirty = true;
|
||||
+#endif
|
||||
+
|
||||
/* From "BXML » GT » MI » vol1a GPU Overview » [Instruction]
|
||||
* PIPELINE_SELECT [DevBWR+]":
|
||||
#if GFX_VER >= 12
|
||||
/* From Tigerlake PRM, Volume 2a, PIPELINE_SELECT:
|
||||
*
|
||||
|
|
|
@ -2,6 +2,9 @@ From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|||
From: Kai-Heng Feng <kai.heng.feng@canonical.com>
|
||||
Date: Thu, 29 Dec 2022 13:43:27 +0800
|
||||
Subject: [PATCH] iris: Retry DRM_IOCTL_I915_GEM_EXECBUFFER2 on ENOMEM
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
We are seeing endless DRM_IOCTL_SYNCOBJ_WAIT ioctl when system memory is
|
||||
under pressured.
|
||||
|
@ -17,30 +20,31 @@ ENOMEM, so instead of resetting the batch, be patient and wait until kernel has
|
|||
enough memory. Once the batch is submiited and snapshots_landed gets
|
||||
flipped, iris_get_query_result() can proceed normally.
|
||||
|
||||
Reviewed-by: José Roberto de Souza <jose.souza@intel.com>
|
||||
Closes: https://gitlab.freedesktop.org/drm/intel/-/issues/6851
|
||||
(cherry picked from commit 3b38add239795fa5fe97ae37e6ec62cab4f1f968)
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/20449>
|
||||
---
|
||||
src/gallium/drivers/iris/iris_batch.c | 11 ++++++++---
|
||||
1 file changed, 8 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/gallium/drivers/iris/iris_batch.c b/src/gallium/drivers/iris/iris_batch.c
|
||||
index d598fd701fbd..9ea1ea3f10e7 100644
|
||||
index c7a08a0e1f5f..deab85ce4aaf 100644
|
||||
--- a/src/gallium/drivers/iris/iris_batch.c
|
||||
+++ b/src/gallium/drivers/iris/iris_batch.c
|
||||
@@ -987,9 +987,14 @@ submit_batch(struct iris_batch *batch)
|
||||
@@ -981,9 +981,14 @@ submit_batch(struct iris_batch *batch)
|
||||
}
|
||||
|
||||
int ret = 0;
|
||||
- if (!batch->screen->devinfo.no_hw &&
|
||||
- if (!batch->screen->devinfo->no_hw &&
|
||||
- intel_ioctl(batch->screen->fd, DRM_IOCTL_I915_GEM_EXECBUFFER2, &execbuf))
|
||||
- ret = -errno;
|
||||
+ if (!batch->screen->devinfo.no_hw) {
|
||||
+ if (!batch->screen->devinfo->no_hw) {
|
||||
+ do {
|
||||
+ ret = intel_ioctl(batch->screen->fd, DRM_IOCTL_I915_GEM_EXECBUFFER2, &execbuf);
|
||||
+ } while (ret && errno == ENOMEM);
|
||||
+
|
||||
+ if (ret)
|
||||
+ ret = -errno;
|
||||
+ ret = -errno;
|
||||
+ }
|
||||
|
||||
simple_mtx_unlock(bo_deps_lock);
|
||||
|
|
|
@ -2,22 +2,26 @@ From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|||
From: Kai-Heng Feng <kai.heng.feng@canonical.com>
|
||||
Date: Thu, 29 Dec 2022 14:01:31 +0800
|
||||
Subject: [PATCH] Revert "iris: Avoid abort() if kernel can't allocate memory"
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
This reverts commit f9d8d9acbb6a620684fb4dac4affe25816587d92.
|
||||
|
||||
Now ENOMEM is handled in submit_batch(), we don't need to check it for
|
||||
resetting anymore.
|
||||
|
||||
(cherry picked from commit e6add12416315b77a420dc8ccb59307ada663a1d)
|
||||
Reviewed-by: José Roberto de Souza <jose.souza@intel.com>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/20449>
|
||||
---
|
||||
src/gallium/drivers/iris/iris_batch.c | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/gallium/drivers/iris/iris_batch.c b/src/gallium/drivers/iris/iris_batch.c
|
||||
index 9ea1ea3f10e7..32bddb72b933 100644
|
||||
index deab85ce4aaf..2993f0ab7ee8 100644
|
||||
--- a/src/gallium/drivers/iris/iris_batch.c
|
||||
+++ b/src/gallium/drivers/iris/iris_batch.c
|
||||
@@ -1103,9 +1103,8 @@ _iris_batch_flush(struct iris_batch *batch, const char *file, int line)
|
||||
@@ -1097,9 +1097,8 @@ _iris_batch_flush(struct iris_batch *batch, const char *file, int line)
|
||||
* with a new logical context, and inform iris_context that all state
|
||||
* has been lost and needs to be re-initialized. If this succeeds,
|
||||
* dubiously claim success...
|
||||
|
|
|
@ -14,8 +14,8 @@ highmem=1
|
|||
pkgbase=mesa
|
||||
pkgname=('vulkan-mesa-layers' 'opencl-mesa' 'vulkan-radeon' 'vulkan-swrast' 'vulkan-virtio' 'vulkan-broadcom' 'vulkan-panfrost' 'libva-mesa-driver' 'mesa-vdpau' 'mesa')
|
||||
pkgdesc="An open-source implementation of the OpenGL specification"
|
||||
pkgver=22.3.6
|
||||
pkgrel=1.1
|
||||
pkgver=23.0.0
|
||||
pkgrel=3
|
||||
arch=('x86_64')
|
||||
makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence' 'libxxf86vm'
|
||||
'libxdamage' 'libvdpau' 'libva' 'wayland' 'wayland-protocols' 'zstd' 'elfutils' 'llvm'
|
||||
|
@ -24,17 +24,16 @@ makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence
|
|||
makedepends+=('rust' 'rust-bindgen' 'spirv-tools' 'spirv-llvm-translator') # rusticl dependencies
|
||||
url="https://www.mesa3d.org/"
|
||||
license=('custom')
|
||||
options=('!lto')
|
||||
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
|
||||
0001-anv-force-MEDIA_INTERFACE_DESCRIPTOR_LOAD-reemit-aft.patch
|
||||
0002-iris-Retry-DRM_IOCTL_I915_GEM_EXECBUFFER2-on-ENOMEM.patch
|
||||
0003-Revert-iris-Avoid-abort-if-kernel-can-t-allocate-mem.patch
|
||||
LICENSE)
|
||||
sha512sums=('506fc69ace128504fe45b7ca0b6b1d1d2a33837d74bff7ae7310fef5100b162136ca77ee6a50745a5bda270d0b8cb1ee99ecc19190eddd83cc78039bd02b1bb7'
|
||||
sha512sums=('127e2759a2a31cacd65a0891719ab7bb4a9188844022b4bccaebbedce9c550b9ccb160ad519178ea0d851c4bcb8f0f56febda248ed2ba82b5ddf804855e4694b'
|
||||
'SKIP'
|
||||
'44981f1f86b72eec0a358d1764546443a7e6734a074e1e15929dc4312fe660eab1a04b8a8359c5f57b6f5815cbe149677f5b3f0e3919112e78c6ec1f64a97b61'
|
||||
'c181cc258a3a96817f9733be53e0ddf3f5b093ec8d7b731e37c095077c1b423d13ddb902993e1056aed29c4163421e4873b64f7593ef5e39d8cba11516651724'
|
||||
'4f3ef686b2244c5da033596336bdffa42f9f55061be7125cba47a5ae3c16037523d1ba9d17269d141498b8ad2e020f25d9d778fdf307329809fc25d30d59c470'
|
||||
'c7832724bad137461fcdffc3db8ba653ea25c56b5980d7c45955844a543ce57ec4360e88e73ab48f7cb69717a2f467a03aca13ede3591f27e36e20409f8982e8'
|
||||
'b089a84333743f2f69889f99903616a9dab28e45edf2de7b1f64d29bbb321daaf898aa05bf60fea6d2feec6b5ff072b807d76bb21efe122ff1a15e275d8acc97'
|
||||
'ac4f1f98c5f1d0c2f875c2cf964fe60f41385b18a3507fea77f899f0cbbbea0baee92d313936f2d325c2301a7d0dfe3294bf881722fb22fa41defd4e4fbd0f98'
|
||||
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7')
|
||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
|
||||
'946D09B5E4C9845E63075FF1D961C596A7203456' # Andres Gomez <tanty@igalia.com>
|
||||
|
|
Loading…
Reference in a new issue