mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/qt5-webengine to 5.10.0-3
This commit is contained in:
parent
244bebffe7
commit
712f3a2969
2 changed files with 104 additions and 1 deletions
|
@ -11,7 +11,7 @@ highmem=1
|
|||
pkgname=qt5-webengine
|
||||
_qtver=5.10.0
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
arch=('x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('LGPL3' 'LGPL2.1' 'BSD')
|
||||
|
@ -23,9 +23,11 @@ groups=('qt' 'qt5')
|
|||
_pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
|
||||
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
|
||||
qtwebengine-harmony.patch
|
||||
qtwebengine-no-gpu.patch
|
||||
'0001-ARM-toolchain-fixes.patch')
|
||||
sha256sums=('a8bf5989ef847a249bbc1f391743a36971825b896747d073e30dbcdefc9567f9'
|
||||
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
|
||||
'6cd70c37f3b3aea926f1ee20c1f59354f2a02d240dbf344c6dc0a75f8aa8e07b'
|
||||
'8202b09a1caa82538a2eacd79b62b61d8661c65cdfb275560d231aa31a362b12')
|
||||
|
||||
prepare() {
|
||||
|
@ -39,6 +41,8 @@ prepare() {
|
|||
|
||||
# FreeType 2.8.1
|
||||
patch -Np1 -i ../qtwebengine-harmony.patch
|
||||
# Disable GPU rendering on nouveau and wayland (openSUSE) https://bugreports.qt.io/browse/QTBUG-65682
|
||||
patch -p1 -i ../qtwebengine-no-gpu.patch
|
||||
|
||||
cd src/3rdparty
|
||||
patch -p1 -i ${srcdir}/0001-ARM-toolchain-fixes.patch
|
||||
|
|
99
extra/qt5-webengine/qtwebengine-no-gpu.patch
Normal file
99
extra/qt5-webengine/qtwebengine-no-gpu.patch
Normal file
|
@ -0,0 +1,99 @@
|
|||
From: Antonio Larrosa <alarrosa@suse.com>
|
||||
Subject: Disable GPU when using nouveau or running on wayland
|
||||
References: boo#1005323, boo#1060990
|
||||
|
||||
Qt WebEngine uses multi-threaded OpenGL, which nouveau does not support.
|
||||
It also crashes when running on wayland, the cause is not yet known.
|
||||
Work around these issues by not doing GPU-accelerated rendering in such
|
||||
cases.
|
||||
|
||||
Index: qtwebengine-everywhere-src-5.10.0/src/core/web_engine_context.cpp
|
||||
===================================================================
|
||||
--- qtwebengine-everywhere-src-5.10.0.orig/src/core/web_engine_context.cpp
|
||||
+++ qtwebengine-everywhere-src-5.10.0/src/core/web_engine_context.cpp
|
||||
@@ -93,6 +93,7 @@
|
||||
#include <QOffscreenSurface>
|
||||
#ifndef QT_NO_OPENGL
|
||||
# include <QOpenGLContext>
|
||||
+# include <QOpenGLFunctions>
|
||||
#endif
|
||||
#include <QQuickWindow>
|
||||
#include <QStringList>
|
||||
@@ -167,6 +168,39 @@ void dummyGetPluginCallback(const std::v
|
||||
}
|
||||
#endif
|
||||
|
||||
+#ifndef QT_NO_OPENGL
|
||||
+QString openGLVendor()
|
||||
+{
|
||||
+ QString vendor;
|
||||
+
|
||||
+ QOpenGLContext *oldContext = QOpenGLContext::currentContext();
|
||||
+ QSurface *oldSurface = 0;
|
||||
+ if (oldContext)
|
||||
+ oldSurface = oldContext->surface();
|
||||
+
|
||||
+ QScopedPointer<QOffscreenSurface> surface( new QOffscreenSurface );
|
||||
+ surface->create();
|
||||
+ QOpenGLContext context;
|
||||
+ if (!context.create()) {
|
||||
+ qDebug() << "Error creating openGL context";
|
||||
+ }
|
||||
+ else if (!context.makeCurrent(surface.data())) {
|
||||
+ qDebug() << "Error making openGL context current context";
|
||||
+ } else {
|
||||
+ const GLubyte *p;
|
||||
+ QOpenGLFunctions *f = context.functions();
|
||||
+ if ((p = f->glGetString(GL_VENDOR)))
|
||||
+ vendor = QString::fromLatin1(reinterpret_cast<const char *>(p));
|
||||
+ }
|
||||
+
|
||||
+ context.doneCurrent();
|
||||
+ if (oldContext && oldSurface)
|
||||
+ oldContext->makeCurrent(oldSurface);
|
||||
+
|
||||
+ return vendor;
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
} // namespace
|
||||
|
||||
namespace QtWebEngineCore {
|
||||
@@ -379,6 +413,27 @@ WebEngineContext::WebEngineContext()
|
||||
const char *glType = 0;
|
||||
#ifndef QT_NO_OPENGL
|
||||
|
||||
+ bool disableGpu = qEnvironmentVariableIsSet("QT_WEBENGINE_DISABLE_GPU");
|
||||
+
|
||||
+ if (!qEnvironmentVariableIsSet("QT_WEBENGINE_DISABLE_WAYLAND_WORKAROUND") && platform.startsWith("wayland", Qt::CaseInsensitive))
|
||||
+ {
|
||||
+ qWarning() << "Running on wayland. Qt WebEngine will disable usage of the GPU.\n"
|
||||
+ "Note: you can set the QT_WEBENGINE_DISABLE_WAYLAND_WORKAROUND\n"
|
||||
+ "environment variable before running this application, but this is \n"
|
||||
+ "not recommended since this usually causes applications to crash.";
|
||||
+ disableGpu = true;
|
||||
+ }
|
||||
+
|
||||
+ if (!qEnvironmentVariableIsSet("QT_WEBENGINE_DISABLE_NOUVEAU_WORKAROUND") && openGLVendor() == QStringLiteral("nouveau"))
|
||||
+ {
|
||||
+ qWarning() << "Nouveau openGL driver detected. Qt WebEngine will disable usage of the GPU.\n"
|
||||
+ "Note: you can set the QT_WEBENGINE_DISABLE_NOUVEAU_WORKAROUND\n"
|
||||
+ "environment variable before running this application, but this is \n"
|
||||
+ "not recommended since this usually causes applications to crash as\n"
|
||||
+ "Nouveau openGL drivers don't support multithreaded rendering";
|
||||
+ disableGpu = true;
|
||||
+ }
|
||||
+
|
||||
bool tryGL =
|
||||
!usingANGLE()
|
||||
&& (!usingSoftwareDynamicGL()
|
||||
@@ -389,7 +444,7 @@ WebEngineContext::WebEngineContext()
|
||||
|| enableWebGLSoftwareRendering
|
||||
#endif
|
||||
)
|
||||
- && !usingQtQuick2DRenderer();
|
||||
+ && !usingQtQuick2DRenderer() && !disableGpu;
|
||||
|
||||
if (tryGL) {
|
||||
if (qt_gl_global_share_context() && qt_gl_global_share_context()->isValid()) {
|
||||
|
Loading…
Reference in a new issue