mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/openssl-1.0 to 1.0.2.k-4
This commit is contained in:
parent
0c2e0ae819
commit
714d5c2533
2 changed files with 69 additions and 59 deletions
|
@ -9,7 +9,7 @@ _ver=1.0.2k
|
|||
# use a pacman compatible version scheme
|
||||
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
|
||||
#pkgver=$_ver
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Security'
|
||||
arch=('i686' 'x86_64')
|
||||
url='https://www.openssl.org'
|
||||
|
@ -22,11 +22,11 @@ source=("https://www.openssl.org/source/openssl-${_ver}.tar.gz"
|
|||
'no-rpath.patch'
|
||||
'ssl3-test-failure.patch'
|
||||
'openssl-1.0-versioned-symbols.patch')
|
||||
md5sums=('f965fc0bf01bf882b31314b61391ae65'
|
||||
'SKIP'
|
||||
'dc78d3d06baffc16217519242ce92478'
|
||||
'62fc492252edd3283871632bb77fadbe'
|
||||
'fb9dab4e571c1110375c8375f809b78e')
|
||||
sha256sums=('6b3977c61f2aedf0f96367dcfb5c6e578cf37e7b8d913b4ecb6643c3cb88d8c0'
|
||||
'SKIP'
|
||||
'754d6107a306311e15a1db6a1cc031b81691c8b9865e8809ac60ca6f184c957c'
|
||||
'c54ae87c602eaa1530a336ab7c6e22e12898e1941012349c153e52553df64a13'
|
||||
'353a84e4c92e36c379ebd9216b8f8fb9c271396583561eb84ac8c825979acaa6')
|
||||
validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491')
|
||||
|
||||
prepare() {
|
||||
|
|
|
@ -1,8 +1,13 @@
|
|||
Index: openssl-1.0.2~beta1.obsolete.0.0498436515490575/Configure
|
||||
===================================================================
|
||||
--- openssl-1.0.2~beta1.obsolete.0.0498436515490575.orig/Configure 2014-02-24 21:02:30.000000000 +0100
|
||||
+++ openssl-1.0.2~beta1.obsolete.0.0498436515490575/Configure 2014-02-24 21:02:30.000000000 +0100
|
||||
@@ -1651,6 +1651,8 @@
|
||||
---
|
||||
Configure | 2
|
||||
engines/ccgost/openssl.ld | 10
|
||||
engines/openssl.ld | 10
|
||||
openssl.ld | 4620 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
4 files changed, 4642 insertions(+)
|
||||
|
||||
--- a/Configure
|
||||
+++ b/Configure
|
||||
@@ -1730,6 +1730,8 @@ if ($strict_warnings)
|
||||
}
|
||||
}
|
||||
|
||||
|
@ -11,12 +16,36 @@ Index: openssl-1.0.2~beta1.obsolete.0.0498436515490575/Configure
|
|||
open(IN,'<Makefile.org') || die "unable to read Makefile.org:$!\n";
|
||||
unlink("$Makefile.new") || die "unable to remove old $Makefile.new:$!\n" if -e "$Makefile.new";
|
||||
open(OUT,">$Makefile.new") || die "unable to create $Makefile.new:$!\n";
|
||||
Index: openssl-1.0.2~beta1.obsolete.0.0498436515490575/openssl.ld
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ openssl-1.0.2~beta1.obsolete.0.0498436515490575/openssl.ld 2014-02-24 22:19:08.601827266 +0100
|
||||
@@ -0,0 +1,4608 @@
|
||||
+OPENSSL_1.0.2d {
|
||||
--- /dev/null
|
||||
+++ b/engines/ccgost/openssl.ld
|
||||
@@ -0,0 +1,10 @@
|
||||
+OPENSSL_1.0.0 {
|
||||
+ global:
|
||||
+ bind_engine;
|
||||
+ v_check;
|
||||
+ OPENSSL_init;
|
||||
+ OPENSSL_finish;
|
||||
+ local:
|
||||
+ *;
|
||||
+};
|
||||
+
|
||||
--- /dev/null
|
||||
+++ b/engines/openssl.ld
|
||||
@@ -0,0 +1,10 @@
|
||||
+OPENSSL_1.0.0 {
|
||||
+ global:
|
||||
+ bind_engine;
|
||||
+ v_check;
|
||||
+ OPENSSL_init;
|
||||
+ OPENSSL_finish;
|
||||
+ local:
|
||||
+ *;
|
||||
+};
|
||||
+
|
||||
--- /dev/null
|
||||
+++ b/openssl.ld
|
||||
@@ -0,0 +1,4620 @@
|
||||
+OPENSSL_1.0.0 {
|
||||
+ global:
|
||||
+ BIO_f_ssl;
|
||||
+ BIO_new_buffer_ssl_connect;
|
||||
|
@ -4314,6 +4343,14 @@ Index: openssl-1.0.2~beta1.obsolete.0.0498436515490575/openssl.ld
|
|||
+ CRYPTO_cbc128_decrypt;
|
||||
+ CRYPTO_cfb128_encrypt;
|
||||
+ CRYPTO_cfb128_8_encrypt;
|
||||
+
|
||||
+ local:
|
||||
+ *;
|
||||
+};
|
||||
+
|
||||
+
|
||||
+OPENSSL_1.0.1 {
|
||||
+ global:
|
||||
+ SSL_renegotiate_abbreviated;
|
||||
+ TLSv1_1_method;
|
||||
+ TLSv1_1_client_method;
|
||||
|
@ -4475,7 +4512,21 @@ Index: openssl-1.0.2~beta1.obsolete.0.0498436515490575/openssl.ld
|
|||
+ BIO_s_datagram_sctp;
|
||||
+ BIO_dgram_is_sctp;
|
||||
+ BIO_dgram_sctp_notification_cb;
|
||||
+} OPENSSL_1.0.0;
|
||||
+
|
||||
+OPENSSL_1.0.1d {
|
||||
+ global:
|
||||
+ CRYPTO_memcmp;
|
||||
+} OPENSSL_1.0.1;
|
||||
+
|
||||
+OPENSSL_1.0.1s {
|
||||
+ global:
|
||||
+ SRP_VBASE_get1_by_user;
|
||||
+ SRP_user_pwd_free;
|
||||
+} OPENSSL_1.0.1d;
|
||||
+
|
||||
+OPENSSL_1.0.2 {
|
||||
+ global:
|
||||
+ SSL_CTX_set_alpn_protos;
|
||||
+ SSL_set_alpn_protos;
|
||||
+ SSL_CTX_set_alpn_select_cb;
|
||||
|
@ -4613,45 +4664,4 @@ Index: openssl-1.0.2~beta1.obsolete.0.0498436515490575/openssl.ld
|
|||
+ BUF_strnlen;
|
||||
+ sk_deep_copy;
|
||||
+ SSL_test_functions;
|
||||
+
|
||||
+ local:
|
||||
+ *;
|
||||
+};
|
||||
+
|
||||
+OPENSSL_1.0.2g {
|
||||
+ global:
|
||||
+ SRP_VBASE_get1_by_user;
|
||||
+ SRP_user_pwd_free;
|
||||
+} OPENSSL_1.0.2d;
|
||||
+
|
||||
Index: openssl-1.0.2~beta1.obsolete.0.0498436515490575/engines/openssl.ld
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ openssl-1.0.2~beta1.obsolete.0.0498436515490575/engines/openssl.ld 2014-02-24 21:02:30.000000000 +0100
|
||||
@@ -0,0 +1,10 @@
|
||||
+OPENSSL_1.0.2 {
|
||||
+ global:
|
||||
+ bind_engine;
|
||||
+ v_check;
|
||||
+ OPENSSL_init;
|
||||
+ OPENSSL_finish;
|
||||
+ local:
|
||||
+ *;
|
||||
+};
|
||||
+
|
||||
Index: openssl-1.0.2~beta1.obsolete.0.0498436515490575/engines/ccgost/openssl.ld
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ openssl-1.0.2~beta1.obsolete.0.0498436515490575/engines/ccgost/openssl.ld 2014-02-24 21:02:30.000000000 +0100
|
||||
@@ -0,0 +1,10 @@
|
||||
+OPENSSL_1.0.2 {
|
||||
+ global:
|
||||
+ bind_engine;
|
||||
+ v_check;
|
||||
+ OPENSSL_init;
|
||||
+ OPENSSL_finish;
|
||||
+ local:
|
||||
+ *;
|
||||
+};
|
||||
+
|
||||
|
||||
+} OPENSSL_1.0.1d;
|
||||
|
|
Loading…
Reference in a new issue