extra/calligra to 3.2.1-16

This commit is contained in:
Kevin Mihelich 2021-07-16 13:09:06 +00:00
parent d1bfc85c3b
commit 71bd1082c6
2 changed files with 46 additions and 3 deletions

View file

@ -0,0 +1,40 @@
From 62f510702ef9c34ac50f8d8601a4290ab558464c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=96mer=20Fad=C4=B1l=20Usta?= <omerusta@gmail.com>
Date: Sun, 6 Jun 2021 08:41:05 +0000
Subject: [PATCH] Update Cmake and deps, Fix Freetype and FontConfig Linkage
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b237f68fcb6..cdcc02f0236 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -599,8 +593,8 @@ if(NOT WIN32 AND NOT APPLE)
)
endif()
-if(NOT FONTCONFIG_FOUND OR NOT FREETYPE_FOUND)
- set(FONTCONFIG_INCLUDE_DIR "")
+if(NOT Fontconfig_FOUND OR NOT FREETYPE_FOUND)
+ set(Fontconfig_INCLUDE_DIRS "")
set(FREETYPE_INCLUDE_DIRS "")
else()
add_definitions( -DSHOULD_BUILD_FONT_CONVERSION )
diff --git a/libs/text/CMakeLists.txt b/libs/text/CMakeLists.txt
index 16d7e066fa2..429afe79704 100644
--- a/libs/text/CMakeLists.txt
+++ b/libs/text/CMakeLists.txt
@@ -152,11 +152,11 @@ if( SHOULD_BUILD_FEATURE_RDF )
endif()
if( FONTCONFIG_FOUND )
- target_link_libraries(kotext PRIVATE ${FONTCONFIG_LIBRARIES})
+ target_link_libraries(kotext PRIVATE Fontconfig::Fontconfig)
endif()
if( FREETYPE_FOUND )
- target_link_libraries(kotext PRIVATE ${FREETYPE_LIBRARIES})
+ target_link_libraries(kotext PRIVATE Freetype::Freetype)
endif()
--
GitLab

View file

@ -9,7 +9,7 @@
pkgname=calligra
pkgdesc="A set of applications for productivity and creative usage"
pkgver=3.2.1
pkgrel=15
pkgrel=16
arch=(x86_64)
url='https://www.calligra-suite.org/'
license=(FDL1.2 GPL2 LGPL)
@ -28,15 +28,18 @@ optdepends=('libwpg: Corel WordPerfect Graphics image importer'
'qt5-quickcontrols: for Calligra Gemini'
'qt5-webengine: for Calligra Gemini')
source=(https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz{,.sig}
calligra-openexr3.patch)
calligra-openexr3.patch
62f51070.patch)
sha256sums=('b1f8a6eb8208543a2f908caa83d089075fcd1e530d00e19f5362b2f9cc371147'
'SKIP'
'0dec106deff4cff342021da4ca4e9759f0bbe5707ea2d4ee8536eaf863409cec')
'0dec106deff4cff342021da4ca4e9759f0bbe5707ea2d4ee8536eaf863409cec'
'9e2a0797ce0667212ec07a3056435a4550e07371ff1f6eefdf65dc3642d24165')
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <foundation@krita.org>
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <danders@get2net.dk>
prepare() {
patch -d $pkgname-$pkgver -p1 < calligra-openexr3.patch # Fix build with OpenEXR 3
patch -d $pkgname-$pkgver -p1 < 62f51070.patch # Fix fontconfig linking
}
build() {