diff --git a/community/sshfs/PKGBUILD b/community/sshfs/PKGBUILD
index cd2106fd2..62375a681 100644
--- a/community/sshfs/PKGBUILD
+++ b/community/sshfs/PKGBUILD
@@ -6,26 +6,22 @@
 #  - use -D_FILE_OFFSET_BITS=64 with 32-bit ARM
 
 pkgname=sshfs
-pkgver=3.7.2
-pkgrel=2
+pkgver=3.7.3
+pkgrel=1
 pkgdesc="FUSE client based on the SSH File Transfer Protocol"
 arch=('x86_64')
 url="https://github.com/libfuse/sshfs"
 license=(GPL)
 depends=(fuse3 glib2 openssh)
 makedepends=('meson' 'python-docutils')
-source=(https://github.com/libfuse/sshfs/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.xz{,.asc}
-        https://github.com/libfuse/sshfs/commit/508e8cb0.patch)
-sha256sums=('1c596d42724d13aeba9f49ee127b8ef2fdeb813e25c6018f92d0c9ec4754fa2d'
-            'SKIP'
-            '629f0f07e1efd6c8251750c29981f106caa8fc4e12338c2092376054bfec059b')
+source=(https://github.com/libfuse/sshfs/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.xz{,.asc})
+sha256sums=('5218ce7bdd2ce0a34137a0d7798e0f6d09f0e6d21b1e98ee730a18b0699c2e99'
+            'SKIP')
 validpgpkeys=('ED31791B2C5C1613AF388B8AD113FCAC3C4E599F') # Nikolaus Rath <Nikolaus@rath.org>
 
 prepare() {
   cd $pkgname-$pkgver
 
-  patch -p1 -i ../508e8cb0.patch # Fix typo that prevents passing the PubkeyAcceptedKeyTypes option to ssh
-
   [[ $CARCH == 'arm' || $CARCH == 'armv6h' || $CARCH == 'armv7h' ]] && export CFLAGS+=" -D_FILE_OFFSET_BITS=64"
   rm -rf build
   mkdir build