mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
Merge pull request #783 from CrawX/wbxbmc
Fix xbmc-imx on linux-imx6-wandboard-dt
This commit is contained in:
commit
7277a6d850
5 changed files with 72 additions and 21 deletions
|
@ -6,14 +6,14 @@
|
||||||
buildarch=4
|
buildarch=4
|
||||||
|
|
||||||
pkgname=xbmc-imx-git
|
pkgname=xbmc-imx-git
|
||||||
pkgver=13.20140324
|
pkgver=13.20140329
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="A software media player and entertainment hub for digital media for select imx6 systems"
|
pkgdesc="A software media player and entertainment hub for digital media for select imx6 systems"
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url="http://xbmc.org"
|
url="http://xbmc.org"
|
||||||
license=('GPL' 'custom')
|
license=('GPL' 'custom')
|
||||||
depends=('fribidi' 'lzo2' 'smbclient' 'libtiff' 'libpng' 'libcdio' 'yajl' 'libmariadbclient' 'libjpeg-turbo' 'libsamplerate' 'libssh' 'libmicrohttpd' 'sdl_image' 'python2' 'libass' 'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump' 'unzip' 'libbluray' 'libnfs' 'afpfs-ng' 'libshairport' 'avahi' 'bluez-libs' 'tinyxml' 'libplist' 'swig' 'taglib' 'libxslt' 'libfslvpuwrap' 'gpu-viv-bin-mx6q-fb' 'libcec-imx6' 'linux-headers-imx6-cubox' )
|
depends=('fribidi' 'lzo2' 'smbclient' 'libtiff' 'libpng' 'libcdio' 'yajl' 'libmariadbclient' 'libjpeg-turbo' 'libsamplerate' 'libssh' 'libmicrohttpd' 'sdl_image' 'python2' 'libass' 'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump' 'unzip' 'libbluray' 'libnfs' 'afpfs-ng' 'libshairport' 'avahi' 'bluez-libs' 'tinyxml' 'libplist' 'swig' 'taglib' 'libxslt' 'libfslvpuwrap' 'gpu-viv-bin-mx6q-fb' 'libcec-imx6')
|
||||||
makedepends=('boost' 'cmake' 'gperf' 'nasm' 'zip' 'udisks' 'upower' 'git' 'autoconf' 'java-runtime-headless')
|
makedepends=('boost' 'cmake' 'gperf' 'nasm' 'zip' 'udisks' 'upower' 'git' 'autoconf' 'java-runtime-headless' 'linux-headers-imx6')
|
||||||
optdepends=(
|
optdepends=(
|
||||||
'lirc: remote controller support'
|
'lirc: remote controller support'
|
||||||
'udisks: automount external drives'
|
'udisks: automount external drives'
|
||||||
|
@ -24,10 +24,12 @@ provides=("xbmc")
|
||||||
conflicts=("xbmc")
|
conflicts=("xbmc")
|
||||||
install="xbmc.install"
|
install="xbmc.install"
|
||||||
source=('xbmc.service'
|
source=('xbmc.service'
|
||||||
|
'fix-wandboard.patch'
|
||||||
'runxbmc')
|
'runxbmc')
|
||||||
|
|
||||||
md5sums=('07096dfd530cc432fa6073ee1a32e7f6'
|
md5sums=('07096dfd530cc432fa6073ee1a32e7f6'
|
||||||
'56ced80db9c37d86fa732961ad2cfe4c')
|
'4ddb9c84c81b03da4e6aae46d7e82edb'
|
||||||
|
'730ac095a89b05c3c2cf2dd93947cb5c')
|
||||||
|
|
||||||
# master branch of xbmc-imx6 organization. Modified by Stephan "wolgar" Rafin, Chris "koying" Browet, Rudi "rudi-warped" Ihle and smallint
|
# master branch of xbmc-imx6 organization. Modified by Stephan "wolgar" Rafin, Chris "koying" Browet, Rudi "rudi-warped" Ihle and smallint
|
||||||
_gitname="xbmc"
|
_gitname="xbmc"
|
||||||
|
@ -54,6 +56,9 @@ prepare() {
|
||||||
|
|
||||||
cd "${srcdir}/${_gitname}"
|
cd "${srcdir}/${_gitname}"
|
||||||
|
|
||||||
|
# fix running on wandboard-dt
|
||||||
|
patch -p0 <../fix-wandboard.patch
|
||||||
|
|
||||||
# fix lsb_release dependency
|
# fix lsb_release dependency
|
||||||
sed -i -e 's:/usr/bin/lsb_release -d:cat /etc/arch-release:' xbmc/utils/SystemInfo.cpp
|
sed -i -e 's:/usr/bin/lsb_release -d:cat /etc/arch-release:' xbmc/utils/SystemInfo.cpp
|
||||||
|
|
||||||
|
@ -69,19 +74,10 @@ build() {
|
||||||
# Bootstrapping XBMC
|
# Bootstrapping XBMC
|
||||||
./bootstrap
|
./bootstrap
|
||||||
|
|
||||||
_kernel_release="$(pacman -Q linux-headers-imx6-cubox | grep -Eo "[^\ ]+$")"
|
|
||||||
|
|
||||||
|
|
||||||
# dirty: copy headers from kernel as we need those but apart from that want to use the ones in /usr/include
|
|
||||||
KERNELSRC=/usr/src/linux-${_kernel_release}
|
|
||||||
mkdir -p linux-includes/include/linux
|
|
||||||
for f in mxcfb.h mxc_v4l2.h ipu.h; do
|
|
||||||
cp "${KERNELSRC}/include/linux/${f}" linux-includes/include/linux/
|
|
||||||
done
|
|
||||||
|
|
||||||
# Configuring XBMC
|
# Configuring XBMC
|
||||||
export PYTHON_VERSION=2 # external python v2
|
export PYTHON_VERSION=2 # external python v2
|
||||||
INCLUDES="-I${srcdir}/${_gitname}/linux-includes/include -I/opt/fsl/include"
|
|
||||||
|
INCLUDES="-I/opt/fsl/include"
|
||||||
export CFLAGS="-Ofast -mfloat-abi=hard -mfpu=vfpv3-d16 -mtls-dialect=gnu -march=armv7-a -mtune=cortex-a9 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 $INCLUDES -Wl,-rpath,/opt/fsl/lib -L/opt/fsl/lib"
|
export CFLAGS="-Ofast -mfloat-abi=hard -mfpu=vfpv3-d16 -mtls-dialect=gnu -march=armv7-a -mtune=cortex-a9 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 $INCLUDES -Wl,-rpath,/opt/fsl/lib -L/opt/fsl/lib"
|
||||||
export CPPFLAGS="-Ofast -mfloat-abi=hard -mfpu=vfpv3-d16 -mtls-dialect=gnu -march=armv7-a -mtune=cortex-a9 -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 $INCLUDES -Wl,-rpath,/opt/fsl/lib -L/opt/fsl/lib"
|
export CPPFLAGS="-Ofast -mfloat-abi=hard -mfpu=vfpv3-d16 -mtls-dialect=gnu -march=armv7-a -mtune=cortex-a9 -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 $INCLUDES -Wl,-rpath,/opt/fsl/lib -L/opt/fsl/lib"
|
||||||
export CXXFLAGS="-Ofast -mfloat-abi=hard -mfpu=vfpv3-d16 -mtls-dialect=gnu -march=armv7-a -mtune=cortex-a9 -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 $INCLUDES -Wl,-rpath,/opt/fsl/lib -L/opt/fsl/lib"
|
export CXXFLAGS="-Ofast -mfloat-abi=hard -mfpu=vfpv3-d16 -mtls-dialect=gnu -march=armv7-a -mtune=cortex-a9 -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 $INCLUDES -Wl,-rpath,/opt/fsl/lib -L/opt/fsl/lib"
|
||||||
|
|
20
alarm/xbmc-imx/fix-wandboard.patch
Normal file
20
alarm/xbmc-imx/fix-wandboard.patch
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
diff --git xbmc/windowing/egl/EGLNativeTypeIMX.cpp xbmc/windowing/egl/EGLNativeTypeIMX.cpp
|
||||||
|
index 4ffa708..e85a633 100644
|
||||||
|
--- xbmc/windowing/egl/EGLNativeTypeIMX.cpp
|
||||||
|
+++ xbmc/windowing/egl/EGLNativeTypeIMX.cpp
|
||||||
|
@@ -48,11 +48,15 @@ bool CEGLNativeTypeIMX::CheckCompatibility()
|
||||||
|
{
|
||||||
|
std::string strName;
|
||||||
|
std::string str2 ("mxc_sdc_fb");
|
||||||
|
+ std::string str3 ("platform:fb.24");
|
||||||
|
get_sysfs_str("/sys/class/graphics/fb0/device/modalias", strName);
|
||||||
|
StringUtils::Trim(strName);
|
||||||
|
size_t found = strName.find(str2);
|
||||||
|
if (found!=std::string::npos)
|
||||||
|
return true;
|
||||||
|
+ found = strName.find(str3);
|
||||||
|
+ if (found!=std::string::npos)
|
||||||
|
+ return true;
|
||||||
|
return false;
|
||||||
|
}
|
||||||
|
|
|
@ -15,7 +15,7 @@ _srcname=linux-linaro-stable-mx6-${_commit}
|
||||||
_kernelname=${pkgname#linux}
|
_kernelname=${pkgname#linux}
|
||||||
_basekernel=3.10
|
_basekernel=3.10
|
||||||
pkgver=${_basekernel}.30
|
pkgver=${_basekernel}.30
|
||||||
pkgrel=10
|
pkgrel=11
|
||||||
arch=('arm')
|
arch=('arm')
|
||||||
url="http://www.kernel.org/"
|
url="http://www.kernel.org/"
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
|
@ -138,7 +138,7 @@ package_linux-imx6-cubox-dt() {
|
||||||
|
|
||||||
package_linux-headers-imx6-cubox-dt() {
|
package_linux-headers-imx6-cubox-dt() {
|
||||||
pkgdesc="Header files and scripts for building modules for linux kernel - i.MX6 cubox-i"
|
pkgdesc="Header files and scripts for building modules for linux kernel - i.MX6 cubox-i"
|
||||||
provides=("linux-headers=${pkgver}")
|
provides=("linux-headers=${pkgver}" "linux-headers-imx6=${pkgver}")
|
||||||
conflicts=('linux-headers-omap' 'linux-headers-trimslice')
|
conflicts=('linux-headers-omap' 'linux-headers-trimslice')
|
||||||
|
|
||||||
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
|
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
|
||||||
|
@ -237,6 +237,17 @@ package_linux-headers-imx6-cubox-dt() {
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/mm"
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/mm"
|
||||||
cp fs/xfs/xfs_sb.h "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h"
|
cp fs/xfs/xfs_sb.h "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h"
|
||||||
|
|
||||||
|
#make uapi headers, some of them are needed for vpu/ipu usage
|
||||||
|
mkdir -p "${srcdir}/headers"
|
||||||
|
make headers_install ARCH=$KARCH INSTALL_HDR_PATH="${srcdir}/headers"
|
||||||
|
|
||||||
|
|
||||||
|
# copy freescale specific headers to /usr/include/linux
|
||||||
|
mkdir -p "${pkgdir}/usr/include/linux"
|
||||||
|
for f in "$srcdir/headers/include/linux"/mxc*.h "$srcdir/headers/include/linux/ipu.h"; do
|
||||||
|
cp "$f" "${pkgdir}/usr/include/linux"
|
||||||
|
done
|
||||||
|
|
||||||
# copy in Kconfig files
|
# copy in Kconfig files
|
||||||
for i in `find . -name "Kconfig*"`; do
|
for i in `find . -name "Kconfig*"`; do
|
||||||
mkdir -p "${pkgdir}"/usr/src/linux-${_kernver}/`echo ${i} | sed 's|/Kconfig.*||'`
|
mkdir -p "${pkgdir}"/usr/src/linux-${_kernver}/`echo ${i} | sed 's|/Kconfig.*||'`
|
||||||
|
|
|
@ -15,7 +15,7 @@ _srcname=linux-imx6-${_commit}
|
||||||
_kernelname=${pkgname#linux}
|
_kernelname=${pkgname#linux}
|
||||||
_basekernel=3.0
|
_basekernel=3.0
|
||||||
pkgver=${_basekernel}.35
|
pkgver=${_basekernel}.35
|
||||||
pkgrel=16
|
pkgrel=17
|
||||||
arch=('arm')
|
arch=('arm')
|
||||||
url="http://www.kernel.org/"
|
url="http://www.kernel.org/"
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
|
@ -140,7 +140,7 @@ package_linux-imx6-cubox() {
|
||||||
|
|
||||||
package_linux-headers-imx6-cubox() {
|
package_linux-headers-imx6-cubox() {
|
||||||
pkgdesc="Header files and scripts for building modules for linux kernel - i.MX6 cubox-i"
|
pkgdesc="Header files and scripts for building modules for linux kernel - i.MX6 cubox-i"
|
||||||
provides=("linux-headers=${pkgver}")
|
provides=("linux-headers=${pkgver}" "linux-headers-imx6=${pkgver}")
|
||||||
conflicts=('linux-headers-omap' 'linux-headers-trimslice')
|
conflicts=('linux-headers-omap' 'linux-headers-trimslice')
|
||||||
|
|
||||||
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
|
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
|
||||||
|
@ -248,6 +248,18 @@ package_linux-headers-imx6-cubox() {
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/mm"
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/mm"
|
||||||
cp fs/xfs/xfs_sb.h "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h"
|
cp fs/xfs/xfs_sb.h "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h"
|
||||||
|
|
||||||
|
|
||||||
|
#make uapi headers, some of them are needed for vpu/ipu usage
|
||||||
|
mkdir -p "${srcdir}/headers"
|
||||||
|
make headers_install ARCH=$KARCH INSTALL_HDR_PATH="${srcdir}/headers"
|
||||||
|
|
||||||
|
|
||||||
|
# copy freescale specific headers to /usr/include/linux
|
||||||
|
mkdir -p "${pkgdir}/usr/include/linux"
|
||||||
|
for f in "$srcdir/headers/include/linux"/mxc*.h "$srcdir/headers/include/linux/ipu.h"; do
|
||||||
|
cp "$f" "${pkgdir}/usr/include/linux"
|
||||||
|
done
|
||||||
|
|
||||||
# copy in Kconfig files
|
# copy in Kconfig files
|
||||||
for i in `find . -name "Kconfig*"`; do
|
for i in `find . -name "Kconfig*"`; do
|
||||||
mkdir -p "${pkgdir}"/usr/src/linux-${_kernver}/`echo ${i} | sed 's|/Kconfig.*||'`
|
mkdir -p "${pkgdir}"/usr/src/linux-${_kernver}/`echo ${i} | sed 's|/Kconfig.*||'`
|
||||||
|
|
|
@ -9,7 +9,7 @@ _srcname=linux-wandboard_imx_3.10.17_1.0.0_beta
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_desc="i.MX6 Wandboard"
|
_desc="i.MX6 Wandboard"
|
||||||
pkgver=3.10.17
|
pkgver=3.10.17
|
||||||
pkgrel=2
|
pkgrel=3
|
||||||
rcnrel=wand6
|
rcnrel=wand6
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url="http://www.kernel.org/"
|
url="http://www.kernel.org/"
|
||||||
|
@ -119,7 +119,7 @@ _package() {
|
||||||
|
|
||||||
_package-headers() {
|
_package-headers() {
|
||||||
pkgdesc="Header files and scripts for building modules for linux kernel - ${_desc}"
|
pkgdesc="Header files and scripts for building modules for linux kernel - ${_desc}"
|
||||||
provides=("linux-headers=${pkgver}")
|
provides=("linux-headers=${pkgver}" "linux-headers-imx6=${pkgver}")
|
||||||
conflicts=('linux-headers-omap' 'linux-headers-trimslice')
|
conflicts=('linux-headers-omap' 'linux-headers-trimslice')
|
||||||
|
|
||||||
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
|
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
|
||||||
|
@ -218,6 +218,18 @@ _package-headers() {
|
||||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/mm"
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/mm"
|
||||||
cp fs/xfs/xfs_sb.h "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h"
|
cp fs/xfs/xfs_sb.h "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h"
|
||||||
|
|
||||||
|
|
||||||
|
#make uapi headers, some of them are needed for vpu/ipu usage
|
||||||
|
mkdir -p "${srcdir}/headers"
|
||||||
|
make headers_install ARCH=$KARCH INSTALL_HDR_PATH="${srcdir}/headers"
|
||||||
|
|
||||||
|
|
||||||
|
# copy freescale specific headers to /usr/include/linux
|
||||||
|
mkdir -p "${pkgdir}/usr/include/linux"
|
||||||
|
for f in "$srcdir/headers/include/linux"/mxc*.h "$srcdir/headers/include/linux/ipu.h"; do
|
||||||
|
cp "$f" "${pkgdir}/usr/include/linux"
|
||||||
|
done
|
||||||
|
|
||||||
# copy in Kconfig files
|
# copy in Kconfig files
|
||||||
for i in `find . -name "Kconfig*"`; do
|
for i in `find . -name "Kconfig*"`; do
|
||||||
mkdir -p "${pkgdir}"/usr/src/linux-${_kernver}/`echo ${i} | sed 's|/Kconfig.*||'`
|
mkdir -p "${pkgdir}"/usr/src/linux-${_kernver}/`echo ${i} | sed 's|/Kconfig.*||'`
|
||||||
|
|
Loading…
Reference in a new issue