mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/mysql-workbench to 8.0.28-1
This commit is contained in:
parent
cace3cc5e2
commit
72a1485793
3 changed files with 10 additions and 65 deletions
|
@ -1,49 +0,0 @@
|
|||
diff --git a/library/grt/src/python_context.cpp b/library/grt/src/python_context.cpp
|
||||
index 49ea3ce..a6f59f2 100644
|
||||
--- a/library/grt/src/python_context.cpp
|
||||
+++ b/library/grt/src/python_context.cpp
|
||||
@@ -31,7 +31,6 @@
|
||||
#include "base/wb_memory.h"
|
||||
|
||||
// python internals
|
||||
-#include <node.h>
|
||||
#include <errcode.h>
|
||||
#include <token.h>
|
||||
#include <frameobject.h>
|
||||
@@ -1598,7 +1597,7 @@ int PythonContext::run_file(const std::string &file, bool interactive) {
|
||||
If line_buffer is null, the passed buffer will be expected to contain complete code.
|
||||
*/
|
||||
int PythonContext::run_buffer(const std::string &buffer, std::string *line_buffer) {
|
||||
- node *n;
|
||||
+ PyObject *n;
|
||||
PyObject *result;
|
||||
PyObject *mainmod;
|
||||
PyObject *globals;
|
||||
@@ -1617,8 +1616,16 @@ int PythonContext::run_buffer(const std::string &buffer, std::string *line_buffe
|
||||
|
||||
WillEnterPython lock;
|
||||
|
||||
- n = PyParser_SimpleParseStringFlags(line_buffer ? line_buffer->c_str() : buffer.c_str(),
|
||||
- line_buffer ? Py_single_input : Py_file_input, 0);
|
||||
+ /* The changelog says:
|
||||
+ A call to PyParser_SimpleParseStringFlags followed by PyNode_Compile can
|
||||
+ be replaced by calling Py_CompileString().
|
||||
+
|
||||
+ We do not have PyNode_Compile()... But looks like `n` is not used anyway.
|
||||
+
|
||||
+ https://docs.python.org/3/whatsnew/3.10.html#changes-in-the-c-api */
|
||||
+
|
||||
+ n = Py_CompileString(line_buffer ? line_buffer->c_str() : buffer.c_str(), NULL,
|
||||
+ line_buffer ? Py_single_input : Py_file_input);
|
||||
|
||||
if (n && (!buffer.empty() && (buffer[0] == ' ' || buffer[0] == '\t')) && line_buffer) {
|
||||
return 0; // continued line
|
||||
@@ -1651,7 +1658,7 @@ int PythonContext::run_buffer(const std::string &buffer, std::string *line_buffe
|
||||
return -1;
|
||||
}
|
||||
|
||||
- PyNode_Free(n);
|
||||
+ Py_DECREF(n);
|
||||
PyErr_Clear();
|
||||
|
||||
// command is supposedly complete, try to execute it
|
|
@ -13,11 +13,11 @@ highmem=1
|
|||
buildarch=12
|
||||
|
||||
pkgname=mysql-workbench
|
||||
pkgver=8.0.27
|
||||
pkgrel=3
|
||||
pkgver=8.0.28
|
||||
pkgrel=1
|
||||
_mysql_version=${pkgver}
|
||||
_connector_version=${pkgver}
|
||||
_gdal_version=3.3.1
|
||||
_gdal_version=3.4.1
|
||||
_boost_version=1.73.0
|
||||
_antlr4_version=4.9.3
|
||||
pkgdesc='A cross-platform, visual database design tool developed by MySQL'
|
||||
|
@ -29,7 +29,7 @@ depends=('cairo' 'antlr4-runtime' 'curl' 'desktop-file-utils' 'freetype2' 'gifli
|
|||
'libxml2' 'libzip' 'pcre' 'proj' 'python' 'rapidjson' 'unixodbc'
|
||||
'vsqlite++' 'zstd')
|
||||
makedepends=('cmake' 'boost' 'mesa' 'swig' 'java-runtime' 'imagemagick' "antlr4=${_antlr4_version}")
|
||||
validpgpkeys=('A4A9406876FCBD3C456770C88C718D3B5072E1F5') # MySQL Release Engineering <mysql-build@oss.oracle.com>
|
||||
validpgpkeys=('859BE8D7C586F538430B19C2467B942D3A79BD29') # MySQL Release Engineering <mysql-build@oss.oracle.com>
|
||||
source=("https://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community-${pkgver}-src.tar.gz"{,.asc}
|
||||
"https://cdn.mysql.com/Downloads/MySQL-${_mysql_version%.*}/mysql-${_mysql_version}.tar.gz"{,.asc}
|
||||
"https://cdn.mysql.com/Downloads/Connector-C++/mysql-connector-c++-${_connector_version}-src.tar.gz"{,.asc}
|
||||
|
@ -39,22 +39,20 @@ source=("https://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community
|
|||
'0002-disable-unsupported-operating-system-warning.patch'
|
||||
'0001-fix-buiild-for-32-bit.patch'
|
||||
'atomic.patch'
|
||||
'0003-python-3-10-parser.patch'
|
||||
'arch_linux_profile.xml')
|
||||
sha256sums=('fd7c821e61ed559f3d280199b441785723c4b79ae41afb9f68ad3b5cc8f3e124'
|
||||
sha256sums=('a6753b08be1157cd6d67fea7cf6a195ea0af46c7bfa2a6462e102375cba864c8'
|
||||
'SKIP'
|
||||
'4a7e72f899e6f24bcd479d378edd2f32f583e687f93a26291774815d5a549b97'
|
||||
'd869369eb6de4f2bb2db8d3b31b7b73968e356e5ffc4354f4b96658ab1e48b22'
|
||||
'SKIP'
|
||||
'5886698fc682a5e8740822ed9b461bc51b60cf9cbadf4e1c7febe59584b2bfb7'
|
||||
'cb26fe9de05a3b5f1ed22a199429b6791ece18433eb0465e2a73fcf44586420b'
|
||||
'SKIP'
|
||||
'48ab00b77d49f08cf66c60ccce55abb6455c3079f545e60c90ee7ce857bccb70'
|
||||
'332f053516ca45101ef0f7fa96309b64242688a8024780a5d93be0230e42173d'
|
||||
'4eb3b8d442b426dc35346235c8733b5ae35ba431690e38c6a8263dce9fcbb402'
|
||||
'cdf687f23bc6e8d52dbee9fa02b23d755e80f88476f0fc2e7c4c71cdfed3792f'
|
||||
'2d0f6dcf38f22e49ef7ab9de0230484f1ffac41b7ac40feaf5ef4538ae2f7a18'
|
||||
'719501bbd1de673767007c429feed2fc48d1176d456161c4ba69cf3165c0438a'
|
||||
'17294a67637ab7ffff5c39262208e63d21acac72cc2492f616ef1d8e0ae9ac02'
|
||||
'9de0ceba08037f15c12f730e4764d08a03813b5c59ed4c8b4d0cfbbcb82d1738'
|
||||
'3a59b46ac2e7c6a0a72733d71ca33ec85146e8399a3f23871cb3a965cd8e749e')
|
||||
'd816164098c90c432b4fe590708c14f95ab137abfe16ad1b7d498b2e83c0e265')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/mysql-workbench-community-${pkgver}-src/"
|
||||
|
@ -66,10 +64,6 @@ prepare() {
|
|||
# disable unsupported operating system warning
|
||||
patch -Np1 < "${srcdir}"/0002-disable-unsupported-operating-system-warning.patch
|
||||
|
||||
# Python 3.10 removed the parser module, which was deprecated in 3.9 due
|
||||
# to the switch to the new PEG parser...
|
||||
patch -Np1 < "${srcdir}"/0003-python-3-10-parser.patch
|
||||
|
||||
# remove '-Werror'
|
||||
sed -i '/^\s*set/s| -Werror||' CMakeLists.txt
|
||||
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
<data>
|
||||
<value type="dict">
|
||||
<value type="string" key="sys.config.path">/etc/mysql/my.cnf</value>
|
||||
<value type="string" key="sys.config.path">/etc/my.cnf</value>
|
||||
<value type="string" key="sys.config.section">mysqld</value>
|
||||
|
||||
<value type="string" key="sys.mysqld.start">systemctl start mariadb</value>
|
||||
|
|
Loading…
Reference in a new issue