extra/i2c-tools to 4.3-6

This commit is contained in:
Kevin Mihelich 2024-04-27 15:32:14 +00:00
parent 630a8d0b78
commit 72c15f06e7
4 changed files with 39 additions and 25 deletions

25
extra/i2c-tools/.SRCINFO Normal file
View file

@ -0,0 +1,25 @@
pkgbase = i2c-tools
pkgdesc = Heterogeneous set of I2C tools for Linux that used to be part of lm-sensors
pkgver = 4.3
pkgrel = 6
url = https://i2c.wiki.kernel.org/index.php/I2C_Tools
arch = x86_64
license = GPL
makedepends = python-setuptools
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
depends = perl
optdepends = read-edid: for decode-edid script
optdepends = python: for smbus module
source = https://www.kernel.org/pub/software/utils/i2c-tools/i2c-tools-4.3.tar.xz
source = https://www.kernel.org/pub/software/utils/i2c-tools/i2c-tools-4.3.tar.sign
source = i2c-tools.sysusers
source = 45-i2c-tools.rules
validpgpkeys = 7CA69F4460F1BDC41FD2C858A5526B9BB3CD4E6A
sha256sums = 1f899e43603184fac32f34d72498fc737952dbc9c97a8dd9467fadfdf4600cf9
sha256sums = SKIP
sha256sums = bf5ee4f9876505628c5ce84e84e918c70d66be70b766d62bb138e294608ffbae
sha256sums = af9dbdc771023cd04f5b0c638c30356e6a824b32f0c04ea61fe929c71122bccd
pkgname = i2c-tools

View file

@ -0,0 +1,5 @@
[i2c-tools]
source = "git"
git = "https://git.kernel.org/pub/scm/utils/i2c-tools/i2c-tools.git/"
prefix = "v"
use_max_tag = true

View file

@ -7,13 +7,13 @@
pkgname=i2c-tools
pkgver=4.3
pkgrel=4
pkgrel=6
pkgdesc="Heterogeneous set of I2C tools for Linux that used to be part of lm-sensors"
arch=('x86_64')
url="https://i2c.wiki.kernel.org/index.php/I2C_Tools"
license=('GPL')
depends=('perl')
makedepends=('python' 'git')
makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
options=('!makeflags')
optdepends=('read-edid: for decode-edid script'
'python: for smbus module')
@ -22,30 +22,27 @@ source=(
"https://www.kernel.org/pub/software/utils/i2c-tools/$pkgname-$pkgver.tar.sign"
"$pkgname.sysusers"
"45-i2c-tools.rules"
"python-makefile.patch"
)
sha256sums=('1f899e43603184fac32f34d72498fc737952dbc9c97a8dd9467fadfdf4600cf9'
'SKIP'
'bf5ee4f9876505628c5ce84e84e918c70d66be70b766d62bb138e294608ffbae'
'af9dbdc771023cd04f5b0c638c30356e6a824b32f0c04ea61fe929c71122bccd'
'2f512928ae4ad5cd3e2388b2391378f70b1d5f537f64ff5a0636e018d02d540e')
'af9dbdc771023cd04f5b0c638c30356e6a824b32f0c04ea61fe929c71122bccd')
validpgpkeys=(
'7CA69F4460F1BDC41FD2C858A5526B9BB3CD4E6A' # Jean Delvare
)
prepare() {
cd "${pkgname}-${pkgver}"
patch -Np1 < "$srcdir/python-makefile.patch"
}
build() {
cd ${pkgname}-${pkgver}
make EXTRA="eeprog py-smbus"
make EXTRA="eeprog"
cd py-smbus
python -m build -wn
}
package() {
cd ${pkgname}-${pkgver}
make EXTRA="eeprog py-smbus" PREFIX="${pkgdir}/usr" sbindir="$pkgdir/usr/bin" install
make EXTRA="eeprog" PREFIX="${pkgdir}/usr" sbindir="$pkgdir/usr/bin" install
cd py-smbus
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 "${srcdir}/$pkgname.sysusers" "${pkgdir}/usr/lib/sysusers.d/$pkgname.conf"
install -Dm644 "${srcdir}/45-i2c-tools.rules" "${pkgdir}/usr/lib/udev/rules.d/45-i2c-tools.rules"
}

View file

@ -1,13 +0,0 @@
diff --git a/py-smbus/Module.mk b/py-smbus/Module.mk
index 04ceb64..1e2ded1 100644
--- a/py-smbus/Module.mk
+++ b/py-smbus/Module.mk
@@ -22,7 +22,7 @@ clean-python:
rm -rf py-smbus/build
install-python:
- $(DISTUTILS) install
+ $(DISTUTILS) install --prefix="$(PREFIX)"
all: all-python