diff --git a/extra/erlang-nox/.SRCINFO b/extra/erlang-nox/.SRCINFO
index 4cc7b1644..ac40c6d4d 100644
--- a/extra/erlang-nox/.SRCINFO
+++ b/extra/erlang-nox/.SRCINFO
@@ -1,6 +1,6 @@
 pkgbase = erlang-nox
 	pkgdesc = General-purpose concurrent functional programming language (headless version)
-	pkgver = 26.2.1
+	pkgver = 26.2.2
 	pkgrel = 1
 	url = https://erlang.org/
 	arch = x86_64
@@ -22,7 +22,7 @@ pkgbase = erlang-nox
 	source = epmd.service
 	source = epmd.socket
 	source = https://erlang.org//download/otp_doc_man_26.1.tar.gz
-	source = git+https://github.com/erlang/otp#commit=ca8b893f9d5bdd0957b78514ba523032e762c644
+	source = git+https://github.com/erlang/otp#commit=b83df13eec5446beab06dd24315d37a5b0633fd2
 	b2sums = 1675ac9bf948ab19e8b63077d870ccf356fcdbce14de2777f00b3488aa1ce34a5e0a5cdc0428707f744dee5940b12653a44e0ded0554de95ebb31bce4676ff87
 	b2sums = 1f765318bcd322ce697a48c064ccdb1bd107b4a84e164a87f62678391cb82a9ab17a397d679cf266e037a5a2d91772b85f7a97f9cc5478c0f18118743b30045f
 	b2sums = c37706f5f6e2d49100104fb442ebf15edd6ee0a1e8038d0364794cf34fd3f02a61b9ad2706228b3327b85b0cadcd11aac6087e7c98408eae2d307a09191b6553
diff --git a/extra/erlang-nox/PKGBUILD b/extra/erlang-nox/PKGBUILD
index 1794e1f6a..97e508c6d 100644
--- a/extra/erlang-nox/PKGBUILD
+++ b/extra/erlang-nox/PKGBUILD
@@ -9,11 +9,11 @@
 #  - configure with --disable-pgo to fix ARM FTBFS
 
 pkgname=erlang-nox
-pkgver=26.2.1
+pkgver=26.2.2
 pkgrel=1
 _docver=26.1
 # https://github.com/erlang/otp/tags
-_commit=ca8b893f9d5bdd0957b78514ba523032e762c644 # OTP-26.2.1
+_commit=b83df13eec5446beab06dd24315d37a5b0633fd2 # OTP-26.2.2
 arch=(x86_64)
 pkgdesc='General-purpose concurrent functional programming language (headless version)'
 url='https://erlang.org/'
@@ -37,11 +37,13 @@ b2sums=('1675ac9bf948ab19e8b63077d870ccf356fcdbce14de2777f00b3488aa1ce34a5e0a5cd
         'SKIP')
 
 prepare() {
+  # adjust how LDFLAGS are handled
+  sed -i 's/^LDFLAGS = /LDFLAGS += /g' otp/lib/{odbc/c_src,megaco/src/flex}/Makefile.in
+
   # let the Java bindings support version 11 or later, ref https://gitlab.archlinux.org/archlinux/packaging/packages/erlang/-/issues/1
   sed -i 's/^JAVA_OPTIONS =/JAVA_OPTIONS = --release 11/g' otp/lib/jinterface/java_src/com/ericsson/otp/erlang/Makefile
 }
 
-
 build() {
   cd otp
   #export CFLAGS+=' -ffat-lto-objects'
@@ -77,5 +79,3 @@ package() {
   # remove files that are included in the erlang-unixodbc package
   rm -rf "$pkgdir/usr/lib/erlang/"{lib/odbc*,man/man3/odbc.3}
 }
-
-# getver: raw.githubusercontent.com/erlang/otp/maint/OTP_VERSION