alarm/uboot-raspberrypi to 2016.11-1

This commit is contained in:
Kevin Mihelich 2016-12-11 21:23:19 +00:00
parent 336839e1a3
commit 734358192a
4 changed files with 79 additions and 39 deletions

View file

@ -1,25 +1,45 @@
From bd799e156242713c39ad2b68a5e5ef7053f37acb Mon Sep 17 00:00:00 2001
From 2c1bea4109c351862aa1ebb425adababd630454c Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 19 Feb 2016 21:40:56 -0700
Subject: [PATCH] arch linux arm modifications
---
include/config_distro_defaults.h | 2 ++
1 file changed, 2 insertions(+)
configs/rpi_2_defconfig | 1 +
configs/rpi_3_defconfig | 1 +
include/configs/rpi.h | 2 +-
3 files changed, 3 insertions(+), 1 deletion(-)
diff --git a/include/config_distro_defaults.h b/include/config_distro_defaults.h
index 0f85cd0..8d6c9e9 100644
--- a/include/config_distro_defaults.h
+++ b/include/config_distro_defaults.h
@@ -7,6 +7,8 @@
#ifndef _CONFIG_CMD_DISTRO_DEFAULTS_H
#define _CONFIG_CMD_DISTRO_DEFAULTS_H
diff --git a/configs/rpi_2_defconfig b/configs/rpi_2_defconfig
index bddee43..1f6fb91 100644
--- a/configs/rpi_2_defconfig
+++ b/configs/rpi_2_defconfig
@@ -27,3 +27,4 @@ CONFIG_USB_KEYBOARD=y
CONFIG_LCD=y
CONFIG_PHYS_TO_BUS=y
CONFIG_OF_LIBFDT=y
+CONFIG_IDENT_STRING=" Arch Linux ARM"
diff --git a/configs/rpi_3_defconfig b/configs/rpi_3_defconfig
index 9b6a72f..a0118f7 100644
--- a/configs/rpi_3_defconfig
+++ b/configs/rpi_3_defconfig
@@ -28,3 +28,4 @@ CONFIG_USB_KEYBOARD=y
CONFIG_LCD=y
CONFIG_PHYS_TO_BUS=y
CONFIG_OF_LIBFDT=y
+CONFIG_IDENT_STRING=" Arch Linux ARM"
diff --git a/include/configs/rpi.h b/include/configs/rpi.h
index 45c8234..12d6473 100644
--- a/include/configs/rpi.h
+++ b/include/configs/rpi.h
@@ -187,7 +187,7 @@
"pxefile_addr_r=0x00100000\0" \
"kernel_addr_r=0x01000000\0" \
"scriptaddr=0x02000000\0" \
- "ramdisk_addr_r=0x02100000\0" \
+ "ramdisk_addr_r=0x03000000\0" \
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
+
/*
* List of all commands and options that when defined enables support for
* features required by distros to support boards in a standardised and
#define BOOT_TARGET_DEVICES(func) \
func(MMC, mmc, 0) \
--
2.7.0
2.10.2

View file

@ -1,51 +1,61 @@
# U-Boot: Raspberry Pi
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
buildarch=4
buildarch=12
pkgname=uboot-raspberrypi
pkgver=2016.03
pkgver=2016.11
pkgrel=1
pkgdesc="U-Boot for Raspberry Pi"
arch=('armv7h')
arch=('armv7h' 'aarch64')
url='http://www.denx.de/wiki/U-Boot/WebHome'
license=('GPL')
backup=('boot/boot.txt' 'boot/boot.scr')
backup=('boot/boot.txt' 'boot/boot.scr' 'boot/config.txt')
makedepends=('bc' 'dtc' 'git')
conflicts=('linux-raspberrypi')
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
conflicts_armv7h=('linux-raspberrypi')
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
'0001-arch-linux-arm-modifications.patch'
'boot.txt'
'boot.txt.v2'
'boot.txt.v3'
'mkscr')
md5sums=('973c1d896be751321cc3aafa564f64b2'
'2fc5fdd1fb48545336a2f534772d7477'
'3631f52fb2a0e940bbcc04ea80701d9a'
md5sums=('ca1f6e019d08aff8d0ca1beb2e66737d'
'7410bad5df89ae981e8c4b680d40e40e'
'c42b8a22509ca7d1580ce3916c28ae74'
'b628c01f99130b5869596326d57634a8'
'021623a04afd29ac3f368977140cfbfd')
prepare() {
cd u-boot-${pkgver}
cd u-boot-${pkgver/rc/-rc}
git apply ../0001-arch-linux-arm-modifications.patch
}
build() {
cd u-boot-${pkgver}
cd u-boot-${pkgver/rc/-rc}
unset CFLAGS
unset CXXFLAGS
unset CPPFLAGS
make distclean
make rpi_2_config
make distclean
[[ $CARCH == "armv7h" ]] && make rpi_2_config
[[ $CARCH == "aarch64" ]] && make rpi_3_config
make EXTRAVERSION=-${pkgrel}
}
package() {
cd u-boot-${pkgver}
cd u-boot-${pkgver/rc/-rc}
mkdir -p "${pkgdir}"/boot
cp u-boot.bin ${pkgdir}/boot/kernel7.img
if [[ $CARCH == "armv7h" ]]; then
cp u-boot.bin ${pkgdir}/boot/kernel7.img
cp ../boot.txt.v2 ../boot.txt
elif [[ $CARCH == "aarch64" ]]; then
cp u-boot.bin ${pkgdir}/boot/kernel8.img
cp ../boot.txt.v3 ../boot.txt
echo "enable_uart=1" > ${pkgdir}/boot/config.txt
fi
tools/mkimage -A arm -O linux -T script -C none -n "U-Boot boot script" -d ../boot.txt "${pkgdir}"/boot/boot.scr
cp ../{boot.txt,mkscr} "${pkgdir}"/boot

View file

@ -1,15 +1,9 @@
# After modifying, run ./mkscr
# MAC address configuration
#setenv macaddr "b8:27:eb:fc:c8:c2"
# Device tree
setenv fdtfile "bcm2836-rpi-2-b.dtb"
# Set root partition to the second partition of boot device
part uuid ${devtype} ${devnum}:2 uuid
setenv bootargs "console=ttyAMA0,115200 root=PARTUUID=${uuid} rw rootwait smsc95xx.macaddr=${macaddr}"
setenv bootargs console=ttyAMA0,115200 root=PARTUUID=${uuid} rw rootwait smsc95xx.macaddr=${usbethaddr}
if load ${devtype} ${devnum}:${bootpart} ${kernel_addr_r} /zImage; then
if load ${devtype} ${devnum}:${bootpart} ${fdt_addr_r} /dtbs/${fdtfile}; then

View file

@ -0,0 +1,16 @@
# After modifying, run ./mkscr
# Set root partition to the second partition of boot device
part uuid ${devtype} ${devnum}:2 uuid
setenv bootargs console=ttyS0,115200 console=tty0 root=PARTUUID=${uuid} rw rootwait smsc95xx.macaddr="${usbethaddr}"
if load ${devtype} ${devnum}:${bootpart} ${kernel_addr_r} /Image; then
if load ${devtype} ${devnum}:${bootpart} ${fdt_addr_r} /dtbs/broadcom/${fdtfile}; then
if load ${devtype} ${devnum}:${bootpart} ${ramdisk_addr_r} /initramfs-linux.img; then
booti ${kernel_addr_r} ${ramdisk_addr_r}:${filesize} ${fdt_addr_r};
else
booti ${kernel_addr_r} - ${fdt_addr_r};
fi;
fi;
fi