mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/linux-kirkwood-dt to 5.5.2-1
This commit is contained in:
parent
aaad3dd1b8
commit
735a561758
4 changed files with 165 additions and 123 deletions
|
@ -94,18 +94,18 @@ diff --git a/include/linux/leds.h b/include/linux/leds.h
|
|||
index 9b2bf574a17a..72f49e02427c 100644
|
||||
--- a/include/linux/leds.h
|
||||
+++ b/include/linux/leds.h
|
||||
@@ -392,6 +392,12 @@ extern void ledtrig_disk_activity(bool write);
|
||||
@@ -450,6 +450,12 @@ void ledtrig_disk_activity(bool write);
|
||||
static inline void ledtrig_disk_activity(bool write) {}
|
||||
#endif
|
||||
|
||||
+#ifdef CONFIG_LEDS_TRIGGER_SATA
|
||||
+extern void ledtrig_sata_activity(int port_number);
|
||||
+void ledtrig_sata_activity(int port_number);
|
||||
+#else
|
||||
+static inline void ledtrig_sata_activity(int port_number) {}
|
||||
+#endif
|
||||
+
|
||||
#ifdef CONFIG_LEDS_TRIGGER_MTD
|
||||
extern void ledtrig_mtd_activity(void);
|
||||
void ledtrig_mtd_activity(void);
|
||||
#else
|
||||
--
|
||||
2.21.0
|
||||
|
|
|
@ -4,10 +4,10 @@
|
|||
buildarch=2
|
||||
|
||||
pkgbase=linux-kirkwood-dt
|
||||
_srcname=linux-5.4
|
||||
_srcname=linux-5.5
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Marvell Kirkwood DT"
|
||||
pkgver=5.4.15
|
||||
pkgver=5.5.2
|
||||
pkgrel=1
|
||||
arch=('arm')
|
||||
url="http://www.kernel.org/"
|
||||
|
@ -25,15 +25,15 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
|
|||
'config'
|
||||
'linux.preset'
|
||||
'99-linux.hook')
|
||||
md5sums=('ce9b2d974d27408a61c53a30d3f98fb9'
|
||||
'bbb20c60fad075793e7a1be91051595e'
|
||||
'5085b2d587c08fe4129b21b784c5ec72'
|
||||
md5sums=('0a78b1dc48dc032fe505b170c1b92339'
|
||||
'2c987564f306f949f34c97a87db0d264'
|
||||
'c46bc6485fedf6551eb3868f24afadf6'
|
||||
'1a3ca8cce7b0fdc7e72ecde511023d97'
|
||||
'9a64b38798167ebea717d614875ef44a'
|
||||
'de322923548e24d0811df22daf1192d3'
|
||||
'1bb5e1f081c2333607640c857a5aef6d'
|
||||
'1798736e24f99d840d764ec590b15f7d'
|
||||
'e3fdfc8a035319304ec4a1ef2484363d'
|
||||
'55222fa310c573677de583751dcdb5c8'
|
||||
'959e49540dac4c5e689ad9037150a360'
|
||||
'79fa396e3f9a09a85156d6d7c2d34b58')
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 5.4.13-1 Kernel Configuration
|
||||
# Linux/arm 5.5.2-1 Kernel Configuration
|
||||
#
|
||||
|
||||
#
|
||||
|
@ -22,7 +22,6 @@ CONFIG_BUILDTIME_EXTABLE_SORT=y
|
|||
CONFIG_BROKEN_ON_SMP=y
|
||||
CONFIG_INIT_ENV_ARG_LIMIT=32
|
||||
# CONFIG_COMPILE_TEST is not set
|
||||
# CONFIG_HEADER_TEST is not set
|
||||
CONFIG_LOCALVERSION="-ARCH"
|
||||
# CONFIG_LOCALVERSION_AUTO is not set
|
||||
CONFIG_BUILD_SALT=""
|
||||
|
@ -490,6 +489,8 @@ CONFIG_CRYPTO_SHA1_ARM=y
|
|||
CONFIG_CRYPTO_SHA256_ARM=y
|
||||
CONFIG_CRYPTO_SHA512_ARM=y
|
||||
CONFIG_CRYPTO_AES_ARM=y
|
||||
# CONFIG_CRYPTO_CHACHA20_NEON is not set
|
||||
# CONFIG_CRYPTO_POLY1305_ARM is not set
|
||||
# CONFIG_VIRTUALIZATION is not set
|
||||
|
||||
#
|
||||
|
@ -545,7 +546,6 @@ CONFIG_HAVE_COPY_THREAD_TLS=y
|
|||
CONFIG_CLONE_BACKWARDS=y
|
||||
CONFIG_OLD_SIGSUSPEND3=y
|
||||
CONFIG_OLD_SIGACTION=y
|
||||
CONFIG_64BIT_TIME=y
|
||||
CONFIG_COMPAT_32BIT_TIME=y
|
||||
CONFIG_ARCH_OPTIONAL_KERNEL_RWX=y
|
||||
CONFIG_ARCH_HAS_STRICT_KERNEL_RWX=y
|
||||
|
@ -553,7 +553,6 @@ CONFIG_ARCH_HAS_STRICT_KERNEL_RWX=y
|
|||
CONFIG_ARCH_HAS_STRICT_MODULE_RWX=y
|
||||
# CONFIG_STRICT_MODULE_RWX is not set
|
||||
CONFIG_ARCH_HAS_PHYS_TO_DMA=y
|
||||
CONFIG_REFCOUNT_FULL=y
|
||||
# CONFIG_LOCK_EVENT_COUNTS is not set
|
||||
|
||||
#
|
||||
|
@ -589,6 +588,7 @@ CONFIG_MODULES_TREE_LOOKUP=y
|
|||
CONFIG_BLOCK=y
|
||||
CONFIG_BLK_RQ_ALLOC_TIME=y
|
||||
CONFIG_BLK_SCSI_REQUEST=y
|
||||
CONFIG_BLK_CGROUP_RWSTAT=y
|
||||
CONFIG_BLK_DEV_BSG=y
|
||||
CONFIG_BLK_DEV_BSGLIB=y
|
||||
CONFIG_BLK_DEV_INTEGRITY=y
|
||||
|
@ -707,6 +707,7 @@ CONFIG_UNIX_SCM=y
|
|||
# CONFIG_UNIX_DIAG is not set
|
||||
CONFIG_TLS=m
|
||||
# CONFIG_TLS_DEVICE is not set
|
||||
# CONFIG_TLS_TOE is not set
|
||||
CONFIG_XFRM=y
|
||||
CONFIG_XFRM_OFFLOAD=y
|
||||
CONFIG_XFRM_ALGO=m
|
||||
|
@ -1353,7 +1354,6 @@ CONFIG_BT_HCIVHCI=m
|
|||
CONFIG_BT_MRVL=m
|
||||
CONFIG_BT_MRVL_SDIO=m
|
||||
CONFIG_BT_ATH3K=m
|
||||
# CONFIG_BT_WILINK is not set
|
||||
# CONFIG_BT_MTKSDIO is not set
|
||||
CONFIG_BT_HCIRSI=m
|
||||
# end of Bluetooth device drivers
|
||||
|
@ -1427,6 +1427,12 @@ CONFIG_PCI_DOMAINS=y
|
|||
CONFIG_PCI_DOMAINS_GENERIC=y
|
||||
CONFIG_PCI_SYSCALL=y
|
||||
# CONFIG_PCIEPORTBUS is not set
|
||||
CONFIG_PCIEASPM=y
|
||||
CONFIG_PCIEASPM_DEFAULT=y
|
||||
# CONFIG_PCIEASPM_POWERSAVE is not set
|
||||
# CONFIG_PCIEASPM_POWER_SUPERSAVE is not set
|
||||
# CONFIG_PCIEASPM_PERFORMANCE is not set
|
||||
# CONFIG_PCIE_PTM is not set
|
||||
# CONFIG_PCI_MSI is not set
|
||||
CONFIG_PCI_QUIRKS=y
|
||||
# CONFIG_PCI_DEBUG is not set
|
||||
|
@ -1441,13 +1447,6 @@ CONFIG_PCI_BRIDGE_EMUL=y
|
|||
# PCI controller drivers
|
||||
#
|
||||
CONFIG_PCI_MVEBU=y
|
||||
|
||||
#
|
||||
# Cadence PCIe controllers support
|
||||
#
|
||||
# CONFIG_PCIE_CADENCE_HOST is not set
|
||||
# end of Cadence PCIe controllers support
|
||||
|
||||
# CONFIG_PCI_FTPCI100 is not set
|
||||
# CONFIG_PCI_HOST_GENERIC is not set
|
||||
# CONFIG_PCIE_XILINX is not set
|
||||
|
@ -1458,6 +1457,12 @@ CONFIG_PCI_MVEBU=y
|
|||
# DesignWare PCI Core Support
|
||||
#
|
||||
# end of DesignWare PCI Core Support
|
||||
|
||||
#
|
||||
# Cadence PCIe controllers support
|
||||
#
|
||||
# CONFIG_PCIE_CADENCE_PLAT_HOST is not set
|
||||
# end of Cadence PCIe controllers support
|
||||
# end of PCI controller drivers
|
||||
|
||||
#
|
||||
|
@ -1493,6 +1498,7 @@ CONFIG_FW_LOADER_PAGED_BUF=y
|
|||
CONFIG_EXTRA_FIRMWARE=""
|
||||
# CONFIG_FW_LOADER_USER_HELPER is not set
|
||||
CONFIG_FW_LOADER_COMPRESS=y
|
||||
CONFIG_FW_CACHE=y
|
||||
# end of Firmware loader
|
||||
|
||||
CONFIG_WANT_DEV_COREDUMP=y
|
||||
|
@ -1634,6 +1640,7 @@ CONFIG_MTD_NAND_ORION=y
|
|||
# CONFIG_MTD_NAND_MXIC is not set
|
||||
# CONFIG_MTD_NAND_GPIO is not set
|
||||
# CONFIG_MTD_NAND_PLATFORM is not set
|
||||
# CONFIG_MTD_NAND_CADENCE is not set
|
||||
|
||||
#
|
||||
# Misc
|
||||
|
@ -1763,39 +1770,7 @@ CONFIG_TI_ST=m
|
|||
#
|
||||
# Intel MIC & related support
|
||||
#
|
||||
|
||||
#
|
||||
# Intel MIC Bus Driver
|
||||
#
|
||||
|
||||
#
|
||||
# SCIF Bus Driver
|
||||
#
|
||||
|
||||
#
|
||||
# VOP Bus Driver
|
||||
#
|
||||
# CONFIG_VOP_BUS is not set
|
||||
|
||||
#
|
||||
# Intel MIC Host Driver
|
||||
#
|
||||
|
||||
#
|
||||
# Intel MIC Card Driver
|
||||
#
|
||||
|
||||
#
|
||||
# SCIF Driver
|
||||
#
|
||||
|
||||
#
|
||||
# Intel MIC Coprocessor State Management (COSM) Drivers
|
||||
#
|
||||
|
||||
#
|
||||
# VOP Driver
|
||||
#
|
||||
# end of Intel MIC & related support
|
||||
|
||||
# CONFIG_ECHO is not set
|
||||
|
@ -2075,15 +2050,7 @@ CONFIG_VETH=m
|
|||
# CONFIG_NLMON is not set
|
||||
# CONFIG_NET_VRF is not set
|
||||
# CONFIG_ARCNET is not set
|
||||
|
||||
#
|
||||
# CAIF transport drivers
|
||||
#
|
||||
CONFIG_CAIF_TTY=m
|
||||
CONFIG_CAIF_SPI_SLAVE=m
|
||||
# CONFIG_CAIF_SPI_SYNC is not set
|
||||
# CONFIG_CAIF_HSI is not set
|
||||
# CONFIG_CAIF_VIRTIO is not set
|
||||
# CONFIG_CAIF_DRIVERS is not set
|
||||
|
||||
#
|
||||
# Distributed Switch Architecture drivers
|
||||
|
@ -2166,8 +2133,6 @@ CONFIG_NET_VENDOR_HISILICON=y
|
|||
# CONFIG_HNS_DSAF is not set
|
||||
# CONFIG_HNS_ENET is not set
|
||||
# CONFIG_HNS3 is not set
|
||||
CONFIG_NET_VENDOR_HP=y
|
||||
# CONFIG_HP100 is not set
|
||||
CONFIG_NET_VENDOR_HUAWEI=y
|
||||
CONFIG_NET_VENDOR_I825XX=y
|
||||
CONFIG_NET_VENDOR_INTEL=y
|
||||
|
@ -2297,6 +2262,7 @@ CONFIG_MDIO_BUS=y
|
|||
# CONFIG_MDIO_BUS_MUX_MULTIPLEXER is not set
|
||||
# CONFIG_MDIO_HISI_FEMAC is not set
|
||||
# CONFIG_MDIO_MSCC_MIIM is not set
|
||||
CONFIG_PHYLINK=m
|
||||
CONFIG_PHYLIB=y
|
||||
CONFIG_SWPHY=y
|
||||
CONFIG_LED_TRIGGER_PHY=y
|
||||
|
@ -2304,11 +2270,11 @@ CONFIG_LED_TRIGGER_PHY=y
|
|||
#
|
||||
# MII PHY device drivers
|
||||
#
|
||||
# CONFIG_SFP is not set
|
||||
# CONFIG_ADIN_PHY is not set
|
||||
# CONFIG_AMD_PHY is not set
|
||||
# CONFIG_AQUANTIA_PHY is not set
|
||||
# CONFIG_AX88796B_PHY is not set
|
||||
CONFIG_AT803X_PHY=m
|
||||
# CONFIG_BCM7XXX_PHY is not set
|
||||
# CONFIG_BCM87XX_PHY is not set
|
||||
# CONFIG_BROADCOM_PHY is not set
|
||||
|
@ -2319,6 +2285,7 @@ CONFIG_CORTINA_PHY=m
|
|||
# CONFIG_DP83TC811_PHY is not set
|
||||
# CONFIG_DP83848_PHY is not set
|
||||
# CONFIG_DP83867_PHY is not set
|
||||
# CONFIG_DP83869_PHY is not set
|
||||
CONFIG_FIXED_PHY=y
|
||||
# CONFIG_ICPLUS_PHY is not set
|
||||
# CONFIG_INTEL_XWAY_PHY is not set
|
||||
|
@ -2332,6 +2299,7 @@ CONFIG_MICROCHIP_PHY=m
|
|||
# CONFIG_MICROSEMI_PHY is not set
|
||||
# CONFIG_NATIONAL_PHY is not set
|
||||
# CONFIG_NXP_TJA11XX_PHY is not set
|
||||
CONFIG_AT803X_PHY=m
|
||||
# CONFIG_QSEMI_PHY is not set
|
||||
CONFIG_REALTEK_PHY=y
|
||||
# CONFIG_RENESAS_PHY is not set
|
||||
|
@ -2901,7 +2869,6 @@ CONFIG_SERIAL_8250_EXAR=m
|
|||
CONFIG_SERIAL_8250_NR_UARTS=4
|
||||
CONFIG_SERIAL_8250_RUNTIME_UARTS=2
|
||||
# CONFIG_SERIAL_8250_EXTENDED is not set
|
||||
# CONFIG_SERIAL_8250_ASPEED_VUART is not set
|
||||
CONFIG_SERIAL_8250_FSL=y
|
||||
# CONFIG_SERIAL_8250_DW is not set
|
||||
# CONFIG_SERIAL_8250_EM is not set
|
||||
|
@ -3096,6 +3063,7 @@ CONFIG_PTP_1588_CLOCK=y
|
|||
#
|
||||
# Enable PHYLIB and NETWORK_PHY_TIMESTAMPING to see the additional clocks.
|
||||
#
|
||||
# CONFIG_PTP_1588_CLOCK_IDTCM is not set
|
||||
# end of PTP clock support
|
||||
|
||||
CONFIG_PINCTRL=y
|
||||
|
@ -3112,6 +3080,7 @@ CONFIG_GENERIC_PINCONF=y
|
|||
CONFIG_PINCTRL_MVEBU=y
|
||||
CONFIG_PINCTRL_KIRKWOOD=y
|
||||
CONFIG_PINCTRL_MADERA=m
|
||||
# CONFIG_PINCTRL_EQUILIBRIUM is not set
|
||||
CONFIG_ARCH_HAVE_CUSTOM_GPIO_H=y
|
||||
CONFIG_GPIOLIB=y
|
||||
CONFIG_GPIOLIB_FASTPATH_LIMIT=512
|
||||
|
@ -3209,6 +3178,7 @@ CONFIG_W1_SLAVE_DS2405=m
|
|||
# CONFIG_W1_SLAVE_DS2406 is not set
|
||||
CONFIG_W1_SLAVE_DS2423=m
|
||||
# CONFIG_W1_SLAVE_DS2805 is not set
|
||||
# CONFIG_W1_SLAVE_DS2430 is not set
|
||||
CONFIG_W1_SLAVE_DS2431=m
|
||||
CONFIG_W1_SLAVE_DS2433=m
|
||||
CONFIG_W1_SLAVE_DS2433_CRC=y
|
||||
|
@ -3308,6 +3278,8 @@ CONFIG_SENSORS_ADT7475=m
|
|||
# CONFIG_SENSORS_POWR1220 is not set
|
||||
# CONFIG_SENSORS_LINEAGE is not set
|
||||
# CONFIG_SENSORS_LTC2945 is not set
|
||||
# CONFIG_SENSORS_LTC2947_I2C is not set
|
||||
# CONFIG_SENSORS_LTC2947_SPI is not set
|
||||
# CONFIG_SENSORS_LTC2990 is not set
|
||||
# CONFIG_SENSORS_LTC4151 is not set
|
||||
# CONFIG_SENSORS_LTC4215 is not set
|
||||
|
@ -3388,6 +3360,7 @@ CONFIG_SENSORS_NSA320=m
|
|||
# CONFIG_SENSORS_TMP108 is not set
|
||||
# CONFIG_SENSORS_TMP401 is not set
|
||||
# CONFIG_SENSORS_TMP421 is not set
|
||||
# CONFIG_SENSORS_TMP513 is not set
|
||||
# CONFIG_SENSORS_VIA686A is not set
|
||||
# CONFIG_SENSORS_VT1211 is not set
|
||||
# CONFIG_SENSORS_VT8231 is not set
|
||||
|
@ -3409,12 +3382,10 @@ CONFIG_THERMAL_OF=y
|
|||
CONFIG_THERMAL_DEFAULT_GOV_STEP_WISE=y
|
||||
# CONFIG_THERMAL_DEFAULT_GOV_FAIR_SHARE is not set
|
||||
# CONFIG_THERMAL_DEFAULT_GOV_USER_SPACE is not set
|
||||
# CONFIG_THERMAL_DEFAULT_GOV_POWER_ALLOCATOR is not set
|
||||
# CONFIG_THERMAL_GOV_FAIR_SHARE is not set
|
||||
CONFIG_THERMAL_GOV_STEP_WISE=y
|
||||
# CONFIG_THERMAL_GOV_BANG_BANG is not set
|
||||
# CONFIG_THERMAL_GOV_USER_SPACE is not set
|
||||
# CONFIG_THERMAL_GOV_POWER_ALLOCATOR is not set
|
||||
# CONFIG_CPU_THERMAL is not set
|
||||
# CONFIG_CLOCK_THERMAL is not set
|
||||
# CONFIG_THERMAL_EMULATION is not set
|
||||
|
@ -4264,7 +4235,7 @@ CONFIG_LCD_CLASS_DEVICE=m
|
|||
# CONFIG_LCD_OTM3225A is not set
|
||||
CONFIG_BACKLIGHT_CLASS_DEVICE=m
|
||||
CONFIG_BACKLIGHT_GENERIC=m
|
||||
# CONFIG_BACKLIGHT_PM8941_WLED is not set
|
||||
# CONFIG_BACKLIGHT_QCOM_WLED is not set
|
||||
# CONFIG_BACKLIGHT_ADP8860 is not set
|
||||
# CONFIG_BACKLIGHT_ADP8870 is not set
|
||||
# CONFIG_BACKLIGHT_LM3639 is not set
|
||||
|
@ -4443,6 +4414,8 @@ CONFIG_SND_SOC_I2C_AND_SPI=m
|
|||
# CONFIG_SND_SOC_ADAU1761_I2C is not set
|
||||
# CONFIG_SND_SOC_ADAU1761_SPI is not set
|
||||
# CONFIG_SND_SOC_ADAU7002 is not set
|
||||
# CONFIG_SND_SOC_ADAU7118_HW is not set
|
||||
# CONFIG_SND_SOC_ADAU7118_I2C is not set
|
||||
# CONFIG_SND_SOC_AK4104 is not set
|
||||
# CONFIG_SND_SOC_AK4118 is not set
|
||||
# CONFIG_SND_SOC_AK4458 is not set
|
||||
|
@ -4475,6 +4448,7 @@ CONFIG_SND_SOC_CS42L51=m
|
|||
# CONFIG_SND_SOC_CS4349 is not set
|
||||
# CONFIG_SND_SOC_CS53L30 is not set
|
||||
# CONFIG_SND_SOC_CX2072X is not set
|
||||
# CONFIG_SND_SOC_DA7213 is not set
|
||||
CONFIG_SND_SOC_DMIC=m
|
||||
# CONFIG_SND_SOC_ES7134 is not set
|
||||
# CONFIG_SND_SOC_ES7241 is not set
|
||||
|
@ -4519,6 +4493,8 @@ CONFIG_SND_SOC_SPDIF=m
|
|||
# CONFIG_SND_SOC_STA350 is not set
|
||||
# CONFIG_SND_SOC_STI_SAS is not set
|
||||
# CONFIG_SND_SOC_TAS2552 is not set
|
||||
# CONFIG_SND_SOC_TAS2562 is not set
|
||||
# CONFIG_SND_SOC_TAS2770 is not set
|
||||
# CONFIG_SND_SOC_TAS5086 is not set
|
||||
# CONFIG_SND_SOC_TAS571X is not set
|
||||
# CONFIG_SND_SOC_TAS5720 is not set
|
||||
|
@ -4931,6 +4907,7 @@ CONFIG_MMC_SDHCI_PLTFM=y
|
|||
# CONFIG_MMC_SDHCI_CADENCE is not set
|
||||
# CONFIG_MMC_SDHCI_PXAV3 is not set
|
||||
# CONFIG_MMC_SDHCI_F_SDH30 is not set
|
||||
# CONFIG_MMC_SDHCI_MILBEAUT is not set
|
||||
# CONFIG_MMC_TIFM_SD is not set
|
||||
CONFIG_MMC_MVSDIO=y
|
||||
# CONFIG_MMC_SPI is not set
|
||||
|
@ -4959,6 +4936,7 @@ CONFIG_LEDS_BRIGHTNESS_HW_CHANGED=y
|
|||
# CONFIG_LEDS_BCM6328 is not set
|
||||
# CONFIG_LEDS_BCM6358 is not set
|
||||
# CONFIG_LEDS_CR0014114 is not set
|
||||
# CONFIG_LEDS_EL15203000 is not set
|
||||
# CONFIG_LEDS_LM3530 is not set
|
||||
# CONFIG_LEDS_LM3532 is not set
|
||||
# CONFIG_LEDS_LM3642 is not set
|
||||
|
@ -5156,6 +5134,7 @@ CONFIG_MV_XOR=y
|
|||
# CONFIG_QCOM_HIDMA is not set
|
||||
# CONFIG_DW_DMAC is not set
|
||||
# CONFIG_DW_DMAC_PCI is not set
|
||||
# CONFIG_SF_PDMA is not set
|
||||
|
||||
#
|
||||
# DMA Clients
|
||||
|
@ -5293,8 +5272,17 @@ CONFIG_88EU_AP_MODE=y
|
|||
CONFIG_USB_WUSB_CBAF=m
|
||||
# CONFIG_USB_WUSB_CBAF_DEBUG is not set
|
||||
# CONFIG_UWB is not set
|
||||
# CONFIG_EXFAT_FS is not set
|
||||
CONFIG_EXFAT_FS=m
|
||||
CONFIG_EXFAT_DISCARD=y
|
||||
# CONFIG_EXFAT_DELAYED_SYNC is not set
|
||||
# CONFIG_EXFAT_KERNEL_DEBUG is not set
|
||||
# CONFIG_EXFAT_DEBUG_MSG is not set
|
||||
CONFIG_EXFAT_DEFAULT_CODEPAGE=437
|
||||
CONFIG_EXFAT_DEFAULT_IOCHARSET="utf8"
|
||||
# CONFIG_QLGE is not set
|
||||
CONFIG_NET_VENDOR_HP=y
|
||||
# CONFIG_HP100 is not set
|
||||
# CONFIG_WFX is not set
|
||||
# CONFIG_GOLDFISH is not set
|
||||
# CONFIG_MFD_CROS_EC is not set
|
||||
# CONFIG_CHROME_PLATFORMS is not set
|
||||
|
@ -5384,6 +5372,7 @@ CONFIG_IOMMU_SUPPORT=y
|
|||
#
|
||||
# NXP/Freescale QorIQ SoC drivers
|
||||
#
|
||||
# CONFIG_FSL_RCPM is not set
|
||||
# end of NXP/Freescale QorIQ SoC drivers
|
||||
|
||||
#
|
||||
|
@ -5461,6 +5450,7 @@ CONFIG_IIO_SW_TRIGGER=m
|
|||
# CONFIG_AD7124 is not set
|
||||
# CONFIG_AD7266 is not set
|
||||
# CONFIG_AD7291 is not set
|
||||
# CONFIG_AD7292 is not set
|
||||
# CONFIG_AD7298 is not set
|
||||
# CONFIG_AD7476 is not set
|
||||
# CONFIG_AD7606_IFACE_PARALLEL is not set
|
||||
|
@ -5661,6 +5651,8 @@ CONFIG_DHT11=m
|
|||
# CONFIG_ADIS16480 is not set
|
||||
# CONFIG_BMI160_I2C is not set
|
||||
# CONFIG_BMI160_SPI is not set
|
||||
# CONFIG_FXOS8700_I2C is not set
|
||||
# CONFIG_FXOS8700_SPI is not set
|
||||
# CONFIG_KMX61 is not set
|
||||
# CONFIG_INV_MPU6050_I2C is not set
|
||||
# CONFIG_INV_MPU6050_SPI is not set
|
||||
|
@ -5671,6 +5663,7 @@ CONFIG_DHT11=m
|
|||
# Light sensors
|
||||
#
|
||||
# CONFIG_ADJD_S311 is not set
|
||||
# CONFIG_ADUX1020 is not set
|
||||
# CONFIG_AL3320A is not set
|
||||
# CONFIG_APDS9300 is not set
|
||||
# CONFIG_APDS9960 is not set
|
||||
|
@ -5709,6 +5702,7 @@ CONFIG_SI1133=m
|
|||
# CONFIG_US5182D is not set
|
||||
# CONFIG_VCNL4000 is not set
|
||||
# CONFIG_VCNL4035 is not set
|
||||
# CONFIG_VEML6030 is not set
|
||||
# CONFIG_VEML6070 is not set
|
||||
# CONFIG_VL6180 is not set
|
||||
# CONFIG_ZOPT2201 is not set
|
||||
|
@ -5823,6 +5817,7 @@ CONFIG_ISL29501=m
|
|||
#
|
||||
# Temperature sensors
|
||||
#
|
||||
# CONFIG_LTC2983 is not set
|
||||
# CONFIG_MAXIM_THERMOCOUPLE is not set
|
||||
# CONFIG_HID_SENSOR_TEMP is not set
|
||||
# CONFIG_MLX90614 is not set
|
||||
|
@ -6203,6 +6198,7 @@ CONFIG_NLS_KOI8_U=m
|
|||
CONFIG_NLS_UTF8=y
|
||||
# CONFIG_DLM is not set
|
||||
# CONFIG_UNICODE is not set
|
||||
CONFIG_IO_WQ=y
|
||||
# end of File systems
|
||||
|
||||
#
|
||||
|
@ -6273,8 +6269,8 @@ CONFIG_CRYPTO_ALGAPI=y
|
|||
CONFIG_CRYPTO_ALGAPI2=y
|
||||
CONFIG_CRYPTO_AEAD=y
|
||||
CONFIG_CRYPTO_AEAD2=y
|
||||
CONFIG_CRYPTO_BLKCIPHER=y
|
||||
CONFIG_CRYPTO_BLKCIPHER2=y
|
||||
CONFIG_CRYPTO_SKCIPHER=y
|
||||
CONFIG_CRYPTO_SKCIPHER2=y
|
||||
CONFIG_CRYPTO_HASH=y
|
||||
CONFIG_CRYPTO_HASH2=y
|
||||
CONFIG_CRYPTO_RNG=y
|
||||
|
@ -6304,6 +6300,7 @@ CONFIG_CRYPTO_DH=m
|
|||
CONFIG_CRYPTO_ECC=m
|
||||
CONFIG_CRYPTO_ECDH=m
|
||||
# CONFIG_CRYPTO_ECRDSA is not set
|
||||
# CONFIG_CRYPTO_CURVE25519 is not set
|
||||
|
||||
#
|
||||
# Authenticated Encryption with Associated Data
|
||||
|
@ -6346,6 +6343,8 @@ CONFIG_CRYPTO_VMAC=m
|
|||
CONFIG_CRYPTO_CRC32C=y
|
||||
CONFIG_CRYPTO_CRC32=y
|
||||
CONFIG_CRYPTO_XXHASH=m
|
||||
CONFIG_CRYPTO_BLAKE2B=m
|
||||
# CONFIG_CRYPTO_BLAKE2S is not set
|
||||
CONFIG_CRYPTO_CRCT10DIF=y
|
||||
CONFIG_CRYPTO_GHASH=m
|
||||
CONFIG_CRYPTO_POLY1305=m
|
||||
|
@ -6357,7 +6356,6 @@ CONFIG_CRYPTO_RMD160=m
|
|||
CONFIG_CRYPTO_RMD256=m
|
||||
CONFIG_CRYPTO_RMD320=m
|
||||
CONFIG_CRYPTO_SHA1=y
|
||||
CONFIG_CRYPTO_LIB_SHA256=y
|
||||
CONFIG_CRYPTO_SHA256=y
|
||||
CONFIG_CRYPTO_SHA512=y
|
||||
CONFIG_CRYPTO_SHA3=m
|
||||
|
@ -6369,11 +6367,9 @@ CONFIG_CRYPTO_WP512=m
|
|||
#
|
||||
# Ciphers
|
||||
#
|
||||
CONFIG_CRYPTO_LIB_AES=y
|
||||
CONFIG_CRYPTO_AES=y
|
||||
CONFIG_CRYPTO_AES_TI=m
|
||||
CONFIG_CRYPTO_ANUBIS=m
|
||||
CONFIG_CRYPTO_LIB_ARC4=y
|
||||
CONFIG_CRYPTO_ARC4=y
|
||||
CONFIG_CRYPTO_BLOWFISH=m
|
||||
CONFIG_CRYPTO_BLOWFISH_COMMON=m
|
||||
|
@ -6381,7 +6377,6 @@ CONFIG_CRYPTO_CAMELLIA=m
|
|||
CONFIG_CRYPTO_CAST_COMMON=m
|
||||
CONFIG_CRYPTO_CAST5=m
|
||||
CONFIG_CRYPTO_CAST6=m
|
||||
CONFIG_CRYPTO_LIB_DES=y
|
||||
CONFIG_CRYPTO_DES=y
|
||||
CONFIG_CRYPTO_FCRYPT=m
|
||||
CONFIG_CRYPTO_KHAZAD=m
|
||||
|
@ -6421,6 +6416,22 @@ CONFIG_CRYPTO_USER_API_RNG=m
|
|||
CONFIG_CRYPTO_USER_API_AEAD=m
|
||||
# CONFIG_CRYPTO_STATS is not set
|
||||
CONFIG_CRYPTO_HASH_INFO=y
|
||||
|
||||
#
|
||||
# Crypto library routines
|
||||
#
|
||||
CONFIG_CRYPTO_LIB_AES=y
|
||||
CONFIG_CRYPTO_LIB_ARC4=y
|
||||
# CONFIG_CRYPTO_LIB_BLAKE2S is not set
|
||||
CONFIG_CRYPTO_LIB_CHACHA_GENERIC=m
|
||||
# CONFIG_CRYPTO_LIB_CHACHA is not set
|
||||
# CONFIG_CRYPTO_LIB_CURVE25519 is not set
|
||||
CONFIG_CRYPTO_LIB_DES=y
|
||||
CONFIG_CRYPTO_LIB_POLY1305_RSIZE=9
|
||||
CONFIG_CRYPTO_LIB_POLY1305_GENERIC=m
|
||||
# CONFIG_CRYPTO_LIB_POLY1305 is not set
|
||||
# CONFIG_CRYPTO_LIB_CHACHA20POLY1305 is not set
|
||||
CONFIG_CRYPTO_LIB_SHA256=y
|
||||
CONFIG_CRYPTO_HW=y
|
||||
CONFIG_CRYPTO_DEV_MARVELL_CESA=m
|
||||
# CONFIG_CRYPTO_DEV_HIFN_795X is not set
|
||||
|
@ -6428,6 +6439,7 @@ CONFIG_CRYPTO_DEV_MARVELL_CESA=m
|
|||
# CONFIG_CRYPTO_DEV_ATMEL_SHA204A is not set
|
||||
# CONFIG_CRYPTO_DEV_SAFEXCEL is not set
|
||||
# CONFIG_CRYPTO_DEV_CCREE is not set
|
||||
# CONFIG_CRYPTO_DEV_AMLOGIC_GXL is not set
|
||||
CONFIG_ASYMMETRIC_KEY_TYPE=y
|
||||
CONFIG_ASYMMETRIC_PUBLIC_KEY_SUBTYPE=y
|
||||
CONFIG_X509_CERTIFICATE_PARSER=y
|
||||
|
@ -6520,6 +6532,7 @@ CONFIG_ARCH_HAS_DMA_WRITE_COMBINE=y
|
|||
CONFIG_DMA_DECLARE_COHERENT=y
|
||||
CONFIG_ARCH_HAS_SETUP_DMA_OPS=y
|
||||
CONFIG_ARCH_HAS_TEARDOWN_DMA_OPS=y
|
||||
CONFIG_DMA_NONCOHERENT_MMAP=y
|
||||
CONFIG_DMA_REMAP=y
|
||||
# CONFIG_DMA_API_DEBUG is not set
|
||||
CONFIG_SGL_ALLOC=y
|
||||
|
@ -6557,6 +6570,8 @@ CONFIG_CONSOLE_LOGLEVEL_QUIET=4
|
|||
CONFIG_MESSAGE_LOGLEVEL_DEFAULT=4
|
||||
# CONFIG_BOOT_PRINTK_DELAY is not set
|
||||
# CONFIG_DYNAMIC_DEBUG is not set
|
||||
CONFIG_SYMBOLIC_ERRNAME=y
|
||||
CONFIG_DEBUG_BUGVERBOSE=y
|
||||
# end of printk and dmesg options
|
||||
|
||||
#
|
||||
|
@ -6567,7 +6582,6 @@ CONFIG_ENABLE_MUST_CHECK=y
|
|||
CONFIG_FRAME_WARN=1024
|
||||
# CONFIG_STRIP_ASM_SYMS is not set
|
||||
# CONFIG_READABLE_ASM is not set
|
||||
CONFIG_DEBUG_FS=y
|
||||
# CONFIG_HEADERS_INSTALL is not set
|
||||
CONFIG_OPTIMIZE_INLINING=y
|
||||
# CONFIG_DEBUG_SECTION_MISMATCH is not set
|
||||
|
@ -6575,9 +6589,19 @@ CONFIG_SECTION_MISMATCH_WARN_ONLY=y
|
|||
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set
|
||||
# end of Compile-time checks and compiler options
|
||||
|
||||
#
|
||||
# Generic Kernel Debugging Instruments
|
||||
#
|
||||
CONFIG_MAGIC_SYSRQ=y
|
||||
CONFIG_MAGIC_SYSRQ_DEFAULT_ENABLE=0x1
|
||||
CONFIG_MAGIC_SYSRQ_SERIAL=y
|
||||
CONFIG_DEBUG_FS=y
|
||||
CONFIG_HAVE_ARCH_KGDB=y
|
||||
# CONFIG_KGDB is not set
|
||||
# CONFIG_UBSAN is not set
|
||||
CONFIG_UBSAN_ALIGNMENT=y
|
||||
# end of Generic Kernel Debugging Instruments
|
||||
|
||||
CONFIG_DEBUG_KERNEL=y
|
||||
CONFIG_DEBUG_MISC=y
|
||||
|
||||
|
@ -6595,6 +6619,7 @@ CONFIG_DEBUG_MISC=y
|
|||
CONFIG_HAVE_DEBUG_KMEMLEAK=y
|
||||
# CONFIG_DEBUG_KMEMLEAK is not set
|
||||
# CONFIG_DEBUG_STACK_USAGE is not set
|
||||
# CONFIG_SCHED_STACK_END_CHECK is not set
|
||||
# CONFIG_DEBUG_VM is not set
|
||||
CONFIG_ARCH_HAS_DEBUG_VIRTUAL=y
|
||||
# CONFIG_DEBUG_VIRTUAL is not set
|
||||
|
@ -6603,29 +6628,30 @@ CONFIG_CC_HAS_KASAN_GENERIC=y
|
|||
CONFIG_KASAN_STACK=1
|
||||
# end of Memory Debugging
|
||||
|
||||
CONFIG_ARCH_HAS_KCOV=y
|
||||
CONFIG_CC_HAS_SANCOV_TRACE_PC=y
|
||||
# CONFIG_KCOV is not set
|
||||
# CONFIG_DEBUG_SHIRQ is not set
|
||||
|
||||
#
|
||||
# Debug Lockups and Hangs
|
||||
# Debug Oops, Lockups and Hangs
|
||||
#
|
||||
# CONFIG_PANIC_ON_OOPS is not set
|
||||
CONFIG_PANIC_ON_OOPS_VALUE=0
|
||||
CONFIG_PANIC_TIMEOUT=0
|
||||
# CONFIG_SOFTLOCKUP_DETECTOR is not set
|
||||
CONFIG_DETECT_HUNG_TASK=y
|
||||
CONFIG_DEFAULT_HUNG_TASK_TIMEOUT=120
|
||||
# CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set
|
||||
CONFIG_BOOTPARAM_HUNG_TASK_PANIC_VALUE=0
|
||||
# CONFIG_WQ_WATCHDOG is not set
|
||||
# end of Debug Lockups and Hangs
|
||||
# end of Debug Oops, Lockups and Hangs
|
||||
|
||||
# CONFIG_PANIC_ON_OOPS is not set
|
||||
CONFIG_PANIC_ON_OOPS_VALUE=0
|
||||
CONFIG_PANIC_TIMEOUT=0
|
||||
#
|
||||
# Scheduler Debugging
|
||||
#
|
||||
CONFIG_SCHED_DEBUG=y
|
||||
CONFIG_SCHED_INFO=y
|
||||
CONFIG_SCHEDSTATS=y
|
||||
# CONFIG_SCHED_STACK_END_CHECK is not set
|
||||
# end of Scheduler Debugging
|
||||
|
||||
# CONFIG_DEBUG_TIMEKEEPING is not set
|
||||
CONFIG_DEBUG_PREEMPT=y
|
||||
|
||||
|
@ -6650,11 +6676,17 @@ CONFIG_LOCK_DEBUGGING_SUPPORT=y
|
|||
CONFIG_STACKTRACE=y
|
||||
# CONFIG_WARN_ALL_UNSEEDED_RANDOM is not set
|
||||
# CONFIG_DEBUG_KOBJECT is not set
|
||||
CONFIG_DEBUG_BUGVERBOSE=y
|
||||
|
||||
#
|
||||
# Debug kernel data structures
|
||||
#
|
||||
# CONFIG_DEBUG_LIST is not set
|
||||
# CONFIG_DEBUG_PLIST is not set
|
||||
# CONFIG_DEBUG_SG is not set
|
||||
# CONFIG_DEBUG_NOTIFIERS is not set
|
||||
# CONFIG_BUG_ON_DATA_CORRUPTION is not set
|
||||
# end of Debug kernel data structures
|
||||
|
||||
# CONFIG_DEBUG_CREDENTIALS is not set
|
||||
|
||||
#
|
||||
|
@ -6669,8 +6701,6 @@ CONFIG_RCU_CPU_STALL_TIMEOUT=21
|
|||
|
||||
# CONFIG_DEBUG_WQ_FORCE_RR_CPU is not set
|
||||
# CONFIG_DEBUG_BLOCK_EXT_DEVT is not set
|
||||
# CONFIG_NOTIFIER_ERROR_INJECTION is not set
|
||||
# CONFIG_FAULT_INJECTION is not set
|
||||
# CONFIG_LATENCYTOP is not set
|
||||
CONFIG_NOP_TRACER=y
|
||||
CONFIG_HAVE_FUNCTION_TRACER=y
|
||||
|
@ -6706,11 +6736,55 @@ CONFIG_KPROBE_EVENTS=y
|
|||
CONFIG_BPF_EVENTS=y
|
||||
CONFIG_DYNAMIC_EVENTS=y
|
||||
CONFIG_PROBE_EVENTS=y
|
||||
# CONFIG_TRACE_EVENT_INJECT is not set
|
||||
# CONFIG_TRACEPOINT_BENCHMARK is not set
|
||||
# CONFIG_RING_BUFFER_BENCHMARK is not set
|
||||
# CONFIG_RING_BUFFER_STARTUP_TEST is not set
|
||||
# CONFIG_PREEMPTIRQ_DELAY_TEST is not set
|
||||
# CONFIG_TRACE_EVAL_MAP_FILE is not set
|
||||
# CONFIG_SAMPLES is not set
|
||||
CONFIG_ARCH_HAS_DEVMEM_IS_ALLOWED=y
|
||||
# CONFIG_STRICT_DEVMEM is not set
|
||||
|
||||
#
|
||||
# arm Debugging
|
||||
#
|
||||
# CONFIG_ARM_PTDUMP_DEBUGFS is not set
|
||||
# CONFIG_DEBUG_WX is not set
|
||||
# CONFIG_UNWINDER_FRAME_POINTER is not set
|
||||
CONFIG_UNWINDER_ARM=y
|
||||
CONFIG_ARM_UNWIND=y
|
||||
CONFIG_DEBUG_USER=y
|
||||
CONFIG_DEBUG_LL=y
|
||||
# CONFIG_DEBUG_MVEBU_UART0_ALTERNATE is not set
|
||||
# CONFIG_DEBUG_MVEBU_UART1_ALTERNATE is not set
|
||||
# CONFIG_DEBUG_ICEDCC is not set
|
||||
# CONFIG_DEBUG_SEMIHOSTING is not set
|
||||
CONFIG_DEBUG_LL_UART_8250=y
|
||||
# CONFIG_DEBUG_LL_UART_PL01X is not set
|
||||
CONFIG_DEBUG_LL_INCLUDE="debug/8250.S"
|
||||
CONFIG_DEBUG_UART_PHYS=0xf1012000
|
||||
CONFIG_DEBUG_UART_VIRT=0xfed12000
|
||||
CONFIG_DEBUG_UART_8250_SHIFT=2
|
||||
# CONFIG_DEBUG_UART_8250_WORD is not set
|
||||
# CONFIG_DEBUG_UART_8250_PALMCHIP is not set
|
||||
# CONFIG_DEBUG_UART_8250_FLOW_CONTROL is not set
|
||||
CONFIG_DEBUG_UNCOMPRESS=y
|
||||
CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
|
||||
CONFIG_EARLY_PRINTK=y
|
||||
# CONFIG_ARM_KPROBES_TEST is not set
|
||||
# CONFIG_CORESIGHT is not set
|
||||
# end of arm Debugging
|
||||
|
||||
#
|
||||
# Kernel Testing and Coverage
|
||||
#
|
||||
# CONFIG_KUNIT is not set
|
||||
# CONFIG_NOTIFIER_ERROR_INJECTION is not set
|
||||
# CONFIG_FAULT_INJECTION is not set
|
||||
CONFIG_ARCH_HAS_KCOV=y
|
||||
CONFIG_CC_HAS_SANCOV_TRACE_PC=y
|
||||
# CONFIG_KCOV is not set
|
||||
CONFIG_RUNTIME_TESTING_MENU=y
|
||||
# CONFIG_LKDTM is not set
|
||||
# CONFIG_TEST_LIST_SORT is not set
|
||||
|
@ -6751,37 +6825,5 @@ CONFIG_RUNTIME_TESTING_MENU=y
|
|||
# CONFIG_TEST_STACKINIT is not set
|
||||
# CONFIG_TEST_MEMINIT is not set
|
||||
# CONFIG_MEMTEST is not set
|
||||
# CONFIG_BUG_ON_DATA_CORRUPTION is not set
|
||||
# CONFIG_SAMPLES is not set
|
||||
CONFIG_HAVE_ARCH_KGDB=y
|
||||
# CONFIG_KGDB is not set
|
||||
# CONFIG_UBSAN is not set
|
||||
CONFIG_UBSAN_ALIGNMENT=y
|
||||
CONFIG_ARCH_HAS_DEVMEM_IS_ALLOWED=y
|
||||
# CONFIG_STRICT_DEVMEM is not set
|
||||
# CONFIG_ARM_PTDUMP_DEBUGFS is not set
|
||||
# CONFIG_DEBUG_WX is not set
|
||||
# CONFIG_UNWINDER_FRAME_POINTER is not set
|
||||
CONFIG_UNWINDER_ARM=y
|
||||
CONFIG_ARM_UNWIND=y
|
||||
CONFIG_DEBUG_USER=y
|
||||
CONFIG_DEBUG_LL=y
|
||||
# CONFIG_DEBUG_MVEBU_UART0_ALTERNATE is not set
|
||||
# CONFIG_DEBUG_MVEBU_UART1_ALTERNATE is not set
|
||||
# CONFIG_DEBUG_ICEDCC is not set
|
||||
# CONFIG_DEBUG_SEMIHOSTING is not set
|
||||
CONFIG_DEBUG_LL_UART_8250=y
|
||||
# CONFIG_DEBUG_LL_UART_PL01X is not set
|
||||
CONFIG_DEBUG_LL_INCLUDE="debug/8250.S"
|
||||
CONFIG_DEBUG_UART_PHYS=0xf1012000
|
||||
CONFIG_DEBUG_UART_VIRT=0xfed12000
|
||||
CONFIG_DEBUG_UART_8250_SHIFT=2
|
||||
# CONFIG_DEBUG_UART_8250_WORD is not set
|
||||
# CONFIG_DEBUG_UART_8250_PALMCHIP is not set
|
||||
# CONFIG_DEBUG_UART_8250_FLOW_CONTROL is not set
|
||||
CONFIG_DEBUG_UNCOMPRESS=y
|
||||
CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
|
||||
CONFIG_EARLY_PRINTK=y
|
||||
# CONFIG_ARM_KPROBES_TEST is not set
|
||||
# CONFIG_CORESIGHT is not set
|
||||
# end of Kernel Testing and Coverage
|
||||
# end of Kernel hacking
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# arg 2: the old package version
|
||||
|
||||
KERNEL_NAME=-kirkwood-dt
|
||||
KERNEL_VERSION=5.3.4-1-ARCH
|
||||
KERNEL_VERSION=5.5.1-1-ARCH
|
||||
|
||||
post_install () {
|
||||
# updating module dependencies
|
||||
|
|
Loading…
Reference in a new issue