mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
pacman 3.4.1
This commit is contained in:
parent
b1f141490e
commit
73e1d6daaf
5 changed files with 17 additions and 73 deletions
|
@ -1,32 +0,0 @@
|
|||
From dc817a2061699cd1f33ca93f0d93a1fbc2f33ea1 Mon Sep 17 00:00:00 2001
|
||||
From: Allan McRae <allan@archlinux.org>
|
||||
Date: Thu, 17 Jun 2010 14:32:08 +1000
|
||||
Subject: [PATCH] makepkg: fallback to sane defaults for library stripping
|
||||
|
||||
If the library stripping variables are not defined in makepkg.conf,
|
||||
libraries will be fully stripped and become broken. Fallback to a
|
||||
sane default stripping level.
|
||||
|
||||
Signed-off-by: Allan McRae <allan@archlinux.org>
|
||||
Signed-off-by: Dan McGee <dan@archlinux.org>
|
||||
---
|
||||
scripts/makepkg.sh.in | 3 +++
|
||||
1 files changed, 3 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/scripts/makepkg.sh.in b/scripts/makepkg.sh.in
|
||||
index d986701..e64b564 100644
|
||||
--- a/scripts/makepkg.sh.in
|
||||
+++ b/scripts/makepkg.sh.in
|
||||
@@ -864,6 +864,9 @@ tidy_install() {
|
||||
|
||||
if [[ $(check_option strip) = y && -n ${STRIP_DIRS[*]} ]]; then
|
||||
msg2 "$(gettext "Stripping unneeded symbols from binaries and libraries...")"
|
||||
+ # make sure library stripping variables are defined to prevent excess stripping
|
||||
+ [[ -z ${STRIP_SHARED+x} ]] && STRIP_SHARED="-S"
|
||||
+ [[ -z ${STRIP_STATIC+x} ]] && STRIP_STATIC="-S"
|
||||
local binary
|
||||
find ${STRIP_DIRS[@]} -type f -perm -u+w 2>/dev/null | while read binary ; do
|
||||
case "$(file -bi "$binary")" in
|
||||
--
|
||||
1.7.1
|
||||
|
46
core/pacman/PKGBUILD
Executable file → Normal file
46
core/pacman/PKGBUILD
Executable file → Normal file
|
@ -1,39 +1,32 @@
|
|||
# Maintainer: Mike Staszel <mikestaszel@plugboxlinux.org>
|
||||
# Maintainer: Aaron Griffin <aaron@archlinux.org>
|
||||
# Maintainer: Dan McGee <dan@archlinux.org>
|
||||
|
||||
# Plugbox changes:
|
||||
# - pacman.conf
|
||||
# - makepkg.conf with ARM stuff
|
||||
|
||||
pkgname=pacman
|
||||
pkgver=3.4.0
|
||||
pkgrel=2
|
||||
pkgver=3.4.1
|
||||
pkgrel=1
|
||||
pkgdesc="A library-based package manager with dependency support"
|
||||
arch=('arm')
|
||||
url="http://www.archlinux.org/pacman/"
|
||||
license=('GPL')
|
||||
groups=('base')
|
||||
depends=('bash' 'libarchive>=2.7.1' 'libfetch>=2.25' 'pacman-mirrorlist')
|
||||
optdepends=('fakeroot: for makepkg usage as normal user')
|
||||
optdepends=('fakeroot: for makepkg usage as normal user'
|
||||
'curl: for rankmirrors usage')
|
||||
backup=(etc/pacman.conf etc/makepkg.conf)
|
||||
install=pacman.install
|
||||
options=(!libtool)
|
||||
source=(ftp://ftp.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz
|
||||
pacman.conf
|
||||
makepkg.conf
|
||||
0001-makepkg-fallback-to-sane-defaults-for-library-stripp.patch)
|
||||
md5sums=('50ad71be1faaad84842c576e239d1bb5'
|
||||
'8a1eea46c9af940a8812dfb4bbbd159d'
|
||||
'ce00f190714c02ef26117ecfdf5fa296'
|
||||
'f8c4a3cc7702a7a70d177659441495c5')
|
||||
makepkg.conf)
|
||||
md5sums=('4e4e8e4f636d9878fbed9cf840f162cf'
|
||||
'1d7e70d6a90de78777d82261182bad4c'
|
||||
'0b347c2e3d2732dcdd055dcd144015ee')
|
||||
|
||||
# keep an upgrade path for older installations
|
||||
PKGEXT='.pkg.tar.gz'
|
||||
|
||||
build() {
|
||||
cd $srcdir/$pkgname-$pkgver
|
||||
patch -Np1 < $srcdir/0001-makepkg-fallback-to-sane-defaults-for-library-stripp.patch
|
||||
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-doc
|
||||
make || return 1
|
||||
}
|
||||
|
@ -44,30 +37,9 @@ package() {
|
|||
|
||||
# install Arch specific stuff
|
||||
mkdir -p $pkgdir/etc
|
||||
install -m644 $srcdir/pacman.conf $pkgdir/etc/
|
||||
install -m644 $srcdir/pacman.conf $pkgdir/etc/pacman.conf
|
||||
install -m644 $srcdir/makepkg.conf $pkgdir/etc/
|
||||
|
||||
# Plugbox wants to be old-fashioned and just use their
|
||||
# files instead of letting sed modify them, so skip the part below
|
||||
|
||||
# # set things correctly in the default conf file
|
||||
# case "$CARCH" in
|
||||
# i686)
|
||||
# mycarch="i686"
|
||||
# mychost="i686-pc-linux-gnu"
|
||||
# myflags="-march=i686 "
|
||||
# ;;
|
||||
# x86_64)
|
||||
# mycarch="x86_64"
|
||||
# mychost="x86_64-unknown-linux-gnu"
|
||||
# myflags="-march=x86-64 "
|
||||
# ;;
|
||||
# esac
|
||||
# sed -i $pkgdir/etc/makepkg.conf \
|
||||
# -e "s|@CARCH[@]|$mycarch|g" \
|
||||
# -e "s|@CHOST[@]|$mychost|g" \
|
||||
# -e "s|@CARCHFLAGS[@]|$myflags|g"
|
||||
|
||||
# install completion files
|
||||
mkdir -p $pkgdir/etc/bash_completion.d/
|
||||
install -m644 contrib/bash_completion $pkgdir/etc/bash_completion.d/pacman
|
||||
|
|
|
@ -72,6 +72,12 @@ OPTIONS=(strip docs libtool emptydirs zipman purge)
|
|||
|
||||
#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
|
||||
INTEGRITY_CHECK=(md5)
|
||||
#-- Options to be used when stripping binaries. See `man strip' for details.
|
||||
STRIP_BINARIES="--strip-all"
|
||||
#-- Options to be used when stripping shared libraries. See `man strip' for details.
|
||||
STRIP_SHARED="--strip-unneeded"
|
||||
#-- Options to be used when stripping static libraries. See `man strip' for details.
|
||||
STRIP_STATIC="--strip-debug"
|
||||
#-- Manual (man and info) directories to compress (if zipman is specified)
|
||||
MAN_DIRS=({usr{,/local}{,/share},opt/*}/{man,info})
|
||||
#-- Doc directories to remove (if !docs is specified)
|
||||
|
@ -98,8 +104,5 @@ PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
|
|||
# EXTENSION DEFAULTS
|
||||
#########################################################################
|
||||
#
|
||||
# WARNING: Do NOT modify these variables unless you know what you are
|
||||
# doing.
|
||||
#
|
||||
PKGEXT='.pkg.tar.gz'
|
||||
PKGEXT='.pkg.tar.xz'
|
||||
SRCEXT='.src.tar.gz'
|
||||
|
|
|
@ -19,6 +19,7 @@ SyncFirst = pacman
|
|||
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
|
||||
#XferCommand = /usr/bin/curl %u > %o
|
||||
#CleanMethod = KeepInstalled
|
||||
Architecture = arm
|
||||
|
||||
# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
|
||||
#IgnorePkg =
|
||||
|
|
0
core/pacman/pacman.install
Executable file → Normal file
0
core/pacman/pacman.install
Executable file → Normal file
Loading…
Reference in a new issue