mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
added community/a2jmidid
This commit is contained in:
parent
36b157d372
commit
741ce9e78c
3 changed files with 84 additions and 0 deletions
44
community/a2jmidid/PKGBUILD
Normal file
44
community/a2jmidid/PKGBUILD
Normal file
|
@ -0,0 +1,44 @@
|
|||
# $Id$
|
||||
# Maintainer : speps <speps at aur dot archlinux dot org>
|
||||
# Contributor: Jiyunatori <tori@0xc29.net>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch for AArch64
|
||||
|
||||
pkgname=a2jmidid
|
||||
pkgver=8
|
||||
pkgrel=1
|
||||
pkgdesc="A daemon for exposing legacy ALSA sequencer applications in JACK MIDI system."
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://home.gna.org/$pkgname/"
|
||||
license=('GPL')
|
||||
depends=('jack' 'python2-dbus')
|
||||
source=("http://download.gna.org/$pkgname/$pkgname-$pkgver.tar.bz2"
|
||||
"$pkgname-dso-pthread.patch"
|
||||
'a2jmidid-aarch64.patch')
|
||||
md5sums=('9cf4edbc3ad2ddeeaf6c8c1791ff3ddd'
|
||||
'4b15e485301aee48371844cb01689ad2'
|
||||
'bff91ac5a995f4faf9acd280b7f949b4')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
# DSO link patch
|
||||
patch -p1 -i ../$pkgname-dso-pthread.patch
|
||||
|
||||
# python2 shebang
|
||||
sed -i 's/python/&2/' a2j_control
|
||||
|
||||
patch -p1 -i ../a2jmidid-aarch64.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
python2 waf configure --prefix=/usr
|
||||
python2 waf
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
python2 waf install --destdir="$pkgdir/"
|
||||
}
|
20
community/a2jmidid/a2jmidid-aarch64.patch
Normal file
20
community/a2jmidid/a2jmidid-aarch64.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- a2jmidid-8/sigsegv.c.orig 2014-10-27 00:55:18.105347411 +0000
|
||||
+++ a2jmidid-8/sigsegv.c 2014-10-27 00:56:07.209296207 +0000
|
||||
@@ -91,7 +91,7 @@
|
||||
a2j_error("info.si_errno = %d", info->si_errno);
|
||||
a2j_error("info.si_code = %d (%s)", info->si_code, si_codes[info->si_code]);
|
||||
a2j_error("info.si_addr = %p", info->si_addr);
|
||||
-#if !defined(__alpha__) && !defined(__ia64__) && !defined(__FreeBSD_kernel__) && !defined(__arm__) && !defined(__hppa__) && !defined(__sh__)
|
||||
+#if !defined(__alpha__) && !defined(__ia64__) && !defined(__FreeBSD_kernel__) && !defined(__arm__) && !defined(__hppa__) && !defined(__sh__) && !defined(__aarch64__)
|
||||
for(i = 0; i < NGREG; i++)
|
||||
a2j_error("reg[%02d] = 0x" REGFORMAT, i,
|
||||
#if defined(__powerpc__)
|
||||
@@ -102,7 +102,7 @@
|
||||
ucontext->uc_mcontext.gregs[i]
|
||||
#endif
|
||||
);
|
||||
-#endif /* alpha, ia64, kFreeBSD, arm, hppa */
|
||||
+#endif /* alpha, ia64, kFreeBSD, arm, hppa, aarch64 */
|
||||
|
||||
#if defined(SIGSEGV_STACK_X86) || defined(SIGSEGV_STACK_IA64)
|
||||
# if defined(SIGSEGV_STACK_IA64)
|
20
community/a2jmidid/a2jmidid-dso-pthread.patch
Normal file
20
community/a2jmidid/a2jmidid-dso-pthread.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
diff -aur a2jmidid-8/wscript a2jmidid-8.patched/wscript
|
||||
--- a2jmidid-8/wscript 2012-07-05 03:14:23.000000000 +0200
|
||||
+++ a2jmidid-8.patched/wscript 2012-07-10 17:48:30.710109306 +0200
|
||||
@@ -67,6 +67,7 @@
|
||||
conf.env['DBUS_ENABLED'] = False
|
||||
|
||||
conf.env['LIB_DL'] = ['dl']
|
||||
+ conf.env['LIB_PTHREAD'] = ['pthread']
|
||||
|
||||
#conf.check_header('expat.h', mandatory=True)
|
||||
#conf.env['LIB_EXPAT'] = ['expat']
|
||||
@@ -152,7 +153,7 @@
|
||||
|
||||
prog.includes = '.' # make waf dependency tracking work
|
||||
prog.target = 'a2jmidid'
|
||||
- prog.uselib = 'ALSA JACK DL'
|
||||
+ prog.uselib = 'ALSA JACK DL PTHREAD'
|
||||
if bld.env()['DBUS_ENABLED']:
|
||||
prog.uselib += " DBUS-1"
|
||||
prog = bld.create_obj('cc', 'program')
|
Loading…
Reference in a new issue