mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
add extra/qt
This commit is contained in:
parent
f11611f08a
commit
742c3ad364
8 changed files with 303 additions and 0 deletions
156
extra/qt/PKGBUILD
Normal file
156
extra/qt/PKGBUILD
Normal file
|
@ -0,0 +1,156 @@
|
|||
# $Id: PKGBUILD 145318 2011-12-21 20:46:52Z andrea $
|
||||
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
|
||||
# Contributor: Pierre Schmitz <pierre@archlinux.de>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - Just say NO to x86 optimizations ;)
|
||||
# - disabled distcc, ccache - bad things happen
|
||||
# - don't use -no-neon on armv7
|
||||
# - added -fno-strict-volatile-bitfields to CXXFLAGS to fix ARM bug
|
||||
# - disabled gcc47.patch since we're not on that yet
|
||||
# - no libfbclient/ibase, issues building on ARM
|
||||
|
||||
pkgbase=qt
|
||||
pkgname=('qt' 'qt-private-headers')
|
||||
pkgver=4.8.4
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL')
|
||||
makedepends=('libtiff' 'libpng' 'libmng' 'sqlite' 'ca-certificates' 'glib2' 'dbus'
|
||||
'fontconfig' 'libgl' 'libsm' 'libxrandr' 'libxv' 'libxi' 'alsa-lib'
|
||||
'xdg-utils' 'hicolor-icon-theme' 'desktop-file-utils' 'mesa' 'postgresql-libs'
|
||||
'mysql' 'unixodbc' 'cups' 'gtk2')
|
||||
options=('!libtool' '!distcc' '!ccache')
|
||||
_pkgfqn="${pkgbase}-everywhere-opensource-src-${pkgver}"
|
||||
source=("http://releases.qt-project.org/qt4/source/${_pkgfqn}.tar.gz"
|
||||
'assistant.desktop' 'designer.desktop' 'linguist.desktop'
|
||||
'qtconfig.desktop'
|
||||
'improve-cups-support.patch'
|
||||
'fix-crash-in-assistant.patch')
|
||||
md5sums=('89c5ecba180cae74c66260ac732dc5cb'
|
||||
'f1837a03fd0ebbd2da58975845f278e3'
|
||||
'480fea1ed076992b688373c8db274be0'
|
||||
'5595c24d5bb942c21e3a4d299e6d0bf1'
|
||||
'824a3b77a25e98567f640e0441ccdebc'
|
||||
'c439c7731c25387352d8453ca7574971'
|
||||
'57590084078b6379f0501f7728b02ae2')
|
||||
|
||||
build() {
|
||||
cd ${_pkgfqn}
|
||||
|
||||
# (FS#28381) (KDEBUG#180051)
|
||||
patch -p1 -i "${srcdir}"/improve-cups-support.patch
|
||||
|
||||
patch -p1 -i "${srcdir}"/fix-crash-in-assistant.patch
|
||||
|
||||
export QT4DIR="${srcdir}"/${_pkgfqn}
|
||||
export LD_LIBRARY_PATH=${QT4DIR}/lib:${LD_LIBRARY_PATH}
|
||||
|
||||
export CXXFLAGS="$CXXFLAGS -fno-strict-volatile-bitfields"
|
||||
|
||||
sed -i "s|-O2|${CXXFLAGS}|" mkspecs/common/{g++,gcc}-base.conf
|
||||
sed -i "/^QMAKE_LFLAGS_RPATH/s| -Wl,-rpath,||g" mkspecs/common/gcc-base-unix.conf
|
||||
sed -i "/^QMAKE_LFLAGS\s/s|+=|+= ${LDFLAGS}|g" mkspecs/common/gcc-base.conf
|
||||
|
||||
./configure -confirm-license -opensource \
|
||||
-prefix /usr \
|
||||
-docdir /usr/share/doc/qt \
|
||||
-plugindir /usr/lib/qt/plugins \
|
||||
-importdir /usr/lib/qt/imports \
|
||||
-datadir /usr/share/qt \
|
||||
-translationdir /usr/share/qt/translations \
|
||||
-sysconfdir /etc/xdg \
|
||||
-examplesdir /usr/share/doc/qt/examples \
|
||||
-demosdir /usr/share/doc/qt/demos \
|
||||
-plugin-sql-{psql,mysql,sqlite,odbc} \
|
||||
-system-sqlite \
|
||||
-no-phonon \
|
||||
-no-phonon-backend \
|
||||
-no-webkit \
|
||||
-graphicssystem raster \
|
||||
-openssl-linked \
|
||||
-nomake demos \
|
||||
-nomake examples \
|
||||
-nomake docs \
|
||||
-silent \
|
||||
-no-rpath \
|
||||
-optimized-qmake \
|
||||
-reduce-relocations \
|
||||
-dbus-linked \
|
||||
-no-openvg \
|
||||
-no-mmx \
|
||||
-no-3dnow \
|
||||
-no-sse \
|
||||
-no-sse2 \
|
||||
-no-sse3 \
|
||||
-no-ssse3 \
|
||||
-no-sse4.1 \
|
||||
-no-sse4.2 \
|
||||
-no-avx \
|
||||
-no-neon
|
||||
make
|
||||
}
|
||||
|
||||
package_qt() {
|
||||
pkgdesc='A cross-platform application and UI framework'
|
||||
depends=('libtiff' 'libpng' 'libmng' 'sqlite' 'ca-certificates' 'glib2' 'dbus'
|
||||
'fontconfig' 'libgl' 'libsm' 'libxrandr' 'libxv' 'libxi' 'alsa-lib'
|
||||
'xdg-utils' 'hicolor-icon-theme' 'desktop-file-utils')
|
||||
optdepends=('postgresql-libs: PostgreSQL driver'
|
||||
'libmysqlclient: MySQL driver'
|
||||
'unixodbc: ODBC driver'
|
||||
'libxinerama: Xinerama support'
|
||||
'libxcursor: Xcursor support'
|
||||
'libxfixes: Xfixes support'
|
||||
'icu: Unicode support')
|
||||
install='qt.install'
|
||||
|
||||
cd ${_pkgfqn}
|
||||
make INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# install missing icons and desktop files
|
||||
for icon in tools/linguist/linguist/images/icons/linguist-*-32.png ; do
|
||||
size=$(echo $(basename ${icon}) | cut -d- -f2)
|
||||
install -p -D -m644 ${icon} \
|
||||
"${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/linguist.png"
|
||||
done
|
||||
install -p -D -m644 src/gui/dialogs/images/qtlogo-64.png \
|
||||
"${pkgdir}/usr/share/icons/hicolor/64x64/apps/qtlogo.png"
|
||||
install -p -D -m644 tools/assistant/tools/assistant/images/assistant.png \
|
||||
"${pkgdir}/usr/share/icons/hicolor/32x32/apps/assistant.png"
|
||||
install -p -D -m644 tools/designer/src/designer/images/designer.png \
|
||||
"${pkgdir}/usr/share/icons/hicolor/128x128/apps/designer.png"
|
||||
install -d "${pkgdir}/usr/share/applications"
|
||||
install -m644 "${srcdir}"/{linguist,designer,assistant,qtconfig}.desktop \
|
||||
"${pkgdir}/usr/share/applications/"
|
||||
|
||||
# install license addition
|
||||
install -D -m644 LGPL_EXCEPTION.txt \
|
||||
${pkgdir}/usr/share/licenses/qt/LGPL_EXCEPTION.txt
|
||||
|
||||
# Fix wrong path in pkgconfig files
|
||||
find "${pkgdir}/usr/lib/pkgconfig" -type f -name '*.pc' \
|
||||
-exec perl -pi -e "s, -L${srcdir}/?\S+,,g" {} \;
|
||||
|
||||
# Fix wrong path in prl files
|
||||
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
|
||||
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d;s/\(QMAKE_PRL_LIBS =\).*/\1/' {} \;
|
||||
}
|
||||
|
||||
package_qt-private-headers(){
|
||||
pkgdesc="Qt private headers for development"
|
||||
depends=("qt=${pkgver}")
|
||||
|
||||
install -d "${pkgdir}"/usr/include/{QtCore,QtDeclarative,QtGui,QtScript}
|
||||
install -d "${pkgdir}"/usr/src/{corelib,declarative,gui,script}
|
||||
|
||||
for i in QtCore QtDeclarative QtGui QtScript; do
|
||||
cp -r ${_pkgfqn}/include/${i}/private/ \
|
||||
"${pkgdir}"/usr/include/${i}/
|
||||
done
|
||||
|
||||
for i in corelib declarative gui script; do
|
||||
cp -r ${_pkgfqn}/src/${i} "${pkgdir}"/usr/src/
|
||||
done
|
||||
}
|
9
extra/qt/assistant.desktop
Normal file
9
extra/qt/assistant.desktop
Normal file
|
@ -0,0 +1,9 @@
|
|||
[Desktop Entry]
|
||||
Name=Qt Assistant
|
||||
Comment=Shows Qt documentation and examples
|
||||
Exec=/usr/bin/assistant
|
||||
Icon=assistant
|
||||
Terminal=false
|
||||
Encoding=UTF-8
|
||||
Type=Application
|
||||
Categories=Qt;Development;Documentation;
|
11
extra/qt/designer.desktop
Normal file
11
extra/qt/designer.desktop
Normal file
|
@ -0,0 +1,11 @@
|
|||
[Desktop Entry]
|
||||
Name=Qt Designer
|
||||
GenericName=Interface Designer
|
||||
Comment=Design GUIs for Qt applications
|
||||
Exec=/usr/bin/designer
|
||||
Icon=designer
|
||||
MimeType=application/x-designer;
|
||||
Terminal=false
|
||||
Encoding=UTF-8
|
||||
Type=Application
|
||||
Categories=Qt;Development;
|
11
extra/qt/fix-crash-in-assistant.patch
Normal file
11
extra/qt/fix-crash-in-assistant.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- qt-everywhere-opensource-src-4.8.2/tools/assistant/tools/assistant/mainwindow.cpp 2012-06-26 17:37:47.334536023 +0000
|
||||
+++ qt-everywhere-opensource-src-4.8.2/tools/assistant/tools/assistant/mainwindow.cpp~ 2012-06-26 17:37:08.531487286 +0000
|
||||
@@ -944,8 +944,7 @@
|
||||
if (helpEngine.usesAppFont())
|
||||
font = helpEngine.appFont();
|
||||
|
||||
- const QWidgetList &widgets = qApp->allWidgets();
|
||||
- foreach (QWidget* widget, widgets)
|
||||
+ foreach (QWidget* widget, QApplication::allWidgets())
|
||||
widget->setFont(font);
|
||||
}
|
84
extra/qt/improve-cups-support.patch
Normal file
84
extra/qt/improve-cups-support.patch
Normal file
|
@ -0,0 +1,84 @@
|
|||
diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp
|
||||
--- qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp 2010-02-11 16:55:22.000000000 +0100
|
||||
+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp 2010-02-28 04:34:16.000000000 +0100
|
||||
@@ -569,6 +569,32 @@
|
||||
void QPrintDialogPrivate::selectPrinter(QCUPSSupport *cups)
|
||||
{
|
||||
options.duplex->setEnabled(cups && cups->ppdOption("Duplex"));
|
||||
+
|
||||
+ if (cups) {
|
||||
+ const ppd_option_t* duplex = cups->ppdOption("Duplex");
|
||||
+ if (duplex) {
|
||||
+ // copy default ppd duplex to qt dialog
|
||||
+ if (qstrcmp(duplex->defchoice, "DuplexTumble") == 0)
|
||||
+ options.duplexShort->setChecked(true);
|
||||
+ else if (qstrcmp(duplex->defchoice, "DuplexNoTumble") == 0)
|
||||
+ options.duplexLong->setChecked(true);
|
||||
+ else
|
||||
+ options.noDuplex->setChecked(true);
|
||||
+ }
|
||||
+
|
||||
+ if (cups->currentPPD()) {
|
||||
+ // set default color
|
||||
+ if (cups->currentPPD()->color_device)
|
||||
+ options.color->setChecked(true);
|
||||
+ else
|
||||
+ options.grayscale->setChecked(true);
|
||||
+ }
|
||||
+
|
||||
+ // set collation
|
||||
+ const ppd_option_t *collate = cups->ppdOption("Collate");
|
||||
+ if (collate)
|
||||
+ options.collate->setChecked(qstrcmp(collate->defchoice, "True")==0);
|
||||
+ }
|
||||
}
|
||||
#endif
|
||||
|
||||
diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp
|
||||
--- qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp 2010-02-11 16:55:22.000000000 +0100
|
||||
+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp 2010-02-28 04:55:15.000000000 +0100
|
||||
@@ -627,6 +627,44 @@
|
||||
&& d_ptr->paintEngine->type() != QPaintEngine::MacPrinter) {
|
||||
setOutputFormat(QPrinter::PdfFormat);
|
||||
}
|
||||
+
|
||||
+#if !defined(QT_NO_CUPS) && !defined(QT_NO_LIBRARY)
|
||||
+ // fill in defaults from ppd file
|
||||
+ QCUPSSupport cups;
|
||||
+
|
||||
+ int printernum = -1;
|
||||
+ for (int i = 0; i < cups.availablePrintersCount(); i++) {
|
||||
+ if (printerName().toLocal8Bit() == cups.availablePrinters()[i].name)
|
||||
+ printernum = i;
|
||||
+ }
|
||||
+ if (printernum >= 0) {
|
||||
+ cups.setCurrentPrinter(printernum);
|
||||
+
|
||||
+ const ppd_option_t* duplex = cups.ppdOption("Duplex");
|
||||
+ if (duplex) {
|
||||
+ // copy default ppd duplex to qt dialog
|
||||
+ if (qstrcmp(duplex->defchoice, "DuplexTumble") == 0)
|
||||
+ setDuplex(DuplexShortSide);
|
||||
+ else if (qstrcmp(duplex->defchoice, "DuplexNoTumble") == 0)
|
||||
+ setDuplex(DuplexLongSide);
|
||||
+ else
|
||||
+ setDuplex(DuplexNone);
|
||||
+ }
|
||||
+
|
||||
+ if (cups.currentPPD()) {
|
||||
+ // set default color
|
||||
+ if (cups.currentPPD()->color_device)
|
||||
+ setColorMode(Color);
|
||||
+ else
|
||||
+ setColorMode(GrayScale);
|
||||
+ }
|
||||
+
|
||||
+ // set collation
|
||||
+ const ppd_option_t *collate = cups.ppdOption("Collate");
|
||||
+ if (collate)
|
||||
+ setCollateCopies(qstrcmp(collate->defchoice, "True")==0);
|
||||
+ }
|
||||
+#endif
|
||||
}
|
||||
|
||||
/*!
|
10
extra/qt/linguist.desktop
Normal file
10
extra/qt/linguist.desktop
Normal file
|
@ -0,0 +1,10 @@
|
|||
[Desktop Entry]
|
||||
Name=Qt Linguist
|
||||
Comment=Add translations to Qt applications
|
||||
Exec=/usr/bin/linguist
|
||||
Icon=linguist
|
||||
MimeType=text/vnd.trolltech.linguist;application/x-linguist;
|
||||
Terminal=false
|
||||
Encoding=UTF-8
|
||||
Type=Application
|
||||
Categories=Qt;Development;
|
12
extra/qt/qt.install
Normal file
12
extra/qt/qt.install
Normal file
|
@ -0,0 +1,12 @@
|
|||
post_install() {
|
||||
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
|
||||
update-desktop-database -q
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
10
extra/qt/qtconfig.desktop
Normal file
10
extra/qt/qtconfig.desktop
Normal file
|
@ -0,0 +1,10 @@
|
|||
[Desktop Entry]
|
||||
Name=Qt Config
|
||||
Comment=Configure Qt behavior, styles, fonts
|
||||
Exec=/usr/bin/qtconfig
|
||||
Icon=qtlogo
|
||||
Terminal=false
|
||||
Encoding=UTF-8
|
||||
Type=Application
|
||||
Categories=Qt;Settings;
|
||||
NoDisplay=true
|
Loading…
Reference in a new issue