community/botan to 2.15.0-2

This commit is contained in:
Kevin Mihelich 2020-10-11 15:58:18 +00:00
parent f810269535
commit 7433173f57
2 changed files with 35 additions and 6 deletions

View file

@ -1,4 +1,5 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
# Maintainer: Antonio Rojas <arojas@archlinux.org>
# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
# Contributor: d'Ronin <daronin@2600.com>
@ -10,17 +11,25 @@
pkgname=botan
pkgver=2.15.0
pkgrel=1
pkgrel=2
pkgdesc='Crypto library written in C++'
arch=(x86_64)
url='https://botan.randombit.net/'
license=(BSD)
makedepends=(python)
optdepends=('python: for using botan2.py')
depends=(xz sqlite)
makedepends=(python boost openssl)
optdepends=('python: for using botan2.py' 'boost-libs: for the botan executable')
validpgpkeys=('621DAF6411E1851C4CF9A2E16211EBF1EFBADFBC')
source=("https://botan.randombit.net/releases/Botan-${pkgver}.tar.xz"{,.asc})
source=("https://botan.randombit.net/releases/Botan-${pkgver}.tar.xz"{,.asc}
botan-ldflags.patch)
sha256sums=('d88af1307f1fefac79aa4f2f524699478d69ce15a857cf2d0a90ac6bf2a50009'
'SKIP')
'SKIP'
'a6e85d537f9a1299be8a6763df09c1b90680f5efd92c42a53ff0f985c82b3000')
prepare() {
cd ${pkgname^}-$pkgver
patch -p1 -i ../botan-ldflags.patch # Fix --as-needed
}
build() {
cd "${pkgname^}-$pkgver"
@ -32,6 +41,9 @@ build() {
--with-bzip \
--with-lzma \
--with-zlib \
--with-boost \
--with-openssl \
--with-sqlite3 \
--with-os-feature=getrandom \
$CONFIG

View file

@ -0,0 +1,17 @@
diff --git a/src/build-data/makefile.in b/src/build-data/makefile.in
index 0d678345f..07a8d9cd5 100644
--- a/src/build-data/makefile.in
+++ b/src/build-data/makefile.in
@@ -72,10 +72,10 @@ TESTOBJS = %{join test_objs}
# Executable targets
$(CLI): $(LIBRARIES) $(CLIOBJS)
- $(EXE_LINK_CMD) $(ABI_FLAGS) $(CLIOBJS) $(EXE_LINKS_TO) $(LDFLAGS) %{output_to_exe}$@
+ $(EXE_LINK_CMD) $(ABI_FLAGS) $(CLIOBJS) $(LDFLAGS) $(EXE_LINKS_TO) %{output_to_exe}$@
$(TEST): $(LIBRARIES) $(TESTOBJS)
- $(EXE_LINK_CMD) $(ABI_FLAGS) $(TESTOBJS) $(EXE_LINKS_TO) $(LDFLAGS) %{output_to_exe}$@
+ $(EXE_LINK_CMD) $(ABI_FLAGS) $(TESTOBJS) $(LDFLAGS) $(EXE_LINKS_TO) %{output_to_exe}$@
%{if build_fuzzers}