mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added extra/dhcp
This commit is contained in:
parent
c7ef3b0b33
commit
745006b441
8 changed files with 223 additions and 0 deletions
13
extra/dhcp/0002-iproute2.patch
Normal file
13
extra/dhcp/0002-iproute2.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/client/scripts/linux b/client/scripts/linux
|
||||
index 5fb16121..c4cef632 100755
|
||||
--- a/client/scripts/linux
|
||||
+++ b/client/scripts/linux
|
||||
@@ -362,7 +362,7 @@ case "$reason" in
|
||||
interface_up_wait_time=5
|
||||
for i in $(seq 0 ${interface_up_wait_time})
|
||||
do
|
||||
- ifconfig ${interface} | grep RUNNING >/dev/null 2>&1
|
||||
+ ${ip} link show dev ${interface} | grep -q LOWER_UP 2>&1
|
||||
if [ $? -eq 0 ]; then
|
||||
break;
|
||||
fi
|
118
extra/dhcp/PKGBUILD
Normal file
118
extra/dhcp/PKGBUILD
Normal file
|
@ -0,0 +1,118 @@
|
|||
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||
# Contributor: Daniel Isenmann <daniel @archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch FTBFS in bundled bind when built without atomics
|
||||
# - disable atomics on v5/v6
|
||||
# - above changes can probably be removed once bundled bind moves beyond 9.11.14
|
||||
|
||||
pkgbase=dhcp
|
||||
pkgname=('dhcp' 'dhclient')
|
||||
|
||||
# separate patch levels with a period to maintain proper versioning.
|
||||
pkgver=4.4.2
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
license=('custom:isc-dhcp')
|
||||
url='https://www.isc.org/dhcp/'
|
||||
makedepends=('bash' 'iproute2' 'openldap')
|
||||
validpgpkeys=('AE3FAC796711EC59FC007AA474BB6B9A4CBB3D38') # Internet Systems Consortium, Inc. (Signing key, 2019-2020) <codesign@isc.org>
|
||||
source=("https://downloads.isc.org/isc/${pkgbase}/${pkgver}/${pkgbase}-${pkgver}.tar.gz"{,.asc}
|
||||
'dhcp-sysusers.conf'
|
||||
'dhcp-tmpfiles.conf'
|
||||
'dhcpd4.service'
|
||||
'dhcpd6.service'
|
||||
'dhclient@.service'
|
||||
'0002-iproute2.patch'
|
||||
'fix-variable-name-in-conditional-block.patch')
|
||||
sha256sums=('1a7ccd64a16e5e68f7b5e0f527fd07240a2892ea53fe245620f4f5f607004521'
|
||||
'SKIP'
|
||||
'b16083e6bb572ffacaa7cd97e7fde5fcfa1b6dbeb166f162e2ec6e8ec4b928d6'
|
||||
'abcd30e9e8428e34d22ab4d3074ef4bd84c2b11f5868597111b47d6f56d204da'
|
||||
'03fce30efab819b2d928085b0bab962a33ce56fc376acae98ad9b30aa278c9c8'
|
||||
'f98a4438f4f69cab7cc5cce6927df4790ee993ebc8f88a169e63043c53d25625'
|
||||
'86cd0b1e0ea1d47ab096f6ee925eee60545116fb887a155761eda589b30e4f0e'
|
||||
'837a64189b949afae951655546967cc8f17f2f2cf370faabff00575364f0fcf7'
|
||||
'895e655f320f3de0053d512d1915a3706f710f24c560ad811a48593a16ef3b34')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${pkgbase}-${pkgver}"
|
||||
|
||||
# no ifconfig, use ip from iproute2
|
||||
patch -Np1 -i ../0002-iproute2.patch
|
||||
|
||||
cd bind
|
||||
bsdtar -xf bind.tar.gz
|
||||
cd bind-9.*
|
||||
patch -p1 -i "${srcdir}/fix-variable-name-in-conditional-block.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgbase}-${pkgver}"
|
||||
|
||||
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && CONFIG='--with-bind-extra-config="--disable-atomic"'
|
||||
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--sbindir=/usr/bin \
|
||||
--sysconfdir=/etc \
|
||||
--enable-binary-leases \
|
||||
--enable-paranoia \
|
||||
--with-ldap \
|
||||
--with-ldapcrypto \
|
||||
--with-srv-lease-file=/var/lib/dhcp/dhcpd.leases \
|
||||
--with-srv6-lease-file=/var/lib/dhcp/dhcpd6.leases \
|
||||
--with-cli-lease-file=/var/lib/dhclient/dhclient.leases \
|
||||
--with-cli6-lease-file=/var/lib/dhclient/dhclient6.leases $CONFIG
|
||||
|
||||
make -j1
|
||||
}
|
||||
|
||||
package_dhcp(){
|
||||
pkgdesc="A DHCP server, client, and relay agent"
|
||||
depends=('glibc' 'libldap')
|
||||
backup=('etc/dhcpd.conf' 'etc/dhcpd6.conf')
|
||||
|
||||
cd "${srcdir}/${pkgbase}-${pkgver}"
|
||||
|
||||
make DESTDIR="${pkgdir}" install
|
||||
|
||||
install -D -m644 "${srcdir}/dhcp-sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/dhcp.conf"
|
||||
install -D -m644 "${srcdir}/dhcp-tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/dhcp.conf"
|
||||
install -D -m644 "${srcdir}/dhcpd4.service" "${pkgdir}/usr/lib/systemd/system/dhcpd4.service"
|
||||
install -D -m644 "${srcdir}/dhcpd6.service" "${pkgdir}/usr/lib/systemd/system/dhcpd6.service"
|
||||
|
||||
# move and install config files in place
|
||||
mv "${pkgdir}/etc/dhcpd.conf.example" "${pkgdir}/etc/dhcpd.conf"
|
||||
install -D -m644 doc/examples/dhcpd-dhcpv6.conf "${pkgdir}/etc/dhcpd6.conf"
|
||||
|
||||
# Remove dhclient
|
||||
make -C client DESTDIR="${pkgdir}" uninstall
|
||||
|
||||
# install license
|
||||
install -m644 -D LICENSE "${pkgdir}/usr/share/licenses/dhcp/LICENSE"
|
||||
}
|
||||
|
||||
package_dhclient(){
|
||||
pkgdesc="A standalone DHCP client from the dhcp package"
|
||||
depends=('glibc' 'bash' 'iproute2')
|
||||
provides=('dhcp-client')
|
||||
|
||||
cd "${srcdir}/${pkgbase}-${pkgver}"
|
||||
|
||||
make -C client DESTDIR="${pkgdir}" install
|
||||
|
||||
install -m755 -d "${pkgdir}/usr/share/dhclient"
|
||||
mv "${pkgdir}/etc/dhclient.conf.example" "${pkgdir}/usr/share/dhclient/"
|
||||
|
||||
install -d "${pkgdir}/var/lib/dhclient"
|
||||
|
||||
# install dhclient linux script
|
||||
install -m755 client/scripts/linux "${pkgdir}/usr/bin/dhclient-script"
|
||||
|
||||
# install license
|
||||
install -m644 -D LICENSE "${pkgdir}/usr/share/licenses/dhclient/LICENSE"
|
||||
|
||||
# install systemd service unit
|
||||
install -m644 -D "$srcdir/dhclient@.service" "${pkgdir}/usr/lib/systemd/system/dhclient@.service"
|
||||
}
|
13
extra/dhcp/dhclient@.service
Normal file
13
extra/dhcp/dhclient@.service
Normal file
|
@ -0,0 +1,13 @@
|
|||
[Unit]
|
||||
Description=dhclient on %I
|
||||
Wants=network.target
|
||||
Before=network.target
|
||||
|
||||
[Service]
|
||||
ExecStart=/usr/bin/dhclient -pf /run/dhclient@%i/dhclient.pid -d %I
|
||||
RuntimeDirectory=dhclient@%i
|
||||
ProtectSystem=on
|
||||
ProtectHome=on
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
1
extra/dhcp/dhcp-sysusers.conf
Normal file
1
extra/dhcp/dhcp-sysusers.conf
Normal file
|
@ -0,0 +1 @@
|
|||
u dhcp - "DHCP daemon" /
|
3
extra/dhcp/dhcp-tmpfiles.conf
Normal file
3
extra/dhcp/dhcp-tmpfiles.conf
Normal file
|
@ -0,0 +1,3 @@
|
|||
d /var/lib/dhcp 0750 dhcp dhcp -
|
||||
f /var/lib/dhcp/dhcpd.leases 0640 dhcp dhcp -
|
||||
f /var/lib/dhcp/dhcpd6.leases 0640 dhcp dhcp -
|
25
extra/dhcp/dhcpd4.service
Normal file
25
extra/dhcp/dhcpd4.service
Normal file
|
@ -0,0 +1,25 @@
|
|||
[Unit]
|
||||
Description=IPv4 DHCP server
|
||||
After=network.target network-online.target
|
||||
Wants=network-online.target
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
ExecStart=/usr/bin/dhcpd -4 -q -cf /etc/dhcpd.conf -pf /run/dhcpd4/dhcpd.pid
|
||||
RuntimeDirectory=dhcpd4
|
||||
PIDFile=/run/dhcpd4/dhcpd.pid
|
||||
User=dhcp
|
||||
AmbientCapabilities=CAP_NET_BIND_SERVICE CAP_NET_RAW
|
||||
ProtectSystem=full
|
||||
ProtectHome=on
|
||||
KillSignal=SIGINT
|
||||
# We pull in network-online.target for a configured network connection.
|
||||
# However this is not guaranteed to be the network connection our
|
||||
# networks are configured for. So try to restart on failure with a delay
|
||||
# of two seconds. Rate limiting kicks in after 12 seconds.
|
||||
RestartSec=2s
|
||||
Restart=on-failure
|
||||
StartLimitInterval=12s
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
25
extra/dhcp/dhcpd6.service
Normal file
25
extra/dhcp/dhcpd6.service
Normal file
|
@ -0,0 +1,25 @@
|
|||
[Unit]
|
||||
Description=IPv6 DHCP server
|
||||
After=network.target network-online.target
|
||||
Wants=network-online.target
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
ExecStart=/usr/bin/dhcpd -6 -q -cf /etc/dhcpd6.conf -pf /run/dhcpd6/dhcpd.pid
|
||||
RuntimeDirectory=dhcpd6
|
||||
PIDFile=/run/dhcpd6/dhcpd.pid
|
||||
User=dhcp
|
||||
AmbientCapabilities=CAP_NET_BIND_SERVICE CAP_NET_RAW
|
||||
ProtectSystem=full
|
||||
ProtectHome=on
|
||||
KillSignal=SIGINT
|
||||
# We pull in network-online.target for a configured network connection.
|
||||
# However this is not guaranteed to be the network connection our
|
||||
# networks are configured for. So try to restart on failure with a delay
|
||||
# of two seconds. Rate limiting kicks in after 12 seconds.
|
||||
RestartSec=2s
|
||||
Restart=on-failure
|
||||
StartLimitInterval=12s
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
25
extra/dhcp/fix-variable-name-in-conditional-block.patch
Normal file
25
extra/dhcp/fix-variable-name-in-conditional-block.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From 261c84d91d1b4581df9f7f0ec031908299de7726 Mon Sep 17 00:00:00 2001
|
||||
From: Mark Andrews <marka@isc.org>
|
||||
Date: Thu, 19 Dec 2019 09:27:44 +1100
|
||||
Subject: [PATCH] fix variable name in conditional block
|
||||
|
||||
---
|
||||
lib/isc/stats.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/isc/stats.c b/lib/isc/stats.c
|
||||
index 5bce3c1100..a7ab97ce53 100644
|
||||
--- a/lib/isc/stats.c
|
||||
+++ b/lib/isc/stats.c
|
||||
@@ -297,7 +297,7 @@ setcounter(isc_stats_t *stats,
|
||||
isc_atomic_store((int32_t *)&stats->counters[counter].lo,
|
||||
(uint32_t)(value & 0xffffffff));
|
||||
# else
|
||||
- stats->counters[counter] = val;
|
||||
+ stats->counters[counter] = value;
|
||||
# endif
|
||||
#endif
|
||||
}
|
||||
--
|
||||
2.24.1
|
||||
|
Loading…
Reference in a new issue