From 7454604db7dee58976064e085ef39d875e0bfc92 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 9 Jan 2013 19:17:07 +0000
Subject: [PATCH] removed extra/firefox

---
 extra/firefox/PKGBUILD                  |  87 -----------------
 extra/firefox/firefox-install-dir.patch |  30 ------
 extra/firefox/firefox.desktop           | 121 ------------------------
 extra/firefox/firefox.install           |  13 ---
 extra/firefox/mozconfig                 |  38 --------
 extra/firefox/shared-libs.patch         |  12 ---
 extra/firefox/vendor.js                 |   9 --
 7 files changed, 310 deletions(-)
 delete mode 100644 extra/firefox/PKGBUILD
 delete mode 100644 extra/firefox/firefox-install-dir.patch
 delete mode 100644 extra/firefox/firefox.desktop
 delete mode 100644 extra/firefox/firefox.install
 delete mode 100644 extra/firefox/mozconfig
 delete mode 100644 extra/firefox/shared-libs.patch
 delete mode 100644 extra/firefox/vendor.js

diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
deleted file mode 100644
index 23aa7850c..000000000
--- a/extra/firefox/PKGBUILD
+++ /dev/null
@@ -1,87 +0,0 @@
-# $Id: PKGBUILD 161877 2012-06-16 01:15:20Z ibiru $
-# Maintainer : Ionut Biru <ibiru@archlinux.org>
-# Contributor: Jakub Schmidtke <sjakub@gmail.com>
-
-# ALARM: Dan Cecile <dancecile@gmail.com>
-#  - changed GCC from 4.6 to system default
-
-buildarch=4
-highmem=1
-
-pkgname=firefox
-pkgver=17.0.1
-pkgrel=1
-pkgdesc="Standalone web browser from mozilla.org"
-arch=('i686' 'x86_64')
-license=('MPL' 'GPL' 'LGPL')
-depends=('gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types' 'dbus-glib' 'alsa-lib'
-         'libnotify' 'desktop-file-utils' 'hicolor-icon-theme'
-         'libvpx' 'libevent' 'nss>=3.13.3' 'hunspell' 'sqlite')
-makedepends=('unzip' 'zip' 'diffutils' 'python2' 'wireless_tools' 'yasm' 'mesa'
-             'autoconf2.13' 'libidl2' 'xorg-server-xvfb' 'imake')
-optdepends=('wireless_tools: Location detection via available WiFi networks')
-url="http://www.mozilla.org/projects/firefox"
-install=firefox.install
-options=(!emptydirs)
-source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.bz2
-        mozconfig firefox.desktop firefox-install-dir.patch vendor.js shared-libs.patch)
-
-build() {
-  cd mozilla-release
-
-  cp ../mozconfig .mozconfig
-  patch -Np1 -i ../firefox-install-dir.patch
-  patch -Np1 -i ../shared-libs.patch
-
-  # Fix PRE_RELEASE_SUFFIX
-  sed -i '/^PRE_RELEASE_SUFFIX := ""/s/ ""//' \
-    browser/base/Makefile.in
-
-  export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/firefox"
-  export PYTHON="/usr/bin/python2"
-  export MOZ_MAKE_FLAGS="$MAKEFLAGS"
-  unset MAKEFLAGS
-
-  # Enable PGO
-  export MOZ_PGO=1
-  export DISPLAY=:99
-  Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
-  _fail=0
-
-  make -f client.mk build  || _fail=1
-
-  kill $! || true
-}
-
-package() {
-  cd mozilla-release
-  make -j1 -f client.mk DESTDIR="$pkgdir" install
-
-  install -Dm644 ../vendor.js "$pkgdir/usr/lib/firefox/defaults/preferences/vendor.js"
-
-  for i in 16 22 24 32 48 256; do
-      install -Dm644 browser/branding/official/default$i.png \
-        "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png"
-  done
-
-  install -Dm644 ../firefox.desktop \
-    "$pkgdir/usr/share/applications/firefox.desktop"
-
-  # Use system-provided dictionaries
-  rm -rf "$pkgdir"/usr/lib/firefox/{dictionaries,hyphenation}
-  ln -s /usr/share/hunspell "$pkgdir/usr/lib/firefox/dictionaries"
-  ln -s /usr/share/hyphen "$pkgdir/usr/lib/firefox/hyphenation"
-
-  # We don't want the development stuff
-  rm -r "$pkgdir"/usr/{include,lib/firefox-devel,share/idl}
-
-  #workaround for now
-  #https://bugzilla.mozilla.org/show_bug.cgi?id=658850
-  ln -sf firefox "$pkgdir/usr/lib/firefox/firefox-bin"
-}
-md5sums=('13d616028eb77de927c29b6655c832c9'
-         '5644c7b42f51013e2023787938fa955e'
-         'eb56667bc1919f2ed93e34bdfc21f7d6'
-         '150ac0fb3ac7b2114c8e8851a9e0516c'
-         '0d053487907de4376d67d8f499c5502b'
-         '52e52f840a49eb1d14be1c0065b03a93')
diff --git a/extra/firefox/firefox-install-dir.patch b/extra/firefox/firefox-install-dir.patch
deleted file mode 100644
index 9c115f0eb..000000000
--- a/extra/firefox/firefox-install-dir.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -Nur mozilla-release.orig/config/baseconfig.mk mozilla-release/config/baseconfig.mk
---- mozilla-release.orig/config/baseconfig.mk	2012-10-09 07:34:41.762092280 +0000
-+++ mozilla-release/config/baseconfig.mk	2012-10-09 07:40:53.052771576 +0000
-@@ -1,9 +1,9 @@
- INCLUDED_AUTOCONF_MK = 1
- 
--includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
--idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
--installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
--sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
-+includedir := $(includedir)/$(MOZ_APP_NAME)
-+idldir = $(datadir)/idl/$(MOZ_APP_NAME)
-+installdir = $(libdir)/$(MOZ_APP_NAME)
-+sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel
- DIST = $(DEPTH)/dist
- 
- # We do magic with OBJ_SUFFIX in config.mk, the following ensures we don't
-diff -Nur mozilla-release.orig/js/src/config/baseconfig.mk mozilla-release/js/src/config/baseconfig.mk
---- mozilla-release.orig/js/src/config/baseconfig.mk	2012-10-09 07:34:58.411973276 +0000
-+++ mozilla-release/js/src/config/baseconfig.mk	2012-10-09 07:39:55.143186168 +0000
-@@ -1,7 +1,7 @@
- INCLUDED_AUTOCONF_MK = 1
- 
--installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
--sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
-+installdir = $(libdir)/$(MOZ_APP_NAME)
-+sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel
- 
- ifneq (,$(filter /%,$(TOP_DIST)))
- DIST = $(TOP_DIST)
diff --git a/extra/firefox/firefox.desktop b/extra/firefox/firefox.desktop
deleted file mode 100644
index 45005dc0f..000000000
--- a/extra/firefox/firefox.desktop
+++ /dev/null
@@ -1,121 +0,0 @@
-[Desktop Entry]
-Name=Firefox
-Name[bn]=ফায়ারফক্স
-Name[eo]=Fajrovulpo
-Name[fi]=Firefox
-Name[pa]=ਫਾਇਰਫੋਕਸ
-Name[tg]=Рӯбоҳи оташин
-GenericName=Web Browser
-GenericName[af]=Web Blaaier
-GenericName[ar]=متصفح ويب
-GenericName[az]=Veb Səyyahı
-GenericName[bg]=Браузър
-GenericName[bn]=ওয়েব ব্রাউজার
-GenericName[br]=Furcher ar Gwiad
-GenericName[bs]=WWW Preglednik
-GenericName[ca]=Fullejador web
-GenericName[cs]=WWW prohlížeč
-GenericName[cy]=Porydd Gwe
-GenericName[da]=Browser
-GenericName[de]=Web-Browser
-GenericName[el]=Περιηγητής Ιστού
-GenericName[eo]=TTT-legilo
-GenericName[es]=Navegador web
-GenericName[et]=Veebilehitseja
-GenericName[eu]=Web arakatzailea
-GenericName[fa]=مرورگر وب
-GenericName[fi]=WWW-selain
-GenericName[fo]=Alnótsfar
-GenericName[fr]=Navigateur web
-GenericName[gl]=Navegador Web
-GenericName[he]=דפדפן אינטרנט
-GenericName[hi]=वेब ब्राउज़र
-GenericName[hr]=Web preglednik
-GenericName[hu]=Webböngésző
-GenericName[is]=Vafri
-GenericName[it]=Browser Web
-GenericName[ja]=ウェブブラウザ
-GenericName[ko]=웹 브라우저
-GenericName[lo]=ເວັບບຣາວເຊີ
-GenericName[lt]=Žiniatinklio naršyklė
-GenericName[lv]=Web Pārlūks
-GenericName[mk]=Прелистувач на Интернет 
-GenericName[mn]=Веб-Хөтөч
-GenericName[nb]=Nettleser
-GenericName[nds]=Nettkieker
-GenericName[nl]=Webbrowser
-GenericName[nn]=Nettlesar
-GenericName[nso]=Seinyakisi sa Web
-GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
-GenericName[pl]=Przeglądarka WWW
-GenericName[pt]=Navegador Web
-GenericName[pt_BR]=Navegador Web
-GenericName[ro]=Navigator de web
-GenericName[ru]=Веб-браузер
-GenericName[se]=Fierpmádatlogan
-GenericName[sk]=Webový prehliadač
-GenericName[sl]=Spletni brskalnik
-GenericName[sr]=Веб претраживач
-GenericName[sr@Latn]=Veb pretraživač
-GenericName[ss]=Ibrawuza yeWeb 
-GenericName[sv]=Webbläsare
-GenericName[ta]=வலை உலாவி
-GenericName[tg]=Тафсиргари вэб
-GenericName[th]=เว็บบราวเซอร์
-GenericName[tr]=Web Tarayıcı
-GenericName[uk]=Навігатор Тенет
-GenericName[uz]=Веб-браузер
-GenericName[ven]=Buronza ya Webu
-GenericName[vi]=Trình duyệt Web
-GenericName[wa]=Betchteu waibe
-GenericName[xh]=Umkhangeli zincwadi we Web
-GenericName[zh_CN]=网页浏览器
-GenericName[zh_TW]=網頁瀏覽器
-GenericName[zu]=Umcingi we-Web
-Comment=Browse the World Wide Web
-Comment[ar]=تصفح الشبكة العنكبوتية العالمية
-Comment[ast]=Restola pela Rede
-Comment[bn]=ইন্টারনেট ব্রাউজ করুন
-Comment[ca]=Navegueu per la web
-Comment[cs]=Prohlížení stránek World Wide Webu
-Comment[da]=Surf på internettet
-Comment[de]=Im Internet surfen
-Comment[el]=Μπορείτε να περιηγηθείτε στο διαδίκτυο (Web)
-Comment[es]=Navegue por la web
-Comment[et]=Lehitse veebi
-Comment[fa]=صفحات شبکه جهانی اینترنت را مرور نمایید
-Comment[fi]=Selaa Internetin WWW-sivuja
-Comment[fr]=Naviguer sur le Web
-Comment[gl]=Navegar pola rede
-Comment[he]=גלישה ברחבי האינטרנט
-Comment[hr]=Pretražite web
-Comment[hu]=A világháló böngészése
-Comment[it]=Esplora il web
-Comment[ja]=ウェブを閲覧します
-Comment[ko]=웹을 돌아 다닙니다
-Comment[ku]=Li torê bigere
-Comment[lt]=Naršykite internete
-Comment[nb]=Surf på nettet
-Comment[nl]=Verken het internet
-Comment[nn]=Surf på nettet
-Comment[no]=Surf på nettet
-Comment[pl]=Przeglądanie stron WWW 
-Comment[pt]=Navegue na Internet
-Comment[pt_BR]=Navegue na Internet
-Comment[ro]=Navigați pe Internet
-Comment[ru]=Доступ в Интернет
-Comment[sk]=Prehliadanie internetu
-Comment[sl]=Brskajte po spletu
-Comment[sv]=Surfa på webben
-Comment[ug]=دۇنيادىكى توربەتلەرنى كۆرگىلى بولىدۇ
-Comment[uk]=Перегляд сторінок Інтернету
-Comment[vi]=Để duyệt các trang web
-Comment[zh_CN]=浏览互联网
-Comment[zh_TW]=瀏覽網際網路
-Exec=firefox %u
-Icon=firefox
-Terminal=false
-Type=Application
-MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
-StartupNotify=true
-Categories=Network;WebBrowser;
diff --git a/extra/firefox/firefox.install b/extra/firefox/firefox.install
deleted file mode 100644
index 1a1f4b16b..000000000
--- a/extra/firefox/firefox.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
-  update-desktop-database -q
-  gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade() {
-  post_install
-}
-
-post_remove() {
-  post_install
-}
-
diff --git a/extra/firefox/mozconfig b/extra/firefox/mozconfig
deleted file mode 100644
index c13380e32..000000000
--- a/extra/firefox/mozconfig
+++ /dev/null
@@ -1,38 +0,0 @@
-. $topsrcdir/browser/config/mozconfig
-
-ac_add_options --prefix=/usr
-ac_add_options --libdir=/usr/lib
-
-# System libraries
-ac_add_options --with-system-nspr
-ac_add_options --with-system-nss
-ac_add_options --with-system-jpeg
-ac_add_options --with-system-zlib
-ac_add_options --with-system-bz2
-ac_add_options --with-system-png
-ac_add_options --with-system-libevent
-ac_add_options --with-system-libvpx
-ac_add_options --enable-system-hunspell
-ac_add_options --enable-system-sqlite
-ac_add_options --enable-system-ffi
-#ac_add_options --enable-system-cairo
-ac_add_options --enable-system-pixman
-ac_add_options --with-pthreads
-
-# Features
-ac_add_options --enable-official-branding
-ac_add_options --enable-startup-notification
-ac_add_options --enable-gio
-#ac_add_options --enable-gstreamer
-
-ac_add_options --disable-gnomevfs
-ac_add_options --disable-crashreporter
-ac_add_options --disable-updater
-ac_add_options --disable-tests
-ac_add_options --disable-installer
-
-# PGO
-mk_add_options PROFILE_GEN_SCRIPT='$(PYTHON) $(MOZ_OBJDIR)/_profile/pgo/profileserver.py 10'
-
-# Needed to enable breakpad in application.ini
-export MOZILLA_OFFICIAL=1
diff --git a/extra/firefox/shared-libs.patch b/extra/firefox/shared-libs.patch
deleted file mode 100644
index 1f22b2b0d..000000000
--- a/extra/firefox/shared-libs.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur mozilla-release.orig/browser/installer/Makefile.in mozilla-release/browser/installer/Makefile.in
---- mozilla-release.orig/browser/installer/Makefile.in	2012-07-17 16:19:29.480356991 +0000
-+++ mozilla-release/browser/installer/Makefile.in	2012-07-17 17:32:41.250937293 +0000
-@@ -50,7 +50,7 @@
- MOZ_PKG_MANIFEST_P = $(srcdir)/package-manifest.in
- # Some files have been already bundled with xulrunner
- ifndef SYSTEM_LIBXUL
--MOZ_PKG_FATAL_WARNINGS = 1
-+MOZ_PKG_FATAL_WARNINGS = 0
- endif
- 
- MOZ_NONLOCALIZED_PKG_LIST = \
diff --git a/extra/firefox/vendor.js b/extra/firefox/vendor.js
deleted file mode 100644
index d8d606bc1..000000000
--- a/extra/firefox/vendor.js
+++ /dev/null
@@ -1,9 +0,0 @@
-// Use LANG environment variable to choose locale
-pref("intl.locale.matchOS", true);
-
-// Disable default browser checking.
-pref("browser.shell.checkDefaultBrowser", false);
-
-// Don't disable our bundled extensions in the application directory
-pref("extensions.autoDisableScopes", 11);
-pref("extensions.shownSelectionUI", true);