mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
removed community/swh-plugins
This commit is contained in:
parent
e85f9fe944
commit
748fa8a556
2 changed files with 0 additions and 95 deletions
|
@ -1,56 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Ray Rashif <schiv@archlinux.org>
|
||||
# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
|
||||
# Contributor: Robert Emil Berge
|
||||
|
||||
# move to github source? see frontpage news updates
|
||||
# and also https://github.com/swh/ladspa
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - build AArch64 with -fPIC
|
||||
|
||||
pkgname=swh-plugins
|
||||
pkgver=0.4.15
|
||||
pkgrel=7
|
||||
pkgdesc="Steve Harris' LADSPA plug-ins suite"
|
||||
arch=('x86_64')
|
||||
url="http://plugin.org.uk/"
|
||||
license=('GPL')
|
||||
depends=('fftw' 'ladspa')
|
||||
makedepends=('libxml2' 'perl-xml-parser')
|
||||
groups=('ladspa-plugins')
|
||||
source=("http://plugin.org.uk/releases/$pkgver/$pkgname-$pkgver.tar.gz"
|
||||
'mbeq_crash_fix.patch')
|
||||
md5sums=('2fbdccef2462ea553901acd429fa3573'
|
||||
'a60422c8dea95bee6f9adcdc70dff7e0')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
# Arch64 fix;
|
||||
# -fPIC seems to be the only option
|
||||
if [ "$CARCH" = 'x86_64' -o "$CARCH" = 'aarch64' ]; then
|
||||
export CFLAGS="$CFLAGS -fPIC"
|
||||
export CXXFLAGS="$CFLAGS"
|
||||
fi
|
||||
|
||||
# fix Firefox crash on x64 when
|
||||
# plugin is in use by ALSA;
|
||||
# see https://bugs.archlinux.org/task/24579
|
||||
patch -Np1 -i "$srcdir/mbeq_crash_fix.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
./configure --prefix=/usr
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
make DESTDIR="$pkgdir/" install
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
|
@ -1,39 +0,0 @@
|
|||
diff -Nru swh-plugins-0.4.15.orig/mbeq_1197.c swh-plugins-0.4.15/mbeq_1197.c
|
||||
--- swh-plugins-0.4.15.orig/mbeq_1197.c 2006-08-09 01:49:15.000000000 +1000
|
||||
+++ swh-plugins-0.4.15/mbeq_1197.c 2011-06-05 10:57:17.929107102 +1000
|
||||
@@ -457,7 +457,8 @@
|
||||
#endif
|
||||
|
||||
// Multiply the bins magnitudes by the coeficients
|
||||
- for (i = 0; i < FFT_LENGTH/2; i++) {
|
||||
+ comp[0] *= coefs[0];
|
||||
+ for (i = 1; i < FFT_LENGTH/2; i++) {
|
||||
comp[i] *= coefs[i];
|
||||
comp[FFT_LENGTH-i] *= coefs[i];
|
||||
}
|
||||
diff -Nru swh-plugins-0.4.15.orig/mbeq_1197.so.c swh-plugins-0.4.15/mbeq_1197.so.c
|
||||
--- swh-plugins-0.4.15.orig/mbeq_1197.so.c 2003-10-22 02:13:40.000000000 +1000
|
||||
+++ swh-plugins-0.4.15/mbeq_1197.so.c 2011-06-05 10:57:52.265774336 +1000
|
||||
@@ -446,7 +446,8 @@
|
||||
#endif
|
||||
|
||||
// Multiply the bins magnitudes by the coeficients
|
||||
- for (i = 0; i < FFT_LENGTH/2; i++) {
|
||||
+ comp[0] *= coefs[0];
|
||||
+ for (i = 1; i < FFT_LENGTH/2; i++) {
|
||||
comp[i] *= coefs[i];
|
||||
comp[FFT_LENGTH-i] *= coefs[i];
|
||||
}
|
||||
diff -Nru swh-plugins-0.4.15.orig/mbeq_1197.xml swh-plugins-0.4.15/mbeq_1197.xml
|
||||
--- swh-plugins-0.4.15.orig/mbeq_1197.xml 2005-06-01 19:51:58.000000000 +1000
|
||||
+++ swh-plugins-0.4.15/mbeq_1197.xml 2011-06-05 10:57:39.335774121 +1000
|
||||
@@ -171,7 +171,8 @@
|
||||
#endif
|
||||
|
||||
// Multiply the bins magnitudes by the coeficients
|
||||
- for (i = 0; i < FFT_LENGTH/2; i++) {
|
||||
+ comp[0] *= coefs[0];
|
||||
+ for (i = 1; i < FFT_LENGTH/2; i++) {
|
||||
comp[i] *= coefs[i];
|
||||
comp[FFT_LENGTH-i] *= coefs[i];
|
||||
}
|
Loading…
Reference in a new issue