mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/chromium to 57.0.2987.98-1
This commit is contained in:
parent
1296f6238f
commit
74d0f61bdd
4 changed files with 33 additions and 95 deletions
|
@ -1,19 +1,40 @@
|
|||
From 3130c331c5694c9c330744c928014fd775806e35 Mon Sep 17 00:00:00 2001
|
||||
From 99b6cda245256c0ccb5c50e4bf7a4c6256ec5c2c Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 23 Oct 2016 10:57:25 -0600
|
||||
Subject: [PATCH 2/2] ARM toolchain fixes
|
||||
Subject: [PATCH] ARM toolchain fixes
|
||||
|
||||
---
|
||||
build/toolchain/linux/BUILD.gn | 28 +++++++++++++++++++++-------
|
||||
1 file changed, 21 insertions(+), 7 deletions(-)
|
||||
build/toolchain/linux/BUILD.gn | 24 ++++++++++--------------
|
||||
1 file changed, 10 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/build/toolchain/linux/BUILD.gn b/build/toolchain/linux/BUILD.gn
|
||||
index 548722d39380..39c5b08bbe55 100644
|
||||
index 86cd7dabc6e8..4b1e73b1aca3 100644
|
||||
--- a/build/toolchain/linux/BUILD.gn
|
||||
+++ b/build/toolchain/linux/BUILD.gn
|
||||
@@ -22,15 +22,13 @@ clang_toolchain("clang_arm64") {
|
||||
}
|
||||
|
||||
gcc_toolchain("arm64") {
|
||||
- toolprefix = "aarch64-linux-gnu-"
|
||||
-
|
||||
- cc = "${toolprefix}gcc"
|
||||
- cxx = "${toolprefix}g++"
|
||||
+ cc = "gcc"
|
||||
+ cxx = "g++"
|
||||
|
||||
- ar = "${toolprefix}ar"
|
||||
+ ar = "ar"
|
||||
ld = cxx
|
||||
- readelf = "${toolprefix}readelf"
|
||||
- nm = "${toolprefix}nm"
|
||||
+ readelf = "readelf"
|
||||
+ nm = "nm"
|
||||
|
||||
toolchain_args = {
|
||||
current_cpu = "arm64"
|
||||
@@ -40,15 +38,13 @@ gcc_toolchain("arm64") {
|
||||
}
|
||||
|
||||
gcc_toolchain("arm") {
|
||||
- toolprefix = "arm-linux-gnueabihf-"
|
||||
-
|
||||
|
@ -32,29 +53,6 @@ index 548722d39380..39c5b08bbe55 100644
|
|||
|
||||
toolchain_args = {
|
||||
current_cpu = "arm"
|
||||
@@ -39,6 +37,22 @@ gcc_toolchain("arm") {
|
||||
}
|
||||
}
|
||||
|
||||
+gcc_toolchain("arm64") {
|
||||
+ cc = "gcc"
|
||||
+ cxx = "g++"
|
||||
+
|
||||
+ ar = "ar"
|
||||
+ ld = cxx
|
||||
+ readelf = "readelf"
|
||||
+ nm = "nm"
|
||||
+
|
||||
+ toolchain_args = {
|
||||
+ current_cpu = "arm64"
|
||||
+ current_os = "linux"
|
||||
+ is_clang = false
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
clang_toolchain("clang_x86") {
|
||||
toolchain_args = {
|
||||
current_cpu = "x86"
|
||||
--
|
||||
2.11.0
|
||||
2.12.0
|
||||
|
|
@ -1,33 +0,0 @@
|
|||
From 24b54472072cd87964cd3ab210516daeb16705a5 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 23 Oct 2016 10:56:44 -0600
|
||||
Subject: [PATCH 1/2] Add aarch64 GN support
|
||||
|
||||
---
|
||||
tools/gn/args.cc | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/tools/gn/args.cc b/tools/gn/args.cc
|
||||
index 7285d7a5388a..54703e17604e 100644
|
||||
--- a/tools/gn/args.cc
|
||||
+++ b/tools/gn/args.cc
|
||||
@@ -266,6 +266,7 @@ void Args::SetSystemVarsLocked(Scope* dest) const {
|
||||
static const char kX86[] = "x86";
|
||||
static const char kX64[] = "x64";
|
||||
static const char kArm[] = "arm";
|
||||
+ static const char kArm64[] = "arm64";
|
||||
static const char kMips[] = "mipsel";
|
||||
static const char kS390X[] = "s390x";
|
||||
static const char kPPC64[] = "ppc64";
|
||||
@@ -280,6 +281,8 @@ void Args::SetSystemVarsLocked(Scope* dest) const {
|
||||
arch = kX64;
|
||||
else if (os_arch.substr(0, 3) == "arm")
|
||||
arch = kArm;
|
||||
+ else if (os_arch == "aarch64")
|
||||
+ arch = kArm64;
|
||||
else if (os_arch == "mips")
|
||||
arch = kMips;
|
||||
else if (os_arch == "s390x")
|
||||
--
|
||||
2.11.0
|
||||
|
|
@ -5,11 +5,8 @@
|
|||
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - add ffmpeg to _system_libs
|
||||
# - makeflags to -j4 on v7, RAM constraints
|
||||
# - Gentoo patch to remove lingering built-in ffmpeg code
|
||||
# - patches to fix GN for AArch64 and ARM toolchain definitions
|
||||
# - patch for https://bugs.chromium.org/p/v8/issues/detail?id=5668
|
||||
# - patch to fix GN ARM toolchain definitions
|
||||
|
||||
buildarch=12
|
||||
highmem=1
|
||||
|
@ -34,7 +31,7 @@ declare -rgA _system_libs=(
|
|||
)
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=56.0.2924.87
|
||||
pkgver=57.0.2987.98
|
||||
pkgrel=1
|
||||
_launcher_ver=3
|
||||
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
|
||||
|
@ -53,21 +50,15 @@ install=chromium.install
|
|||
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
|
||||
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
|
||||
chromium.desktop
|
||||
chromium-glib-2.24.patch
|
||||
chromium-system-ffmpeg-r4.patch
|
||||
chromium-widevine.patch
|
||||
0001-Add-aarch64-GN-support.patch
|
||||
0002-ARM-toolchain-fixes.patch
|
||||
https://codereview.chromium.org/download/issue2615533007_1.diff)
|
||||
sha256sums=('9aac081ffccaae6497068100477a4e6ac7086bd15ad3c3cd009b9a760b7a53e0'
|
||||
0001-ARM-toolchain-fixes.patch)
|
||||
sha256sums=('16b5ecf70fcab8476231636ec20f5415897781b01ed21640283cb358322f792d'
|
||||
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
|
||||
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
|
||||
'6953651c002efe7fca8cda3143e963037ed38a0a4bc7ccb79304637c45340047'
|
||||
'e3c474dbf3822a0be50695683bd8a2c9dfc82d41c1524a20b4581883c0c88986'
|
||||
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
|
||||
'c855bfd9533bb51a618be3d0fd7fcc7df723dd9e91d629615b4fc65445901a88'
|
||||
'5d00d0db4cc34a73a9dbb6f6640c850d77b0ef503d1e9bffb3c50f00bbb843ac'
|
||||
'4d75e93206d6e73f0affe2ec70e4a0aa3ac4f6f26da46e6caa75df890796d25d')
|
||||
'8489d2a85b32e9b08f5c30d47b40ae41911d1915f48b6de3c41fe350dfecfef6')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
# Note: These are for Arch Linux use ONLY. For your own distribution, please
|
||||
|
@ -82,9 +73,7 @@ prepare() {
|
|||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
# Arch Linux ARM fixes
|
||||
patch -Np1 -i ../0001-Add-aarch64-GN-support.patch
|
||||
patch -Np1 -i ../0002-ARM-toolchain-fixes.patch
|
||||
patch -Np1 -d v8 -i ../../issue2615533007_1.diff
|
||||
patch -Np1 -i ../0001-ARM-toolchain-fixes.patch
|
||||
|
||||
[[ $CARCH == "armv7h" ]] && MAKEFLAGS="-j4" && CFLAGS=`echo $CFLAGS | sed -e 's/vfpv3-d16/neon/'` && CXXFLAGS="$CFLAGS"
|
||||
|
||||
|
@ -96,7 +85,6 @@ prepare() {
|
|||
|
||||
# Fixes from Gentoo
|
||||
patch -Np1 -i ../chromium-system-ffmpeg-r4.patch
|
||||
patch -Np1 -i ../chromium-glib-2.24.patch
|
||||
|
||||
# Work around bug in blink in which GCC 6 optimizes away null pointer checks
|
||||
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=833524
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
--- a/third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp.orig 2017-01-05 20:50:56.329369189 +0000
|
||||
+++ b/third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp 2017-01-05 20:51:32.926099779 +0000
|
||||
@@ -242,6 +242,12 @@
|
||||
ASSERT(!(len & kSystemPageOffsetMask));
|
||||
#if OS(POSIX)
|
||||
int ret = madvise(addr, len, MADV_FREE);
|
||||
+ if (ret != 0 && errno == EINVAL) {
|
||||
+ // MADV_FREE only works on Linux 4.5+ . If request failed,
|
||||
+ // retry with older MADV_DONTNEED . Note that MADV_FREE
|
||||
+ // being defined at compile time doesn't imply runtime support.
|
||||
+ ret = madvise(addr, len, MADV_DONTNEED);
|
||||
+ }
|
||||
RELEASE_ASSERT(!ret);
|
||||
#else
|
||||
setSystemPagesInaccessible(addr, len);
|
Loading…
Reference in a new issue