extra/python to 3.2.2-2

This commit is contained in:
Kevin Mihelich 2011-11-30 13:47:34 -05:00
parent be71b3861e
commit 754b0a24c0
2 changed files with 26 additions and 6 deletions

View file

@ -1,9 +1,9 @@
# $Id: PKGBUILD 136999 2011-09-05 05:47:36Z allan $
# $Id: PKGBUILD 143817 2011-11-29 13:33:42Z stephane $
# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: Jason Chu <jason@archlinux.org>
# ALARM: Kevin Mihelich <kevin@plugapps.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - removed valgrind from makedepends, can't build it for ARM
# - removed --with-valgrind from configure line
@ -11,7 +11,7 @@ plugrel=1
pkgname=python
pkgver=3.2.2
pkgrel=1
pkgrel=2
_pybasever=3.2
pkgdesc="Next generation of the python high-level scripting language"
arch=('i686' 'x86_64')
@ -23,8 +23,10 @@ optdepends=('tk: for tkinter' 'sqlite3')
provides=('python3')
replaces=('python3')
options=('!makeflags')
source=(http://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz)
sha1sums=('5e654dbd48476193ccdef4d604ed4f45b48c6769')
source=(http://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz
gdbm-magic-values.patch)
sha1sums=('5e654dbd48476193ccdef4d604ed4f45b48c6769'
'43bfbe3e23360f412b95cb284ff29b2cbe338be9')
build() {
cd "${srcdir}/Python-${pkgver}"
@ -32,6 +34,10 @@ build() {
# FS#23997
sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
# gdbm has new magic that whichdb does not recognize
# http://bugs.python.org/issue13007
patch -Np1 -i ../gdbm-magic-values.patch
# Ensure that we are using the system copy of various libraries (expat, zlib and libffi),
# rather than copies shipped in the tarball
rm -r Modules/expat
@ -45,6 +51,7 @@ build() {
--enable-ipv6 \
--with-wide-unicode \
--with-system-expat \
--with-dbmliborder=gdbm:ndbm \
--with-system-ffi
make
@ -53,7 +60,7 @@ build() {
check() {
cd "${srcdir}/Python-${pkgver}"
LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
"${srcdir}/Python-${pkgver}/python" -m test.regrtest -x test_distutils test_site
"${srcdir}/Python-${pkgver}/python" -m test.regrtest -x test_distutils test_site test_uuid
}
package() {

View file

@ -0,0 +1,13 @@
diff -up Python-3.2.2/Lib/dbm/__init__.py.gdbm-1.9-magic Python-3.2.2/Lib/dbm/__init__.py
--- Python-3.2.2/Lib/dbm/__init__.py.gdbm-1.9-magic 2011-09-03 12:16:40.000000000 -0400
+++ Python-3.2.2/Lib/dbm/__init__.py 2011-09-30 15:47:27.488863694 -0400
@@ -166,7 +166,7 @@ def whichdb(filename):
return ""
# Check for GNU dbm
- if magic == 0x13579ace:
+ if magic in (0x13579ace, 0x13579acd, 0x13579acf):
return "dbm.gnu"
# Later versions of Berkeley db hash file have a 12-byte pad in
diff -up Python-3.2.2/Misc/NEWS.gdbm-1.9-magic Python-3.2.2/Misc/NEWS