mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/gst-plugins-bad to 1.18.0+54+gbd3532008-1
This commit is contained in:
parent
41131aa0e4
commit
7561b2fb9e
3 changed files with 29 additions and 30 deletions
|
@ -0,0 +1,22 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@ltnglobal.com>
|
||||
Date: Mon, 26 Oct 2020 16:24:08 +0100
|
||||
Subject: [PATCH] opencv: allow compilation against 4.5.x
|
||||
|
||||
---
|
||||
ext/opencv/meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build
|
||||
index 074272a9c..e3d1865da 100644
|
||||
--- a/ext/opencv/meson.build
|
||||
+++ b/ext/opencv/meson.build
|
||||
@@ -66,7 +66,7 @@ if opencv_found
|
||||
endif
|
||||
endforeach
|
||||
else
|
||||
- opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.5.0'], required : false)
|
||||
+ opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.6.0'], required : false)
|
||||
opencv_found = opencv_dep.found()
|
||||
if opencv_found
|
||||
foreach h : libopencv4_headers
|
|
@ -1,24 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
|
||||
Date: Sat, 12 Sep 2020 02:23:37 +0200
|
||||
Subject: [PATCH] tests: svthevcenc: Fix test_encode_simple
|
||||
|
||||
Pick the same I420 format the other test use. Without this, the source
|
||||
picks AYUV64, which fails.
|
||||
---
|
||||
tests/check/elements/svthevcenc.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tests/check/elements/svthevcenc.c b/tests/check/elements/svthevcenc.c
|
||||
index d1234fc27..1b938e10c 100644
|
||||
--- a/tests/check/elements/svthevcenc.c
|
||||
+++ b/tests/check/elements/svthevcenc.c
|
||||
@@ -29,7 +29,7 @@ GST_START_TEST (test_encode_simple)
|
||||
h = gst_harness_new_parse ("svthevcenc speed=9 bitrate=1000 ! h265parse");
|
||||
|
||||
gst_harness_add_src_parse (h, "videotestsrc is-live=true ! "
|
||||
- "capsfilter caps=\"video/x-raw,width=320,height=240,framerate=25/1\"",
|
||||
+ "capsfilter caps=\"video/x-raw,format=I420,width=320,height=240,framerate=25/1\"",
|
||||
TRUE);
|
||||
|
||||
/* Push 25 buffers into the encoder */
|
|
@ -7,8 +7,8 @@
|
|||
|
||||
pkgbase=gst-plugins-bad
|
||||
pkgname=(gst-plugins-bad-libs gst-plugins-bad gst-plugin-opencv)
|
||||
pkgver=1.18.0
|
||||
pkgrel=2
|
||||
pkgver=1.18.0+54+gbd3532008
|
||||
pkgrel=1
|
||||
pkgdesc="Multimedia graph framework - bad plugins"
|
||||
url="https://gstreamer.freedesktop.org/"
|
||||
arch=(x86_64)
|
||||
|
@ -27,11 +27,11 @@ makedepends=(mjpegtools curl chromaprint libmms faad2 libdca libdvdnav
|
|||
zxing-cpp opencv libva)
|
||||
checkdepends=(xorg-server-xvfb)
|
||||
options=(!emptydirs)
|
||||
_commit=7cb583bb0427819a6b59b783e7df67961df2155f # tags/1.18.0^0
|
||||
_commit=bd3532008f2a12377c2d5b56e93cbfa53e1979cf # 1.18
|
||||
source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad.git#commit=$_commit"
|
||||
0001-tests-svthevcenc-Fix-test_encode_simple.patch)
|
||||
0001-opencv-allow-compilation-against-4.5.x.patch)
|
||||
sha256sums=('SKIP'
|
||||
'04b276b7dc5ae63d2a5bfcef446597114e9d28c743e325c60038f8fc5375f445')
|
||||
'b310123298a4de09033c84b6e2a1ec01c7122320cddc3bff655c42c56d21d064')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgbase
|
||||
|
@ -40,7 +40,8 @@ pkgver() {
|
|||
|
||||
prepare() {
|
||||
cd $pkgbase
|
||||
git apply -3 ../0001-tests-svthevcenc-Fix-test_encode_simple.patch
|
||||
git cherry-pick -n 3ea6387f969c0b08027fc959b8b8cd102708bceb # Fix svthevcenc test
|
||||
git apply -3 ../0001-opencv-allow-compilation-against-4.5.x.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue