core/linux-veyron to 3.14.0-9

This commit is contained in:
Kevin Mihelich 2015-08-05 03:45:45 +00:00
parent dd1daa14ef
commit 758c9c7d45
6 changed files with 56 additions and 18 deletions

View file

@ -1,7 +1,7 @@
From d1f7cbbd8efbc022222d84a697595ba9f6637de0 Mon Sep 17 00:00:00 2001
From 0cdd50365d92a617e3db5bc9dd2feec6fd0dca3d Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 25 Jun 2015 20:35:06 -0600
Subject: [PATCH 1/4] use chromiumos mwifiex drivers
Subject: [PATCH 1/5] use chromiumos mwifiex drivers
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -26,5 +26,5 @@ index f9ee413..9686025 100644
#define BLOCK_MODE 1
--
2.4.4
2.5.0

View file

@ -1,7 +1,7 @@
From d24fdf29978108413eb405302255139fdbb94a16 Mon Sep 17 00:00:00 2001
From 0eace2f735da15d64c1806f61d11650615ddc52b Mon Sep 17 00:00:00 2001
From: Bing Zhao <bzhao@marvell.com>
Date: Mon, 19 Aug 2013 16:10:21 -0700
Subject: [PATCH 2/4] mwifiex: do not create AP and P2P interfaces upon driver
Subject: [PATCH 2/5] mwifiex: do not create AP and P2P interfaces upon driver
loading
Bug 60747 - 1286:2044 [Microsoft Surface Pro]
@ -59,5 +59,5 @@ index b3f9247..a503264 100644
mwifiex_drv_get_driver_version(adapter, fmt, sizeof(fmt) - 1);
--
2.4.4
2.5.0

View file

@ -1,7 +1,7 @@
From c0c863786b85a631e22eeae78f572d3f151af490 Mon Sep 17 00:00:00 2001
From e941d1d7a7c730edbd7fc18e1654b88700a32242 Mon Sep 17 00:00:00 2001
From: Heiko Stuebner <heiko@sntech.de>
Date: Mon, 25 May 2015 16:38:07 +0200
Subject: [PATCH 3/4] UPSTREAM: soc/rockchip: add handler for usb-uart
Subject: [PATCH 3/5] UPSTREAM: soc/rockchip: add handler for usb-uart
functionality
Some Rockchip SoCs provide the possibility to use a usb-phy as passthru for
@ -302,5 +302,5 @@ index 0000000..97754f9
+}
+early_param("rockchip.usb_uart", rockchip_usb_uart);
--
2.4.4
2.5.0

View file

@ -1,7 +1,7 @@
From 6dc781566c97f06b5c0d491f34c9b23e72cb74be Mon Sep 17 00:00:00 2001
From d102c36cab907b5a7be1e9fcf36a48fd0cbb3200 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 2 Jul 2015 17:48:41 -0600
Subject: [PATCH 4/4] fix brcmfmac oops and race condition
Subject: [PATCH 4/5] fix brcmfmac oops and race condition
This fixes a potential null pointer dereference by checking if null before
freeing the vif struct.
@ -110,5 +110,5 @@ index 128161c..d3db8f7 100644
free_netdev(p2p_ifp->ndev);
drvr->iflist[1] = NULL;
--
2.4.4
2.5.0

View file

@ -0,0 +1,35 @@
From 66a7e7a7f2c011762df4e91c9b889e17f7277fc2 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 4 Aug 2015 20:37:24 -0600
Subject: [PATCH 5/5] Revert "FROMLIST: drm/rockchip: vop: switch cursor plane
to window 3"
This reverts commit 181c3fef0d1bab102720cc28d87e96e2fd6f4b8c.
---
drivers/gpu/drm/rockchip/rockchip_drm_vop.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/gpu/drm/rockchip/rockchip_drm_vop.c b/drivers/gpu/drm/rockchip/rockchip_drm_vop.c
index 97402b0..00b2846 100644
--- a/drivers/gpu/drm/rockchip/rockchip_drm_vop.c
+++ b/drivers/gpu/drm/rockchip/rockchip_drm_vop.c
@@ -329,13 +329,13 @@ static const struct vop_reg_data vop_init_reg_table[] = {
/*
* Note: rk3288 has a dedicated 'cursor' window, however, that window requires
* special support to get alpha blending working. For now, just use overlay
- * window 3 for the drm cursor.
+ * window 1 for the drm cursor.
*/
static const struct vop_win_data rk3288_vop_win_data[] = {
{ .base = 0x00, .phy = &win01_data, .type = DRM_PLANE_TYPE_PRIMARY },
- { .base = 0x40, .phy = &win01_data, .type = DRM_PLANE_TYPE_OVERLAY },
+ { .base = 0x40, .phy = &win01_data, .type = DRM_PLANE_TYPE_CURSOR },
{ .base = 0x00, .phy = &win23_data, .type = DRM_PLANE_TYPE_OVERLAY },
- { .base = 0x50, .phy = &win23_data, .type = DRM_PLANE_TYPE_CURSOR },
+ { .base = 0x50, .phy = &win23_data, .type = DRM_PLANE_TYPE_OVERLAY },
{ .base = 0x00, .phy = &cursor_data, .type = DRM_PLANE_TYPE_OVERLAY },
};
--
2.5.0

View file

@ -7,8 +7,8 @@ pkgbase=linux-veyron
_kernelname=${pkgbase#linux}
_desc="Veyron Chromebooks"
pkgver=3.14.0
pkgrel=8
_commit=6e6a92b14a6298d4ccca36cf664b31a17039dd88
pkgrel=9
_commit=7ffb6599e297922b75a969bea6bfad7f47b16748
arch=('armv7h')
url="https://chromium.googlesource.com/chromiumos/third_party/kernel/+/chromeos-3.14"
license=('GPL2')
@ -21,6 +21,7 @@ source=("https://chromium.googlesource.com/chromiumos/third_party/kernel/+archiv
'0002-mwifiex-do-not-create-AP-and-P2P-interfaces-upon-dri.patch'
'0003-UPSTREAM-soc-rockchip-add-handler-for-usb-uart-funct.patch'
'0004-fix-brcmfmac-oops-and-race-condition.patch'
'0005-Revert-FROMLIST-drm-rockchip-vop-switch-cursor-plane.patch'
'config'
'kernel.its'
'kernel.keyblock'
@ -33,10 +34,11 @@ md5sums=('SKIP'
'5e2d7cd74de07d13052de99411c13a2f'
'1534c1dbfe5df35a5634072f7b912840'
'20f8931f3795e5226829d48c3d470334'
'c052528d853e04cfe40f90ec681bac53'
'7c505a86de18e42158dbdfc146e2cee7'
'16072b50894af1550d3d767259f0f98c'
'e4d12c67b4c14cd9431887a6a7792547'
'600f20ce8286ab7a20d9f6de653a2eec'
'612b8420971ec68df1284cacfcd6bcf7'
'867486ec04dcfe0ea6594ea89f3a9df5'
'389ba1ecb6d62d62499cc0d5c832ae99'
'256274adf9c0ee60268bb3e6f4991916'
'd3d0d08037ec930c4e2b4c53dce7ddb1'
'1d77c34a9c759a7f54df718cd80de567'
'61c5ff73c136ed07a7aadbf58db3d96a'
@ -50,6 +52,7 @@ prepare() {
git apply 0002-mwifiex-do-not-create-AP-and-P2P-interfaces-upon-dri.patch
git apply 0003-UPSTREAM-soc-rockchip-add-handler-for-usb-uart-funct.patch
git apply 0004-fix-brcmfmac-oops-and-race-condition.patch
git apply 0005-Revert-FROMLIST-drm-rockchip-vop-switch-cursor-plane.patch
cp config .config