mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
removed extra/kinfocenter
This commit is contained in:
parent
887b4350b9
commit
75bc754b3c
2 changed files with 0 additions and 76 deletions
|
@ -1,63 +0,0 @@
|
|||
# $Id: PKGBUILD 224713 2014-10-18 08:27:20Z andrea $
|
||||
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||
# Contributor: Antonio Rojas
|
||||
|
||||
# ALARM on armv6h: Arno Rehn <arno@arnorehn.de>
|
||||
# - Disable the failing EGLonX parts (not available on the R-Pi). Needs better upstream support.
|
||||
|
||||
pkgname=kinfocenter
|
||||
pkgver=5.2.1
|
||||
pkgrel=1
|
||||
pkgdesc='KInfocenter'
|
||||
arch=('i686' 'x86_64')
|
||||
url='https://projects.kde.org/projects/kde/workspace/kinfocenter'
|
||||
license=('LGPL')
|
||||
depends=('kdelibs4support' 'kcmutils' 'pciutils' 'glu' 'libraw1394' 'kwayland')
|
||||
makedepends=('extra-cmake-modules' 'kdoctools' 'python' 'plasma-framework')
|
||||
conflicts=('kdebase-workspace')
|
||||
groups=('plasma')
|
||||
source=("http://download.kde.org/stable/plasma/${pkgver}/$pkgname-$pkgver.tar.xz"
|
||||
"kinfocenter_disable_eglonx.patch")
|
||||
md5sums=('6c74821a6110910eed5f174d5f839a2b'
|
||||
'a43a82b8be9aea5a4666b6372eecc7d2')
|
||||
|
||||
prepare() {
|
||||
mkdir build
|
||||
|
||||
cd "${pkgname}-${pkgver}"
|
||||
|
||||
# # Raspberry Pi
|
||||
# if [ "$CARCH" == 'armv6h' ]; then
|
||||
# patch -p1 -i "${srcdir}/kinfocenter_disable_eglonx.patch"
|
||||
# fi
|
||||
}
|
||||
|
||||
build() {
|
||||
# # Raspberry Pi
|
||||
# if [ "$CARCH" == 'armv6h' ]; then
|
||||
# VC_INCLUDE_DIR="/opt/vc/include;/opt/vc/include/interface/vcos/pthreads;/opt/vc/include/interface/vmcs_host/linux"
|
||||
# VC_EGL_LIB="/opt/vc/lib/libEGL.so"
|
||||
# VC_GLESv2_LIB="/opt/vc/lib/libGLESv2.so"
|
||||
|
||||
# CMAKE_EXTRA_CONFIG_OPTIONS="-DOPENGLES_EGL_INCLUDE_DIR=$VC_INCLUDE_DIR \
|
||||
# -DOPENGLES_EGL_LIBRARY=$VC_EGL_LIB \
|
||||
# -DOPENGLES_INCLUDE_DIR=$VC_INCLUDE_DIR \
|
||||
# -DOPENGLES_LIBRARY=$VC_GLESv2_LIB"
|
||||
# fi
|
||||
|
||||
cd build
|
||||
cmake ../${pkgname}-${pkgver} \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DLIB_INSTALL_DIR=lib \
|
||||
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
|
||||
-DBUILD_TESTING=OFF \
|
||||
$CMAKE_EXTRA_CONFIG_OPTIONS
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd build
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
|
@ -1,13 +0,0 @@
|
|||
diff --git a/Modules/opengl/opengl.cpp b/Modules/opengl/opengl.cpp
|
||||
index c87cde8..dcb09ff 100644
|
||||
--- a/Modules/opengl/opengl.cpp
|
||||
+++ b/Modules/opengl/opengl.cpp
|
||||
@@ -818,7 +818,7 @@ static QTreeWidgetItem *get_gl_info_egl(Display *dpy, int scrnum, QTreeWidgetIte
|
||||
return result;
|
||||
}
|
||||
|
||||
- surf = eglCreateWindowSurface(egl_dpy, config, win, NULL);
|
||||
+ surf = 0;
|
||||
if (!surf) {
|
||||
qDebug() << "Error: eglCreateWindowSurface failed\n";
|
||||
eglDestroyContext(egl_dpy, ctx);
|
Loading…
Reference in a new issue