core/linux-armv7 to 3.10.999-1

This commit is contained in:
Kevin Mihelich 2013-07-16 05:23:16 +00:00
parent 8b2f1d279e
commit 75dda030c9
3 changed files with 687 additions and 1657 deletions

View file

@ -7,41 +7,37 @@ pkgbase=linux-armv7
pkgname=('linux-armv7' 'linux-headers-armv7')
_kernelname=${pkgname#linux}
_basekernel=3.10
pkgver=${_basekernel}.0
pkgrel=2
rcnrel=armv7-x2
pkgver=${_basekernel}.999
pkgrel=1
rcnrel=armv7-d1
rcver=3.11
rcrel=rc1
arch=('armv7h')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v3.0/linux-${_basekernel}.tar.xz"
# "ftp://ftp.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.bz2"
"http://rcn-ee.net/deb/sid-armhf/v${pkgver}-${rcnrel}/patch-${_basekernel}-${rcnrel}.diff.gz"
'config'
# "ftp://ftp.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.bz2"
"ftp://ftp.kernel.org/pub/linux/kernel/v3.x/testing/patch-${rcver}-${rcrel}.xz"
"http://rcn-ee.net/deb/sid-armhf/v${rcver}.0-${rcrel}-${rcnrel}/patch-${rcver}-${rcrel}-${rcnrel}.diff.gz"
# "aufs3-${_basekernel}.patch.xz"
'change-default-console-loglevel.patch')
'config')
md5sums=('4f25cd5bec5f8d5a7d935b3f2ccb8481'
'eaedc9c5a74ffe4103cf84cc59206267'
'3fff3cb4520c85c1c88aa6e57e6c6752'
'9d3c56a4b999c8bfbd4018089a62f662')
'd790b034867145dd9c5828ed58eaac45'
'bb59d902754fd8d6b3e7770b585f5d5c'
'59b6f7d4485d0f5a653f0e796dacb996')
build() {
cd "${srcdir}/linux-${_basekernel}"
# stable patches
# patch -p1 -i "${srcdir}/patch-${pkgver}"
# git apply "${srcdir}/patch-${_basekernel}-${rcnrel}.diff"
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
# ALARM patches
git apply "${srcdir}/patch-${_basekernel}-${rcnrel}.diff"
# patch -Np1 -i "${srcdir}/aufs3-${_basekernel}.patch"
# testing patches
patch -p1 -i "${srcdir}/patch-${rcver}-${rcrel}"
git apply "${srcdir}/patch-${rcver}-${rcrel}-${rcnrel}.diff"
cat "${srcdir}/config" > ./.config

View file

@ -1,12 +0,0 @@
diff -upr linux-3.0.orig/kernel/printk.c linux-3.0/kernel/printk.c
--- linux-3.0.orig/kernel/printk.c 2011-07-22 05:17:23.000000000 +0300
+++ linux-3.0/kernel/printk.c 2011-07-27 14:43:07.000000000 +0300
@@ -58,7 +58,7 @@ void asmlinkage __attribute__((weak)) ea
/* We show everything that is MORE important than this.. */
#define MINIMUM_CONSOLE_LOGLEVEL 1 /* Minimum loglevel we let people use */
-#define DEFAULT_CONSOLE_LOGLEVEL 7 /* anything MORE serious than KERN_DEBUG */
+#define DEFAULT_CONSOLE_LOGLEVEL 4 /* anything MORE serious than KERN_DEBUG */
DECLARE_WAIT_QUEUE_HEAD(log_wait);

File diff suppressed because it is too large Load diff