mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/qt4 to 4.8.7-10
This commit is contained in:
parent
2b03e58f38
commit
75e5ce8432
2 changed files with 45 additions and 5 deletions
|
@ -12,18 +12,16 @@
|
|||
|
||||
pkgname=qt4
|
||||
pkgver=4.8.7
|
||||
pkgrel=9
|
||||
pkgrel=10
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL' 'FDL' 'custom')
|
||||
pkgdesc='A cross-platform application and UI framework'
|
||||
depends=('libtiff' 'libpng' 'sqlite' 'ca-certificates' 'dbus'
|
||||
'fontconfig' 'libgl' 'libxrandr' 'libxv' 'libxi' 'alsa-lib'
|
||||
depends=('sqlite' 'ca-certificates' 'fontconfig' 'libgl' 'libxrandr' 'libxv' 'libxi' 'alsa-lib'
|
||||
'xdg-utils' 'hicolor-icon-theme' 'desktop-file-utils' 'libmng')
|
||||
makedepends=('postgresql-libs' 'mariadb' 'unixodbc' 'cups' 'gtk2'
|
||||
'mesa')
|
||||
optdepends=('qtchooser: set the default Qt toolkit'
|
||||
'postgresql-libs: PostgreSQL driver'
|
||||
optdepends=('postgresql-libs: PostgreSQL driver'
|
||||
'libmariadbclient: MariaDB driver'
|
||||
'unixodbc: ODBC driver'
|
||||
'libxinerama: Xinerama support'
|
||||
|
@ -46,6 +44,7 @@ source=("http://download.qt.io/official_releases/qt/4.8/${pkgver}/${_pkgfqn}.tar
|
|||
'disable-sslv3.patch'
|
||||
'l-qclipboard_fix_recursive.patch'
|
||||
'l-qclipboard_delay.patch'
|
||||
'qt4-gcc6.patch'
|
||||
'qt-aarch64.patch')
|
||||
md5sums=('d990ee66bf7ab0c785589776f35ba6ad'
|
||||
'a16638f4781e56e7887ff8212a322ecc'
|
||||
|
@ -61,6 +60,7 @@ md5sums=('d990ee66bf7ab0c785589776f35ba6ad'
|
|||
'1803ab6313df762d807678e58fc85f53'
|
||||
'009de09b4e589a7770fba74405656c99'
|
||||
'addc5e88d538ee55e17bd49ba337ca67'
|
||||
'98e00c5c7e5fee12e11ecbedd03f01ff'
|
||||
'2a9572f3b758fc3ca9ff5fc40012a2a4')
|
||||
|
||||
prepare() {
|
||||
|
@ -101,11 +101,15 @@ prepare() {
|
|||
cp mkspecs/common/linux{,32}.conf
|
||||
sed -i "/^QMAKE_LIBDIR\s/s|=|= /usr/lib32|g" mkspecs/common/linux32.conf
|
||||
sed -i "s|common/linux.conf|common/linux32.conf|" mkspecs/linux-g++-32/qmake.conf
|
||||
|
||||
# Fix build with GCC6 (Fedora)
|
||||
patch -p1 -i "$srcdir"/qt4-gcc6.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
export QT4DIR="${srcdir}"/${_pkgfqn}
|
||||
export LD_LIBRARY_PATH=${QT4DIR}/lib:${LD_LIBRARY_PATH}
|
||||
export CXXFLAGS+=" -std=gnu++98" # Fix build with GCC 6
|
||||
|
||||
if [[ $CARCH == "aarch64" ]]; then
|
||||
MAKEFLAGS="-j3"
|
||||
|
|
36
extra/qt4/qt4-gcc6.patch
Normal file
36
extra/qt4/qt4-gcc6.patch
Normal file
|
@ -0,0 +1,36 @@
|
|||
diff -up qt-everywhere-opensource-src-4.8.7/configure.gcc6 qt-everywhere-opensource-src-4.8.7/configure
|
||||
--- qt-everywhere-opensource-src-4.8.7/configure.gcc6 2016-04-15 07:04:19.430268222 -0500
|
||||
+++ qt-everywhere-opensource-src-4.8.7/configure 2016-04-15 07:05:22.157568689 -0500
|
||||
@@ -7744,7 +7744,7 @@ case "$XPLATFORM" in
|
||||
*-g++*)
|
||||
# Check gcc's version
|
||||
case "$(${QMAKE_CONF_COMPILER} -dumpversion)" in
|
||||
- 5*|4*|3.4*)
|
||||
+ 8*|7*|6*|5*|4*|3.4*)
|
||||
;;
|
||||
3.3*)
|
||||
canBuildWebKit="no"
|
||||
@@ -8060,7 +8060,7 @@ g++*)
|
||||
3.*)
|
||||
COMPILER_VERSION="3.*"
|
||||
;;
|
||||
- 5*|4.*)
|
||||
+ 8*|7*|6*|5*|4.*)
|
||||
COMPILER_VERSION="4"
|
||||
;;
|
||||
*)
|
||||
diff -up qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.gcc6
|
||||
qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h
|
||||
--- qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.gcc6 2015-05-07 09:14:48.000000000 -0500
|
||||
+++ qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h 2016-04-15 07:04:19.431268227 -0500
|
||||
@@ -70,8 +70,8 @@ namespace QPatternist
|
||||
ForegroundShift = 10,
|
||||
BackgroundShift = 20,
|
||||
SpecialShift = 20,
|
||||
- ForegroundMask = ((1 << ForegroundShift) - 1) << ForegroundShift,
|
||||
- BackgroundMask = ((1 << BackgroundShift) - 1) << BackgroundShift
|
||||
+ ForegroundMask = 0x1f << ForegroundShift,
|
||||
+ BackgroundMask = 0x7 << BackgroundShift
|
||||
};
|
||||
|
||||
public:
|
Loading…
Reference in a new issue