core/gcc: neon fix

This commit is contained in:
Kevin Mihelich 2016-05-20 03:17:17 +00:00
parent b8863cb46f
commit 7615302b2f
3 changed files with 93 additions and 3 deletions

View file

@ -1,7 +1,7 @@
From 0a6763fb3a2c11d41b9b580a84ae24809db71749 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 7 Jan 2015 18:43:57 -0700
Subject: [PATCH] ARMv5: disable LDRD/STRD
Subject: [PATCH 1/2] ARMv5: disable LDRD/STRD
---
gcc/config/arm/arm.h | 2 +-

View file

@ -0,0 +1,85 @@
From 7286da3d2d19806e8a1273558fb08e094bb7ffe7 Mon Sep 17 00:00:00 2001
From: ktkachov <ktkachov@138bc75d-0d04-0410-961f-82ee72b054a4>
Date: Thu, 19 May 2016 13:43:58 +0000
Subject: [PATCH 2/2] PR target/71056: Don't use vectorized builtins when NEON
is not available
PR target/71056
* config/arm/arm-builtins.c (arm_builtin_vectorized_function): Return
NULL_TREE early if NEON is not available. Remove now redundant check
in ARM_CHECK_BUILTIN_MODE.
* gcc.target/arm/pr71056.c: New test.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@236459 138bc75d-0d04-0410-961f-82ee72b054a4
---
gcc/config/arm/arm-builtins.c | 6 +++++-
gcc/testsuite/gcc.target/arm/pr71056.c | 32 ++++++++++++++++++++++++++++++++
2 files changed, 37 insertions(+), 1 deletion(-)
create mode 100644 gcc/testsuite/gcc.target/arm/pr71056.c
diff --git a/gcc/config/arm/arm-builtins.c b/gcc/config/arm/arm-builtins.c
index 90fb40f..68b2839 100644
--- a/gcc/config/arm/arm-builtins.c
+++ b/gcc/config/arm/arm-builtins.c
@@ -2861,6 +2861,10 @@ arm_builtin_vectorized_function (unsigned int fn, tree type_out, tree type_in)
int in_n, out_n;
bool out_unsigned_p = TYPE_UNSIGNED (type_out);
+ /* Can't provide any vectorized builtins when we can't use NEON. */
+ if (!TARGET_NEON)
+ return NULL_TREE;
+
if (TREE_CODE (type_out) != VECTOR_TYPE
|| TREE_CODE (type_in) != VECTOR_TYPE)
return NULL_TREE;
@@ -2875,7 +2879,7 @@ arm_builtin_vectorized_function (unsigned int fn, tree type_out, tree type_in)
NULL_TREE is returned if no such builtin is available. */
#undef ARM_CHECK_BUILTIN_MODE
#define ARM_CHECK_BUILTIN_MODE(C) \
- (TARGET_NEON && TARGET_FPU_ARMV8 \
+ (TARGET_FPU_ARMV8 \
&& flag_unsafe_math_optimizations \
&& ARM_CHECK_BUILTIN_MODE_1 (C))
diff --git a/gcc/testsuite/gcc.target/arm/pr71056.c b/gcc/testsuite/gcc.target/arm/pr71056.c
new file mode 100644
index 0000000..136754e
--- /dev/null
+++ b/gcc/testsuite/gcc.target/arm/pr71056.c
@@ -0,0 +1,32 @@
+/* PR target/71056. */
+/* { dg-do compile } */
+/* { dg-require-effective-target arm_vfp3_ok } */
+/* { dg-options "-O3 -mfpu=vfpv3" } */
+
+/* Check that compiling for a non-NEON target doesn't try to introduce
+ a NEON vectorized builtin. */
+
+extern char *buff;
+int f2 ();
+struct T1
+{
+ int reserved[2];
+ unsigned int ip;
+ unsigned short cs;
+ unsigned short rsrv2;
+};
+void
+f3 (const char *p)
+{
+ struct T1 x;
+ __builtin_memcpy (&x, p, sizeof (struct T1));
+ x.reserved[0] = __builtin_bswap32 (x.reserved[0]);
+ x.reserved[1] = __builtin_bswap32 (x.reserved[1]);
+ x.ip = __builtin_bswap32 (x.ip);
+ x.cs = x.cs << 8 | x.cs >> 8;
+ x.rsrv2 = x.rsrv2 << 8 | x.rsrv2 >> 8;
+ if (f2 ())
+ {
+ __builtin_memcpy (buff, "\n", 1);
+ }
+}
--
2.7.2

View file

@ -30,10 +30,12 @@ checkdepends=('dejagnu' 'inetutils')
options=('!emptydirs' '!distcc')
source=(https://github.com/gcc-mirror/gcc/archive/${_commit}.tar.gz
http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
0001-ARMv5-disable-LDRD-STRD.patch)
0001-ARMv5-disable-LDRD-STRD.patch
0002-PR-target-71056-Don-t-use-vectorized-builtins-when-N.patch)
md5sums=('405eea1379f597d9876e33636c9cb6c7'
'ac1f25a0677912952718a51f5bc20f32'
'd1edb21866a5215b0a5d16083c93a157')
'ca6e64ae2d104e1c2bece200ed015843'
'fad1bba965c4fd341eb027950d35111d')
_libdir="usr/lib/gcc/$CHOST/$pkgver"
@ -63,6 +65,9 @@ prepare() {
# Disable LDRD/STRD on ARMv5 (64-bit alignment issues)
patch -p1 -i ../0001-ARMv5-disable-LDRD-STRD.patch
# Fix for NEON assembly being emitted when NEON is not used
patch -p1 -i ../0002-PR-target-71056-Don-t-use-vectorized-builtins-when-N.patch
}
build() {