removed extra/avogadro

This commit is contained in:
Kevin Mihelich 2016-06-18 18:01:02 +00:00
parent 2440c6b571
commit 76407a90b2
2 changed files with 0 additions and 108 deletions

View file

@ -1,48 +0,0 @@
# $Id$
# Maintainer:
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Nick B <Shirakawasuna at gmail _dot_com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix FTBFS on ARM
pkgname=avogadro
pkgver=1.1.1
pkgrel=9
pkgdesc="An advanced molecular editor based on Qt"
arch=('i686' 'x86_64')
url="http://avogadro.openmolecules.net/wiki/Main_Page"
license=('GPL2')
depends=('openbabel' 'python2-pyqt4' 'boost-libs' 'glew' 'python2-numpy')
makedepends=('cmake' 'boost' 'doxygen' 'mesa-libgl' 'eigen2')
source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
'boost153.patch'
'https://github.com/cryos/avogadro/commit/6f1a111bab5798a4289187bdf747c3be4e176534.patch')
md5sums=('1223bb18f50dccd2c60538aa90d58c7a'
'aa2573f78d5dbd85b3cb79e08acde8ab'
'eac1985ccd6ea8d6549b451ee0f68c45')
prepare() {
mkdir build
cd ${pkgname}-${pkgver}
patch -p1 -i "${srcdir}"/boost153.patch
patch -p1 -i ../6f1a111bab5798a4289187bdf747c3be4e176534.patch
}
build() {
cd build
export CXXFLAGS="$CXXFLAGS -lX11 -lopenbabel"
cmake ../${pkgname}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-DQT_MKSPECS_RELATIVE=share/qt4/mkspecs
make
}
package() {
cd build
make DESTDIR="${pkgdir}" install
}

View file

@ -1,60 +0,0 @@
--- avogadro-1.1.0/libavogadro/src/pythonengine_p.h~ 2013-03-29 12:46:16.306165881 +0000
+++ avogadro-1.1.0/libavogadro/src/pythonengine_p.h 2013-03-29 12:45:43.123089622 +0000
@@ -27,7 +27,9 @@
#include <avogadro/global.h>
#include <avogadro/engine.h>
+#ifndef Q_MOC_RUN
#include <boost/python.hpp>
+#endif
namespace Avogadro {
--- avogadro-1.1.0/libavogadro/src/pythonextension_p.h~ 2013-03-29 12:46:32.156043085 +0000
+++ avogadro-1.1.0/libavogadro/src/pythonextension_p.h 2013-03-29 12:47:07.265771087 +0000
@@ -29,7 +29,9 @@
#include <avogadro/extension.h>
#include <avogadro/primitive.h>
#include <avogadro/glwidget.h>
+#ifndef Q_MOC_RUN
#include <boost/python.hpp>
+#endif
#include <QWidget>
#include <QList>
--- avogadro-1.1.0/libavogadro/src/pythontool_p.h~ 2013-03-29 12:47:33.335569185 +0000
+++ avogadro-1.1.0/libavogadro/src/pythontool_p.h 2013-03-29 12:47:50.732101147 +0000
@@ -27,7 +27,9 @@
#include <avogadro/global.h>
#include <avogadro/tool.h>
+#ifndef Q_MOC_RUN
#include <boost/python.hpp>
+#endif
#include <QObject>
#include <QAction>
--- avogadro-1.1.0/libavogadro/src/pythoninterpreter.h~ 2013-03-29 12:50:46.550738652 +0000
+++ avogadro-1.1.0/libavogadro/src/pythoninterpreter.h 2013-03-29 12:51:00.853961341 +0000
@@ -26,7 +26,9 @@
#define PYTHONINTERPRETER_H
#include <avogadro/global.h>
+#ifndef Q_MOC_RUN
#include <boost/python.hpp>
+#endif
#include <avogadro/primitive.h>
#include <QString>
--- avogadro-1.1.0/libavogadro/src/pythonscript.h~ 2013-03-29 12:52:00.723488935 +0000
+++ avogadro-1.1.0/libavogadro/src/pythonscript.h 2013-03-29 12:52:11.676745364 +0000
@@ -27,7 +27,9 @@
#define PYTHONSCRIPT_H
#include <avogadro/global.h>
+#ifndef Q_MOC_RUN
#include <boost/python.hpp>
+#endif
#include "pythonerror.h"