alarm/omxplayer-git to 504.12b472e-1

This commit is contained in:
Kevin Mihelich 2016-10-11 00:51:16 +00:00
parent 6550657d48
commit 764ee62a28
2 changed files with 11 additions and 11 deletions

View file

@ -1,4 +1,4 @@
From 7f9fbea4929df87d96878d5899f2e4b017fc9fa8 Mon Sep 17 00:00:00 2001
From f8fbb3661bbb1861fab47b73e574378bfeb4c08a Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 24 Sep 2014 08:47:14 -0600
Subject: [PATCH] alarm fixes
@ -10,22 +10,22 @@ Subject: [PATCH] alarm fixes
3 files changed, 16 insertions(+), 62 deletions(-)
diff --git a/Makefile b/Makefile
index bcfadfb..3e6a994 100644
index 2857e94..2638e07 100644
--- a/Makefile
+++ b/Makefile
@@ -2,9 +2,9 @@ include Makefile.include
CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
-LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
+LDFLAGS+=-L./ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
-LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
+LDFLAGS+=-L./ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include
+INCLUDES+=-I./ -Ilinux
DIST ?= omxplayer-dist
@@ -39,7 +39,7 @@ SRC=linux/XMemUtils.cpp \
@@ -40,7 +40,7 @@ SRC= linux/XMemUtils.cpp \
OBJS+=$(filter %.o,$(SRC:.cpp=.o))
@ -34,7 +34,7 @@ index bcfadfb..3e6a994 100644
%.o: %.cpp
@rm -f $@
@@ -51,7 +51,7 @@ version:
@@ -52,7 +52,7 @@ version:
bash gen_version.sh > version.h
omxplayer.bin: version $(OBJS)
@ -43,7 +43,7 @@ index bcfadfb..3e6a994 100644
$(STRIP) omxplayer.bin
help.h: README.md Makefile
@@ -74,19 +74,9 @@ clean:
@@ -75,19 +75,9 @@ clean:
@rm -rf $(DIST)
@rm -f omxplayer-dist.tar.gz
@ -119,7 +119,7 @@ index 58e9560..4789f10 100644
+LDFLAGS += -L/opt/vc/lib/
+INCLUDES += -I/opt/vc/include -I/opt/vc/include/interface/vmcs_host/linux -I/opt/vc/include/interface/vcos/pthreads -I/usr/include/freetype2 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include
diff --git a/omxplayer.cpp b/omxplayer.cpp
index 5c03171..d3b4abc 100644
index 428ccb6..6005439 100644
--- a/omxplayer.cpp
+++ b/omxplayer.cpp
@@ -83,8 +83,8 @@ bool m_osd = true;
@ -134,5 +134,5 @@ index 5c03171..d3b4abc 100644
bool m_asked_for_font = false;
bool m_asked_for_italic_font = false;
--
2.8.2
2.10.0

View file

@ -5,7 +5,7 @@
buildarch=20
pkgname=omxplayer-git
pkgver=494.791d7df
pkgver=504.12b472e
pkgrel=1
pkgdesc="omxplayer is a command line media player for the RaspberryPi"
arch=('armv6h' 'armv7h')
@ -19,7 +19,7 @@ conflicts=('omxplayer' 'omxplayer-bin')
source=('git://github.com/popcornmix/omxplayer.git'
'0001-alarm-fixes.patch')
md5sums=('SKIP'
'9950f307ba9921feb75ad25cf35a7d39')
'747cab115c7820ed6107925c63a5383b')
pkgver() {
cd omxplayer