mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
core/pacman to 5.0.2-3
This commit is contained in:
parent
bb36944608
commit
76553bdb8d
2 changed files with 45 additions and 2 deletions
|
@ -0,0 +1,38 @@
|
||||||
|
From c6ffa8bb3eea231c36dab87e6051c04b16e8c0e6 Mon Sep 17 00:00:00 2001
|
||||||
|
Message-Id: <c6ffa8bb3eea231c36dab87e6051c04b16e8c0e6.1524246116.git.jan.steffens@gmail.com>
|
||||||
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||||
|
Date: Fri, 20 Apr 2018 19:25:55 +0200
|
||||||
|
Subject: [PATCH] libmakepkg: Support file 5.33's application/x-pie-executable
|
||||||
|
|
||||||
|
file 5.33 introduces a new MIME type "application/x-pie-executable",
|
||||||
|
which is used for relocatable binaries. makepkg ignored these binaries
|
||||||
|
and did not attempt to strip them.
|
||||||
|
|
||||||
|
Handle the new MIME type like the old "application/x-sharedlib".
|
||||||
|
Stripping the binaries with --strip-unneeded to keep relocation
|
||||||
|
information should be the correct thing to do.
|
||||||
|
|
||||||
|
file 5.33 also misidentifies actual libraries as PIE executables, so we
|
||||||
|
didn't strip any shared libraries, either. We now work around this bug.
|
||||||
|
|
||||||
|
Signed-off-by: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||||
|
---
|
||||||
|
scripts/libmakepkg/tidy/strip.sh.in | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/scripts/libmakepkg/tidy/strip.sh.in b/scripts/libmakepkg/tidy/strip.sh.in
|
||||||
|
index e20114c0..36d1b89e 100644
|
||||||
|
--- a/scripts/libmakepkg/tidy/strip.sh.in
|
||||||
|
+++ b/scripts/libmakepkg/tidy/strip.sh.in
|
||||||
|
@@ -125,6 +125,8 @@ tidy_strip() {
|
||||||
|
esac;;
|
||||||
|
*application/x-executable*) # Binaries
|
||||||
|
strip_flags="$STRIP_BINARIES";;
|
||||||
|
+ *application/x-pie-executable*) # Relocatable binaries
|
||||||
|
+ strip_flags="$STRIP_SHARED";;
|
||||||
|
*)
|
||||||
|
continue ;;
|
||||||
|
esac
|
||||||
|
--
|
||||||
|
2.17.0
|
||||||
|
|
|
@ -12,9 +12,9 @@
|
||||||
|
|
||||||
pkgname=pacman
|
pkgname=pacman
|
||||||
pkgver=5.0.2
|
pkgver=5.0.2
|
||||||
pkgrel=2.1
|
pkgrel=3
|
||||||
pkgdesc="A library-based package manager with dependency support"
|
pkgdesc="A library-based package manager with dependency support"
|
||||||
arch=('i686' 'x86_64')
|
arch=('x86_64')
|
||||||
url="http://www.archlinux.org/pacman/"
|
url="http://www.archlinux.org/pacman/"
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
groups=('base' 'base-devel')
|
groups=('base' 'base-devel')
|
||||||
|
@ -31,6 +31,7 @@ options=('strip' 'debug')
|
||||||
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
|
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
|
||||||
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
|
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
|
||||||
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
|
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
|
||||||
|
0001-libmakepkg-Support-file-5.33-s-application-x-pie-exe.patch
|
||||||
0001-Sychronize-filesystem.patch
|
0001-Sychronize-filesystem.patch
|
||||||
0002-Revert-close-stdin-before-running-install-scripts.patch
|
0002-Revert-close-stdin-before-running-install-scripts.patch
|
||||||
0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
|
0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
|
||||||
|
@ -38,6 +39,7 @@ source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig
|
||||||
makepkg.conf)
|
makepkg.conf)
|
||||||
sha256sums=('dfd36086ad68564bcd977f4a1fafe51dd328acd4a95093ac4bf1249be9c41f0e'
|
sha256sums=('dfd36086ad68564bcd977f4a1fafe51dd328acd4a95093ac4bf1249be9c41f0e'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
|
'78129351e96d19e14b05bda30480df3e834a96153b7cfe72ca5c91f5cc5cae40'
|
||||||
'5b81731c07945db05011db153cced5294187f16e487ca2fa221bb50aa4a18dc7'
|
'5b81731c07945db05011db153cced5294187f16e487ca2fa221bb50aa4a18dc7'
|
||||||
'47b3583d093a9d5305f52f402f103fc5584c986a0272acbd36acfc96a9f01147'
|
'47b3583d093a9d5305f52f402f103fc5584c986a0272acbd36acfc96a9f01147'
|
||||||
'c8610fbae271167c2a1ae0bf69692038eac24f13921cabf925855a8697ea82f9'
|
'c8610fbae271167c2a1ae0bf69692038eac24f13921cabf925855a8697ea82f9'
|
||||||
|
@ -47,6 +49,9 @@ sha256sums=('dfd36086ad68564bcd977f4a1fafe51dd328acd4a95093ac4bf1249be9c41f0e'
|
||||||
prepare() {
|
prepare() {
|
||||||
cd $srcdir/$pkgname-$pkgver
|
cd $srcdir/$pkgname-$pkgver
|
||||||
|
|
||||||
|
# Fix up makepkg stripping with file 5.33
|
||||||
|
patch -Np1 -i ../0001-libmakepkg-Support-file-5.33-s-application-x-pie-exe.patch
|
||||||
|
|
||||||
patch -p1 -i ../0001-Sychronize-filesystem.patch
|
patch -p1 -i ../0001-Sychronize-filesystem.patch
|
||||||
patch -p1 -i ../0002-Revert-close-stdin-before-running-install-scripts.patch
|
patch -p1 -i ../0002-Revert-close-stdin-before-running-install-scripts.patch
|
||||||
patch -p1 -i ../0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
|
patch -p1 -i ../0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
|
||||||
|
|
Loading…
Reference in a new issue