mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
removed community/gpac
This commit is contained in:
parent
b3c903d289
commit
7655714d6a
3 changed files with 0 additions and 114 deletions
|
@ -1,61 +0,0 @@
|
||||||
# Maintainer: Eric Bélanger <eric@archlinux.org>
|
|
||||||
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
|
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
# - use PIC with AArch64
|
|
||||||
|
|
||||||
pkgname=gpac
|
|
||||||
pkgver=0.8.0
|
|
||||||
pkgrel=2
|
|
||||||
epoch=1
|
|
||||||
pkgdesc='A multimedia framework based on the MPEG-4 Systems standard'
|
|
||||||
arch=(x86_64)
|
|
||||||
url=https://gpac.wp.imt.fr/
|
|
||||||
license=(LGPL)
|
|
||||||
depends=(
|
|
||||||
ffmpeg
|
|
||||||
glu
|
|
||||||
libxv
|
|
||||||
)
|
|
||||||
makedepends=(
|
|
||||||
git
|
|
||||||
jack
|
|
||||||
a52dec
|
|
||||||
freetype2
|
|
||||||
faad2
|
|
||||||
libmad
|
|
||||||
mesa
|
|
||||||
sdl2
|
|
||||||
)
|
|
||||||
optdepends=(
|
|
||||||
'jack: for jack support'
|
|
||||||
'a52dec: for A52 support'
|
|
||||||
'faad2: for AAC support'
|
|
||||||
'libmad: for mp3 support'
|
|
||||||
'sdl2: for sdl support'
|
|
||||||
)
|
|
||||||
provides=(libgpac.so)
|
|
||||||
options=(staticlibs)
|
|
||||||
source=(git+https://github.com/gpac/gpac.git#tag=v${pkgver})
|
|
||||||
sha256sums=('SKIP')
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd gpac
|
|
||||||
|
|
||||||
[[ $CARCH == 'aarch64' ]] && CONFIG='--enable-pic'
|
|
||||||
|
|
||||||
./configure \
|
|
||||||
--prefix=/usr \
|
|
||||||
--mandir=/usr/share/man \
|
|
||||||
--X11-path=/usr \
|
|
||||||
--use-js=no $CONFIG
|
|
||||||
make
|
|
||||||
}
|
|
||||||
|
|
||||||
package() {
|
|
||||||
cd gpac
|
|
||||||
|
|
||||||
make DESTDIR="${pkgdir}" STRIP=true install install-lib
|
|
||||||
}
|
|
||||||
|
|
||||||
# vim: ts=2 sw=2 et:
|
|
|
@ -1,42 +0,0 @@
|
||||||
diff -rupN gpac-0.7.1.orig/applications/dashcast/video_encoder.c gpac-0.7.1/applications/dashcast/video_encoder.c
|
|
||||||
--- gpac-0.7.1.orig/applications/dashcast/video_encoder.c 2018-04-26 09:19:52.938118328 +0200
|
|
||||||
+++ gpac-0.7.1/applications/dashcast/video_encoder.c 2018-04-26 09:20:03.165170164 +0200
|
|
||||||
@@ -144,7 +144,7 @@ int dc_video_encoder_open(VideoOutputFil
|
|
||||||
}
|
|
||||||
|
|
||||||
//the global header gives access to the extradata (SPS/PPS)
|
|
||||||
- video_output_file->codec_ctx->flags |= CODEC_FLAG_GLOBAL_HEADER;
|
|
||||||
+ video_output_file->codec_ctx->flags |= AV_CODEC_FLAG_GLOBAL_HEADER;
|
|
||||||
|
|
||||||
video_output_file->vstream_idx = 0;//video_stream->index;
|
|
||||||
|
|
||||||
diff -rupN gpac-0.7.1.orig/modules/ffmpeg_in/ffmpeg_decode.c gpac-0.7.1/modules/ffmpeg_in/ffmpeg_decode.c
|
|
||||||
--- gpac-0.7.1.orig/modules/ffmpeg_in/ffmpeg_decode.c 2018-04-26 09:19:53.034788555 +0200
|
|
||||||
+++ gpac-0.7.1/modules/ffmpeg_in/ffmpeg_decode.c 2018-04-26 09:30:09.739463486 +0200
|
|
||||||
@@ -49,7 +49,7 @@
|
|
||||||
static uint8_t * ffmpeg_realloc_buffer(uint8_t * oldBuffer, u32 size) {
|
|
||||||
uint8_t * buffer;
|
|
||||||
/* Size of buffer must be larger, see avcodec_decode_video2 documentation */
|
|
||||||
- u32 allocatedSz = sizeof( char ) * (FF_INPUT_BUFFER_PADDING_SIZE + size);
|
|
||||||
+ u32 allocatedSz = sizeof( char ) * (AV_INPUT_BUFFER_PADDING_SIZE + size);
|
|
||||||
if (oldBuffer)
|
|
||||||
gf_free(oldBuffer);
|
|
||||||
buffer = (uint8_t*)gf_malloc( allocatedSz );
|
|
||||||
@@ -577,7 +577,7 @@ static GF_Err FFDEC_GetCapabilities(GF_B
|
|
||||||
capability->cap.valueInt = 1;
|
|
||||||
return GF_OK;
|
|
||||||
case GF_CODEC_PADDING_BYTES:
|
|
||||||
- capability->cap.valueInt = FF_INPUT_BUFFER_PADDING_SIZE;
|
|
||||||
+ capability->cap.valueInt = AV_INPUT_BUFFER_PADDING_SIZE;
|
|
||||||
return GF_OK;
|
|
||||||
case GF_CODEC_REORDER:
|
|
||||||
capability->cap.valueInt = 1;
|
|
||||||
@@ -669,7 +669,7 @@ static GF_Err FFDEC_GetCapabilities(GF_B
|
|
||||||
break;
|
|
||||||
|
|
||||||
case GF_CODEC_PADDING_BYTES:
|
|
||||||
- capability->cap.valueInt = FF_INPUT_BUFFER_PADDING_SIZE;
|
|
||||||
+ capability->cap.valueInt = AV_INPUT_BUFFER_PADDING_SIZE;
|
|
||||||
break;
|
|
||||||
default:
|
|
||||||
capability->cap.valueInt = 0;
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/src/utils/downloader.c
|
|
||||||
+++ b/src/utils/downloader.c
|
|
||||||
@@ -391,7 +391,6 @@
|
|
||||||
}
|
|
||||||
SSL_library_init();
|
|
||||||
SSL_load_error_strings();
|
|
||||||
- SSLeay_add_all_algorithms();
|
|
||||||
SSLeay_add_ssl_algorithms();
|
|
||||||
_ssl_is_initialized = GF_TRUE;
|
|
||||||
GF_LOG(GF_LOG_DEBUG, GF_LOG_NETWORK, ("[HTTPS] Initalization of SSL library complete.\n"));
|
|
||||||
|
|
Loading…
Reference in a new issue