mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/mariadb to 10.1.29-1
This commit is contained in:
parent
3494bd43d0
commit
769b41d9a0
2 changed files with 65 additions and 6 deletions
|
@ -0,0 +1,53 @@
|
|||
From 8b18a44fa7e5ddf6c8caee37de4f6112c64dfc87 Mon Sep 17 00:00:00 2001
|
||||
From: Sergei Golubchik <serg@mariadb.org>
|
||||
Date: Mon, 13 Nov 2017 13:11:53 +0800
|
||||
Subject: [PATCH] mroonga after-merge CMakeLists.txt fixes
|
||||
|
||||
1. remove erroneously committed *.orig
|
||||
2. fix LZ4 detection on Mac OS X and FreeBSD. Cannot do
|
||||
|
||||
pkg_check_modules(LIBLZ4 liblz4)
|
||||
find_library(LIBLZ4_LIBS ... )
|
||||
|
||||
because find_library(X) does not do anything if X is defined (documented),
|
||||
and pkg_check_modules(Y) sets Y_LIBS to "" (undocumented!)
|
||||
---
|
||||
storage/mroonga/vendor/groonga/CMakeLists.txt | 4 +-
|
||||
storage/mroonga/vendor/groonga/lib/CMakeLists.txt | 2 +-
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
delete mode 100644 storage/mroonga/CMakeLists.txt.orig
|
||||
delete mode 100644 storage/mroonga/vendor/groonga/CMakeLists.txt.orig
|
||||
|
||||
diff --git a/storage/mroonga/vendor/groonga/CMakeLists.txt b/storage/mroonga/vendor/groonga/CMakeLists.txt
|
||||
index 3d957c9d5152..e27070f9e0c3 100644
|
||||
--- a/storage/mroonga/vendor/groonga/CMakeLists.txt
|
||||
+++ b/storage/mroonga/vendor/groonga/CMakeLists.txt
|
||||
@@ -355,13 +355,13 @@ if(NOT ${GRN_WITH_LZ4} STREQUAL "no")
|
||||
if(GRN_WITH_BUNDLED_LZ4)
|
||||
set(LIBLZ4_INCLUDE_DIRS
|
||||
"${CMAKE_CURRENT_SOURCE_DIR}/vendor/lz4-${GRN_BUNDLED_LZ4_VERSION}/lib")
|
||||
- set(LIBLZ4_LIBS liblz4)
|
||||
+ set(LZ4_LIBS liblz4)
|
||||
else()
|
||||
if(NOT DEFINED LIBLZ4_FOUND)
|
||||
pkg_check_modules(LIBLZ4 liblz4)
|
||||
endif()
|
||||
if(LIBLZ4_FOUND)
|
||||
- find_library(LIBLZ4_LIBS
|
||||
+ find_library(LZ4_LIBS
|
||||
NAMES ${LIBLZ4_LIBRARIES}
|
||||
PATHS ${LIBLZ4_LIBRARY_DIRS}
|
||||
NO_DEFAULT_PATH)
|
||||
diff --git a/storage/mroonga/vendor/groonga/lib/CMakeLists.txt b/storage/mroonga/vendor/groonga/lib/CMakeLists.txt
|
||||
index a90cea0043eb..6765261feb7d 100644
|
||||
--- a/storage/mroonga/vendor/groonga/lib/CMakeLists.txt
|
||||
+++ b/storage/mroonga/vendor/groonga/lib/CMakeLists.txt
|
||||
@@ -94,7 +94,7 @@ set(GRN_ALL_LIBRARIES
|
||||
${RT_LIBS}
|
||||
${PTHREAD_LIBS}
|
||||
${Z_LIBS}
|
||||
- ${LIBLZ4_LIBS}
|
||||
+ ${LZ4_LIBS}
|
||||
${LIBZSTD_LIBS}
|
||||
${MESSAGE_PACK_LIBS}
|
||||
${DL_LIBS}
|
|
@ -8,22 +8,24 @@
|
|||
|
||||
pkgbase=mariadb
|
||||
pkgname=('libmariadbclient' 'mariadb-clients' 'mytop' 'mariadb')
|
||||
pkgver=10.1.28
|
||||
pkgver=10.1.29
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL')
|
||||
url='http://mariadb.org/'
|
||||
makedepends=('cmake' 'zlib' 'libaio' 'libxml2' 'openssl' 'pcre' 'jemalloc'
|
||||
makedepends=('cmake' 'zlib' 'libaio' 'libxml2' 'openssl' 'jemalloc'
|
||||
'lz4' 'boost' 'libevent' 'systemd')
|
||||
validpgpkeys=('199369E5404BD5FC7D2FE43BCBCB082A1BB943DB') # MariaDB Package Signing Key <package-signing-key@mariadb.org>
|
||||
source=("https://ftp.heanet.ie/mirrors/mariadb/mariadb-$pkgver/source/mariadb-$pkgver.tar.gz"{,.asc}
|
||||
'0001-openssl-1-1-0.patch'
|
||||
'0002-mroonga-after-merge-CMakeLists.txt-fixes.patch'
|
||||
'atomic.patch'
|
||||
'mariadb-sysusers.conf'
|
||||
'mariadb-tmpfile.conf')
|
||||
sha256sums=('292dc8fff420c4bdaf3a2c3381ec3c99292965db2b09de0d7fec414c00032bbd'
|
||||
sha256sums=('73bbd5602f52ab5aa4d83f465134871b6c87bda25371d098f6da5a3d98517ed4'
|
||||
'SKIP'
|
||||
'40d298ca77c0459ade4ef9fc68a3a7450273b098b9f7edfb0a5251c5db434cfc'
|
||||
'98736aefef21e575e450f8066685ba82771264409412e33491ab0a54e4407ba7'
|
||||
'2ddfe7dc5eae905ed77d7438d6869f9bb26684945c2f82cc19f84926b1cb849f'
|
||||
'e1a22777c65854041f16fc0a2db3218d17b4d7e7ec7ab7a77cf49c71277c1515'
|
||||
'2af318c52ae0fe5428e8a9245d1b0fc3bc5ce153842d1563329ceb1edfa83ddd')
|
||||
|
@ -41,6 +43,10 @@ prepare() {
|
|||
# openssl 1.1.0
|
||||
patch -Np1 < "${srcdir}"/0001-openssl-1-1-0.patch
|
||||
|
||||
# revert to fix the build
|
||||
# mroonga after-merge CMakeLists.txt fixes
|
||||
patch -Np1 -R < "${srcdir}"/0002-mroonga-after-merge-CMakeLists.txt-fixes.patch
|
||||
|
||||
if [[ $CARCH == arm || $CARCH == armv6h ]]; then
|
||||
patch -p0 -i ../atomic.patch
|
||||
fi
|
||||
|
@ -76,7 +82,7 @@ build() {
|
|||
-DWITH_READLINE=ON \
|
||||
-DWITH_ZLIB=system \
|
||||
-DWITH_SSL=system \
|
||||
-DWITH_PCRE=system \
|
||||
-DWITH_PCRE=bundled \
|
||||
-DWITH_LIBWRAP=OFF \
|
||||
-DWITH_JEMALLOC=ON \
|
||||
-DWITH_EXTRA_CHARSETS=complex \
|
||||
|
@ -100,7 +106,7 @@ build() {
|
|||
|
||||
package_libmariadbclient() {
|
||||
pkgdesc='MariaDB client libraries'
|
||||
depends=('openssl' 'libaio' 'zlib' 'pcre' 'lz4' 'lzo' 'xz')
|
||||
depends=('openssl' 'libaio' 'zlib' 'lz4' 'lzo' 'xz')
|
||||
conflicts=('libmysqlclient')
|
||||
|
||||
cd build
|
||||
|
@ -149,7 +155,7 @@ package_mariadb() {
|
|||
backup=('etc/mysql/my.cnf'
|
||||
'etc/mysql/wsrep.cnf')
|
||||
install=mariadb.install
|
||||
depends=("mariadb-clients=${pkgver}" 'inetutils' 'libaio' 'libxml2' 'pcre' 'jemalloc'
|
||||
depends=("mariadb-clients=${pkgver}" 'inetutils' 'libaio' 'libxml2' 'jemalloc'
|
||||
'lz4' 'boost-libs' 'lzo' 'libevent' 'libsystemd')
|
||||
optdepends=('galera: for MariaDB cluster with Galera WSREP'
|
||||
'perl-dbd-mysql: for mysqlhotcopy, mysql_convert_table_format and mysql_setpermission')
|
||||
|
|
Loading…
Reference in a new issue