mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/vlc to 3.0.18-1
This commit is contained in:
parent
230686bfc0
commit
76b3d2fbce
4 changed files with 114 additions and 152 deletions
|
@ -7,11 +7,11 @@
|
|||
# - enable gles2
|
||||
|
||||
pkgname=vlc
|
||||
_vlcver=3.0.17.4
|
||||
_vlcver=3.0.18
|
||||
# optional fixup version including hyphen
|
||||
_vlcfixupver=
|
||||
pkgver=${_vlcver}${_vlcfixupver//-/.r}
|
||||
pkgrel=11
|
||||
pkgrel=1
|
||||
pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player'
|
||||
url='https://www.videolan.org/vlc/'
|
||||
arch=('x86_64')
|
||||
|
@ -104,16 +104,14 @@ conflicts=('vlc-plugin')
|
|||
replaces=('vlc-plugin')
|
||||
options=('debug' '!emptydirs')
|
||||
source=(https://download.videolan.org/${pkgname}/${_vlcver}/${pkgname}-${_vlcver}${_vlcfixupver}.tar.xz{,.asc}
|
||||
$pkgname-dav1d-1.0.patch::https://github.com/videolan/vlc/commit/2202c892c8dc.patch
|
||||
libplacebo-5.patch
|
||||
update-vlc-plugin-cache.hook
|
||||
caca-fix-to-newer-version.patch
|
||||
vlc-live-media-2021.patch)
|
||||
sha512sums=('dac14c6586603c064294672eb878253e52b3a7bef431fb10303345e5400591b5c1f2d452a2af03f503db0ca186582a84be06fdf05ab011c33f7b0bd5389c51fb'
|
||||
sha512sums=('6fc8fdaa7e8862ad7133d69b3dab99ab9cd3945846a6ce5e2379b7f68ee9accd385c53b8573fc7c82f732c24678b4932b1154d2ad8accf06305f2f578d6fcd8e'
|
||||
'SKIP'
|
||||
'5f7aa43a7b248812758a8ef82d15d59fb566327fc3e837002a8f4741cabde09ed7caca905f6fe168554b9a4b7561816b3eff877f4dd6664ceaf0964281facb4f'
|
||||
'a06b04a8b059dbbef77d27435bd5bec3c26f937390bd112b0843385587e866e617c3dd0e66f99eed5fa4a91bc5f0fd9b5623f65b2f2435a54456dde2aa96209b'
|
||||
'b247510ffeadfd439a5dadd170c91900b6cdb05b5ca00d38b1a17c720ffe5a9f75a32e0cb1af5ebefdf1c23c5acc53513ed983a736e8fa30dd8fad237ef49dd3'
|
||||
'ef479a246dc98f882a05ca56a1c2872cc67ced154c625790070b887858ddc250d55b1295db82c9122e5ecd3c2c9c712ec9718e28d0a9d21ff6a230eb6c5010ce'
|
||||
'ad17d6f4f2cc83841c1c89623c339ec3ee94f6084ea980e2c8cbc3903854c85e5396e31bfd8dc90745b41794670903d854c4d282d8adec263087a9d47b226ccc')
|
||||
'322461cb5e89e4828483dd0a5c6595f99e767885ae9a1aa2e4d0514ac7354f2ee93b3e5c80993dcff7cd218d7af210374724337b3fc8bc196d35ef5e2b41695d')
|
||||
validpgpkeys=('65F7C6B4206BD057A7EB73787180713BE58D1ADC') # VideoLAN Release Signing Key
|
||||
|
||||
prepare() {
|
||||
|
|
|
@ -1,130 +0,0 @@
|
|||
From 900318072a7ebce28745aa3863e1364b7258baff Mon Sep 17 00:00:00 2001
|
||||
From: Alexandre Janniaux <ajanni@videolabs.io>
|
||||
Date: Wed, 10 Nov 2021 15:37:52 +0100
|
||||
Subject: [PATCH] caca: fix to newer version
|
||||
|
||||
Migrate to the new API instead of libcucul API, which has been merged
|
||||
into libcaca since 0.99.beta15:
|
||||
|
||||
commit f61816ceb7445f8bf818936151554ac060764b39
|
||||
Author: Sam Hocevar <sam@hocevar.net>
|
||||
Date: Sat Sep 27 13:12:46 2008 +0000
|
||||
|
||||
Starting refactoring to get rid of libcucul. The initial reason for the
|
||||
split is rendered moot by the plugin system: when enabled, binaries do
|
||||
not link directly with libX11 or libGL. I hope this is a step towards
|
||||
more consisteny and clarity.
|
||||
|
||||
It was then completely wiped out by the following commit, which is part
|
||||
of v0.99.beta20:
|
||||
|
||||
commit 5f0ec215f8c9915ed028324a8ecac8212f68e18d
|
||||
Author: Sam Hocevar <sam@hocevar.net>
|
||||
Date: Thu May 3 10:33:30 2018 +0200
|
||||
|
||||
Remove legacy code from 10 years ago.
|
||||
|
||||
(cherry picked from commit d35391caa03c046149e7fe2497f51bf59ed8551d)
|
||||
---
|
||||
modules/video_output/caca.c | 30 +++++++++++++++---------------
|
||||
1 file changed, 15 insertions(+), 15 deletions(-)
|
||||
|
||||
diff --git a/modules/video_output/caca.c b/modules/video_output/caca.c
|
||||
index 33a0409820..a2e922a864 100644
|
||||
--- a/modules/video_output/caca.c
|
||||
+++ b/modules/video_output/caca.c
|
||||
@@ -74,9 +74,9 @@ static void Place(vout_display_t *, vout_display_place_t *);
|
||||
|
||||
/* */
|
||||
struct vout_display_sys_t {
|
||||
- cucul_canvas_t *cv;
|
||||
+ caca_canvas_t *cv;
|
||||
caca_display_t *dp;
|
||||
- cucul_dither_t *dither;
|
||||
+ caca_dither_t *dither;
|
||||
|
||||
picture_pool_t *pool;
|
||||
vout_display_event_thread_t *et;
|
||||
@@ -153,9 +153,9 @@ static int Open(vlc_object_t *object)
|
||||
if (!sys)
|
||||
goto error;
|
||||
|
||||
- sys->cv = cucul_create_canvas(0, 0);
|
||||
+ sys->cv = caca_create_canvas(0, 0);
|
||||
if (!sys->cv) {
|
||||
- msg_Err(vd, "cannot initialize libcucul");
|
||||
+ msg_Err(vd, "cannot initialize libcaca");
|
||||
goto error;
|
||||
}
|
||||
|
||||
@@ -209,11 +209,11 @@ error:
|
||||
if (sys->pool)
|
||||
picture_pool_Release(sys->pool);
|
||||
if (sys->dither)
|
||||
- cucul_free_dither(sys->dither);
|
||||
+ caca_free_dither(sys->dither);
|
||||
if (sys->dp)
|
||||
caca_free_display(sys->dp);
|
||||
if (sys->cv)
|
||||
- cucul_free_canvas(sys->cv);
|
||||
+ caca_free_canvas(sys->cv);
|
||||
|
||||
free(sys);
|
||||
}
|
||||
@@ -235,9 +235,9 @@ static void Close(vlc_object_t *object)
|
||||
if (sys->pool)
|
||||
picture_pool_Release(sys->pool);
|
||||
if (sys->dither)
|
||||
- cucul_free_dither(sys->dither);
|
||||
+ caca_free_dither(sys->dither);
|
||||
caca_free_display(sys->dp);
|
||||
- cucul_free_canvas(sys->cv);
|
||||
+ caca_free_canvas(sys->cv);
|
||||
|
||||
#if defined(_WIN32)
|
||||
FreeConsole();
|
||||
@@ -266,7 +266,7 @@ static void Prepare(vout_display_t *vd, picture_t *picture, subpicture_t *subpic
|
||||
|
||||
if (!sys->dither) {
|
||||
/* Create the libcaca dither object */
|
||||
- sys->dither = cucul_create_dither(32,
|
||||
+ sys->dither = caca_create_dither(32,
|
||||
vd->source.i_visible_width,
|
||||
vd->source.i_visible_height,
|
||||
picture->p[0].i_pitch,
|
||||
@@ -284,12 +284,12 @@ static void Prepare(vout_display_t *vd, picture_t *picture, subpicture_t *subpic
|
||||
vout_display_place_t place;
|
||||
Place(vd, &place);
|
||||
|
||||
- cucul_set_color_ansi(sys->cv, CUCUL_COLOR_DEFAULT, CUCUL_COLOR_BLACK);
|
||||
- cucul_clear_canvas(sys->cv);
|
||||
+ caca_set_color_ansi(sys->cv, CACA_DEFAULT, CACA_BLACK);
|
||||
+ caca_clear_canvas(sys->cv);
|
||||
|
||||
const int crop_offset = vd->source.i_y_offset * picture->p->i_pitch +
|
||||
vd->source.i_x_offset * picture->p->i_pixel_pitch;
|
||||
- cucul_dither_bitmap(sys->cv, place.x, place.y,
|
||||
+ caca_dither_bitmap(sys->cv, place.x, place.y,
|
||||
place.width, place.height,
|
||||
sys->dither,
|
||||
&picture->p->p_pixels[crop_offset]);
|
||||
@@ -328,7 +328,7 @@ static int Control(vout_display_t *vd, int query, va_list args)
|
||||
|
||||
case VOUT_DISPLAY_CHANGE_SOURCE_CROP:
|
||||
if (sys->dither)
|
||||
- cucul_free_dither(sys->dither);
|
||||
+ caca_free_dither(sys->dither);
|
||||
sys->dither = NULL;
|
||||
return VLC_SUCCESS;
|
||||
|
||||
@@ -366,8 +366,8 @@ static void Place(vout_display_t *vd, vout_display_place_t *place)
|
||||
|
||||
vout_display_PlacePicture(place, &vd->source, vd->cfg, false);
|
||||
|
||||
- const int canvas_width = cucul_get_canvas_width(sys->cv);
|
||||
- const int canvas_height = cucul_get_canvas_height(sys->cv);
|
||||
+ const int canvas_width = caca_get_canvas_width(sys->cv);
|
||||
+ const int canvas_height = caca_get_canvas_height(sys->cv);
|
||||
const int display_width = caca_get_display_width(sys->dp);
|
||||
const int display_height = caca_get_display_height(sys->dp);
|
||||
|
108
extra/vlc/libplacebo-5.patch
Normal file
108
extra/vlc/libplacebo-5.patch
Normal file
|
@ -0,0 +1,108 @@
|
|||
patch vaguely ported from: https://code.videolan.org/videolan/vlc/-/merge_requests/2233
|
||||
|
||||
diff --git a/modules/video_output/opengl/converter.h b/modules/video_output/opengl/converter.h
|
||||
index 7000e1f..49fa667 100644
|
||||
--- a/modules/video_output/opengl/converter.h
|
||||
+++ b/modules/video_output/opengl/converter.h
|
||||
@@ -26,6 +26,9 @@
|
||||
#include <vlc_picture_pool.h>
|
||||
#include <vlc_opengl.h>
|
||||
|
||||
+#include <libplacebo/log.h>
|
||||
+#include <libplacebo/shaders.h>
|
||||
+
|
||||
/* if USE_OPENGL_ES2 is defined, OpenGL ES version 2 will be used, otherwise
|
||||
* normal OpenGL will be used */
|
||||
#ifdef __APPLE__
|
||||
@@ -253,10 +256,6 @@ static inline bool HasExtension(const char *apis, const char *api)
|
||||
return false;
|
||||
}
|
||||
|
||||
-struct pl_context;
|
||||
-struct pl_shader;
|
||||
-struct pl_shader_res;
|
||||
-
|
||||
/*
|
||||
* Structure that is filled by "glhw converter" module probe function
|
||||
* The implementation should initialize every members of the struct that are
|
||||
@@ -273,7 +272,7 @@ struct opengl_tex_converter_t
|
||||
vlc_gl_t *gl;
|
||||
|
||||
/* libplacebo context, created by the caller (optional) */
|
||||
- struct pl_context *pl_ctx;
|
||||
+ pl_log pl_log;
|
||||
|
||||
/* Function pointers to OpenGL functions, set by the caller */
|
||||
const opengl_vtable_t *vt;
|
||||
@@ -337,7 +336,7 @@ struct opengl_tex_converter_t
|
||||
bool yuv_color;
|
||||
GLfloat yuv_coefficients[16];
|
||||
|
||||
- struct pl_shader *pl_sh;
|
||||
+ pl_shader pl_sh;
|
||||
const struct pl_shader_res *pl_sh_res;
|
||||
|
||||
/* Private context */
|
||||
diff --git a/modules/video_output/opengl/fragment_shaders.c b/modules/video_output/opengl/fragment_shaders.c
|
||||
index ecf7226..29f4148 100644
|
||||
--- a/modules/video_output/opengl/fragment_shaders.c
|
||||
+++ b/modules/video_output/opengl/fragment_shaders.c
|
||||
@@ -611,7 +611,7 @@ opengl_fragment_shader_init_impl(opengl_tex_converter_t *tc, GLenum tex_target,
|
||||
|
||||
#ifdef HAVE_LIBPLACEBO
|
||||
if (tc->pl_sh) {
|
||||
- struct pl_shader *sh = tc->pl_sh;
|
||||
+ pl_shader sh = tc->pl_sh;
|
||||
struct pl_color_map_params color_params = pl_color_map_default_params;
|
||||
color_params.intent = var_InheritInteger(tc->gl, "rendering-intent");
|
||||
color_params.tone_mapping_algo = var_InheritInteger(tc->gl, "tone-mapping");
|
||||
@@ -634,7 +634,7 @@ opengl_fragment_shader_init_impl(opengl_tex_converter_t *tc, GLenum tex_target,
|
||||
pl_color_space_from_video_format(&tc->fmt),
|
||||
dst_space, NULL, false);
|
||||
|
||||
- struct pl_shader_obj *dither_state = NULL;
|
||||
+ pl_shader_obj dither_state = NULL;
|
||||
int method = var_InheritInteger(tc->gl, "dither-algo");
|
||||
if (method >= 0) {
|
||||
|
||||
diff --git a/modules/video_output/opengl/vout_helper.c b/modules/video_output/opengl/vout_helper.c
|
||||
index 13d65e0..1ee99af 100644
|
||||
--- a/modules/video_output/opengl/vout_helper.c
|
||||
+++ b/modules/video_output/opengl/vout_helper.c
|
||||
@@ -570,8 +570,7 @@ opengl_deinit_program(vout_display_opengl_t *vgl, struct prgm *prgm)
|
||||
|
||||
#ifdef HAVE_LIBPLACEBO
|
||||
FREENULL(tc->uloc.pl_vars);
|
||||
- if (tc->pl_ctx)
|
||||
- pl_context_destroy(&tc->pl_ctx);
|
||||
+ pl_log_destroy(&tc->pl_log);
|
||||
#endif
|
||||
|
||||
vlc_object_release(tc);
|
||||
@@ -622,21 +621,21 @@ opengl_init_program(vout_display_opengl_t *vgl, struct prgm *prgm,
|
||||
// create the main libplacebo context
|
||||
if (!subpics)
|
||||
{
|
||||
- tc->pl_ctx = pl_context_create(PL_API_VER, &(struct pl_context_params) {
|
||||
+ tc->pl_log = pl_log_create(PL_API_VER, &(struct pl_log_params) {
|
||||
.log_cb = log_cb,
|
||||
.log_priv = tc,
|
||||
.log_level = PL_LOG_INFO,
|
||||
});
|
||||
- if (tc->pl_ctx) {
|
||||
+ if (tc->pl_log) {
|
||||
# if PL_API_VER >= 20
|
||||
- tc->pl_sh = pl_shader_alloc(tc->pl_ctx, &(struct pl_shader_params) {
|
||||
+ tc->pl_sh = pl_shader_alloc(tc->pl_log, &(struct pl_shader_params) {
|
||||
.glsl.version = tc->glsl_version,
|
||||
.glsl.gles = tc->is_gles,
|
||||
});
|
||||
# elif PL_API_VER >= 6
|
||||
- tc->pl_sh = pl_shader_alloc(tc->pl_ctx, NULL, 0);
|
||||
+ tc->pl_sh = pl_shader_alloc(tc->pl_log, NULL, 0);
|
||||
# else
|
||||
- tc->pl_sh = pl_shader_alloc(tc->pl_ctx, NULL, 0, 0);
|
||||
+ tc->pl_sh = pl_shader_alloc(tc->pl_log, NULL, 0, 0);
|
||||
# endif
|
||||
}
|
||||
}
|
|
@ -10,17 +10,3 @@ diff -ru vlc-3.0.13.orig/configure.ac vlc-3.0.13/configure.ac
|
|||
other_libs_pic="-lgroupsock_pic -lBasicUsageEnvironment_pic -lUsageEnvironment_pic"
|
||||
AS_IF([test "${SYS}" = "mingw32"], [
|
||||
# add ws2_32 for closesocket, select, recv
|
||||
diff -ru vlc-3.0.13.orig/modules/access/live555.cpp vlc-3.0.13/modules/access/live555.cpp
|
||||
--- vlc-3.0.13.orig/modules/access/live555.cpp 2019-03-29 20:01:15.000000000 +0100
|
||||
+++ vlc-3.0.13/modules/access/live555.cpp 2021-05-03 16:04:38.030121796 +0200
|
||||
@@ -852,7 +852,9 @@
|
||||
if( !p_sys->b_multicast )
|
||||
{
|
||||
/* We need different rollover behaviour for multicast */
|
||||
- p_sys->b_multicast = IsMulticastAddress( sub->connectionEndpointAddress() );
|
||||
+ struct sockaddr_storage tempAddr;
|
||||
+ sub->getConnectionEndpointAddress(tempAddr);
|
||||
+ p_sys->b_multicast = IsMulticastAddress( tempAddr );
|
||||
}
|
||||
|
||||
tk = (live_track_t*)malloc( sizeof( live_track_t ) );
|
||||
|
|
Loading…
Reference in a new issue