From 76d7e2be6a5c9ee315b9d016a97fd84a7ede80c3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 6 Sep 2012 12:48:39 +0000
Subject: [PATCH] community/linux-tools to 3.5-5

---
 community/linux-tools/PKGBUILD         |  6 +----
 community/linux-tools/cpupower.pmutils | 37 --------------------------
 2 files changed, 1 insertion(+), 42 deletions(-)
 delete mode 100644 community/linux-tools/cpupower.pmutils

diff --git a/community/linux-tools/PKGBUILD b/community/linux-tools/PKGBUILD
index dda044e83..00ca0deb3 100644
--- a/community/linux-tools/PKGBUILD
+++ b/community/linux-tools/PKGBUILD
@@ -7,7 +7,7 @@
 pkgbase=linux-tools
 pkgname=('perf' 'cpupower' 'usbip')
 pkgver=3.5
-pkgrel=4
+pkgrel=5
 license=('GPL2')
 arch=('i686' 'x86_64')
 url='http://www.kernel.org'
@@ -28,7 +28,6 @@ source=("http://ftp.kernel.org/pub/linux/kernel/v3.x/linux-$pkgver.tar.xz"
         'cpupower.rc'
         'cpupower.systemd'
         'cpupower.service'
-        'cpupower.pmutils'
         'usbipd.conf'
         'usbipd.rc'
         'usbipd.service')
@@ -37,7 +36,6 @@ md5sums=('24153eaaa81dedc9481ada8cd9c3b83d'
          '1d9214637968b91706b6e616a100d44b'
          'c0d17b5295fe964623c772a2dd981771'
          '2450e8ff41b30eb58d43b5fffbfde1f4'
-         '1c2743ce57b56e16feec86a8b49f3391'
          'e8fac9c45a628015644b4150b139278a'
          '8a3831d962ff6a9968c0c20fd601cdec'
          'ba7c1c513314dd21fb2334fb8417738f')
@@ -109,8 +107,6 @@ package_cpupower() {
   install -Dm 644 $pkgname.conf "$pkgdir/etc/conf.d/$pkgname"
   install -Dm 644 $pkgname.service "$pkgdir/usr/lib/systemd/system/$pkgname.service"
   install -Dm 755 $pkgname.systemd "$pkgdir/usr/lib/systemd/scripts/$pkgname"
-  # install pm-utils hook
-  install -Dm 755 $pkgname.pmutils "$pkgdir/usr/lib/pm-utils/power.d/$pkgname"
 }
 
 package_usbip() {
diff --git a/community/linux-tools/cpupower.pmutils b/community/linux-tools/cpupower.pmutils
deleted file mode 100644
index fb93cd7c1..000000000
--- a/community/linux-tools/cpupower.pmutils
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/bash
-
-[[ -x /usr/bin/cpupower ]] || exit $NA
-
-CPUPOWER_GOVERNOR_AC=${CPUPOWER_GOVERNOR_AC:-ondemand}
-CPUPOWER_GOVERNOR_BAT=${CPUPOWER_GOVERNOR_BAT:-conservative}
-
-help() {
-    cat <<EOF
---------
-$0: Select cpupower frequency governor.
-
-Parameters:
-CPUPOWER_GOVERNOR_AC = Governor to use on AC.
-Defaults to ondemand.
-
-CPUPOWER_GOVERNOR_BAT = Governor to use on battery.
-Defaults to conservative.
-
-EOF
-}
-
-cpupow() {
-  printf 'Setting cpupower frequency governor to %s...' "$1"
-  cpupower -c all frequency-set -g "$1"
-}
-
-case $1 in
-  true) cpupow "$CPUPOWER_GOVERNOR_BAT" ;;
-  false) cpupow "$CPUPOWER_GOVERNOR_AC" ;;
-  help) help;;
-  *) exit $NA ;;
-esac
-
-exit 0
-
-# vim:set ts=2 sw=2 ft=sh et: