AUR cleanup, separation into alarm repo

This commit is contained in:
Kevin Mihelich 2012-03-12 16:54:09 -04:00
parent dfa0c3686e
commit 76e0d5eb28
39 changed files with 0 additions and 1054 deletions

View file

@ -1,23 +0,0 @@
# Maintainer: Kai Uwe Jesussek <kajot@gmx.net>
plugrel=1
pkgname=gmu-z2
pkgver=0.7.2
pkgrel=1
pkgdesc="A very nice Music Player, based on SDL, optimized for zipit z2"
arch=('i686' 'x86_64' 'arm')
url="http://wejp.k.vu"
license=('GPL2')
depends=('z2-sdl-profile' 'sdl' 'sdl_image' 'sdl_gfx' 'libvorbisdec-svn' 'flac' 'mpg123-arm' 'libmikmod' 'speex')
source=('http://wejp.k.vu/files/gmu-0.7.2.tar.gz' 'gmu.conf' 'gmuinput.z2.conf' 'zipit-z2.keymap')
md5sums=('dea481ab0f8f9f10b38aa21605dbb18d' 'b5e3da96885250a665600c4daac439a6' '705519d822f77ab3f48b7738751798f5' '5befd516c3d8226c5de8b3725cf27ba3')
provides=('gmu')
build() {
cd ${srcdir}/gmu-${pkgver}
make || return 1
make DESTDIR=${pkgdir} install
cd ${srcdir}
mkdir -p ${pkgdir}/usr/local/share/gmu/
cp gmu.conf gmuinput.z2.conf zipit-z2.keymap ${pkgdir}/usr/local/share/gmu/
}

View file

@ -1,39 +0,0 @@
DefaultPlayMode=random+repeat
RememberLastPlaylist=yes
RememberSettings=yes
EnableCoverArtwork=yes
CoverArtworkFilePattern=cover.jpg;cover.png;front.jpg;*.jpg;*.png
LoadEmbeddedCoverArtwork=first
LyricsFilePattern=$.txt;*.txt;*.nfo
FileSystemCharset=UTF-8
PlaylistSavePresets=rock.m3u;pop.m3u;electronic.m3u;classic.m3u;alternative.m3u;soundtrack.m3u;chiptunes.m3u;playlist1.m3u;playlist2.m3u;playlist3.m3u;playlist4.m3u;playlist5.m3u;playlist6.m3u;playlist7.m3u;playlist8.m3u;playlist9.m3u;playlist10.m3u
TimeDisplay=remaining
CPUClock=default
DefaultFileBrowserPath=/
VolumeControl=Software
VolumeHardwareMixerChannel=0
Volume=15
DefaultSkin=default-modern
AutoSelectCurrentPlaylistItem=yes
AutoPlayOnProgramStart=no
Scroll=always
FileBrowserFoldersFirst=yes
BacklightPowerOnOnTrackChange=no
KeyMap=zipit-z2.keymap
AllowVolumeControlInHoldState=no
SecondsUntilBacklightPowerOff=0
CoverArtworkLarge=no
SmallCoverArtworkAlignment=right
FirstRun=no
ResumePlayback=yes
InputConfigFile=gmuinput.z2.conf
Shutdown=0
ShutdownCommand=/sbin/poweroff
Log.Enable=no
Log.MinimumPlaytimeSec=30
Log.MinimumPlaytimePercent=50
LastPlayedPlaylistItem=None
LastPlayedPlaylistItemTime=0
SDL_frontend.Width=240
SDL_frontend.Height=240
SDL_frontend.Fullscreen=no

View file

@ -1,83 +0,0 @@
FullKeyboard=yes
Button-0=13,Return
Button-1=32,Space
Button-2=13,Enter
Button-3=97,A
Button-4=98,B
Button-5=99,C
Button-6=100,D
Button-7=101,E
Button-8=102,F
Button-9=103,G
Button-10=104,H
Button-11=105,I
Button-12=106,J
Button-13=107,K
Button-14=108,L
Button-15=109,M
Button-16=110,N
Button-17=111,O
Button-18=112,P
Button-19=113,Q
Button-20=114,R
Button-21=115,S
Button-22=116,T
Button-23=117,U
Button-24=118,V
Button-25=119,W
Button-26=120,X
Button-27=121,Y
Button-28=122,Z
Button-29=43,+
Button-30=45,-
Button-31=32,Space
Button-32=13,Enter
Button-33=27,ESC
Button-34=308,Alt
Button-35=306,CTRL
Button-36=305,CTRL_R
Button-37=313,AltGr
Button-38=304,ShiftL
Button-39=303,ShiftR
Button-40=8,Backspace
Button-41=127,Delete
Button-42=277,Insert
Button-43=48,0
Button-44=49,1
Button-45=50,2
Button-46=51,3
Button-47=52,4
Button-48=53,5
Button-49=54,6
Button-50=55,7
Button-51=56,8
Button-52=57,9
Button-53=9,Tab
Button-54=301,CapsLock
Button-55=282,F1
Button-56=283,F2
Button-57=284,F3
Button-58=285,F4
Button-59=286,F5
Button-60=287,F6
Button-61=288,F7
Button-62=289,F8
Button-63=290,F9
Button-64=291,F10
Button-65=292,F11
Button-66=293,F12
Button-67=44,<
Button-68=46,>
Button-69=273,Up
Button-70=274,Down
Button-71=276,Left
Button-72=275,Right
Button-73=280,Volume+
Button-74=281,Volume-
Button-75=279,(B)
Button-76=278,(A)
Button-75=9,Tab
Button-76=303,(L)
Button-77=305,(R)
Button-78=46,Dot
Button-79=44,Comma

View file

@ -1,67 +0,0 @@
# Gmu key mappings
# Required keys: Modifier, Up,
# Down, Pause, ProgramInfo, Exit,
# PlaylistPlayItem, PlaylistClear,
# FileBrowserAddFileToPlaylistOrChDir
# Buttons names are defined in gmuinput.conf.
Modifier=Alt
# Global mappings:
Left=Left
Right=Right
Up=Up
Down=Down
IncreaseVolume=Volume+
DecreaseVolume=Volume-
ToggleTime=T
Pause=P
Stop=X
ToggleView=Space
PreviousTrack=Comma
NextTrack=Dot
SeekForward=M
SeekBackward=N
Hold=Mod+Up
Exit=ESC
ShutdownTimer=Mod+Down
Help=H
# Program info mappings:
ProgramInfo=I
ProgramInfoOkay=Enter
# File browser mappings:
#FileBrowserDirUp=LEFT
#FileBrowserChDir=RIGHT
FileBrowserPlayFile=A
FileBrowserAddFileToPlaylistOrChDir=Enter
FileBrowserAddDirToPlaylist=Y
FileBrowserInsertFileIntoPlaylist=Mod+B
FileBrowserNewPlFromDir=Mod+Y
#FileBrowserDeleteFile=Mod+X
# Playlist mappings:
PlaylistPlayItem=Enter
PlaylistToggleRandomMode=R
PlaylistRemoveItem=Y
PlaylistClear=Mod+C
PlaylistSave=S
# Playlist save dialog:
PlaylistSaveSelect=Enter
PlaylistSaveCancel=C
PlaylistSaveLoadList=L
PlaylistSaveAppendList=Mod+Y
#PlaylistDeleteFile=Mod+X
PlaylistQueue=Q
# Track info mappings:
TrackInfoToggleCover=A
TrackInfoToggleText=B
# Question dialog mappings:
QuestionYes=Enter
QuestionNo=C
# Setup mappings:
SetupSelect=B
SetupSaveAndExit=X
SetupSaveAndRunGmu=Y
SetupFileBrowserSelect=B
SetupFileBrowserChDir=A
SetupFileBrowserCancel=X

View file

@ -1,36 +0,0 @@
# Maintainer: evnu <mamuelle@informatik.hu-berlin.de>
plugrel=1
pkgname=libvorbisdec-svn
pkgver=17636
pkgrel=1
pkgdesc="Tremor is a fixed-point version of the Ogg Vorbis decoder for those platforms that can't do floating point math. It can be installed with libvorbis together"
arch=('arm')
url="http://wiki.xiph.org/index.php/Tremor"
license=('GPL')
depends=('libogg')
makedepends=('subversion' 'autoconf' 'automake')
source=()
md5sums=()
_svntrunk="http://svn.xiph.org/trunk/Tremor/"
_svnmod=Tremor
build() {
cd $srcdir
if [ -d "${_svnmod}"/.svn ]
then
msg "Starting SVN update ..."
cd "${_svnmod}"
svn up
msg "... updating finished."
else
msg "Starting SVN checkout ..."
svn co ${_svntrunk}
msg "... checkout finished."
fi
cd $srcdir/${_svnmod}
./autogen.sh --prefix=/usr/
make || return 1
make DESTDIR=${pkgdir} install || return 1
}

View file

@ -1,52 +0,0 @@
# $Id: PKGBUILD 117246 2011-03-30 14:23:30Z ibiru $
# Maintainer: Kai Uwe Jesussek <kajot@gmx.net>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
plugrel=1
pkgname=mplayer-z2
pkgver=1.0rc4
pkgrel=1
pkgdesc="A movie player for linux"
arch=('i686' 'x86_64' 'arm')
depends=('libmad' 'cdparanoia' 'libxinerama' 'sdl' 'lame' 'libtheora' 'xvidcore' 'libmng' 'libxss'
'smbclient' 'aalib' 'libcaca' 'x264' 'faac' 'ttf-dejavu' 'libxvmc' 'enca' 'mpg123-arm'
'opencore-amr' 'libdca' 'a52dec')
license=('GPL')
url="http://www.mplayerhq.hu/"
makedepends=('unzip' 'yasm')
backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
source=('mplayer-1.0rc4-pxa-wejp.patch' 'mplayer.conf' 'http://www.mplayerhq.hu/MPlayer/releases/MPlayer-1.0rc4.tar.bz2' )
conflicts=('mplayer')
provides=('mplayer')
md5sums=('480d11daa4962629e6fb26bd61993a0f'
'6e960e87b4aee28889f0ea5c65f711fb'
'1699c94de39da9c4c5d34e8f58e418f0')
build() {
# Custom CFLAGS break the mplayer build
unset CFLAGS LDFLAGS
cd ${srcdir}/MPlayer-1.0rc4
patch -p1 < ${srcdir}/mplayer-1.0rc4-pxa-wejp.patch
./configure --enable-armv5te --enable-iwmmxt --enable-pxa \
--enable-faad-fixed --enable-tremor-low \
--disable-mp3lib --disable-libvorbis --disable-vidix \
--extra-cflags="-march=iwmmxt" \
--disable-runtime-cpudetection --disable-sighandler \
--disable-live --enable-alsa --enable-mpg123 \
--extra-ldflags="-lmpg123" \
--confdir=/etc/mplayer
[ "$CARCH" = "i686" ] && sed 's|-march=i486|-march=i686|g' -i config.mak
#make
make -j1 DESTDIR=${pkgdir} install
install -Dm644 etc/{codecs.conf,input.conf,example.conf} ${pkgdir}/etc/mplayer/
mkdir -p ${pkgdir}/etc/mplayer/
cp ${srcdir}/mplayer.conf ${pkgdir}/etc/mplayer/
install -dm755 ${pkgdir}/usr/share/mplayer/
ln -s /usr/share/fonts/TTF/DejaVuSans.ttf ${pkgdir}/usr/share/mplayer/subfont.ttf
rm -rf ${pkgdir}/usr/share/mplayer/font
}

View file

@ -1,393 +0,0 @@
diff -ruN MPlayer-1.0rc4/configure MPlayer-1.0rc4-pxa/configure
--- MPlayer-1.0rc4/configure 2010-07-29 02:31:57.000000000 +0200
+++ MPlayer-1.0rc4-pxa/configure 2011-02-27 14:12:12.000000000 +0100
@@ -630,6 +630,7 @@
_svga=auto
_vesa=auto
_fbdev=auto
+_pxa=no
_dvb=auto
_dxr2=auto
_dxr3=auto
@@ -997,6 +998,8 @@
--enable-fbdev) _fbdev=yes ;;
--disable-fbdev) _fbdev=no ;;
--enable-dvb) _dvb=yes ;;
+ --enable-pxa) _pxa=yes ;;
+ --disable-pxa) _pxa=no ;;
--disable-dvb) _dvb=no ;;
--enable-dxr2) _dxr2=yes ;;
--disable-dxr2) _dxr2=no ;;
@@ -4875,7 +4878,15 @@
fi
echores "$_fbdev"
-
+echocheck "PXA27x Overlay Support"
+if test "$_pxa" = yes ; then
+ def_pxa='#define CONFIG_PXA 1'
+ vomodules="pxa $vomodules"
+else
+ def_pxa='#undef CONFIG_PXA'
+ novomodules="pxa $novomodules"
+fi
+echores "$_pxa"
echocheck "DVB"
if test "$_dvb" = auto ; then
@@ -8644,6 +8655,7 @@
PRIORITY = $_priority
PULSE = $_pulse
PVR = $_pvr
+PXA = $_pxa
QTX_CODECS = $_qtx
QTX_CODECS_WIN32 = $_qtx_codecs_win32
QTX_EMULATION = $_qtx_emulation
@@ -9121,6 +9133,7 @@
$def_dxr2
$def_dxr3
$def_fbdev
+$def_pxa
$def_ggi
$def_ggiwmh
$def_gif
diff -ruN MPlayer-1.0rc4/libvo/video_out.c MPlayer-1.0rc4-pxa/libvo/video_out.c
--- MPlayer-1.0rc4/libvo/video_out.c 2010-06-13 14:04:13.000000000 +0200
+++ MPlayer-1.0rc4-pxa/libvo/video_out.c 2011-02-27 03:24:10.000000000 +0100
@@ -114,6 +114,7 @@
extern vo_functions_t video_out_fbdev;
extern const vo_functions_t video_out_fbdev2;
extern vo_functions_t video_out_svga;
+extern const vo_functions_t video_out_pxa;
extern const vo_functions_t video_out_png;
extern const vo_functions_t video_out_ggi;
extern const vo_functions_t video_out_aa;
@@ -214,6 +215,9 @@
&video_out_fbdev,
&video_out_fbdev2,
#endif
+#ifdef CONFIG_PXA
+ &video_out_pxa,
+#endif
#ifdef CONFIG_SVGALIB
&video_out_svga,
#endif
diff -ruN MPlayer-1.0rc4/libvo/vo_pxa.c MPlayer-1.0rc4-pxa/libvo/vo_pxa.c
--- MPlayer-1.0rc4/libvo/vo_pxa.c 1970-01-01 01:00:00.000000000 +0100
+++ MPlayer-1.0rc4-pxa/libvo/vo_pxa.c 2011-02-26 22:18:06.000000000 +0100
@@ -0,0 +1,304 @@
+/*
+ * Video driver for PXA27x/3xx Overlay 2
+ * by Vasily Khoruzhick <anarsoul@gmail.com>
+ * (C) 2007
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <errno.h>
+#include <fcntl.h>
+
+#include <linux/fb.h>
+
+#include <sys/ioctl.h>
+#include <sys/types.h>
+#include <sys/stat.h>
+#include <sys/mman.h>
+
+#include "config.h"
+#include "video_out.h"
+#include "video_out_internal.h"
+#include "sub.h"
+#include "aspect.h"
+#include "mp_msg.h"
+#include "subopt-helper.h"
+
+static vo_info_t info = {
+ "PXA27x/3xx overlay",
+ "pxa",
+ "Vasily Khoruzhick <anarsoul@gmail.com>",
+ ""
+};
+
+LIBVO_EXTERN(pxa);
+
+/* VO driver state */
+
+static int overlay_width, overlay_height, overlay_x, overlay_y;
+static int overlay_fd = -1;
+static void *overlay_mem;
+static size_t overlay_mem_size;
+static uint8_t *y_plane;
+static uint8_t *u_plane;
+static uint8_t *v_plane;
+
+static int vo_pxa_check_format(uint32_t format)
+{
+ switch (format)
+ {
+ /* Planar YUV Formats */
+ case IMGFMT_YV12:
+ case IMGFMT_IYUV:
+ case IMGFMT_I420:
+ return( VFCAP_CSP_SUPPORTED | VFCAP_CSP_SUPPORTED_BY_HW
+ | VFCAP_ACCEPT_STRIDE );
+ break;
+
+ }
+
+ mp_msg(MSGT_VO, MSGL_ERR, "vo_pxa: format %s is not supported\n",
+ vo_format_name(format));
+
+ return 0;
+}
+
+/*****************************************************************************
+ * preinit
+ *
+ * Preinitializes driver
+ * arg - currently it's vo_subdevice
+ * returns: zero on successful initialization, non-zero on error.
+ *
+ ****************************************************************************/
+static int preinit(const char *vo_subdevice)
+{
+ int r, fb = -1;
+ struct fb_var_screeninfo fbvar;
+
+ fb = open("/dev/fb0", O_RDWR);
+ r = ioctl(fb, FBIOGET_VSCREENINFO, &fbvar);
+ if (r) {
+ mp_msg(MSGT_VO, MSGL_V, "vo_pxa: get_vscreeninfo ioctl failed");
+ return -1;
+ }
+
+ overlay_width = fbvar.xres;
+ overlay_height = fbvar.yres;
+
+ mp_msg(MSGT_VO, MSGL_V, "vo_pxa: main plane res is %dx%d\n",
+ overlay_width, overlay_height);
+
+ close(fb);
+
+ return 0;
+}
+
+
+/*****************************************************************************
+ * config
+ *
+ * Config the display driver.
+ * params:
+ * src_width,srcheight: image source size
+ * dst_width,dst_height: size of the requested window size, just a hint
+ * fullscreen: flag, 0=windowd 1=fullscreen, just a hint
+ * title: window title, if available
+ * format: fourcc of pixel format
+ * returns : zero on successful initialization, non-zero on error.
+ *
+ ****************************************************************************/
+static int config(uint32_t src_width, uint32_t src_height,
+ uint32_t dst_width, uint32_t dst_height, uint32_t flags,
+ char *title, uint32_t format)
+{
+ int r;
+ struct fb_var_screeninfo fbvar;
+ struct fb_fix_screeninfo fbfix;
+ int i;
+
+ mp_msg(MSGT_VO, MSGL_V, "vo_pxa: config() src_width:%d, src_height:%d, dst_width:%d, dst_height:%d\n",
+ src_width, src_height, dst_width, dst_height);
+
+ /* Check format */
+ if (!vo_pxa_check_format(format))
+ goto error;
+
+ /* Check src image */
+ if (src_width > overlay_width || src_height > overlay_height) {
+ mp_msg(MSGT_VO, MSGL_ERR, "vo_pxa: src image is too big, scaling not supported.\n");
+ goto error;
+ }
+
+ if (dst_width > overlay_width || dst_height > overlay_height) {
+ mp_msg(MSGT_VO, MSGL_ERR, "vo_pxa: dst is too big, scaling not supported.\n");
+ goto error;
+ }
+
+ if (src_width != dst_width || src_height != dst_height) {
+ mp_msg(MSGT_VO, MSGL_ERR, "vo_pxa: src != dst, scaling not supported.\n");
+ goto error;
+ }
+
+ overlay_x = (overlay_width - dst_width) / 2;
+ overlay_y = (overlay_height - dst_height) / 2;
+
+ overlay_fd = open("/dev/fb2", O_RDWR);
+ r = ioctl(overlay_fd, FBIOGET_VSCREENINFO, &fbvar);
+ if (r) {
+ mp_msg(MSGT_VO, MSGL_ERR, "vo_pxa: get_vscreeninfo ioctl failed\n");
+ goto error;
+ }
+
+ fbvar.xres_virtual = fbvar.xres = overlay_width;
+ fbvar.yres_virtual = fbvar.yres = overlay_height;
+ fbvar.bits_per_pixel = 16;
+ fbvar.activate = FB_ACTIVATE_NOW;
+
+ fbvar.nonstd = (4 << 20) | (0 << 10) | (0); /* YUV420P, X=0, Y=0 */
+
+ r = ioctl(overlay_fd, FBIOPUT_VSCREENINFO, &fbvar);
+ if (r) {
+ mp_msg(MSGT_VO, MSGL_ERR, "vo_pxa: put_vscreeninfo ioctl failed\n");
+ goto error;
+ }
+ r = ioctl(overlay_fd, FBIOGET_FSCREENINFO, &fbfix);
+ if (r) {
+ mp_msg(MSGT_VO, MSGL_ERR, "vo_pxa: get_fscreeninfo ioctl failed\n");
+ goto error;
+ }
+
+ overlay_mem_size = fbfix.smem_len;
+ overlay_mem = mmap(NULL, overlay_mem_size, (PROT_READ | PROT_WRITE),
+ MAP_SHARED, overlay_fd, 0);
+
+ if (overlay_mem == MAP_FAILED) {
+ mp_msg(MSGT_VO, MSGL_ERR, "vo_pxa: failed to mmap overlay");
+ goto error;
+ }
+
+ y_plane = overlay_mem;
+ u_plane = y_plane + overlay_width * overlay_height;
+ v_plane = u_plane + overlay_width * overlay_height / 4;
+
+ /* Fill the overlay with black */
+ memset(y_plane, 16,
+ overlay_width * overlay_height);
+ memset(u_plane, 128,
+ overlay_width * overlay_height / 4);
+ memset(v_plane, 128,
+ overlay_width * overlay_height / 4);
+
+ mp_msg(MSGT_VO, MSGL_V, "vo_pxa: configured and opened 2nd overlay");
+
+ return 0;
+
+error:
+ if (overlay_mem)
+ munmap(overlay_mem, overlay_mem_size);
+ if (overlay_fd != -1)
+ close(overlay_fd);
+
+ overlay_mem = NULL;
+ overlay_fd = -1;
+
+ return -1;
+}
+
+static int control(uint32_t request, void *data, ...)
+{
+ mp_msg(MSGT_VO, MSGL_V, "vo_pxa: control %08x\n", request );
+
+ switch( request )
+ {
+ case VOCTRL_QUERY_FORMAT:
+ return( vo_pxa_check_format( *(uint32_t *)data ) );
+ break;
+ }
+
+ return VO_NOTIMPL;
+}
+
+
+int draw_frame(uint8_t *src[])
+{
+ return 1;
+}
+
+
+/*****************************************************************************
+ *
+ * draw_slice
+ *
+ * Draw a planar YUV slice to the buffer:
+ * params:
+ * src[3] = source image planes (Y,U,V)
+ * stride[3] = source image planes line widths (in bytes)
+ * w,h = width*height of area to be copied (in Y pixels)
+ * x,y = position at the destination image (in Y pixels)
+ *
+ ****************************************************************************/
+int draw_slice(uint8_t *src[], int stride[], int w,int h, int x,int y)
+{
+ int i;
+
+ x += overlay_x;
+ y += overlay_y;
+
+ uint8_t *dst_y = y_plane + y * overlay_width + x;
+ uint8_t *dst_u = u_plane + y * overlay_width / 4 + x / 2;
+ uint8_t *dst_v = v_plane + y * overlay_width / 4 + x / 2;
+ uint8_t *src_y = src[0];
+ uint8_t *src_u = src[1];
+ uint8_t *src_v = src[2];
+
+ mp_msg(MSGT_VO, MSGL_V, "vo_pxa: draw_slice() w %d h %d x %d y %d stride %d %d %d\n",
+ w, h, x, y, stride[0], stride[1], stride[2] );
+
+ if (w + x > overlay_width || h + y > overlay_height) {
+ mp_msg(MSGT_VO, MSGL_ERR, "vo_pxa: too big image\n");
+ return 0;
+ }
+
+ for (i = 0; i < h; i++) {
+ fast_memcpy(dst_y, src_y, w);
+ src_y += stride[0];
+ dst_y += overlay_width;
+ }
+ for (i = 0; i < h / 2; i++) {
+ fast_memcpy(dst_u, src_u, w / 2);
+ fast_memcpy(dst_v, src_v, w / 2);
+ src_u += stride[1];
+ src_v += stride[2];
+ dst_u += overlay_width / 2;
+ dst_v += overlay_width / 2;
+ }
+
+ return 0;
+}
+
+static void draw_osd(void)
+{
+ /* FIXME */
+ /* vo_draw_text(in_width, in_height, draw_alpha); */
+}
+
+static void flip_page(void)
+{
+}
+
+static void check_events(void)
+{
+}
+
+static void uninit(void)
+{
+ if (overlay_mem)
+ munmap(overlay_mem, overlay_mem_size);
+ if (overlay_fd != -1)
+ close(overlay_fd);
+
+ overlay_mem = NULL;
+ overlay_fd = -1;
+}
diff -ruN MPlayer-1.0rc4/Makefile MPlayer-1.0rc4-pxa/Makefile
--- MPlayer-1.0rc4/Makefile 2010-07-29 19:08:19.000000000 +0200
+++ MPlayer-1.0rc4-pxa/Makefile 2011-02-27 14:14:21.000000000 +0100
@@ -541,6 +541,7 @@
SRCS_MPLAYER-$(DXR3) += libvo/vo_dxr3.c
SRCS_MPLAYER-$(ESD) += libao2/ao_esd.c
SRCS_MPLAYER-$(FBDEV) += libvo/vo_fbdev.c libvo/vo_fbdev2.c
+SRCS_MPLAYER-$(PXA) += libvo/vo_pxa.c
SRCS_MPLAYER-$(GGI) += libvo/vo_ggi.c
SRCS_MPLAYER-$(GIF) += libvo/vo_gif89a.c
SRCS_MPLAYER-$(GL) += libvo/gl_common.c libvo/vo_gl.c \

View file

@ -1,3 +0,0 @@
ao=alsa
vo=pxa
vf=rotate=2

View file

@ -1,193 +0,0 @@
Index: netsurf/framebuffer/fbtk/event.c
===================================================================
--- netsurf/framebuffer/fbtk/event.c (revision 12174)
+++ netsurf/framebuffer/fbtk/event.c (working copy)
@@ -250,7 +250,7 @@
-1, -1, -1, 13, -1, -1, -1, -1, -1, -1, /* 10 - 19 */
-1, -1, -1, -1, -1, -1, -1, 27, -1, -1, /* 20 - 29 */
-1, -1, ' ', '!', '"', '~', '$', -1, '&', '@', /* 30 - 39 */
- '(', ')', '*', '+', '<', '_', '>', '?', ')', '!', /* 40 - 49 */
+ '(', ')', '*', '+', '(', '_', ')', '?', ')', '!', /* 40 - 49 */
'"', 243, '$', '%', '^', '&', '*', '(', ';', ':', /* 50 - 59 */
'<', '+', '>', '?', '@', -1, -1, -1, -1, -1, /* 60 - 69 */
-1, -1, -1, -1, -1, -1, -1, -1, -1, -1, /* 70 - 79 */
@@ -261,16 +261,34 @@
'X', 'Y', 'Z', -1, -1, -1, -1, -1, -1, -1, /* 120 - 129 */
};
-
+static int alt_keymap[] = {
+ /* 0 1 2 3 4 5 6 7 8 9 */
+ -1, -1, -1, -1, -1, -1, -1, -1, 8, 9, /* 0 - 9 */
+ -1, -1, -1, 13, -1, -1, -1, -1, -1, -1, /* 10 - 19 */
+ -1, -1, -1, -1, -1, -1, -1, 27, -1, -1, /* 20 - 29 */
+ -1, -1, ' ', '!', '"', '#', '$', -1, '&','\'', /* 30 - 39 */
+ '(', ')', '*', '+', '<', '-', '>', '/', '0', '1', /* 40 - 49 */
+ '2', '3', '4', '5', '6', '7', '8', '9', ':', ';', /* 50 - 59 */
+ '<', '=', '>', '?', '@', -1, -1, -1, -1, -1, /* 60 - 69 */
+ -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, /* 70 - 79 */
+ -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, /* 80 - 89 */
+ -1, '[','\\', ']', '~', '_', '`', '$', '=', '+', /* 90 - 99 */
+ '&', '3', '@', '"', '\'', '8', '[', ']', '-', '?', /* 100 - 109 */
+ '_', '9', '0', '1', '4', '#', '5', '7', '*', '2', /* 110 - 119 */
+ '/', '6', '!', -1, -1, -1, -1, -1, -1, -1, /* 120 - 129 */
+};
/* exported function documented in fbtk.h */
int
fbtk_keycode_to_ucs4(int code, uint8_t mods)
{
int ucs4 = -1;
- if (mods) {
+ if (mods & FBTK_MT_SHIFT) {
if ((code >= 0) && (code < (int) NOF_ELEMENTS(sh_keymap)))
ucs4 = sh_keymap[code];
+ } else if (mods & FBTK_MT_ALT) {
+ if ((code >= 0) && (code < (int) NOF_ELEMENTS(sh_keymap)))
+ ucs4 = alt_keymap[code];
} else {
if ((code >= 0) && (code < (int) NOF_ELEMENTS(keymap)))
ucs4 = keymap[code];
Index: netsurf/framebuffer/fbtk/text.c
===================================================================
--- netsurf/framebuffer/fbtk/text.c (revision 12174)
+++ netsurf/framebuffer/fbtk/text.c (working copy)
@@ -248,11 +248,18 @@
if (cbi->event->type != NSFB_EVENT_KEY_DOWN) {
switch (value) {
case NSFB_KEY_RSHIFT:
- modifier &= ~1;
+ case NSFB_KEY_LSHIFT:
+ modifier &= ~(FBTK_MT_SHIFT);
break;
+
+ case NSFB_KEY_LALT:
+ case NSFB_KEY_RALT:
+ modifier &= ~(FBTK_MT_ALT);
+ break;
- case NSFB_KEY_LSHIFT:
- modifier &= ~(1<<1);
+ case NSFB_KEY_LCTRL:
+ case NSFB_KEY_RCTRL:
+ modifier &= ~(FBTK_MT_CTRL);
break;
default:
@@ -284,22 +291,38 @@
break;
case NSFB_KEY_RSHIFT:
- modifier |= 1;
+ case NSFB_KEY_LSHIFT:
+ modifier |= FBTK_MT_SHIFT;
break;
- case NSFB_KEY_LSHIFT:
- modifier |= 1<<1;
+ case NSFB_KEY_LALT:
+ case NSFB_KEY_RALT:
+ modifier |= FBTK_MT_ALT;
break;
- default:
- /* allow for new character and null */
- temp = realloc(widget->u.text.text, widget->u.text.idx + 2);
+ case NSFB_KEY_LCTRL:
+ case NSFB_KEY_RCTRL:
+ modifier |= FBTK_MT_CTRL;
+ break;
+ case NSFB_KEY_ESCAPE:
+ temp = realloc(widget->u.text.text, 1);
if (temp != NULL) {
widget->u.text.text = temp;
- widget->u.text.text[widget->u.text.idx] = fbtk_keycode_to_ucs4(value, modifier);
- widget->u.text.text[widget->u.text.idx + 1] = '\0';
- widget->u.text.idx++;
+ widget->u.text.text[0] = '\0';
+ widget->u.text.idx = 0;
}
+ break;
+ default:
+ if (value >= 32 && value < 127) {
+ /* allow for new character and null */
+ temp = realloc(widget->u.text.text, widget->u.text.idx + 2);
+ if (temp != NULL) {
+ widget->u.text.text = temp;
+ widget->u.text.text[widget->u.text.idx] = fbtk_keycode_to_ucs4(value, modifier);
+ widget->u.text.text[widget->u.text.idx + 1] = '\0';
+ widget->u.text.idx++;
+ }
+ }
break;
}
Index: netsurf/framebuffer/Makefile.target
===================================================================
Index: netsurf/framebuffer/gui.c
===================================================================
--- netsurf/framebuffer/gui.c (revision 12174)
+++ netsurf/framebuffer/gui.c (working copy)
@@ -712,13 +712,20 @@
break;
case NSFB_KEY_RSHIFT:
- modifier |= 1;
+ case NSFB_KEY_LSHIFT:
+ modifier |= FBTK_MT_SHIFT;
break;
- case NSFB_KEY_LSHIFT:
- modifier |= 1<<1;
+ case NSFB_KEY_LALT:
+ case NSFB_KEY_RALT:
+ modifier |= FBTK_MT_ALT;
break;
+ case NSFB_KEY_LCTRL:
+ case NSFB_KEY_RCTRL:
+ modifier |= FBTK_MT_CTRL;
+ break;
+
default:
ucs4 = fbtk_keycode_to_ucs4(cbi->event->value.keycode,
modifier);
@@ -731,11 +738,18 @@
case NSFB_EVENT_KEY_UP:
switch (cbi->event->value.keycode) {
case NSFB_KEY_RSHIFT:
- modifier &= ~1;
+ case NSFB_KEY_LSHIFT:
+ modifier &= ~(FBTK_MT_SHIFT);
break;
+
+ case NSFB_KEY_LALT:
+ case NSFB_KEY_RALT:
+ modifier &= ~(FBTK_MT_ALT);
+ break;
- case NSFB_KEY_LSHIFT:
- modifier &= ~(1<<1);
+ case NSFB_KEY_LCTRL:
+ case NSFB_KEY_RCTRL:
+ modifier &= ~(FBTK_MT_CTRL);
break;
default:
Index: netsurf/framebuffer/fbtk.h
===================================================================
--- netsurf/framebuffer/fbtk.h (revision 12174)
+++ netsurf/framebuffer/fbtk.h (working copy)
@@ -181,6 +181,12 @@
*/
bool fbtk_tgrab_pointer(fbtk_widget_t *widget);
+enum fbtk_mod_type {
+ FBTK_MT_SHIFT = 1,
+ FBTK_MT_ALT = 2,
+ FBTK_MT_CTRL = 4,
+};
+
/** Convert a framebuffer keycode to ucs4.
*
* Character mapping between keycode with modifier state and ucs-4.

View file

@ -1,13 +0,0 @@
Index: content/fetchers/curl.c
===================================================================
--- netsurf/content/fetchers/curl.c (revision 12174)
+++ netsurf/content/fetchers/curl.c (working copy)
@@ -586,7 +586,7 @@
SETOPT(CURLOPT_PROXY, NULL);
}
- if (urldb_get_cert_permissions(f->url)) {
+ if (1) { //urldb_get_cert_permissions(f->url)) {
/* Disable certificate verification */
SETOPT(CURLOPT_SSL_VERIFYPEER, 0L);
SETOPT(CURLOPT_SSL_VERIFYHOST, 0L);

View file

@ -1,24 +0,0 @@
Index: content/content.c
===================================================================
--- netsurf/content/content.c (revision 12174)
+++ netsurf/content/content.c (working copy)
@@ -1306,6 +1306,9 @@
*/
int content_get_width(hlcache_handle *h)
{
+ if (h == NULL)
+ return 0;
+
return content__get_width(hlcache_handle_get_content(h));
}
@@ -1325,6 +1328,9 @@
*/
int content_get_height(hlcache_handle *h)
{
+ if (h == NULL)
+ return 0;
+
return content__get_height(hlcache_handle_get_content(h));
}

View file

@ -1,69 +0,0 @@
# Contributor: Alexander Rødseth <rodseth@gmail.com>
# Thanks to: Georgij Kondratjev <smpuj@bk.ru>
plugrel=1
pkgname=netsurf-svn-z2
pkgver=12570
pkgrel=1
pkgdesc="Lightweight and fast web browser"
arch=('arm' 'i686' 'x86_64')
url="http://www.netsurf-browser.org/"
license=("GPL")
depends=('libnsfb-svn' 'libmng' 'curl' 'lcms' 'librsvg' 'libnsbmp-svn' 'libnsgif-svn' 'libcss-svn' 'hubbub-svn' 'libpng' 'libmng')
optdepends=('mouse-emul-git: Mouse emulation')
makedepends=('subversion')
provides=('netsurf')
conflicts=('netsurf')
source=('0002-netsurf-add-zipit-keymap.patch' '0004-curl-disable-verify-peer.patch' '0005-fix-content_get_width_height.patch' 'netsurf.sh')
md5sums=('36f5e546979269d93196ceedaa1f6fe8'
'41f9b588580af155e563412664935172'
'50e1d946985d5d5ae0e85e3f54bdbfd2'
'7ce7ad37c1375201d40f9690d4e12e2d')
_svntrunk=svn://svn.netsurf-browser.org/trunk/netsurf
_svnmod=netsurf-svn
build() {
cd "$srcdir"
#msg "Fetching two extra files..."
curl http://www.sqlite.org/cvstrac/getfile/sqlite/tool/lemon.c -O || return 1
curl http://www.sqlite.org/cvstrac/getfile/sqlite/tool/lempar.c -O || return 1
if [ -d $_svnmod/.svn ]; then
(cd $_svnmod && svn up -r $pkgver)
else
svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
fi
msg "SVN checkout done or server timeout"
msg "Preparing..."
gcc lemon.c -o lemon
PATH=`pwd`:$PATH
cp -rT $_svnmod $_svnmod-build
ln -sf $_svnmod-build netsurf #will not compile otherwise
cd netsurf
patch -p1 < ../0002-netsurf-add-zipit-keymap.patch
patch -p1 < ../0004-curl-disable-verify-peer.patch
patch -p1 < ../0005-fix-content_get_width_height.patch
echo "override NETSURF_FB_FRONTEND := sdl" > Makefile.config
sed -i -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' ./framebuffer/convert_image.c
msg "Compiling Netsurf..."
make TARGET=framebuffer || return 1
msg "Packaging executables..."
mkdir -p ${pkgdir}/usr/bin
install nsfb ${pkgdir}/usr/bin
install -Dm755 ${srcdir}/netsurf.sh ${pkgdir}/usr/bin/netsurf
install -d ${pkgdir}/usr/bin ${pkgdir}/usr/share/netsurf
msg "Packaging resources..."
rm -rf framebuffer/res/.svn gtk/res/docs/.svn
cp -RL framebuffer/res ${pkgdir}/usr/share/netsurf
msg "Cleaning up..."
find "$pkgdir" -name ".svn" -print0 | xargs -0 rm -rf
}

View file

@ -1,2 +0,0 @@
#!/bin/sh
NETSURFRES=/usr/share/netsurf/res /usr/bin/nsfb $*

View file

@ -1,46 +0,0 @@
# ALARM: Kevin Mihelich <kevin@plugapps.com>
# - This package uses Debian's armel openjdk6
# Dropping plugrel so we don't index into builder, this package is
# screwing up deps in v7h.
#plugrel=1
pkgname=openjdk6-debian
pkgver=6.b20pre1
pkgrel=1
pkgdesc="Debian's package of OpenJDK6, including the Zero and Shark VMs"
depends=('glibc' 'gcc-libs')
makedepends=()
conflicts=('java-environment' 'java-runtime')
provides=('java-environment=6' 'java-runtime=6' 'openjdk6')
url="http://packages.debian.org/sid/openjdk-6-jre-zero"
install=(openjdk6-debian.install)
source=("http://ftp.us.debian.org/debian/pool/main/o/openjdk-6/openjdk-6-jre-headless_6b20~pre1-2_armel.deb"
"http://ftp.us.debian.org/debian/pool/main/o/openjdk-6/openjdk-6-jdk_6b20~pre1-2_armel.deb"
"http://ftp.us.debian.org/debian/pool/main/o/openjdk-6/openjdk-6-jre-lib_6b21~pre1-1_all.deb")
arch=('arm')
license="GPLv2"
build() {
ar x `basename ${source[0]}`
tar xf data.tar.gz -C ${pkgdir}
ar x `basename ${source[0]}`
tar xf data.tar.gz -C ${pkgdir}
ar x `basename ${source[1]}`
tar xf data.tar.gz -C ${pkgdir}
ar x `basename ${source[1]}`
tar xf data.tar.gz -C ${pkgdir}
ar x `basename ${source[2]}`
tar xf data.tar.gz -C ${pkgdir}
ar x `basename ${source[2]}`
tar xf data.tar.gz -C ${pkgdir}
rm -rf ${pkgdir}/usr/share/lintian
mkdir -p ${pkgdir}/usr/bin
}
md5sums=('cc3dc3589774ede2371fc66695ebcb80'
'5887ac5a94b762678743ca2e6e55653c'
'f34f0b7163babd721fb298666c0176a6')

View file

@ -1,11 +0,0 @@
post_install() {
ln -sf /usr/lib/jvm/java-6-openjdk/bin/* /usr/bin
}
post_upgrade() {
post_install
}
op=$1
shift
$op $*