mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/uboot-beagleboard to 2016.11-1
This commit is contained in:
parent
6969dec1dd
commit
7792a6be4d
2 changed files with 23 additions and 31 deletions
|
@ -1,4 +1,4 @@
|
|||
From 490d8292fbbd162468db8ce5746c37c8c4e69498 Mon Sep 17 00:00:00 2001
|
||||
From f01dde647e6dbb2d22ad378073a2594ad52b83ec Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 7 Jun 2015 18:24:03 -0600
|
||||
Subject: [PATCH] arch linux arm modifications
|
||||
|
@ -6,12 +6,12 @@ Subject: [PATCH] arch linux arm modifications
|
|||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
board/ti/beagle/beagle.c | 38 +++++++--
|
||||
include/configs/omap3_beagle.h | 172 +++++++++++++-------------------------
|
||||
include/configs/ti_armv7_common.h | 3 -
|
||||
3 files changed, 93 insertions(+), 120 deletions(-)
|
||||
configs/omap3_beagle_defconfig | 1 +
|
||||
include/configs/omap3_beagle.h | 171 ++++++++++++++---------------------------
|
||||
3 files changed, 93 insertions(+), 117 deletions(-)
|
||||
|
||||
diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c
|
||||
index 0ed4f52..622be01 100644
|
||||
index cfdab3e..ebf4683 100644
|
||||
--- a/board/ti/beagle/beagle.c
|
||||
+++ b/board/ti/beagle/beagle.c
|
||||
@@ -56,6 +56,7 @@
|
||||
|
@ -111,16 +111,24 @@ index 0ed4f52..622be01 100644
|
|||
twl4030_power_init();
|
||||
switch (get_board_revision()) {
|
||||
case REVISION_XM_AB:
|
||||
diff --git a/configs/omap3_beagle_defconfig b/configs/omap3_beagle_defconfig
|
||||
index 7a1fd44..4504396 100644
|
||||
--- a/configs/omap3_beagle_defconfig
|
||||
+++ b/configs/omap3_beagle_defconfig
|
||||
@@ -36,3 +36,4 @@ CONFIG_G_DNL_MANUFACTURER="TI"
|
||||
CONFIG_G_DNL_VENDOR_NUM=0x0451
|
||||
CONFIG_G_DNL_PRODUCT_NUM=0xd022
|
||||
CONFIG_OF_LIBFDT=y
|
||||
+CONFIG_IDENT_STRING=" Arch Linux ARM"
|
||||
diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
|
||||
index 4dbe2b6..945475b 100644
|
||||
index 8a69a5f..2901c64 100644
|
||||
--- a/include/configs/omap3_beagle.h
|
||||
+++ b/include/configs/omap3_beagle.h
|
||||
@@ -82,6 +82,12 @@
|
||||
@@ -76,6 +76,11 @@
|
||||
#define CONFIG_USB_ETHER_MCS7830
|
||||
#define CONFIG_USB_ETHER_SMSC95XX
|
||||
|
||||
+/* Arch Linux ARM extras */
|
||||
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
|
||||
+#define CONFIG_SUPPORT_RAW_INITRD
|
||||
+#define CONFIG_CMD_PART
|
||||
+#define CONFIG_PARTITION_UUIDS
|
||||
|
@ -128,7 +136,7 @@ index 4dbe2b6..945475b 100644
|
|||
/* GPIO banks */
|
||||
#define CONFIG_OMAP3_GPIO_5 /* GPIO128..159 is in GPIO bank 5 */
|
||||
#define CONFIG_OMAP3_GPIO_6 /* GPIO160..191 is in GPIO bank 6 */
|
||||
@@ -112,50 +118,62 @@
|
||||
@@ -105,50 +110,62 @@
|
||||
/* devices */
|
||||
|
||||
#define CONFIG_EXTRA_ENV_SETTINGS \
|
||||
|
@ -230,7 +238,7 @@ index 4dbe2b6..945475b 100644
|
|||
"findfdt=" \
|
||||
"if test $beaglerev = AxBx; then " \
|
||||
"setenv fdtfile omap3-beagle.dtb; fi; " \
|
||||
@@ -168,81 +186,11 @@
|
||||
@@ -161,81 +178,11 @@
|
||||
"if test $beaglerev = xMC; then " \
|
||||
"setenv fdtfile omap3-beagle-xm.dtb; fi; " \
|
||||
"if test $fdtfile = undefined; then " \
|
||||
|
@ -315,22 +323,6 @@ index 4dbe2b6..945475b 100644
|
|||
|
||||
/*
|
||||
* OMAP3 has 12 GP timers, they can be driven by the system clock
|
||||
diff --git a/include/configs/ti_armv7_common.h b/include/configs/ti_armv7_common.h
|
||||
index 7db0881..47cbcc6 100644
|
||||
--- a/include/configs/ti_armv7_common.h
|
||||
+++ b/include/configs/ti_armv7_common.h
|
||||
@@ -244,11 +244,8 @@
|
||||
#define CONFIG_SPL_LIBDISK_SUPPORT
|
||||
#define CONFIG_SPL_MMC_SUPPORT
|
||||
#define CONFIG_SPL_FAT_SUPPORT
|
||||
-#define CONFIG_SPL_EXT_SUPPORT
|
||||
#endif
|
||||
|
||||
-#define CONFIG_SYS_THUMB_BUILD
|
||||
-
|
||||
/* General parts of the framework, required. */
|
||||
#define CONFIG_SPL_I2C_SUPPORT
|
||||
#define CONFIG_SPL_LIBCOMMON_SUPPORT
|
||||
--
|
||||
2.9.0
|
||||
2.10.2
|
||||
|
||||
|
|
|
@ -4,7 +4,7 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=uboot-beagleboard
|
||||
pkgver=2016.09
|
||||
pkgver=2016.11
|
||||
pkgrel=1
|
||||
pkgdesc="U-Boot for BeagleBoard and BeagleBoard-xM"
|
||||
arch=('armv7h')
|
||||
|
@ -15,8 +15,8 @@ backup=('boot/uEnv.txt')
|
|||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
|
||||
'0001-arch-linux-arm-modifications.patch'
|
||||
'uEnv.txt')
|
||||
md5sums=('2e69dda70eb28f8042d2f9fbeb1feaa1'
|
||||
'0bd6e9db86c801ee18f2a6c26af5eb6c'
|
||||
md5sums=('ca1f6e019d08aff8d0ca1beb2e66737d'
|
||||
'f193e2494de5c54a582d7cffd0a141e7'
|
||||
'd41d8cd98f00b204e9800998ecf8427e')
|
||||
|
||||
prepare() {
|
||||
|
|
Loading…
Reference in a new issue