mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-06 23:47:10 +00:00
community/blender to 2.92.0-5
This commit is contained in:
parent
977261b855
commit
77a3e534bb
2 changed files with 49 additions and 3 deletions
|
@ -15,7 +15,7 @@ buildarch=8
|
|||
|
||||
pkgname=blender
|
||||
pkgver=2.92.0
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
epoch=17
|
||||
pkgdesc="A fully integrated 3D graphics creation suite"
|
||||
arch=('x86_64')
|
||||
|
@ -33,13 +33,15 @@ source=("git+https://git.blender.org/blender.git#tag=v$pkgver"
|
|||
"git+https://git.blender.org/blender-addons-contrib.git"
|
||||
"git+https://git.blender.org/blender-translations.git"
|
||||
"git+https://git.blender.org/blender-dev-tools.git"
|
||||
https://developer.download.nvidia.com/redist/optix/v7.0/OptiX-7.0.0-include.zip)
|
||||
https://developer.download.nvidia.com/redist/optix/v7.0/OptiX-7.0.0-include.zip
|
||||
blender-openexr3.patch)
|
||||
sha512sums=('SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'b2cff73def3757d4259f4b4d318a8ccfe166bf7c215cbb2124f1c81bd6e742f96207285b24eb4d99b527b7b97dc6d5e8fdf2f16d78d5d1e2684c26d681328491')
|
||||
'b2cff73def3757d4259f4b4d318a8ccfe166bf7c215cbb2124f1c81bd6e742f96207285b24eb4d99b527b7b97dc6d5e8fdf2f16d78d5d1e2684c26d681328491'
|
||||
'e2dd7210d26b70445e9ae8e33dea35111ad0b0aca9d3b4ded3df560d0fcc8dc044868f729e0f090a04b6f316f083b5505a7056ce088e8702065add87b9b457e5')
|
||||
|
||||
prepare() {
|
||||
cd "$pkgname"
|
||||
|
@ -51,6 +53,8 @@ prepare() {
|
|||
git config submodule."source/tools".url "${srcdir}/blender-dev-tools"
|
||||
git submodule update
|
||||
git submodule foreach git checkout v${pkgver}
|
||||
|
||||
patch -p1 < "$srcdir"/blender-openexr3.patch # Fix build with OpenEXR 3
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
42
community/blender/blender-openexr3.patch
Normal file
42
community/blender/blender-openexr3.patch
Normal file
|
@ -0,0 +1,42 @@
|
|||
diff --git a/build_files/cmake/Modules/FindOpenEXR.cmake b/build_files/cmake/Modules/FindOpenEXR.cmake
|
||||
index 090f80b8df7..a2f7b4c622b 100644
|
||||
--- a/build_files/cmake/Modules/FindOpenEXR.cmake
|
||||
+++ b/build_files/cmake/Modules/FindOpenEXR.cmake
|
||||
@@ -34,11 +34,10 @@ ENDIF()
|
||||
SET(_openexr_libs_ver_init "2.0")
|
||||
|
||||
SET(_openexr_FIND_COMPONENTS
|
||||
- Half
|
||||
Iex
|
||||
- IlmImf
|
||||
- IlmThread
|
||||
Imath
|
||||
+ OpenEXR
|
||||
+ IlmThread
|
||||
)
|
||||
|
||||
SET(_openexr_SEARCH_DIRS
|
||||
@@ -120,7 +119,7 @@ FIND_PACKAGE_HANDLE_STANDARD_ARGS(OpenEXR DEFAULT_MSG
|
||||
IF(OPENEXR_FOUND)
|
||||
SET(OPENEXR_LIBRARIES ${_openexr_LIBRARIES})
|
||||
# Both include paths are needed because of dummy OSL headers mixing #include <OpenEXR/foo.h> and #include <foo.h> :(
|
||||
- SET(OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR} ${OPENEXR_INCLUDE_DIR}/OpenEXR)
|
||||
+ SET(OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR} ${OPENEXR_INCLUDE_DIR}/OpenEXR ${OPENEXR_INCLUDE_DIR}/Imath)
|
||||
ENDIF()
|
||||
|
||||
MARK_AS_ADVANCED(
|
||||
diff --git a/source/blender/imbuf/intern/openexr/openexr_api.cpp b/source/blender/imbuf/intern/openexr/openexr_api.cpp
|
||||
index 382d86f2645..eff50b19c31 100644
|
||||
--- a/source/blender/imbuf/intern/openexr/openexr_api.cpp
|
||||
+++ b/source/blender/imbuf/intern/openexr/openexr_api.cpp
|
||||
@@ -38,8 +38,10 @@
|
||||
#include <ImfChannelList.h>
|
||||
#include <ImfCompression.h>
|
||||
#include <ImfCompressionAttribute.h>
|
||||
+#include <ImfFrameBuffer.h>
|
||||
#include <ImfIO.h>
|
||||
#include <ImfInputFile.h>
|
||||
+#include <ImfInt64.h>
|
||||
#include <ImfOutputFile.h>
|
||||
#include <ImfPixelType.h>
|
||||
#include <ImfStandardAttributes.h>
|
Loading…
Reference in a new issue