community/seamonkey to 2.46-1

This commit is contained in:
Kevin Mihelich 2016-12-23 14:31:58 +00:00
parent e9459770e3
commit 77b363b722
5 changed files with 30 additions and 91 deletions

View file

@ -4,13 +4,15 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - mozconfig additions used in xulrunner, just in case
highmem=1
pkgname=seamonkey
pkgver=2.40
pkgrel=7
pkgver=2.46
pkgrel=1
pkgdesc="SeaMonkey internet suite"
arch=('i686' 'x86_64')
license=('MPL')
depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'hunspell' 'libevent' 'libnotify' 'libvpx' 'libxt' 'mime-types' 'mozilla-common' 'nss' 'sqlite' 'startup-notification' 'libpulse' 'icu' 'gconf')
depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'gtk3' 'hunspell' 'libevent' 'libnotify' 'libvpx' 'libxt' 'mime-types' 'mozilla-common' 'nss' 'sqlite' 'startup-notification' 'libpulse' 'icu' 'gconf')
makedepends=('unzip' 'zip' 'pkg-config' 'python2' 'yasm' 'wireless_tools' 'mesa' 'autoconf2.13' 'imake' 'python3' 'gst-plugins-base')
optdepends=('gst-plugins-base: vorbis decoding, ogg demuxing'
'gst-plugins-bad: aac, vp8 and opus decoding'
@ -21,14 +23,12 @@ source=(https://archive.mozilla.org/pub/mozilla.org/seamonkey/releases/$pkgver/s
mozconfig
seamonkey-2.0-lang.patch
rhbz-966424.patch
mozilla-1245076.patch
mozilla-1245076-1.patch)
md5sums=('5789df8f96e14577c275f10fdf8462f3'
'2111b1c045308ba8c5647135c2307191'
xulrunner-27.0-build-arm.patch)
md5sums=('436a158e16eee151b97f96c053b82d45'
'e904af9abed61515e17c2c7457aca74f'
'25b6fe16ac24cd5c852213e5c1adb272'
'8c1578232b7a60fa1caa9a0b322d1e2b'
'43550e772f110a338d5a42914ee2c3a6'
'772aac58e3a7e8a32bedd898bc35dc90')
'f6f758612d23c2a6e1497889b70bc57a')
prepare() {
cd "$pkgname-$pkgver"
@ -36,7 +36,7 @@ prepare() {
#patch -Np1 -i ../seamonkey-2.0-lang.patch
# FS#48404
echo "ac_add_options --enable-gstreamer=1.0" >> .mozconfig
#echo "ac_add_options --enable-gstreamer=1.0" >> .mozconfig
# https://bugs.archlinux.org/task/41689
patch -Np1 -d mozilla -i ../../rhbz-966424.patch
@ -51,9 +51,11 @@ prepare() {
# 2.26 build fix from wgnie (blfs ch 37)
sed -i 's/$(MOZ_ZLIB_CFLAGS)/& $(MOZ_PIXMAN_CFLAGS)/' config/config.mk
# GCC 6
patch -Np1 -d mozilla -i ../../mozilla-1245076.patch
patch -Np1 -d mozilla -i ../../mozilla-1245076-1.patch
[[ $CARCH != "aarch64" ]] && echo "ac_add_options --disable-ion" >> .mozconfig \
&& echo "ac_add_options --disable-elf-hack" >> .mozconfig \
&& echo "ac_add_options --disable-neon" >> .mozconfig
LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
patch -p2 -d mozilla -i "${srcdir}"/xulrunner-27.0-build-arm.patch
}
build() {
@ -92,3 +94,4 @@ package() {
rm -f "$pkgdir/usr/lib/pkgconfig/"seamonkey-ns{s,pr}.pc
#rm -r "$pkgdir"/usr/{include,lib/seamonkey-devel-$pkgver,share/idl}
}

View file

@ -3,10 +3,6 @@ ac_add_options --enable-application=suite
ac_add_options --prefix=/usr
ac_add_options --libdir=/usr/lib
ac_add_options --disable-elf-hack
ac_add_options --disable-neon
ac_add_options --disable-ion
# System libraries
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
@ -31,10 +27,10 @@ ac_add_options --enable-gio
ac_add_options --enable-pulseaudio
ac_add_options --disable-gnomevfs
#ac_add_options --disable-gnomevfs
ac_add_options --disable-crashreporter
ac_add_options --disable-updater
ac_add_options --disable-tests
ac_add_options --disable-installer
#ac_add_options --disable-installer
export MOZILLA_OFFICIAL=1

View file

@ -1,49 +0,0 @@
diff --git a/config/gcc-stl-wrapper.template.h b/config/gcc-stl-wrapper.template.h
--- a/config/gcc-stl-wrapper.template.h
+++ b/config/gcc-stl-wrapper.template.h
@@ -12,33 +12,39 @@
// compiling ObjC.
#if defined(__EXCEPTIONS) && __EXCEPTIONS && !(__OBJC__ && __GNUC__ && XP_IOS)
# error "STL code can only be used with -fno-exceptions"
#endif
// Silence "warning: #include_next is a GCC extension"
#pragma GCC system_header
+#ifndef moz_dont_include_mozalloc_for_cstdlib
+# define moz_dont_include_mozalloc_for_cstdlib
+#endif
+#ifndef moz_dont_include_mozalloc_for_${HEADER}
// mozalloc.h wants <new>; break the cycle by always explicitly
// including <new> here. NB: this is a tad sneaky. Sez the gcc docs:
//
// `#include_next' does not distinguish between <file> and "file"
// inclusion, nor does it check that the file you specify has the
// same name as the current file. It simply looks for the file
// named, starting with the directory in the search path after the
// one where the current file was found.
-#include_next <new>
+# include_next <new>
// See if we're in code that can use mozalloc. NB: this duplicates
// code in nscore.h because nscore.h pulls in prtypes.h, and chromium
// can't build with that being included before base/basictypes.h.
-#if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
-# include "mozilla/mozalloc.h"
-#else
-# error "STL code can only be used with infallible ::operator new()"
+# if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
+# include "mozilla/mozalloc.h"
+# else
+# error "STL code can only be used with infallible ::operator new()"
+# endif
+
#endif
#if defined(DEBUG) && !defined(_GLIBCXX_DEBUG)
// Enable checked iterators and other goodies
//
// FIXME/bug 551254: gcc's debug STL implementation requires -frtti.
// Figure out how to resolve this with -fno-rtti. Maybe build with
// -frtti in DEBUG builds?

View file

@ -1,23 +0,0 @@
diff --git a/gfx/graphite2/src/Collider.cpp b/gfx/graphite2/src/Collider.cpp
--- a/gfx/graphite2/src/Collider.cpp
+++ b/gfx/graphite2/src/Collider.cpp
@@ -21,17 +21,17 @@
Alternatively, the contents of this file may be used under the terms of the
Mozilla Public License (http://mozilla.org/MPL) or the GNU General Public
License, as published by the Free Software Foundation, either version 2
of the License or (at your option) any later version.
*/
#include <algorithm>
#include <limits>
-#include <math.h>
+#include <cmath>
#include <string>
#include <functional>
#include "inc/Collider.h"
#include "inc/Segment.h"
#include "inc/Slot.h"
#include "inc/GlyphCache.h"
#include "inc/Sparse.h"

View file

@ -0,0 +1,12 @@
diff -up xulrunner-27.0/mozilla-release/gfx/ycbcr/moz.build.arm xulrunner-27.0/mozilla-release/gfx/ycbcr/moz.build
--- firefox-27.0/mozilla-release/gfx/ycbcr/moz.build.arm 2014-01-28 05:03:42.000000000 +0100
+++ firefox-27.0/mozilla-release/gfx/ycbcr/moz.build 2014-02-03 11:14:34.062219509 +0100
@@ -61,7 +61,7 @@ else:
'yuv_row_other.cpp',
]
-if CONFIG['CPU_ARCH'] == 'arm' and CONFIG['HAVE_ARM_NEON']:
+if CONFIG['HAVE_ARM_NEON']:
SOURCES += [
'yuv_row_arm.s',
]