mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/libtg_owt to 0.git25.afd9d5d-1
This commit is contained in:
parent
ed990329e7
commit
77cb3ac2f2
3 changed files with 10 additions and 33 deletions
|
@ -1,7 +1,7 @@
|
|||
pkgbase = libtg_owt
|
||||
pkgdesc = WebRTC library
|
||||
pkgver = 0.git24.592b14d
|
||||
pkgrel = 2
|
||||
pkgver = 0.git25.afd9d5d
|
||||
pkgrel = 1
|
||||
url = https://github.com/desktop-app/tg_owt
|
||||
arch = x86_64
|
||||
license = BSD
|
||||
|
@ -23,13 +23,14 @@ pkgbase = libtg_owt
|
|||
makedepends = libxtst
|
||||
makedepends = libepoxy
|
||||
depends = libdrm
|
||||
depends = libxdamage
|
||||
options = staticlibs
|
||||
source = git+https://github.com/desktop-app/tg_owt.git#commit=592b14d13bf9103226e90a83571e24c49f6bfdcd
|
||||
source = git+https://github.com/desktop-app/tg_owt.git#commit=afd9d5d31798d3eacf9ed6c30601e91d0f1e4d60
|
||||
source = git+https://chromium.googlesource.com/libyuv/libyuv/
|
||||
source = git+https://github.com/google/crc32c
|
||||
source = git+https://github.com/abseil/abseil-cpp
|
||||
source = git+https://github.com/cisco/libsrtp
|
||||
b2sums = c43ea062f8d28696fea5068f51a3548330b906606a256e8096e3e73f346b4bb5942db05b79f3e98daf1bcf195e8f966f52cc2e8e630af25ba06ac671ea5fd233
|
||||
b2sums = b9f1270b273f87bac80c481599a001b67b47aff6127977e21e5cc16fc70312f771accf7d49d1b55706442d04df5b76c53e374c488926cccb47e499aeb9b13f3a
|
||||
b2sums = SKIP
|
||||
b2sums = SKIP
|
||||
b2sums = SKIP
|
||||
|
|
|
@ -7,15 +7,15 @@
|
|||
pkgname=libtg_owt
|
||||
# It seems the currently desired version can be gotten from
|
||||
# https://github.com/telegramdesktop/tdesktop/blob/dev/Telegram/build/docker/centos_env/Dockerfile
|
||||
_commit=592b14d13bf9103226e90a83571e24c49f6bfdcd
|
||||
pkgver=0.git24.${_commit:0:7}
|
||||
pkgrel=2
|
||||
_commit=afd9d5d31798d3eacf9ed6c30601e91d0f1e4d60
|
||||
pkgver=0.git25.${_commit:0:7}
|
||||
pkgrel=1
|
||||
pkgdesc='WebRTC library'
|
||||
arch=('x86_64')
|
||||
url='https://github.com/desktop-app/tg_owt'
|
||||
license=('BSD')
|
||||
# libdrm is dynamically loaded via dlopen
|
||||
depends=('libdrm')
|
||||
depends=('libdrm' 'libxdamage')
|
||||
makedepends=('git' 'ninja' 'unzip' 'cmake' 'protobuf' 'libxrandr' 'libxcomposite' 'openssl' 'glibc'
|
||||
'ffmpeg' 'libva' 'opus' 'yasm' 'libjpeg-turbo' 'pipewire' 'libxtst' 'libepoxy')
|
||||
options=('staticlibs')
|
||||
|
@ -24,7 +24,7 @@ source=("git+${url}.git#commit=${_commit}"
|
|||
"git+https://github.com/google/crc32c"
|
||||
"git+https://github.com/abseil/abseil-cpp"
|
||||
"git+https://github.com/cisco/libsrtp")
|
||||
b2sums=('c43ea062f8d28696fea5068f51a3548330b906606a256e8096e3e73f346b4bb5942db05b79f3e98daf1bcf195e8f966f52cc2e8e630af25ba06ac671ea5fd233'
|
||||
b2sums=('b9f1270b273f87bac80c481599a001b67b47aff6127977e21e5cc16fc70312f771accf7d49d1b55706442d04df5b76c53e374c488926cccb47e499aeb9b13f3a'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
diff --git a/src/modules/audio_processing/transient/file_utils.h b/src/modules/audio_processing/transient/file_utils.h
|
||||
index b7483377..687ebcef 100644
|
||||
--- a/src/modules/audio_processing/transient/file_utils.h
|
||||
+++ b/src/modules/audio_processing/transient/file_utils.h
|
||||
@@ -12,6 +12,7 @@
|
||||
#define MODULES_AUDIO_PROCESSING_TRANSIENT_FILE_UTILS_H_
|
||||
|
||||
#include <string.h>
|
||||
+#include <cstdint>
|
||||
|
||||
#include "rtc_base/system/file_wrapper.h"
|
||||
|
||||
diff --git a/src/rtc_base/third_party/base64/base64.h b/src/rtc_base/third_party/base64/base64.h
|
||||
index 4190a79d..e224ffd0 100644
|
||||
--- a/src/rtc_base/third_party/base64/base64.h
|
||||
+++ b/src/rtc_base/third_party/base64/base64.h
|
||||
@@ -14,6 +14,7 @@
|
||||
|
||||
#include <string>
|
||||
#include <vector>
|
||||
+#include <cstdint>
|
||||
|
||||
#include "absl/strings/string_view.h"
|
||||
#include "rtc_base/system/rtc_export.h"
|
Loading…
Reference in a new issue