mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/chromium to 55.0.2883.75-1
This commit is contained in:
parent
77df05c548
commit
77e4302363
6 changed files with 173 additions and 79 deletions
|
@ -1,7 +1,7 @@
|
|||
From 354891ae65c570ebe8e54923a19b3bdbabfdfe2c Mon Sep 17 00:00:00 2001
|
||||
From 9ed900289d43c849da0ddaad60254a350e73d0cf Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 23 Oct 2016 10:56:44 -0600
|
||||
Subject: [PATCH 2/3] Add aarch64 GN support
|
||||
Subject: [PATCH 1/2] Add aarch64 GN support
|
||||
|
||||
---
|
||||
tools/gn/args.cc | 3 +++
|
||||
|
@ -29,5 +29,5 @@ index 9aaafb0..7ddfba4 100644
|
|||
arch = kMips;
|
||||
else
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
|
@ -1,14 +1,14 @@
|
|||
From 69d032371b025928e54c4304b8443fed7b12c08c Mon Sep 17 00:00:00 2001
|
||||
From 091bb27160baee02c93a3b14c8c078e6c3f5bdba Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 23 Oct 2016 10:57:25 -0600
|
||||
Subject: [PATCH 3/3] ARM toolchain fixes
|
||||
Subject: [PATCH 2/2] ARM toolchain fixes
|
||||
|
||||
---
|
||||
build/toolchain/linux/BUILD.gn | 28 +++++++++++++++++++++-------
|
||||
1 file changed, 21 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/build/toolchain/linux/BUILD.gn b/build/toolchain/linux/BUILD.gn
|
||||
index 548722d..39c5b08 100644
|
||||
index 548722d..39c5b08b 100644
|
||||
--- a/build/toolchain/linux/BUILD.gn
|
||||
+++ b/build/toolchain/linux/BUILD.gn
|
||||
@@ -22,15 +22,13 @@ clang_toolchain("clang_arm64") {
|
||||
|
@ -56,5 +56,5 @@ index 548722d..39c5b08 100644
|
|||
toolchain_args = {
|
||||
current_cpu = "x86"
|
||||
--
|
||||
2.10.0
|
||||
2.10.2
|
||||
|
|
@ -19,6 +19,7 @@ declare -rgA _system_libs=(
|
|||
[ffmpeg]=ffmpeg
|
||||
[flac]=flac
|
||||
[harfbuzz-ng]=harfbuzz-icu
|
||||
[icu]=icu
|
||||
[libjpeg]=libjpeg
|
||||
[libpng]=libpng
|
||||
[libvpx]=libvpx
|
||||
|
@ -28,11 +29,11 @@ declare -rgA _system_libs=(
|
|||
[re2]=re2
|
||||
[snappy]=snappy
|
||||
[yasm]=
|
||||
#[zlib]=zlib # Error during build
|
||||
[zlib]=minizip
|
||||
)
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=54.0.2840.100
|
||||
pkgver=55.0.2883.75
|
||||
pkgrel=1
|
||||
_launcher_ver=3
|
||||
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
|
||||
|
@ -43,7 +44,7 @@ depends=('gtk2' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libexif' 'libgcrypt'
|
|||
'ttf-font' 'systemd' 'dbus' 'libpulse' 'perl' 'perl-file-basedir'
|
||||
'pciutils' 'desktop-file-utils' 'hicolor-icon-theme')
|
||||
depends+=(${_system_libs[@]})
|
||||
makedepends=('python2' 'gperf' 'yasm' 'mesa' 'ninja')
|
||||
makedepends=('python2' 'gperf' 'yasm' 'mesa' 'ninja' 'git')
|
||||
optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
|
||||
'gnome-keyring: for storing passwords in GNOME keyring'
|
||||
'kwallet: for storing passwords in KWallet')
|
||||
|
@ -52,20 +53,20 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
|
|||
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
|
||||
chromium.desktop
|
||||
chromium-52.0.2743.116-unset-madv_free.patch
|
||||
chromium-53.0.2785.92-last-commit-position.patch
|
||||
chromium-system-ffmpeg-r4.patch
|
||||
chromium-icu58.patch
|
||||
chromium-widevine.patch
|
||||
0001-system-ffmpeg-fixes.patch
|
||||
0002-Add-aarch64-GN-support.patch
|
||||
0003-ARM-toolchain-fixes.patch)
|
||||
sha256sums=('e2e7f54a780c93ec2e933af09e1126837e6cf940b57213d39f36d58df10c89df'
|
||||
0001-Add-aarch64-GN-support.patch
|
||||
0002-ARM-toolchain-fixes.patch)
|
||||
sha256sums=('5bcf7180935bebc7648f7e2577f612da681f7846127f79dac22630ded9984e55'
|
||||
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
|
||||
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
|
||||
'3b3aa9e28f29e6f539ed1c7832e79463b13128863a02e9c6fecd16c30d61c227'
|
||||
'd3dc397956a26ec045e76c25c57a1fac5fc0acff94306b2a670daee7ba15709e'
|
||||
'e3c474dbf3822a0be50695683bd8a2c9dfc82d41c1524a20b4581883c0c88986'
|
||||
'fad964da0295a6a7b4393778e717ebdfd37dec33fe78beb2c639abd3973deb7a'
|
||||
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
|
||||
'0bb0d916a2bc332de61dc72e0726cae0cd677761d025bffc77052648ebfa3bd6'
|
||||
'001c913c608482d49080c520b53a669ce7d1941ed484f5dee713bb44ca195fdc'
|
||||
'ab2c1864df8f2aa36a4d8beef9d9a25fa52ed5dbb1993e11d9e5da62422f9014')
|
||||
'b2333cf0097264632a7e8bd11c3ee25a5f615f1d83481d2867aa18686e52f6ce'
|
||||
'140b79fcb3f12c8f9b4bb6d32d366c7731830d99a527602d6c7b3874933f75d0')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
# Note: These are for Arch Linux use ONLY. For your own distribution, please
|
||||
|
@ -80,9 +81,8 @@ prepare() {
|
|||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
# Arch Linux ARM fixes
|
||||
patch -Np1 -i ../0001-system-ffmpeg-fixes.patch
|
||||
patch -Np1 -i ../0002-Add-aarch64-GN-support.patch
|
||||
patch -Np1 -i ../0003-ARM-toolchain-fixes.patch
|
||||
patch -Np1 -i ../0001-Add-aarch64-GN-support.patch
|
||||
patch -Np1 -i ../0002-ARM-toolchain-fixes.patch
|
||||
|
||||
[[ $CARCH == "armv7h" ]] && MAKEFLAGS="-j4" && CFLAGS=`echo $CFLAGS | sed -e 's/vfpv3-d16/neon/'` && CXXFLAGS="$CFLAGS"
|
||||
|
||||
|
@ -92,13 +92,14 @@ prepare() {
|
|||
sed "s/@WIDEVINE_VERSION@/Pinkie Pie/" ../chromium-widevine.patch |
|
||||
patch -Np1
|
||||
|
||||
# Build fixes from Gentoo
|
||||
patch -Np1 -i ../chromium-system-ffmpeg-r4.patch
|
||||
patch -Np1 -i ../chromium-icu58.patch
|
||||
|
||||
# Disable MADV_FREE (if set by glibc)
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1361157
|
||||
patch -Np1 -i ../chromium-52.0.2743.116-unset-madv_free.patch
|
||||
|
||||
# Disable last_commit_position as we don't build from git repository
|
||||
patch -Np1 -i ../chromium-53.0.2785.92-last-commit-position.patch
|
||||
|
||||
# Work around bug in blink in which GCC 6 optimizes away null pointer checks
|
||||
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=833524
|
||||
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68853#c2
|
||||
|
@ -120,6 +121,7 @@ prepare() {
|
|||
find -type f -path "*third_party/$_lib/*" \
|
||||
\! -path "*third_party/$_lib/chromium/*" \
|
||||
\! -path "*third_party/$_lib/google/*" \
|
||||
\! -path "*base/third_party/icu/*" \
|
||||
\! -regex '.*\.\(gn\|gni\|isolate\|py\)' \
|
||||
-delete
|
||||
done
|
||||
|
@ -152,7 +154,6 @@ build() {
|
|||
'proprietary_codecs=true'
|
||||
'link_pulseaudio=true'
|
||||
'linux_use_bundled_binutils=false'
|
||||
'use_allocator="none"'
|
||||
'use_cups=true'
|
||||
'use_gconf=false'
|
||||
'use_gnome_keyring=false'
|
||||
|
@ -194,7 +195,7 @@ package() {
|
|||
install -Dm4755 out/Release/chrome_sandbox \
|
||||
"$pkgdir/usr/lib/chromium/chrome-sandbox"
|
||||
|
||||
cp -a out/Release/{*.pak,*.bin,chromedriver,libwidevinecdmadapter.so,icudtl.dat} \
|
||||
cp -a out/Release/{*.pak,*.bin,chromedriver,libwidevinecdmadapter.so} \
|
||||
out/Release/locales \
|
||||
out/Release/gen/content/content_resources.pak \
|
||||
"$pkgdir/usr/lib/chromium/"
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
--- a/tools/gn/gn_main.cc.orig 2015-11-12 11:49:56.260549036 +0000
|
||||
+++ b/tools/gn/gn_main.cc 2015-11-12 11:50:14.780931485 +0000
|
||||
@@ -11,13 +11,7 @@
|
||||
#include "tools/gn/standard_out.h"
|
||||
#include "tools/gn/switches.h"
|
||||
|
||||
-// Only the GN-generated build makes this header for now.
|
||||
-// TODO(brettw) consider adding this if we need it in GYP.
|
||||
-#if defined(GN_BUILD)
|
||||
-#include "tools/gn/last_commit_position.h"
|
||||
-#else
|
||||
#define LAST_COMMIT_POSITION "UNKNOWN"
|
||||
-#endif
|
||||
|
||||
namespace {
|
||||
|
||||
--- a/tools/gn/BUILD.gn.orig 2015-11-12 11:50:43.513524769 +0000
|
||||
+++ b/tools/gn/BUILD.gn 2015-11-12 11:50:57.697817632 +0000
|
||||
@@ -227,7 +227,6 @@
|
||||
|
||||
deps = [
|
||||
":gn_lib",
|
||||
- ":last_commit_position",
|
||||
"//base",
|
||||
"//build/config/sanitizers:deps",
|
||||
]
|
136
extra/chromium/chromium-icu58.patch
Normal file
136
extra/chromium/chromium-icu58.patch
Normal file
|
@ -0,0 +1,136 @@
|
|||
From 424584b4984bde7c831f42e9fb47f1ad583a1c46 Mon Sep 17 00:00:00 2001
|
||||
From: jshin <jshin@chromium.org>
|
||||
Date: Fri, 21 Oct 2016 01:15:50 -0700
|
||||
Subject: [PATCH] Update aspirational_scripts per Unicode 9
|
||||
|
||||
This is a preparation to update ICU to 58.1.
|
||||
Without this change, ICU update CL cannot be tested on
|
||||
trybots because a compile will fail due to '#error' checking
|
||||
if ICU version is less than 58.
|
||||
|
||||
BUG=637001
|
||||
TEST=None
|
||||
TBR=pkasting@chromium.org
|
||||
|
||||
Review-Url: https://chromiumcodereview.appspot.com/2436113003
|
||||
Cr-Commit-Position: refs/heads/master@{#426749}
|
||||
---
|
||||
components/url_formatter/url_formatter.cc | 10 +++++-----
|
||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/components/url_formatter/url_formatter.cc b/components/url_formatter/url_formatter.cc
|
||||
index 4455db3..2b82c0c 100644
|
||||
--- a/components/url_formatter/url_formatter.cc
|
||||
+++ b/components/url_formatter/url_formatter.cc
|
||||
@@ -428,9 +428,9 @@ void IDNSpoofChecker::SetAllowedUnicodeSet(UErrorCode* status) {
|
||||
// section at
|
||||
// http://www.unicode.org/Public/security/latest/xidmodifications.txt) are
|
||||
// are added to the allowed set. The list has to be updated when a new
|
||||
- // version of Unicode is released. The current version is 8.0.0 and ICU 58
|
||||
- // will have Unicode 9.0 data.
|
||||
-#if U_ICU_VERSION_MAJOR_NUM < 58
|
||||
+ // version of Unicode is released. The current version is 9.0.0 and ICU 60
|
||||
+ // will have Unicode 10.0 data.
|
||||
+#if U_ICU_VERSION_MAJOR_NUM < 60
|
||||
const icu::UnicodeSet aspirational_scripts(
|
||||
icu::UnicodeString(
|
||||
// Unified Canadian Syllabics
|
||||
@@ -444,13 +444,13 @@ void IDNSpoofChecker::SetAllowedUnicodeSet(UErrorCode* status) {
|
||||
// Yi
|
||||
"\\uA000-\\uA48C"
|
||||
// Miao
|
||||
- "\\U00016F00-\\U00016F44\\U00016F50-\\U00016F7F"
|
||||
+ "\\U00016F00-\\U00016F44\\U00016F50-\\U00016F7E"
|
||||
"\\U00016F8F-\\U00016F9F]",
|
||||
-1, US_INV),
|
||||
*status);
|
||||
allowed_set.addAll(aspirational_scripts);
|
||||
#else
|
||||
-#error "Update aspirational_scripts per Unicode 9.0"
|
||||
+#error "Update aspirational_scripts per Unicode 10.0"
|
||||
#endif
|
||||
|
||||
// U+0338 is included in the recommended set, while U+05F4 and U+2027 are in
|
||||
--
|
||||
2.10.2
|
||||
|
||||
From e60b571faa3f14dd9119a6792dccf12f8bf80192 Mon Sep 17 00:00:00 2001
|
||||
From: jshin <jshin@chromium.org>
|
||||
Date: Fri, 21 Oct 2016 12:20:05 -0700
|
||||
Subject: [PATCH] Prepare to upgrade ICU to 58 part 2
|
||||
|
||||
U_LB_COUNT is assumed to be 40 in Blink line breaking code, but it's
|
||||
43 in ICU 58/Unicode 9.
|
||||
|
||||
Three new classes (Emoji Base, Emoji Modifier, and ZWJ) should behave
|
||||
identically whether or not 'word-break: break-all' is in effect.
|
||||
|
||||
BUG=637001
|
||||
TEST=TextBreakIterator.cpp is compiled without an error with ICU 58.
|
||||
R=kojii@chromium.org
|
||||
CQ_INCLUDE_TRYBOTS=master.tryserver.blink:linux_precise_blink_rel
|
||||
|
||||
Review-Url: https://chromiumcodereview.appspot.com/2440923002
|
||||
Cr-Commit-Position: refs/heads/master@{#426860}
|
||||
---
|
||||
.../WebKit/Source/platform/text/TextBreakIterator.cpp | 16 ++++++++++++----
|
||||
1 file changed, 12 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp b/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp
|
||||
index 568dc0a..36121eb 100644
|
||||
--- a/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp
|
||||
+++ b/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp
|
||||
@@ -28,6 +28,9 @@
|
||||
#include "wtf/StdLibExtras.h"
|
||||
#include "wtf/text/CharacterNames.h"
|
||||
|
||||
+#include <unicode/uchar.h>
|
||||
+#include <unicode/uvernum.h>
|
||||
+
|
||||
namespace blink {
|
||||
|
||||
unsigned numGraphemeClusters(const String& string) {
|
||||
@@ -129,6 +132,11 @@ static const unsigned char asciiLineBreakTable[][(asciiLineBreakTableLastChar -
|
||||
};
|
||||
// clang-format on
|
||||
|
||||
+#if U_ICU_VERSION_MAJOR_NUM >= 58
|
||||
+#define BA_LB_COUNT (U_LB_COUNT - 3)
|
||||
+#else
|
||||
+#define BA_LB_COUNT U_LB_COUNT
|
||||
+#endif
|
||||
// Line breaking table for CSS word-break: break-all. This table differs from
|
||||
// asciiLineBreakTable in:
|
||||
// - Indices are Line Breaking Classes defined in UAX#14 Unicode Line Breaking
|
||||
@@ -136,7 +144,7 @@ static const unsigned char asciiLineBreakTable[][(asciiLineBreakTableLastChar -
|
||||
// - 1 indicates additional break opportunities. 0 indicates to fallback to
|
||||
// normal line break, not "prohibit break."
|
||||
// clang-format off
|
||||
-static const unsigned char breakAllLineBreakClassTable[][U_LB_COUNT / 8 + 1] = {
|
||||
+static const unsigned char breakAllLineBreakClassTable[][BA_LB_COUNT / 8 + 1] = {
|
||||
// XX AI AL B2 BA BB BK CB CL CM CR EX GL HY ID IN IS LF NS NU OP PO PR QU SA SG SP SY ZW NL WJ H2 H3 JL JT JV CP CJ HL RI
|
||||
{ B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0) }, // XX
|
||||
{ B(0, 1, 1, 0, 1, 0, 0, 0), B(0, 0, 0, 0, 0, 1, 0, 0), B(0, 0, 0, 1, 1, 0, 1, 0), B(1, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 1, 0) }, // AI
|
||||
@@ -190,7 +198,7 @@ static_assert(WTF_ARRAY_LENGTH(asciiLineBreakTable) ==
|
||||
asciiLineBreakTableLastChar - asciiLineBreakTableFirstChar +
|
||||
1,
|
||||
"asciiLineBreakTable should be consistent");
|
||||
-static_assert(WTF_ARRAY_LENGTH(breakAllLineBreakClassTable) == U_LB_COUNT,
|
||||
+static_assert(WTF_ARRAY_LENGTH(breakAllLineBreakClassTable) == BA_LB_COUNT,
|
||||
"breakAllLineBreakClassTable should be consistent");
|
||||
|
||||
static inline bool shouldBreakAfter(UChar lastCh, UChar ch, UChar nextCh) {
|
||||
@@ -226,8 +234,8 @@ static inline ULineBreak lineBreakPropertyValue(UChar lastCh, UChar ch) {
|
||||
|
||||
static inline bool shouldBreakAfterBreakAll(ULineBreak lastLineBreak,
|
||||
ULineBreak lineBreak) {
|
||||
- if (lineBreak >= 0 && lineBreak < U_LB_COUNT && lastLineBreak >= 0 &&
|
||||
- lastLineBreak < U_LB_COUNT) {
|
||||
+ if (lineBreak >= 0 && lineBreak < BA_LB_COUNT && lastLineBreak >= 0 &&
|
||||
+ lastLineBreak < BA_LB_COUNT) {
|
||||
const unsigned char* tableRow = breakAllLineBreakClassTable[lastLineBreak];
|
||||
return tableRow[lineBreak / 8] & (1 << (lineBreak % 8));
|
||||
}
|
||||
--
|
||||
2.10.2
|
||||
|
|
@ -1,29 +1,17 @@
|
|||
From 95b245cd1a23298440e283d36d150cdc0ec4cba7 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 6 Mar 2016 20:26:53 -0700
|
||||
Subject: [PATCH 1/3] system ffmpeg fixes
|
||||
|
||||
---
|
||||
media/ffmpeg/ffmpeg_common.h | 5 -----
|
||||
media/filters/ffmpeg_demuxer.cc | 18 ------------------
|
||||
2 files changed, 23 deletions(-)
|
||||
|
||||
diff --git a/media/ffmpeg/ffmpeg_common.h b/media/ffmpeg/ffmpeg_common.h
|
||||
index fa5dfee..db045f3 100644
|
||||
--- a/media/ffmpeg/ffmpeg_common.h
|
||||
+++ b/media/ffmpeg/ffmpeg_common.h
|
||||
--- a/media/ffmpeg/ffmpeg_common.h.orig 2016-09-09 13:16:07.757294768 +0000
|
||||
+++ b/media/ffmpeg/ffmpeg_common.h 2016-09-09 13:16:41.705989273 +0000
|
||||
@@ -22,10 +22,6 @@
|
||||
|
||||
// Include FFmpeg header files.
|
||||
extern "C" {
|
||||
-// Disable deprecated features which result in spammy compile warnings. This
|
||||
-// list of defines must mirror those in the 'defines' section of BUILD.gn file &
|
||||
-// ffmpeg.gyp file or the headers below will generate different structures!
|
||||
-// list of defines must mirror those in the 'defines' section of FFmpeg's
|
||||
-// BUILD.gn file or the headers below will generate different structures!
|
||||
-#define FF_API_CONVERGENCE_DURATION 0
|
||||
// Upstream libavcodec/utils.c still uses the deprecated
|
||||
// av_dup_packet(), causing deprecation warnings.
|
||||
// The normal fix for such things is to disable the feature as below,
|
||||
@@ -39,7 +35,6 @@ extern "C" {
|
||||
@@ -35,7 +35,6 @@
|
||||
MSVC_PUSH_DISABLE_WARNING(4244);
|
||||
#include <libavcodec/avcodec.h>
|
||||
#include <libavformat/avformat.h>
|
||||
|
@ -31,11 +19,9 @@ index fa5dfee..db045f3 100644
|
|||
#include <libavformat/avio.h>
|
||||
#include <libavutil/avutil.h>
|
||||
#include <libavutil/imgutils.h>
|
||||
diff --git a/media/filters/ffmpeg_demuxer.cc b/media/filters/ffmpeg_demuxer.cc
|
||||
index b34d8bc..3a2ebe6 100644
|
||||
--- a/media/filters/ffmpeg_demuxer.cc
|
||||
+++ b/media/filters/ffmpeg_demuxer.cc
|
||||
@@ -1151,24 +1151,6 @@ void FFmpegDemuxer::OnFindStreamInfoDone(const PipelineStatusCB& status_cb,
|
||||
--- a/media/filters/ffmpeg_demuxer.cc.orig 2016-09-09 14:21:40.185828912 +0000
|
||||
+++ b/media/filters/ffmpeg_demuxer.cc 2016-09-09 14:21:52.894089352 +0000
|
||||
@@ -1185,24 +1185,6 @@
|
||||
// If no estimate is found, the stream entry will be kInfiniteDuration.
|
||||
std::vector<base::TimeDelta> start_time_estimates(format_context->nb_streams,
|
||||
kInfiniteDuration);
|
||||
|
@ -59,7 +45,4 @@ index b34d8bc..3a2ebe6 100644
|
|||
- }
|
||||
|
||||
std::unique_ptr<MediaTracks> media_tracks(new MediaTracks());
|
||||
AVStream* audio_stream = NULL;
|
||||
--
|
||||
2.10.0
|
||||
|
||||
|
Loading…
Reference in a new issue